INDEKS (funksjon)

INDEKS-funksjonen returnerer en verdi eller referansen til en verdi fra en tabell eller et område.

Nettleseren støtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Det finnes to måter å bruke INDEKS-funksjonen på:

  • Hvis du vil returnere verdien til en angitt celle eller matrise av celler, kan du se Matriseform.

  • Hvis du vil returnere en referanse til angitte celler, kan du se Referanseform.

Matriseform

Beskrivelse

Returnerer verdien av et element i en tabell eller en matrise, valgt av nummerindeksene for rad og kolonne.

Bruk matriseformelen hvis det første argumentet i INDEKS er en matrisekonstant.

Syntaks

INDEKS(matrise; rad_nr; [kolonne_nr])

Syntaksen for INDEKS har følgende argumenter:

  • Matrise    Obligatorisk. Et celleområde eller en matrisekonstant.

    • Hvis matrisen bare inneholder én rad eller kolonne, er tilsvarende argument rad_nr eller kolonne_nr valgfritt.

    • Hvis matrise har mer enn én rad og mer enn én kolonne, og bare rad_nr eller kolonne_nr brukes, returnerer INDEKS en matrise av hele raden eller kolonnen i matrisen.

  • Rad_nr    Obligatorisk. Velger raden i en matrise som en verdi skal returneres fra. Hvis rad_nr utelates, kreves kolonne_nr.

  • Kolonne_nr     Valgfri. Velger kolonnen i en matrise som en verdi skal returneres fra. Hvis kolonne_nr utelates, kreves rad_nr.

Merknader

  • Hvis begge argumentene rad_nr og kolonne_nr brukes, returnerer INDEKS verdien i cellen i skjæringspunktet mellom rad_nr og kolonne_nr.

  • Hvis du angir rad_nr eller kolonne_nr til 0 (null), returnerer INDEKS matrisen med verdier for hele kolonnen eller raden. Hvis du vil bruke verdier som returneres som en matrise, skriver du inn INDEKS-funksjonen som en matriseformel i et vannrett celleområde for en rad, og i et loddrett celleområde for en kolonne. Trykk CTRL+SKIFT+ENTER hvis du vil skrive inn en matriseformel.

    Merknad: I Excel Web App kan du ikke opprette matriseformler.

  • Rad_nr og kolonne_nr må peke på en celle innenfor matrise, ellers returnerer INDEKS feilverdien #REF!.

Eksempler

Eksempel 1

Disse eksemplene bruker INDEKS-funksjonen til å finne verdien i cellen i skjæringspunktet der en rad og kolonne møtes.

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Data

Data

Epler

Sitroner

Bananer

Pærer

Formel

Beskrivelse

Resultat

=INDEKS(A2:B3,2,2)

Verdien i skjæringspunktet mellom andre rad og andre kolonne i området A2:B3.

Pærer

=INDEKS(A2:B3;2;1)

Verdien i skjæringspunktet mellom andre rad og første kolonne i området A2:B3.

Bananer

Eksempel 2

Dette eksemplet bruker INDEKS-funksjonen i en matriseformel til å finne verdiene i to celler angitt i en 2x2-matrise.

I dette tilfellet merker du to loddrette celler, for eksempel A1:A2, limer inn følgende formel =INDEKS({1,2;3,4},0,2) i den første cellen, og trykker deretter CTRL + SKIFT + ENTER. Når den blir angitt som en matriseformel vil Excel automatisk lime inn formelen til den andre cellen.

Formel

Beskrivelse

Resultat

=INDEKS({1,2;3,4},0,2)

Verdien i første rad, andre kolonne i matrisen. Matrisen inneholder 1 og 2 i første rad og 3 og 4 i andre rad.

2

Verdien i andre rad, andre kolonne i matrisen (samme matrise som ovenfor).

4

Merknad: Dette er en matriseformel, og den må angis med CTRL+SKIFT+ENTER. Excel vil automatisk sette formelen i klammeparenteser {}. Hvis du prøver å angi dem selv, viser Excel formelen som tekst. Hvis du ikke bruker CTRL+SKIFT+ENTER, vil formelen returnere en #VALUE!-feil.

Til toppen av siden

Referanseform

Beskrivelse

Returnerer referansen for cellen i skjæringspunktet mellom en bestemt rad eller kolonne. Hvis referansen består av sammensatte merkede områder, kan du velge det merkede området du vil se i.

Syntaks

INDEKS(referanse; rad_nr;[kolonne_nr]; [område_nr])

Syntaksen for INDEKS har følgende argumenter:

  • Referanse    Obligatorisk. En referanse til ett eller flere celleområder.

    • Hvis du angir et sammensatt område for referanse, setter du referansen i parenteser.

    • Hvis hvert område i referanse bare inneholder én rad eller kolonne, er argumentet rad_nr eller kolonne_nr valgfritt. For en referanse til en enkelt rad, bruker du for eksempel INDEKS(referanse;kolonne_nr).

  • Rad_nr    Obligatorisk. Nummeret på raden i referanse som en referanse returneres fra.

  • Kolonne_nr     Valgfri. Nummeret på kolonnen i referanse som en referanse returneres fra.

  • Område_nr    valgfritt. Merker et område i referansen som skjæringspunktet mellom rad_nr og kolonne_nr skal returneres fra. Det første området som velges eller legges inn, får nummer 1, det andre er 2 og så videre. Hvis område_nr utelates, vil INDEKS bruke område 1.  Alle områdene som er oppført her, må finnes på ett ark.  Hvis du angir områder som ikke er på samme ark som de andre, vil det føre til en #VALUE! feil.  Hvis du trenger å bruke områder som er plassert på ark som er forskjellige fra hverandre, anbefales det at du bruker matriseformen av INDEKS-funksjonen, og bruker en annen funksjon til å beregne området som utgjør matrisen.  Du kan for eksempel bruke VELG-funksjonen til å beregne hvilket område som skal brukes.

Hvis for eksempel referanse beskriver cellene (A1:B4;D1:E4;G1:H4), er område_nr 1 området A1:B4, område_nr 2 er området D1:E4 og område_nr 3 er området G1:H4.

Merknader

  • Etter at referanse og område_nr har valgt et bestemt område, velger rad_nr og kolonne_nr en bestemt celle: Rad_nr 1 er den første raden i området, kolonne_nr 1 er den første kolonnen, og så videre. Referansen som returneres av INDEKS, er skjæringspunktet mellom rad_nr og kolonne_nr.

  • Hvis du angir rad_nr eller kolonne_nr til 0 (null), returnerer INDEKS referansen for hele kolonnen eller raden.

  • Rad_nr, kolonne_nr og område_nr må peke på en celle innenfor referansen, ellers returnerer INDEKS feilverdien #REF!. Hvis rad_nr og kolonne_nr utelates, returnerer INDEKS området i referansen angitt av område_nr.

  • Resultatet av INDEKS-funksjonen er en referanse og tolkes som en referanse av andre formler. Avhengig av formelen, kan returverdien fra INDEKS brukes som en referanse eller som en verdi. Formelen CELLE("bredde";INDEKS(A1:B2;1;2)) er for eksempel ekvivalent med CELLE("bredde";B1). CELLE-funksjonen bruker returverdien fra INDEKS som en cellereferanse. På den andre siden vil en formel som for eksempel 2*INDEKS(A1:B2;1;2) oversette returverdien fra INDEKS til tallet i celle B1.

Merknad: Funksjonen CELLE er ikke tilgjengelig i Excel Web App.

Eksempler

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Frukt

Pris

count

Epler

$0.69

40

Bananer

$0.34

38

Sitroner

$0.55

15

Appelsiner

$0.25

25

Pærer

$0.59

40

Mandler

$2.80

10

Acajounøtter

$3.55

16

Peanøtter

$1.25

20

Valnøtter

$1.75

12

Formel

Beskrivelse

Resultat

=INDEKS(A2:C6;2;3)

Skjæringspunktet mellom den andre raden og den tredje kolonnen i området A2:C6, som er innholdet i celle C3.

38

=INDEKS((A1:C6;A8:C11);2;2;2)

Skjæringspunktet mellom den andre raden og den andre kolonnen i det andre området for A8:C11, som er innholdet i celle B9.

1,25

=SUMMER(INDEKS(A1:C11;0;3;1))

Summen av den tredje kolonnen i det første området av område A1:C11, som er summen av C1:C11.

216

=SUMMER(B2:INDEKS(A2:C6;5;2))

Summen av området som starter i B2, og slutter i skjæringspunktet mellom den femte raden og den andre kolonnen i området A2:A6, som er summen av B2:B6.

2,42

Til toppen av siden

Se også

FINN.RAD-funksjonen

SAMMENLIGNE-funksjonen

INDIREKTE-funksjon

Retningslinjer og eksempler på matriseformler

Oppslags- og referansefunksjoner (referanse)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×