IKKE (funksjon)

Bruk IKKE-funksjonen, én av de logiske funksjonene, når du vil forsikre deg om at en verdi ikke er lik en annen.

Eksempel

Eksempler på IKKE-funksjonen for å reversere argumenter.  F.EKS =IKKE(1+1=2)

IKKE-funksjonen reverserer verdien av argumentet sitt.

En vanlig bruk av IKKE-funksjonen er å utvide nytten av andre funksjoner som utfører logiske tester. For eksempel utfører HVIS-funksjonen en logisk test, der den returnerer en verdi hvis testen evalueres til SANN, og en annen verdi hvis testen evalueres til USANN. Ved å bruke IKKE-funksjonen som logisk_test-argument for HVIS-funksjonen, kan du teste mange forskjellige vilkår og ikke bare ett.

Syntaks

IKKE(logisk)

IKKE-funksjonens syntaks har følgende argumenter:

  • Logisk    Obligatorisk. En verdi eller et uttrykk som kan returnere verdiene SANN eller USANN.

Merknader

Hvis logisk er lik USANN, returnerer IKKE resultatet SANN. Hvis logisk er USANN, returnerer IKKE resultatet USANN.

Eksempler

Her er noen generelle eksempler på bruk av IKKE alene, og i forbindelse med HVIS, OG og ELLER.

Eksempler på IKKE med HVIS-, OG- og ELLER-funksjoner

Formel

Beskrivelse

=IKKE(A2>100)

A2 er IKKE større enn 100

=HVIS(OG(IKKE(A2>1),IKKE(A2<100)),A2,"Verdien er utenfor område")

50 er større enn 1 (SANN), OG 50 er mindre enn 100 (SANN), så IKKE reverserer begge argumentene til USANN. OG krever at begge argumentene er SANN, slik at den returnerer resultatet hvis det er USANN.

=HVIS(ELLER(IKKE(A3<0),IKKE(A3>50)),A3, «Verdien er utenfor området»)

100 ikke er mindre enn 0 (USANN) og 100 er større enn 50 (SANN), slik at IKKE reverserer argumentene til SANN/USANN. ELLER krever bare at ett argument er SANN, slik at den returnerer resultatet hvis det er SANN.

Beregning av salgsprovisjoner

Her er en ganske vanlig situasjon der vi skal beregne om selgere kvalifiserer for en bonus ved bruk av IKKE med HVIS og OG.

Eksempel på beregning av salgsbonus med HVIS, OG og IKKE.  Formelen i celle E14 er  =HVIS(OG(IKKE(B14<$B$7),IKKE(C14<$B$5)),B14*$B$8,0)
  • =HVIS(OG(IKKE(B14<$B$7),IKKE(C14<$B$5)),B14*$B$8,0)- HVIS totale salg IKKE er mindre enn salgsmål, OG kontoer IKKE er mindre enn kontomålet, multipliser da salg totalt med provisjons-%, hvis ikke, returner 0.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Beslektede emner

Video: Avanserte HVIS-funksjoner
Lær hvordan du bruker nestede funksjoner i en formel
HVIS-funksjonen
OG-funksjonen
ELLER-funksjonen
Oversikt over formler i Excel
Hvordan unngå formler med feil
Bruk feilkontroll for å oppdage feil i formler
Hurtigtaster i Excel 2016 for Windows
Hurtigtaster i Excel 2016 for Mac
Logiske funksjoner (referanse)
Excel-funksjoner(alfabetisk)
Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×