Hvordan rette opp en #I/T-feil

Hvordan rette opp en #I/T-feil

#I/A-feilen indikerer vanligvis at en formel ikke finner det den er satt opp til å se etter.

Første løsning

Den vanligste årsaken til #I/A-feilen er i funksjonene FINN.RAD, FINN.KOLONNE, SLÅ.OPP eller SAMMENLIGNE, når en formel ikke finner en referert verdi. Oppslagsverdien din finnes for eksempel ikke i kildedataene.

Oppslagsverdien finnes ikke.  Formelen i celle E2 er =FINN.RAD(D2,$D$6:$E$8,2,USANN).  Finner ikke verdien Banan, så formelen returnerer en #I/T-feil.
Element finnes ikke i kildedataene

I dette tilfellet er ikke «Banan» oppført i oppslagstabellen, så FINN.RAD returnerer en #I/A-feil.

Løsning: Du må enten sørge for at oppslagsverdien finnes i kildedataene, eller du må bruke en feilbehandler, for eksempel HVISFEIL i formelen. For eksempel: =HVISFEIL(FORMEL(),0), som sier:

  • = HVIS(formelen beregnes til en feil, vis da 0, ellers, vis formelens resultat)

Du kan bruke "" til ikke å vise noe, eller du kan bytte ut tomrommet med egen tekst: =HVISFEIL(FORMEL(),"Feilmelding her")

Hvis du ikke er sikker på hva du skal gjøre nå, eller hva slags hjelp du trenger, kan du søke etter lignende spørsmål i Forum for Excel-fellesskapet, eller publisere et eget spørsmål.

Kobling til forumet for Excel-fellesskapet

Hvis du vil gå videre, kan følgende sjekkliste gir deg hjelp til feilsøking, slik at du kan finne ut hva som sannsynligvis har gått galt i formlene.

Oppslagsverdien og kildedataene representerer forskjellige datatyper. Du prøver for eksempel å få FINN.RAD til å referere et tall, men kildedataene er lagret som tekst.

Feile verdityper.  Eksemplet viser en FINN.RAD-formel som returnerer en #I/T-feil fordi oppslagselementet er formatert som et tall, mens oppslagstabellen er formatert som tekst.
#I/A-feil forårsaket av forskjell i datatyper

Løsning: Påse at datatypene er like. Du kan kontrollere celleformater ved å merke en celle eller et celleområde, deretter høyreklikke og velge Formater celler > Tall (eller trykk Ctrl+1) og om nødvendig endre tallformatet.

Formater celler-dialogboksen som viser Tall-fanen og Tekst-alternativet som valgt

Tips!: Hvis du må tvinge en formatendring på en hel kolonne, bruker du først det ønskede formatet, og deretter kan du bruke Data > Tekst til kolonner > Fullfør.

Du kan bruke TRIMME-funksjonen til å fjerne innledende eller etterfølgende mellomrom. Følgende eksempel bruker TRIMME nestet inni en FINN.RAD-funksjon for å fjerne innledende mellomrom fra navnene i A2:A7 og returnere avdelingsnavnet.

Bruke FINN.RAD med TRIM i en matriseformel for å fjerne innledende/etterfølgende mellomrom.  Formelen i celle E3 er {=FINN.RAD(D2,TRIM(A2:B7),2,USANN)} og må angis med CTRL+SKIFT+ENTER.

{=FINN.RAD(D2,TRIMME(A2:B7),2,USANN)}

Merknad: Dette er en matriseformel som må angis med Ctrl+Skift+Enter. Excel bryter automatisk teksten i formelen med {} for deg. Hvis du prøver å angi dem selv, viser Excel formelen som tekst.

Funksjoner som slår opp informasjon i tabeller, må som standard sorteres i stigende rekkefølge. Regnearkfunksjonene FINN.RAD og FINN.KOLONNE kan imidlertid inneholde et søkeområde-argument som instruerer funksjonen til å finne et nøyaktig samsvar, selv om tabellen ikke er sortert. For å finne et nøyaktig samsvar angir du søkeområde-argumentet til USANN. Legg merke til at bruk av SANN, som forteller funksjonen at den skal se etter et tilnærmet samsvar, ikke bare resulterer i en #I/A-feil, men den kan også returnere feil resultater, som vist i eksempelet nedenfor.

Eksempel på hvordan bruk av FINN.RAD med argumentet range_lookup satt til verdien SANN kan føre til feilaktige resultater.
FINN.RAD mislykkes på grunn av bruk av tilnærmet samsvar-argumentet i en tabell som ikke er sortert

I dette eksemplet returnerer ikke bare «Banan» en #I/A-feil, «Pære» returnerer feil pris. Dette skyldes bruk av SANN-argumentet, som forteller FINN.RAD at den skal se etter et tilnærmet samsvar i stedet for et nøyaktig samsvar. Det finnes ikke noe tilnærmet samsvar for «Banan», og «Pære» kommer etter «Aprikos» alfabetisk. I dette tilfellet returnerer bruk av FINN.RAD med USANN-argumentet den riktige prisen for «Pære», men «Banan» returnerer fremdeles en #I/A-feil, da det ikke finnes noe som tilsvarer «Banan» i oppslagslisten.

Hvis du bruker SAMMENLIGNE-funksjonen, kan du prøve å endre verdien av type-argumentet for å angi sorteringsrekkefølgen i tabellen. For å finne et nøyaktig treff setter du type-argumentet til 0 (null).

Du kan løse dette ved å sørge for at området som refereres av matriseformelen, har samme antall rader og kolonner som celleområdet der matriseformelen ble angitt, eller angi matriseformelen i færre eller flere celler, slik at den svarer til områdereferansen i formelen.

I dette eksemplet har celle E2 referert til ikke-samsvarende områder:

Eksempel for matriseformel med ugyldige områdereferanser som forårsaker en #I/T-feil.  Formelen i celle E2 er {=SUM(IF(A2:A11=D2,B2:B5))} og må angis med CTRL+SKIFT+ENTER.

{=SUMMER(HVIS(A2:A11=D2,B2:B5))}

For at formelen skal beregnes riktig, må den endres slik at begge områdene viser til rad 2–11.

{=SUMMER(HVIS(A2:A11=D2,B2:B11))}

Merknad: Dette er en matriseformel som må angis med Ctrl+Skift+Enter. Excel bryter automatisk teksten i formelen med {} for deg. Hvis du prøver å angi dem selv, viser Excel formelen som tekst.

Eksempel på #I/T satt inn i celler, som hindrer at en SUM-formel beregnes riktig.

I dette tilfellet har mai–desember #I/A-verdier, slik at totalen ikke kan beregnes og det returneres i stedet en #I/A-feil.

Du løser dette ved å sjekke formelsyntaksen for funksjonen du bruker, og angi alle påkrevde argumenter i formelen som returnerer feilen. Dette kan kreve at du går inn i Visual Basic Editor (VBE) for å sjekke funksjonen. Du får tilgang til VBE fra Utvikler-fanen eller med Alt+F11.

Du kan løse dette ved å kontrollere at arbeidsboken som inneholder den brukerdefinerte funksjonen, er åpen, og at funksjonen fungerer riktig.

Du kan løse dette ved å kontrollere at argumentene i funksjonen er riktige og brukt på riktig sted.

For å løse dette problemet trykker du Ctrl+Alt+F9 for å beregne regnearket på nytt

Du kan bruke funksjonsveiviseren for å hjelpe deg, hvis du ikke er sikker på de riktige argumentene. Merk cellen med formelen i spørsmålet, gå så til Formel-fanen på båndet, og trykk Sett inn funksjon.

Sett inn Funksjon-knappen.

Excel laster veiviseren automatisk:

Eksempel på dialogboksen Formelveiviser.

Etter hvert som du klikker argumentene, gir Excel deg relevant informasjon for hvert enkelt argument.

#I/A kan være nyttig! Det er en vanlig praksis å bruke #I/A ved bruk av data som følgende i for eksempel diagrammer, da #I/A-verdier ikke plottes på et diagram. Her er noen eksempler på hvordan et diagram ser ut med 0-er kontra #I/A.

Eksempel på et linjediagram som tegner inn 0-verdier.

I forrige eksempel ser du at 0-verdiene er plottet og vises som en flat linje nederst i diagrammet, og så skyter den opp for å vise totalen. I eksemplet nedenfor vises 0-verdiene som erstattet med #I/A.

Eksempel på et linjediagram som ikke tegner inn #I/T-verdier.

Du finner mer informasjon om forekomst av #I/A-feil i en bestemt funksjon i følgende emner nedenfor:

Til toppen av siden

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Konverter tall lagret som tekst til tall

FINN.RAD-funksjonen

FINN.KOLONNE-funksjonen

SLÅ.OPP-funksjonen

SAMMENLIGN-funksjonen

Oversikt over formler i Excel

Slik unngår du brutte formler

Bruk av feilkontroll for å oppdage feil i formler

Hurtigtaster i Excel for Windows

Hurtigtaster i Excel for Mac

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×