HVISFEIL (funksjon)

Denne artikkelen beskriver formelsyntaks for og bruk av funksjonen HVISFEIL i Microsoft Excel.

Beskrivelse

Returnerer en verdi du angir hvis en formel evaluerer til en feil. Ellers returnerer den resultatet av formelen. Bruk funksjonen HVISFEIL til å fange opp og håndtere feil i en formel.

Syntaks

HVISFEIL(verdi;verdi_hvis_feil)

Syntaksen for funksjonen HVISFEIL har følgende argumenter:

  • Verdi    Obligatorisk. Argumentet som er kontrollert for en feil.

  • Verdi_hvis_feil    Obligatorisk. Verdien som skal returneres hvis formelen evaluerer til en feil. Følgende feiltyper evalueres: #I/T, #VERDI!, #REF!, #DIV/0!, #NUM!, #NAVN? eller #NULL!.

Merknader

  • Hvis verdi eller verdi_hvis_feil er en tom celle, behandler HVISFEIL den som en tom strengverdi ("").

  • Hvis verdi er en matriseformel, returnerer HVISFEIL et matriseresultat for hver celle i området som er angitt i verdi. Se det andre eksemplet nedenfor.

Eksempler

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Kvote

Solgte enheter

210

35

55

0

23

Formel

Beskrivelse

Resultat

=HVISFEIL(A2/B2; "Feil i beregning")

Kontrollerer om det er en feil i formelen i det første argumentet (del 210 med 35), finner ingen feil, og returnerer deretter resultatet av formelen

6

=HVISFEIL(A3/B3; "Feil i beregning")

Kontrollerer om det er en feil i formelen i det første argumentet (del 55 med 0), finner en deling med 0 feil, og returnerer deretter verdi_hvis_feil

Feil i beregning

=HVISFEIL(A4/B4; "Feil i beregning")

Kontrollerer om det er en feil i formelen i det første argumentet (del "" med 23), finner ingen feil, og returnerer deretter resultatet av formelen.

0

Eksempel 2

Kvote

Solgte enheter

Forhold

210

35

6

55

0

Feil i beregning

23

0

Formel

Beskrivelse

Resultat

=C2

Kontrollerer om det er en feil i formelen i det første argumentet i det første elementet i matrisen (A2/B2 eller del 210 med 35), finner ingen feil, og returnerer deretter resultatet av formelen

6

=C3

Kontrollerer om det er en feil i formelen i det første argumentet i det andre elementet i matrisen (A2/B2 eller del 55 med 0), finner en deling med 0 feil, og returnerer deretter verdi_hvis_feil

Feil i beregning

=C4

Kontrollerer om det er en feil i formelen i det første argumentet i det tredje elementet i matrisen (A4/B4 eller del "" med 23), finner ingen feil, og returnerer deretter resultatet av formelen

0

Obs! Formelen i eksemplet må angis som en matriseformel. Når du har kopiert eksemplet til et tomt regneark, merker du området C2:C4, trykker F2 og trykker deretter CTRL+SKIFT+ENTER.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×