HVIS (funksjon)

HVIS-funksjonen er en av de mest populære funksjonene i Excel. Den gjør det mulig å foreta logiske sammenligninger mellom en verdi og hva du forventer. I sin enkleste form sier HVIS-funksjonen:

  • HVIS (noe er SANN, gjøre noe, ellers gjør noe annet)

Et HVIS-uttrykk kan derfor ha to resultater. Det første resultatet er hvis sammenligningen er SANN, og det andre er hvis den er USANN.

Hvis du vil gå videre og arbeide med flere HVIS-uttrykk, kan du se: Avanserte HVIS-funksjoner – arbeide med nestede formler og unngå feller.

Bruk HVIS-funksjonen, en av de logiske funksjonene, for å returnere én verdi hvis en betingelse er sann, og en annen verdi hvis den er usann.

Syntaks

HVIS(logisk_test; verdi_hvis_sann; [verdi_hvis_usann])

Eksempel:

  • =HVIS(A2>B2;"Over budsjettet";"OK")

  • =HVIS(A2=B2,B4-A4,"")

Argumentnavn

Beskrivelse

logisk_test    (obligatorisk)

Betingelsen du vil teste.

verdi_hvis_sann    (obligatorisk)

Verdien som returneres hvis resultatet av logisk_test er SANN.

verdi_hvis_usann    (valgfritt)

Verdien som returneres hvis resultatet av logisk_test er USANN.

Enkle HVIS-eksempler

Cell D2 inneholder en formel =HVIS(C2="Ja",1,2)
  • =HVIS(C2="ja",1,2)

I eksemplet ovenfor sier celle D2: HVIS(C2 = Ja, returner deretter en 1, hvis ikke, returner en 2)

Celle D2 inneholder formelen =HVIS(C2=1,"JA","NEI")
  • =HVIS(C2=1,"ja","nei")

I dette eksemplet sier formelen i celle D2: HVIS(C2 = 1, returner Ja, hvis ikke returner Nei)

Som du ser, kan HVIS-funksjonen brukes til å evaluere både tekst og verdier. Den kan også brukes til å evaluere feil. Du begrenses ikke til bare å kontrollere om noe er likt med noe annet og returnere ett enkelt resultat. Du kan også bruke matematiske operatorer og utføre flere beregninger, avhengig av kriteriene. Du kan også neste flere HVIS-funksjoner sammen for å utføre flere sammenligninger.

Merknad: Hvis du skal bruke tekst i formler, må du sette teksten i anførselstegn (f.eks. «Tekst»). Det eneste unntaket fra dette er bruk av SANN eller USANN, som Excel automatisk forstår.

Slik kommer du i gang

Den beste måten å begynne å skrive et HVIS-uttrykk på er å tenke på hva du prøver å oppnå. Hvilken sammenligning prøver du å gjøre? Mange ganger kan det å skrive et HVIS-uttrykk være så enkelt som å tenke logisk: «Hva bør skje hvis denne betingelsen innfris, i motsetning til hva som bør skje hvis det ikke innfris?» Det er viktig å alltid sørge for at trinnene har en logisk utvikling, ellers vil ikke formelen gjøre det du forventer. Dette er spesielt viktig når du oppretter komplekse (nestede) HVIS-uttrykk.

Flere HVIS-eksempler

Formelen i celle D2 er = HVIS(C2>B2; "Over budsjett"; "Innenfor budsjett")
  • = HVIS(C2>B2,"Over budsjett","Innenfor budsjett")

I eksemplet ovenfor sier HVIS-funksjonen i D2 HVIS(C2 er større enn B2, returner da «Over budsjett", hvis ikke, returner "Innenfor budsjettet")

Formelen i celle E2 er =HVIS(C2>B2; C2-B2,"")
  • = HVIS(C2>B2,C2-B2,0)

I illustrasjonen ovenfor skal vi returnere en matematisk beregning i stedet for å returnere et tekstresultat. Formelen i E2 sier at HVIS(faktisk er høyere enn budsjettert, trekk da budsjettert beløp fra det faktiske beløpet. Hvis ikke returneres ingenting).

Formelen i celle F7 er HVIS(E7="Ja",F5*0,0825,0)
  • =HVIS(E7="ja",F5*0,0825,0)

I dette eksemplet sier formelen i F7 HVIS(E7 = "Ja", beregn da totalbeløpet i F5* 8,25 %, hvis ikke, skal Ingen salgsavgifter til forfall returnere 0)

Anbefalte fremgangsmåter – konstanter

I det siste eksemplet ser du at både «Ja» og MVA-satsen (0,0825) er skrevet direkte inn i formelen. Det er vanligvis ikke god praksis å legge tegnkonstanter (verdier som du må endre fra tid til annen) direkte inn i formler, fordi de kan være vanskelige å finne og endre i fremtiden. Det er mye bedre å legge inn konstantene i egne celler, der de står for seg selv og er enkle å finne og endre. I dette tilfellet er det OK, fordi det bare er én HVIS-funksjon, og MVA-satsen endres sjelden. Selv om det skulle skje, er det enkelt å endre det i formelen.

Beregningsoperatorer

Hvis du vil ha mer informasjon om de ulike beregningsoperatorene du kan bruke i formler, (< mindre enn, > større enn, = er lik, <> ikke lik og så videre), kan du se denne artikkelen: Beregningsoperatorer og prioritet.

Bruke HVIS til å sjekke om en celle er tom

Noen ganger må du sjekke om en celle er tom, vanligvis fordi du ikke vil at en formel skal vise et resultat uten inndata.

Formelen i celle E2 er =HVIS(D2=1,"Ja",HVIS(D2=2,"Nei","Kanskje"))

I dette tilfellet bruker vi HVIS med ERTOM-funksjonen:

  • =HVIS(ERTOM(D2), "Tom", "Ikke tom")

Som sier HVIS(D2 er tom, returner resultatet «Tom», og hvis ikke, returner «Ikke tom»). Du kan også bruke din egen formel for «Ikke tom»-betingelsen. I neste eksempel bruker vi «» i stedet for ERTOM. I praksis betyr «» «ingenting».

Sjekk om en celle er tom – formel i celle E2 er =HVIS(ERTOM(D2),"Tom","Ikke tom")
  • =HVIS(D3="","Tom", "Ikke tom")

Denne formelen sier HVIS(D3 er tom, returner resultatet «Tom», og hvis ikke, returner «Ikke tom»). Her er et eksempel på en svært vanlig måte å bruke «» på for å hindre at en formel beregner hvorvidt en underordnet celle er tom:

  • =HVIS(D3="","",DinFormel())

    HVIS(D3 er tom, skal ingenting gis i resultatet, hvis den ikke er tom, beregnes en egen formel).

Nestede HVIS-eksempel

Der enkle HVIS-funksjoner bare har to resultater (Sann eller Usann), kan nestede HVIS-funksjoner ha fra 3 til 64 resultater.

Bruk "" for å finne en tom celle – formel i celle E3 er =HVIS(D3="","Tom","Ikke tom")
  • =HVIS(D2=1,"JA",HVIS(D2=2,"Nei","Kanskje"))

I illustrasjonen ovenfor er formelen i E2: HVIS(D2 er lik 1; returner «Ja»; og hvis ikke HVIS(D2 er lik 2; returner «Nei»; ellers returner «Kanskje»). Vær oppmerksom på at det er to høyreparenteser på slutten av formelen. De er nødvendige for å fullføre begge av HVIS-funksjonene, og hvis du prøver å angi formelen uten begge de avsluttende parentesene, prøver Excel å rette den for deg.

En liten advarsel

Selv om du kan neste opptil 64 forskjellige HVIS-funksjoner med Excel, anbefales det ikke å gjøre dette. Hvorfor?

  • Flere HVIS-uttrykk sammen krever mer oppmerksomhet, slik at de bygges opp riktig. Du må kontrollere at logikken kan kalkulere riktig gjennom hver betingelse helt frem til slutten. Hvis du ikke nester HVIS-uttrykkene 100 prosent nøyaktig, fungerer de kanskje 75 prosent av tiden, men returnerer uventede resultater 25 prosent av tiden. Sannsynligheten for å få øye på de 25 prosentene er liten.

  • Flere HVIS-setninger kan bli veldig vanskelig å vedlikeholde, særlig når du kommer tilbake litt senere og prøver å finne ut hva du, eller enda verre, noen andre prøvde å gjøre.

  • Flere HVIS-setninger krever flere åpne og avsluttende parenteser (), som kan være vanskelig å behandle avhengig av hvor kompleks formelen blir.

Vanlige problemer

Problem

Hva gikk galt

0 (null) i celle

Det var ikke noe argument for argumentet verdi_hvis_sann eller verdi_hvis_usann. Legg til argumentteksten i de to argumentene eller legg til SANN eller USANN i argumentet, slik at riktig verdi blir returnert.

#NAVN? i celle

Dette betyr vanligvis at formelen er feilstavet.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Video: Avanserte HVIS-funksjoner

HVIS.SETT-funksjon (Office 365, Excel 2016 og senere)

Avanserte HVIS-funksjoner – arbeide med nestede formler og unngå feller

Opplæringsvideoer: Avanserte HVIS-funksjoner

ANTALL.HVIS-funksjonen teller verdier basert på ett enkelt vilkår

ANTALL.HVIS.SETT-funksjonen teller verdier basert på flere vilkår

SUMMERHVIS-funksjonen summerer verdier basert på ett enkelt vilkår

SUMMER.HVIS.SETT-funksjonen summerer verdier basert på flere vilkår

OG-funksjonen

ELLER-funksjonen

FINN.RAD-funksjonen

Oversikt over formler i Excel

Unngå formler med feil

Bruke feilkontroll for å oppdage feil i formler

Logiske funksjoner

Funksjoner i Excel

Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×