FORSKYVNING (funksjon)

Denne artikkelen beskriver formelsyntaks for og bruk av funksjonen FORSKYVNING i Microsoft Excel.

Beskrivelse

Returnerer en referanse til et område som består av et angitt antall rader og kolonner fra en celle eller et celleområde. Referansen som returneres, kan være en enkelt celle eller et celleområde. Du kan angi antallet rader og kolonner som skal returneres.

Syntaks

FORSKYVNING(referanse; rader; kolonner; [høyde]; [bredde])

Syntaksen for funksjonen FORSKYVNING har følgende argumenter:

  • Referanse    Obligatorisk. Referansen som du vil basere forskyvningen på. Referansen må referere til en celle eller et område av tilstøtende celler, ellers returnerer FORSKYVNING feilverdien #VERDI!.

  • Rader    Obligatorisk. Antallet rader, opp eller ned, som du vil at øvre venstre celle skal referere til. Hvis 5 brukes som argument for raden, angis det at øvre venstre celle i referansen er fem rader under referansen. Rader kan være positive (under startreferansen) eller negative (over startreferansen).

  • Kolonner    Obligatorisk. Antallet kolonner, til høyre eller venstre, som du vil at øvre venstre celle i resultatet skal referere til. Brukes 5 som argument for kolonnen, angis det at øvre venstre celle i referansen er fem kolonner til høyre i referansen. Kolonner kan være positive (til høyre for startreferansen) eller negative (til venstre for startreferansen).

  • Høyde    Valgfritt. Høyden, i antall rader, som du vil at den returnerte referansen skal være. Høyde må være et positivt tall.

  • Bredde    Valgfritt. Bredden, i antall kolonner, som du vil at den returnerte referansen skal være. Bredde må være et positivt tall.

Merknader

  • Hvis rader og kolonner forskyver referansen over kanten på regnearket, returnerer FORSKYVNING feilverdien #REF!.

  • Hvis høyde eller bredde utelates, antas det det at høyde og bredde er lik referansen.

  • FORSKYVNING flytter ingen celler og endrer ikke utvalget, men returnerer bare en referanse. FORSKYVNING kan brukes med alle funksjoner som venter et referanseargument. Formelen SUMMER(FORSKYVNING(C2;1;2;3;1)) beregner totalverdien av et område med 3 rader og 1 kolonne som er 1 rad under og 2 kolonner til høyre for celle C2.

Eksempel

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Formel

Beskrivelse

Resultat

=FORSKYVNING(D3;3;-2;1;1)

Viser verdien i celle B6 (4)

4

=SUMMER(FORSKYVNING(D3:F5;3;-2;0;3;3))

Summerer området B6:C8

34

=FORSKYVNING(D3; -3; -3)

Returnerer en feil fordi referansen er til et ikke-eksisterende område på regneaket.

#REF!

Data

Data

4

10

8

3

3

6

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×