FEIL.TYPE (funksjon)

Denne artikkelen beskriver formelsyntaks for og bruk av funksjonen FEIL.TYPE i Microsoft Excel.

Beskrivelse

Returnerer et tall som svarer til en av feilverdiene i Microsoft Excel, eller returnerer feilen #I/T hvis det ikke eksisterer noen feil. Du kan bruke FEIL.TYPE i en HVIS-funksjon hvis du vil teste for en feilverdi og returnere en tekststreng, for eksempel en melding, i stedet for feilverdien.

Syntaks

FEIL.TYPE(feilverdi)

Syntaksen for funksjonen FEIL.TYPE har følgende argumenter:

  • Feilverdi    Obligatorisk. Dette er feilverdien som du vil finne identifiseringsnummeret til. Selv om feilverdi kan være en faktisk feilverdi, vil argumentet vanligvis være en referanse til en celle som inneholder en formel du vil teste.

Hvis feilverdi er lik

Returnerer funksjonen FEIL.TYPE

#NULL!

1

#DIV/0!

2

#VERDI!

3

#REF!

4

#NAVN?

5

#NUM!

6

#I/T

7

#HENTER_DATA

8

Annet

#I/T

Eksempel

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Data

#NULL!

#DIV/0!

Formel

Beskrivelse

Resultat

=FEIL.TYPE(A2)

Tallet som svarer til #NULL!-feilen (1)

1

=HVIS(FEIL.TYPE(A3)<3;VELG(FEIL.TYPE(A3);"Områdene i formelen krysser ikke hverandre";" Deler på null"))

Kontrollerer celle A3 for å finne ut om cellen inneholder feilverdien #NULL! eller #DIV/0!. Hvis den gjør det, blir tallet for feilverdien brukt i regnearkfunksjonen VELG for å vise én av to meldinger. Hvis ikke returneres feilverdien #I/T.

Deler på null

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×