ELLER (funksjon)

Bruk ELLER-funksjonen, som er en av de logiske funksjonene, for å finne ut om noen av vilkårene i en test er SANN.

Eksempel

Eksempler på bruk av ELLER-funksjonen.

ELLER-funksjonen returnerer SANN hvis noen av argumentene evalueres til SANN, og USANN hvis alle argumenter evalueres til USANN.

En vanlig bruk av ELLER-funksjonen er å utvide nytten av andre funksjoner som utfører logiske tester. For eksempel utfører HVIS-funksjonen en logisk test, hvor den returnere en verdi hvis testen evalueres til SANN og en annen verdi hvis testen evalueres til USANN. Ved hjelp av ELLER-funksjonen som logisk_test-argument for HVIS-funksjonen kan du teste mange forskjellige forhold og ikke bare ett.

Syntaks

ELLER(Logisk1; [logisk2];...)

ELLER-funksjonens syntaks har følgende argumenter:

Argument

Beskrivelse

Logisk1

Obligatorisk. Den første betingelsen du vil teste som kan evalueres til SANN eller USANN.

Logisk2, ...

Valgfritt. Andre tilstander du vil teste som kan evalueres til SANN eller USANN, opptil maksimalt 255 betingelser.

Merknader

  • Argumentene må evaluere til logiske verdier som SANN eller USANN, eller i matriser eller referanser som inneholder logiske verdier.

  • Hvis et matrise- eller referanseargument inneholder tekst eller tomme celler, ignoreres disse verdiene.

  • Hvis det angitte området ikke inneholder noen logiske verdier, vil ELLER-funksjonen returnere en #VALUE!-feilverdi.

  • Du kan bruke en ELLER-matriseformel for å se om en verdi forekommer i en matrise. Hvis du vil angi en matriseformel, trykker du CTRL+SKIFT+ENTER.

Eksempler

Her er noen generelle eksempler på bruk av ELLER alene og i forbindelse med HVIS.

Eksempler på bruk av ELLER-funksjonen med HVIS-funksjonen.

Formel

Beskrivelse

=ELLER(A2>1,A2<100)

Viser SANN hvis A2 er større enn 1 ELLER mindre enn 100, viser ellers USANN.

=HVIS(ELLER(A2>1,A2<100),A3,"Verdien er utenfor området")

Viser verdien i celle A3 hvis den er mindre enn 1 ELLER mindre enn 100, ellers vises meldingen «Verdien er utenfor området».

=HVIS(ELLER(A2<0,A2>50),A2,"Verdien er utenfor området")

Viser verdien i celle A2 hvis den er mindre enn 0 ELLER større enn 50, ellers vises det en melding.

Beregning av salgsprovisjoner

Her er en ganske vanlig situasjon der må vi beregne om selgere kvalifiserer for en kommisjon ved hjelp av HVIS og ELLER.

Eksempel på bruk av HVIS og ELLER til å beregne salgsprovisjoner.
  • =HVIS(ELLER(B14>=$B$4; C14>=$B$5); B14*$B$6,0)HVIS totalsalget er større enn eller lik (>=) salgsmålet, ELLER kontoene er større enn eller lik (>=) kontomålet, multipliseres totalsalget med provisjonsprosenten – ellers returneres 0.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Beslektede emner

Video: Avanserte HVIS-funksjoner
Lær hvordan du bruker nestede funksjoner i en formel
HVIS-funksjonen
OG-funksjonen
IKKE-funksjonen
Oversikt over formler i Excel
Hvordan unngå formler med feil
Bruk feilkontroll for å oppdage feil i formler
Hurtigtaster i Excel 2016 for Windows
Hurtigtaster i Excel 2016 for Mac
Logiske funksjoner (referanse)
Excel-funksjoner(alfabetisk)
Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×