Bruke nestede funksjoner i en formel

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

Bruke en funksjon som et av argumentene i en formel som bruker en funksjon kalles nestenivåer, og vi vil referere til funksjonen som en nestet funksjon. Hvis du for eksempel ved å neste funksjonen GJENNOMSNITT og summer i argumentene til Hvis-funksjonen, summerer formelen nedenfor et sett med tall(G2:G5) bare hvis gjennomsnittet av et annet sett med tall (F2: F5) er større enn 50. Ellers returneres 0.

Nestede funksjoner

GJENNOMSNITT og summer er nestet i Hvis-funksjonen.

Du kan neste opptil 64 nivåer med funksjoner i en formel.

  1. Klikk i cellen der du vil sette inn formelen.

  2. Hvis du vil begynne formelen med funksjonen, klikker du Sett inn funksjon Knapp på formelen stolpe Knapp .

    Likhetstegnet (=) settes inn automatisk for deg.

  3. Velg Alle i boksen Eller velg en kategori.

    Hvis du kjenner til funksjonskategoriene, kan du også velge en kategori.

    Hvis du ikke er sikker på hvilken funksjon du skal bruke, kan du skrive inn et spørsmål som beskriver hva du vil gjøre, i boksen Søk etter en funksjon ("legge sammen tall" returnerer for eksempel funksjonen SUMMER).

  4. Hvis du vil sette inn en annen funksjon som argument, skriver du inn funksjonen i den argumentboksen du vil bruke.

    Delene av formelen som vises i dialogboksen Funksjonsargumenter, viser funksjonen du valgte i det forrige trinnet.

    Hvis du klikker HVIS, viser dialogboksen Funksjonsargumenter argumentene for HVIS-funksjonen. Hvis du vil neste til en annen funksjon, kan du skrive den inn i argumentboksen. Du kan for eksempel angi SUM(G2:G5) i boksen Verdi_hvis_sann for HVIS-funksjonen.

  5. Skriv inn eventuelle argumenter som er nestet, for å fullføre formelen.

    I stedet for å skrive inn cellereferanser, kan du også velge cellene du vil referere. Klikk Knapp for å minimere dialogboksen, merk cellene du vil referere, og klikk deretter Knapp for å vise dialogboksen igjen.

    Tips!: Hvis du vil ha mer informasjon om funksjonen og argumentene, klikker du Hjelp med denne funksjonen.

  6. Når du har valgt argumentene for formelen, klikker du OK.

  1. Klikk i cellen der du vil sette inn formelen.

  2. Hvis du vil begynne formelen med funksjonen, klikker du Sett inn funksjon Knapp på formelen stolpe Knapp .

  3. Velg alle i dialogboksen Sett inn funksjon i boksen Velg en kategori.

    Hvis du kjenner til funksjonskategoriene, kan du også velge en kategori.

  4. Hvis du vil angi en annen funksjon som argument, skriver du inn funksjonen i argumentboksen i Formelverktøy eller direkte i cellen.

  5. Skriv inn eventuelle argumenter som er nestet, for å fullføre formelen.

  6. Når du har fullført argumentene for formelen, trykker du ENTER.

Eksempler

Følgende viser et eksempel på bruk av nestede Hvis-funksjoner til å tilordne en bokstavkarakter til en numerisk teste poengsum.

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Poengsum

45

90

78

Formel

Beskrivelse

Resultat

'=HVIS(A2>89;"A";HVIS(A2>79;"B";HVIS(A2>69;"C";HVIS(A2>59;"D";"F"))))

Bruker nestede HVIS-betingelser til å tilordne en bokstavkarakter til poengsummen i celle A2.

=HVIS(A2>89;"A";HVIS(A2>79;"B";HVIS(A2>69;"C";HVIS(A2>59;"D";"F"))))

'=HVIS(A3>89;"A";HVIS(A3>7;"B";HVIS(A3>69;"C";HVIS(A3>59;"D";"F"))))

Bruker nestede HVIS-betingelser til å tilordne en bokstavkarakter til poengsummen i celle A3.

=HVIS(A3>89;"A";HVIS(A3>7;"B"; HVIS(A3>69;"C";HVIS(A3>59;"D";"F"))))

'=HVIS(A4>89;"A";HVIS(A4>79;"B";HVIS(A4>69;"C";HVIS(A4>59;"D";"F"))))

Bruker nestede HVIS-betingelser til å tilordne en bokstavkarakter til poengsummen i celle A4.

=HVIS(A4>89;"A";HVIS(A4>79;"B";HVIS(A4>69;"C";HVIS(A4>59;"D";"F"))))

Tips: 

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet, eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Se også

Video: Nestede Hvis-funksjoner

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×