Bruke matrisekonstanter i matriseformler

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

Når du angir en matriseformel, du oftest bruker et celleområde i regnearket, men du trenger ikke å. Du kan også bruke matrisekonstanter, verdiene du angir bare på formellinjen inne i parenteser: {}. Deretter kan du Gi navn til konstanten slik det er enklere å bruke på nytt.

Du kan bruke konstanter i matriseformler eller alene.

  1. Skriv inn en venstre klammeparentes, de ønskede verdiene og en avsluttende klammeparentes i matriseformel. Her er et eksempel: = SUMMER (A1:E1* {1,2,3,4,5})

    Konstantene står i klammeparenteser ({}), som du må skrive manuelt.

  2. Skriv resten av formelen, og trykk CTRL+SKIFT+ENTER.

    Formelen ser omtrent slik {= SUMMER (A1:E1* {1,2,3,4,5})}, og resultatet vil se slik ut:


    En matrisekonstant nestet i en SUMMER-formel

    Formelen multipliserer A1 med 1 og B1 med 2 osv., og sparer deg fra å måtte skrive 1;2;3;4;5 i celler i regnearket.

Bruke en konstant til å skrive inn verdier i en kolonne

Hvis du vil skrive inn verdier i én enkelt kolonne, for eksempel tre celler i kolonne C, gjør du følgende:

  1. Merk cellene du vil bruke.

  2. Skriv inn et likhetstegn og konstanten. Skille verdier i konstanten med semikolon, ikke komma, og hvis du skriver inn tekst, omslutter du den med doble anførselstegn. For eksempel: = {"Kvartal 1";" Quarter2";" Kvartal 3"}

  3. Trykk CTRL+SKIFT+ENTER. Konstanten ser slik ut:

    En loddrett matrisekonstant som bruker tekst

    Dette kalles en endimensjonal loddrett konstant.

Bruke en konstant til å skrive inn verdier i en rad

Hvis du raskt vil skrive inn verdier i én enkelt rad, for eksempel celle F1, G1 og H1, gjør du følgende:

  1. Merk cellene du vil bruke.

  2. Skriv inn et likhetstegn og konstanten, men denne gangen du Skill verdier med komma, ikke semikolon. For eksempel: = {1,2,3,4,5}

  3. Trykk CTRL+SKIFT+ENTER, og konstanten ser slik ut:

    En endimensjonal vannrett matrisekonstant

    Dette kalles en endimensjonal vannrett konstant.

Bruke en konstant til å skrive inn verdier i flere kolonner og rader

  1. Merk de aktuelle cellene.

    Pass på at du merker samme antall rader og kolonner som du har antall verdier i konstanten. Hvis konstanten for eksempel skal skrive data til fire kolonner og tre rader, merker du tilsvarende antall kolonner og rader.

  2. Skriv et likhetstegn etterfulgt av konstanten. I dette tilfelle skiller du verdiene i hver rad med semikolon, og bruker omvendt skråstrek på slutten av hver rad. Eksempel:

    = {1,2,3,4; 5,6,7,8; 9,10,11,12}

  3. Trykk CTRL+SKIFT+ENTER.

    En todimensjonal matrisekonstant

    Dette kalles en todimensjonal konstant, fordi den fyller kolonner og rader. Du kan ikke lage en tredimensjonal konstant, fordi du ikke kan neste en konstant inne i en annen.

Bruke en konstant i en formel

Nå som du er kjent med matrisekonstanter, kan du se på et praktisk eksempel.

  • Skriv inn (eller kopier og lim inn) formelen nedenfor i en tom celle, og trykk deretter CTRL+SKIFT+ENTER.

    =SUM(A1:E1*{1;2;3;4;5})

    Verdien 85 vises i celle A3.

    Hva skjedde? Du multipliserte verdien i A1 med 1, verdien i celle B2 med 2, og så videre, deretter la SUMMER-funksjonen sammen disse resultatene. Du kan også skrive formelen slik: =SUMMER(A1*1;B1*2;C1*3;D1*4;E1*5)

Du kan også skrive begge sett med verdier som matrisekonstanter:

=SUMMER({3;4;5;6;7}*{1;2;3;4;5})

Du kan prøve dette ved å kopiere formelen, merke en tom celle og lime inn formelen i formellinjen og deretter trykke CTRL+SKIFT+ENTER. Samme resultat vises.

Kommentarer: Se etter følgende problemer hvis konstantene ikke fungerer:

  • Kontroller at verdiene er skilt med riktig tegn. Hvis du utelater et semikolon eller en omvendt skråstrek, eller hvis du setter tegnet på feil sted, kan det bli en feil i matrisekonstanten, eller det kan vises en advarsel.

  • Du kan ha merket et celleområde som ikke samsvarer med antallet elementer i konstanten. Hvis du for eksempel merker en kolonne med seks celler for bruk med en femcellers konstant, vises feilen #I/T i den tomme cellen. Hvis du ikke merker nok celler, utelates verdiene som ikke har en tilsvarende celle.

  • Du finner mer informasjon om matriseformler her:

Til toppen av siden

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×