Bruke matriseargumentet i en oppslagsfunksjon

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

Når du oppretter en formel ved hjelp av funksjonen FINN.RAD eller FINN.KOLONNE, angir du et matriseargument, som er et celleområde, for eksempel D2:F39. Funksjonen søker etter dataene du prøver å finne i det området

Matriseargumentet er alltid det andre argumentet i en FINN.RAD- eller FINN.KOLONNE-funksjon (det første er verdien du prøver å finne). Disse funksjonene fungerer ikke uten matriseargumentet .

Det første argumentet kan være en bestemt verdi som "41" eller "Berg", eller det kan være en cellereferanse, for eksempel F2. Det første argumentet kan se slik ut:

=FINN.RAD(F2;...

Matriseargumentet følger alltid oppslagsverdien, som dette:

=FINN.RAD(F2;B4:D39; ...

Celleområdet som er oppført i matriseargumentet, kan bruke relative eller absolutte cellereferanser. Hvis du skal kopiere formelen til andre celler, må du bruke absolutte cellereferanser (legg merke til $-symbolet), som dette:

=FINN.RAD(F2;$B$2:BD$39; ...

Hvis cellene i matriseargumentet er i et annet regneark i arbeidsboken, må argumentet inkludere arknavnet etterfulgt av et utropstegn. Formelen kan se slik ut:

=FINN.RAD(F2,Sheet2!$C$14:E$42, ...

Kolonnen som inneholder verdiene du prøver å finne, er det tredje argumentet du angir. Dette kalles oppslagskolonnen. Hvis verdiene du vil se, er i kolonne D (den tredje kolonnen i matrisen), er det siste argumentet 3.

=FINN.RAD(F2;B4:D39;3)

Selv om det er valgfritt anbefales det at du bruker et fjerde argument, enten Sann eller Usann. Bruk Usann hvis du leter etter et nøyaktig samsvar.

=FINN.RAD(F2,B4:D39,3,Usann)

Hvis du bruker Sann eller lar det fjerde argument stå tomt, returnerer funksjonen et omtrentlig samsvar med verdien i det første argumentet. Så hvis det første argument er Berg og du bruker Sann, returnerer FINN.RAD Berg, Bergset og så videre. Men hvis du bruker Usann blir resultatet bare Berg, det vil si nøyaktig samsvar. Som regel er det dette folk ønsker.

Hvis oppslagskolonnen (kolonnen du angir i tredje argument) ikke er sortert i stigende rekkefølge (A–Å eller laveste til høyeste tall), kan du få feil resultat.

Hvis du vil ha mer informasjon om FINN.RAD og FINN.KOLONNE, kan du se Oppslags- og referansefunksjoner (referanse).

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×