Bruke matriseargumentet i en oppslagsfunksjon

Obs!:  Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

Når du oppretter en formel som bruker funksjonene Finn.rad eller Finn.kolonne , kan du angi en Matriseargumentet, som er et celleområde, for eksempel D2:F39. Funksjonen søker området for dataene du prøver å finne.

Matriseargumentet er alltid det andre argumentet i en FINN.RAD- eller FINN.KOLONNE-funksjon (det første er verdien du prøver å finne). Disse funksjonene fungerer ikke uten matriseargumentet .

Det første argumentet kan være en bestemt verdi som "41" eller "Berg", eller det kan være en cellereferanse, for eksempel F2. Det første argumentet kan se slik ut:

=FINN.RAD(F2;...

Matriseargumentet følger alltid oppslagsverdien, som dette:

=FINN.RAD(F2;B4:D39; ...

Celleområdet som er oppført i matriseargumentet, kan bruke relative eller absolutte cellereferanser. Hvis du skal kopiere formelen til andre celler, må du bruke absolutte cellereferanser (legg merke til $-symbolet), som dette:

=FINN.RAD(F2;$B$2:BD$39; ...

Hvis cellene i matriseargumentet er i et annet regneark i arbeidsboken, må argumentet inkludere arknavnet etterfulgt av et utropstegn. Formelen kan se slik ut:

=FINN.RAD(F2,Sheet2!$C$14:E$42, ...

Kolonnen som inneholder verdiene du prøver å finne, er det tredje argumentet du angir. Dette kalles oppslagskolonnen. Hvis verdiene du vil se, er i kolonne D (den tredje kolonnen i matrisen), er det siste argumentet 3.

=FINN.RAD(F2;B4:D39;3)

Selv om det er valgfritt anbefales det at du bruker et fjerde argument, enten Sann eller Usann. Bruk Usann hvis du leter etter et nøyaktig samsvar.

=FINN.RAD(F2,B4:D39,3,Usann)

Hvis du bruker Sann eller lar det fjerde argument stå tomt, returnerer funksjonen et omtrentlig samsvar med verdien i det første argumentet. Så hvis det første argument er Berg og du bruker Sann, returnerer FINN.RAD Berg, Bergset og så videre. Men hvis du bruker Usann blir resultatet bare Berg, det vil si nøyaktig samsvar. Som regel er det dette folk ønsker.

Hvis oppslagskolonnen (kolonnen du angir i tredje argument) ikke er sortert i stigende rekkefølge (A–Å eller laveste til høyeste tall), kan du få feil resultat.

For mer informasjon om Finn.rad og Finn.kolonne, kan du se oppslags- og referansefunksjoner (referanse).

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×