Bruke funksjoner og nestede funksjoner i Excel-formler

Funksjoner er forhåndsdefinerte formler som utfører beregninger ved hjelp av bestemte verdier, kalt argumenter, i en bestemt rekkefølge eller struktur. Funksjoner kan brukes til å utføre enkle eller kompliserte beregninger. Du kan finne alle funksjonene i Excel på Formler-fanen på båndet:

Formler-fanen på båndet i Excel
  • Funksjonssynktaks i Excel

    Følgende eksempel på AVRUND-funksjonen som runder av et tall i celle A10, illustrerer syntaksen til en funksjon.

    Struktur på en funksjon

    1. Struktur Strukturen på en funksjon begynner med et likhetstegn (=), etterfulgt av funksjonens navn, en venstreparentes, argumentene til funksjonen atskilt med komma, og en høyreparentes.

    2. Funksjonsnavn. Hvis du vil ha en liste over tilgjengelige funksjoner, kan du klikke en celle og trykke SKIFT+F3. Dette vil starte dialogen Sett inn funksjon

    Formler i Excel – dialogboks for funksjonen Sett inn

    3. Argumenter. Argumenter kan være tall, tekst, logiske verdier som SANN eller USANN, matriser, feilverdier som #I/T eller cellereferanser. Argumentet du angir, må gi en gyldig verdi for argumentet. Argumenter kan også være konstanter, formler eller andre funksjoner.

    4. Verktøytips for argumenter. Et verktøytips med syntaksen og argumentene vises når du skriver inn funksjonen. Skriv for eksempel =AVRUND(, så vises verktøytipset. Verktøytips vises bare for innebygde funksjoner.

    Obs!: Du ikke trenger å skrive inn funksjoner med store bokstaver, som = AVRUND, da Excel automatisk vil endre til store bokstaver for funksjonsnavnet når du trykker ENTER. Hvis du feilstaver et funksjonsnavn, for eksempel =SUME(A1:A10) i stedet for = SUMMER(A1:A10), så vil Excel returnere feilmeldingen #NAME?

  • Skrive inn Excel-funksjoner

    Når du lager en formel som inneholder en funksjon, kan du bruke dialogboksen Sett inn funksjon for å få hjelp til å sette inn regnearkfunksjoner. Når du velger en funksjon fra dialogboksen Sett inn funksjon, vil Excel starte en funksjonsveiviser som viser navnet på funksjonen, alle argumentene, en beskrivelse av funksjonen og hvert enkelt argument, gjeldende resultat av funksjonen og gjeldende resultat av hele formelen.

    Veiviser for Excel-funksjon

    Du kan gjøre det enklere å opprette og redigere formler, og redusere skrivefeil og syntaksfeil ved hjelp av Autofullfør-formel. Når du har skrevet inn et = (likhetstegn) og de første bokstavene i en funksjon, vil Excel vise en dynamisk rullegardinliste med gyldige funksjoner, argumenter og navn som samsvarer med bokstavene. Du kan velge et element fra rullegardinlisten, og Excel vil sette det inn for deg.

    Autofullføring av formler i Excel

  • Neste Excel-funksjoner

    I noen tilfeller kan det være at du må bruke en funksjon som et av argumentene i en annen funksjon. I den følgende funksjonen brukes for eksempel en nestet GJENNOMSNITT-funksjon, og resultatet sammenlignes med verdien 50.

    Nestede funksjoner

    1. Funksjonene GJENNOMSNITT og SUMMER er nestet i IF-funksjonen.

    Gyldige resultater    Når en nestet funksjon brukes som et argument, må den nestede funksjonen returnere den samme verditypen som brukes i argumentet. Hvis for eksempel argumentet returnerer en SANN- eller USANN-verdi, må den nestede funksjonen returnere en SANN- eller USANN-verdi. Hvis funksjonen ikke gjør det, vises feilverdien #VERDI! i Excel.

    Grenser for nestenivåer    En formel kan inneholde opptil sju nivåer med nestede funksjoner. Når én funksjon (vi kaller denne Funksjon B) brukes som et argument i en annen funksjon (vi kaller denne for Funksjon A), fungerer Funksjon B som en funksjon på andre nivå. GJENNOMSNITT-funksjonen og SUMMER-funksjonen er for eksempel begge andrenivåfunksjoner hvis de brukes som argumenter for HVIS-funksjonen. En funksjon som nestes inne i den nestede GJENNOMSNITT-funksjonen, er da en tredjenivåfunksjon osv.

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×