Bruke SUMMERPRODUKT til å summere produktet av tilhørende verdier i én eller flere matriser

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

SUMMERPRODUKT bruker celleområder (eller matriser) som argumenter (delene av formelen som gjør at den fungerer). Den multipliserer elementene i matrisen og summerer deretter resultatet.

Dette eksemplet er en handleliste med én matriseliste som inneholder prisen for hver vare, og den andre matriselisten inneholder antall varer som skal kjøpes.

Priser og antall multipliseres og summeres deretter

  1. Du oppretter formelen ved å skrive inn =SUMMERPRODUKT(B3:B6;C3:C6) og trykke ENTER.

Hver celle i kolonne B multipliseres med tilsvarende celle i samme rad i celle C, og resultatene summeres. Det totale beløpet for dagligvarer er kr 216,00.

  1. Du skriver en lengre formel som gir samme resultat, type = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 og trykker Enter.

Når du har trykket ENTER, er resultatet det samme: kr 216,00. Celle B3 multipliseres med C3, og resultatet legges til resultatene for celle B4 x celle C4 og så videre. Tenk deg hvor mye enklere det er å bruke SUMMERPRODUKT hvis du har tusenvis (eller hundrevis) av rader.

Kommentarer: 

  • Kolonnene eller radene (matriser) må ha like lengder.

  • Hvis det er tekst i en celle i stedet for tall, behandles den som null.

Eksempel

Hvis du vil prøve SUMMERPRODUKT og matriser, finner du en Excel Online-arbeidsbok her med andre data enn dem som brukes i denne artikkelen.

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

En

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Resultat

'=SUMMERPRODUKT(A2:B4;D2:E4)

=SUMMERPRODUKT(A2:B4;D2:E4)

Multipliserer alle komponenter i de to matrisene (A2:B4 og D2:E4) og legger deretter sammen produktene \endash det vil si 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Hvis du vil ha en mer fullstendig opplevelse, kan du også åpne arbeidsboken i Excel. Klikk Excel-ikonet nederst til høyre i arbeidsboken  Excel-ikon i Excel Online , lagre filen på en praktisk plassering på datamaskinen, og deretter åpner du den.

Til toppen av siden

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×