Bruk HVIS-funksjoner med OG-, ELLER- og IKKE-funksjoner

Med HVIS-funksjoner kan du foreta en logisk sammenligning mellom en verdi og hva du forventer: Test for en betingelse og returner et resultat hvis denne betingelsen er SANN eller USANN.

  • =HVIS(noe er SANN, gjøre noe, ellers gjør noe annet)

Men hva om du må teste flere vilkår? La oss si at alle vilkår må være SANN eller USANN (OG), eller bare én betingelse må være SANN eller USANN (ELLER), eller hvis du vil kontrollere om en betingelse IKKE oppfyller vilkårene dine? Alle tre funksjoner kan brukes på egenhånd, men det er vanligere knytte dem sammen med HVIS-funksjoner.

Bruk HVIS-funksjonen sammen med OG, ELLER og IKKE for å utføre flere evalueringer hvis betingelsene er SANN eller USANN.

Syntaks

  • HVIS(OG()) – HVIS(OG(logisk1, [logisk2], ...), verdi_hvis_sann, [verdi_hvis_usann]))

  • HVIS(ELLER()) – HVIS(ELLER(logisk1, [logisk2], ...), verdi_hvis_sann, [verdi_hvis_usann]))

  • HVIS(IKKE()) – HVIS(IKKE(logisk1), verdi_hvis_sann, [verdi_hvis_usann]))

Argumentnavn

Beskrivelse

logisk_test (obligatorisk)

Betingelsen du vil teste.

verdi_hvis_sann (obligatorisk)

Verdien som returneres hvis resultatet av logisk_test er SANN.

verdi_hvis_usann (valgfritt)

Verdien som returneres hvis resultatet av logisk_test er USANN.

Her er en oversikt over hvordan du strukturerer OG-, ELLER- og IKKE-funksjoner enkeltvis. Når du kombinerer hver av dem med en HVIS-funksjon, ser de slik ut:

  • OG – =HVIS(OG(noe er SANN, noe annet er SANN), verdi hvis SANN, verdi hvis USANN)

  • ELLER – =HVIS(ELLER(noe er SANN, noe annet er SANN), verdi hvis SANN, verdi hvis USANN)

  • IKKE – =HVIS(IKKE(noe er SANN), verdi hvis SANN, verdi hvis USANN)

Eksempler

Følgende er eksempler på noen vanlige nestede HVIS(OG()), HVIS(ELLER()) og HVIS(IKKE())-setninger. OG- og ELLER-funksjonene kan støtte opptil 255 individuelle betingelser, men det er ikke god praksis å bruke mer enn noen få, fordi komplekse, nestede formler kan bli svært vanskelig å bygge, teste og vedlikeholde. IKKE-funksjonen kan bare ha én betingelse.

Eksempler på bruk av HVIS med OG, ELLER og IKKE for å evaluere tallverdier og tekst

Her vises formlene i henhold til sin logiske funksjon:

Formel

Beskrivelse

=HVIS(OG(A2>0,B2<100),SANN, USANN)

Hvis A2 (25) er større enn 0, og B2 (75) er mindre enn 100, vil den returnere SANN, ellers returnerer den USANN. I dette tilfellet er begge betingelsene SANN, så SANN blir returnert.

=HVIS(OG(A3="Rød",B3="Grønn"),SANN,USANN)

Hvis A3 ("blå") = "Rød", og B3 ("grønn") er lik "grønn", returneres SANN, ellers returneres USANN. I dette tilfellet er bare den første betingelsen sann, så USANN returneres.

=HVIS(ELLER(A4>0,B4<50),SANN, USANN)

Hvis A4 (25) er større enn 0, ELLER B4 (75) er mindre enn 50, returneres SANN, ellers returneres USANN. I dette tilfellet er bare den første betingelsen SANN, men siden ELLER bare krever at ett argument er sann, returnerer formelen SANN.

=HVIS(ELLER(A5="Rød",B5="Grønn"),SANN,USANN)

Hvis A5 ("blå") er lik "Rød", ELLER B5 ("grønn") er lik "grønn", returneres SANN, ellers returneres USANN. I dette tilfellet er det andre argumentet SANN, slik at formelen returnerer SANN.

=HVIS(IKKE(A6>50),SANN,USANN)

Hvis A6 (25) IKKE er større enn 50, returneres SANN, ellers returneres USANN. I dette tilfellet er 25 ikke større enn 50, så formelen returnerer SANN.

=HVIS(IKKE(A7="Rød"),SANN,USANN)

Hvis A7 ("Blå") IKKE er lik "Rød", returneres SANN, ellers returneres USANN.

Vær oppmerksom på at alle eksemplene har en høyreparentes etter at deres respektive betingelser er angitt. De gjenstående SANN/USANN-argumentene blir deretter etterlatt som en del av det ytre HVIS-utrykket. Du kan også erstatte tekst eller numeriske verdier for SANN/USANN-verdier som skal returneres i eksemplene.

Her er noen eksempler på bruk av OG, ELLER og IKKE for å evaluere datoer.

Eksempler på bruk av HVIS med OG, ELLER og IKKE for å evaluere datoer

Her vises formlene i henhold til sin logiske funksjon:

Formel

Beskrivelse

=HVIS(A2>B2,SANN,USANN)

Hvis A2 er større enn B2, returneres SANN, ellers returneres USANN. 03/12/14 er ikke større enn 01/01/14, så formelen returnerer SANN.

=HVIS(OG(A3>B2,A3<C2),SANN,USANN)

Hvis A3 er større enn B2, OG A3 er mindre enn C2, returneres SANN, ellers returneres USANN. I dette tilfellet er begge argumentene SANN, så formelen returnerer SANN.

=HVIS(ELLER(A4>B2,A4<B2+60),SANN,USANN)

Hvis A4 er større enn B2, ELLER A4 er mindre enn B2 + 60, returneres SANN, ellers returneres USANN. I dette tilfellet er det første argumentet SANN, men det andre er USANN. Siden ELLER bare krever at et av argumentene er SANN, returnerer formelen SANN. Hvis du bruker veiviseren for Evaluer formel fra Formel-fanen, ser du hvordan Excel evaluerer formelen.

=HVIS(IKKE(A5>B2),SANN,USANN)

Hvis A5 ikke er større enn B2, returneres SANN, ellers returneres USANN. I dette tilfellet er A5 større enn B2, så formelen returnerer USANN.

Eksempel på Evaluer formel-veiviseren

Bruke OG, ELLER og IKKE med betinget formatering

Du kan også bruke OG, ELLER og IKKE til å angi kriterier for betinget formatering med formelalternativet. Når du gjør dette, kan du utelate HVIS-funksjonen og bruke OG, ELLER og IKKE på egenhånd.

Gå til Hjem-fanen, klikk Betinget formatering > Ny regel. Velg deretter alternativet Bruk en formel til å fastslå hvilke celler som skal formateres , skriv inn formelen og bruk et valgfritt format.

Betinget formatering > Rediger regel-dialogboksen som viser formelmetoden

Her er hvordan formlene vil se ut, med eksempelet med datoer vi brukte tidligere.

Eksempel på bruk av OG, ELLER og IKKE som tester for Betinget formatering


Formel

Beskrivelse

=A2>B2

Hvis A2 er større enn B2, må du formatere cellen, ellers trenger du ikke gjøre noe.

=OG(A3>B2,A3<C2)

Hvis A3 er større enn B2 OG A3 er mindre enn C2, må du formatere cellen, ellers trenger du ikke gjøre noe.

=ELLER(A4>B2,A4<B2+60)

Hvis A4 er større enn B2 ELLER A4 er mindre enn B2 pluss 60 (dager), må du formatere cellen, ellers trenger du ikke gjøre noe.

=IKKE(A5>B2)

Hvis A5 IKKE er større enn B2, må du formatere cellen, ellers trenger du ikke gjøre noe. I dette tilfellet er A5 større enn B2, så resultatet returnerer USANN. Hvis du skulle endre formelen slik at =IKKE(B2>A5), vil SANN returneres og cellen formateres.

Merknad: En vanlig feil er å skrive inn en formel til betinget formatering uten likhetstegnet (=). Hvis du gjør dette, ser du at dialogboksen for Betinget formatering vil legge til likhetstegn og anførselstegn i formelen – ="ELLER(A4>B2,A4<B2+60)", så du må fjerne anførselstegnene for at formelen skal svare riktig.

Til toppen av siden

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Se en video om hvordan du bruker HVIS-funksjonen

Lær hvordan du bruker nestede funksjoner i en formel

HVIS-funksjonen

OG-funksjonen

ELLER-funksjonen

IKKE-funksjonen

Oversikt over formler i Excel

Slik unngår du formler med feil

Bruk feilkontroll for å oppdage feil i formler

Hurtigtaster i Excel for Windows

Hurtigtaster i Excel for Mac

Logiske funksjoner (referanse)

Excel-funksjoner (alfabetisk)

Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×