ANTALL.HVIS (funksjon)

Bruk ANTALL.HVIS, en av de statistiske funksjonene, til å telle antall celler som oppfyller et vilkår, for eksempel å telle antall ganger en bestemt by vises i en kundeliste.

På det enkleste så sier ANTALL.HVIS:

  • =ANTALL.HVIS (Hvor ønsker du å lete? Hva vil du lete etter?)

Eksempel:

  • =ANTALL.HVIS(A2:A5,"London")

  • =ANTALL.HVIS(A2:A5;A4)

Nettleseren støtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

ANTALL.HVIS(område, vilkår)

Argumentnavn

Beskrivelse

område    (obligatorisk)

Cellegruppen du vil telle. Området kan inneholde tall, matriser, et navngitt område eller referanser som inneholder tall. Tomme celler og tekstverdier ignoreres.

Lær hvordan du merker områder i et regneark.

vilkår    (obligatorisk)

Et tall, et uttrykk, en cellereferanse eller tekststreng som definerer hvilke celler som skal telles.

Du kan for eksempel bruke et tall som 32, en sammenligning som ">32", en celle som B4 eller et ord som "epler".

ANTALL.HVIS bruker bare et enkelt vilkår. Bruk ANTALL.HVIS.SETT hvis du vil bruke flere vilkår.

Eksempler

Hvis du vil bruke disse eksemplene i Excel, kopierer du dataene i tabellen nedenfor og limer dem inn i celle A1 i et nytt regneark.

Data

Data

epler

32

appelsiner

54

fersken

75

epler

86

Formel

Beskrivelse

=SUMMERHVIS(A2:A5;"epler")

Teller antall celler med epler i cellene A2 til og med A5. Resultatet er to.

=ANTALL.HVIS(A2:A5;A4)

Teller antall celler med ferskener (verdien i A4) i cellene A2 til og med A5. Resultatet er 1.

=ANTALL.HVIS(A2:A5,A2)+ANTALL.HVIS(A2:A5,A3)

Teller antallet epler (verdien i A2) og appelsiner (verdien i A3) i cellene A2 til og med A5. Resultatet er 3. Denne formelen bruker ANTALL.HVIS to ganger til å spesifisere flere vilkår, ett vilkår per uttrykk. Du kan også bruke ANTALL.HVIS.SETT-funksjonen.

=ANTALL.HVIS(B2:B5;">55")

Teller antall celler med en verdi som er høyere enn 55 i cellene B2 til og med B5. Resultatet er to.

=ANTALL.HVIS(B2:B5;"<>"&B4)

Teller antall celler med en verdi som ikke er lik 75, i cellene B2 til og med B5. &-tegnet slår sammen sammenligningsoperator <> (ikke lik) og verdien i B4 for å lese =ANTALL.HVIS(B2:B5;"<>75"). Resultatet er 3.

=ANTALL.HVIS(B2:B5;">=32")-ANTALL.HVIS(B2:B5;">85")

Teller antall celler med en verdi som er større enn (>) eller lik (=) 32 og mindre enn (<) eller lik (=) 85, i cellene B2 til og med B5. Resultatet er 3.

=ANTALL.HVIS(A2:A5;"*")

Teller antall celler som inneholder tekst i cellene A2 til og med A5. Jokertegnet * brukes til å sammenligne alle tegn. Resultatet er 4.

=ANTALL.HVIS(A2:A5;"?????es")

Teller antall celler som har nøyaktig 7 tegn som slutter med bokstavene es, i cellene A2 til og med A5. Spørsmålstegnet (?) brukes som jokertegn til å sammenligne individuelle tegn. Resultatet er 2.

Vanlige problemer

Problem

Hva gikk galt

Feil verdi returneres for lange strenger.

Funksjonen ANTALL.HVIS returnerer uriktige resultater når du bruker den til å sammenligne strenger som er lengre enn 255 tegn.

Bruk funksjonen KJEDE.SAMMEN eller kjede-sammen-operatoren & til å sammenligne strenger som er lengre enn 255 tegn. For eksempel, =ANTALL.HVIS(A2:A5;"lang streng"&"en annen lang streng").

Ingen verdi returneres når du forventer en verdi.

Pass på at du omgir vilkårargumentet med anførselstegn.

En ANTALL.HVIS-formel mottar en #VERDI!-feil når du refererer til et annet regneark.

Denne feilen oppstår når formelen som inneholder funksjonen refererer til celler eller et område i en lukket arbeidsbok, og cellene beregnes. For at denne funksjonen skal fungere, må den andre arbeidsboken være åpen.

Anbefalt fremgangsmåte

Gjør du dette

Hvorfor

Vær oppmerksom på at ANTALL.HVIS ignorerer store og små bokstaver i tekststrenger.

Det skilles ikke mellom små og store bokstaver i vilkår. Strenger som «epler» og «EPLER» sammenligner derfor med samme celler.

Bruke jokertegn.

Jokertegnene spørsmålstegn (?) og stjerne (*) kan brukes i vilkår. Et spørsmålstegn sammenligner et hvilket som helst enkelttegn, og en stjerne sammenligner alle rekkefølger av tegn. Hvis du vil finne et faktisk spørsmålstegn eller stjerne, må du taste inn en tilde (~) før tegnet.

ANTALL.HVIS (A2:A5;"eple?" teller alle tilfeller av "eple" med en siste bokstav som kan variere.

Kontroller at dataene ikke inneholder feilaktige tegn.

Når du teller tekstverdier, må du kontrollere at dataene i denne kolonnen ikke har innledende mellomrom, etterfølgende mellomrom, inkonsekvent bruk av rette og krøllete anførselstegn eller tegn som ikke kan skrives ut. I disse tilfellene, kan ANTALL.HVIS returnere en uventet verdi.

Prøv å bruke RENSK-funksjonen eller TRIMME-funksjonen.

Bruk navngitte områder av praktiske årsaker

ANTALL.HVIS støtter navngitte områder i en formel (for eksempel =ANTALL.HVIS (frukt,">=32")-ANTALL.HVIS (frukt,">85"). Det navngitte området kan være i gjeldende regneark, et annet regneark i samme arbeidsbok eller fra en annen arbeidsbok. Hvis du vil referere fra en annen arbeidsbok, må den andre arbeidsboken også være åpen.

Merknad: ANTALL.HVIS-funksjonen teller ikke cellene basert på cellebakgrunn eller skriftfarge. Excel støtter imidlertid brukerdefinerte funksjoner (UDF-er) ved hjelp av Microsoft Visual Basic for Applications (VBA)-handlinger på cellene basert på bakgrunnen eller skriftfarge. Her er et eksempel på hvordan du kan telle antall celler med bestemt cellefarge ved hjelp av VBA.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Bruke ANTALLA-funksjonen til å telle celler som ikke er tomme

Bruke ANTALL.HVIS.SETT-funksjonen til å telle celler som oppfyller flere kriterier

Se en video om hvordan du bruker ANTALL.HVIS.SETT-funksjonen

SUMMER.HVIS-funksjonen legger bare til verdier som oppfyller et enkeltkriterium.

SUMMER.HVIS.SETT-funksjonen legger bare til verdier som oppfyller flere kriterier.

HVIS.SETT-funksjonen (Office 365, Excel 2016 og senere)

Bruke TRIMME-funksjonen til å fjerne innledende og avsluttende mellomrom fra celler

Bruke RENSK-funksjonen til å fjerne tegn som ikke skrives ut fra celler

Oversikt over formler i Excel

Slik unngår du ødelagte formler

Oppdage feil i formler

Statistiske funksjoner

Excel-formler (alfabetisk)

Excel-funksjoner (etter kategori)

Bruke SUMMER.HVIS og relaterte funksjoner til raske dataanalyser (kostnadsfri forhåndsvisning)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×