Menyelitkan helaian data kepada borang

Penting: Artikel ini diterjemahkan oleh mesin, lihatlah notis penafian. Sila dapatkan versi Bahasa Inggeris artikel ini di sini sebagai rujukan anda

Helaian Data ialah pandangan ringkas data yang disusun dalam baris dan lajur. Jika anda dwiklik Jadual dalam anak tetingkap navigasi, Microsoft Office Access 2007 memaparkan Jadual sebagai helaian data. Disebabkan mereka persembahan padat data, helaian data berfungsi apabila ia digunakan sebagai subborang untuk memaparkan data daripada bahagian "banyak" hubungan satu ke banyak. Artikel ini memerihalkan cara anda boleh menambahkan helaian data untuk borang anda dalam Office Access 2007.

Apakah yang anda ingin lakukan?

Lihat contoh helaian data pada borang

Mewujudkan perhubungan antara Jadual

Mencipta borang yang mengandungi helaian data dengan menggunakan alat borang

Mencipta borang yang mengandungi helaian data menggunakan pandangan tataletak

Menyelitkan helaian data ke dalam borang sedia ada menggunakan pandangan tataletak

Menyelitkan helaian data ke dalam borang sedia ada menggunakan pandangan Reka bentuk

Memahami perbezaan antara borang pisah dan borang yang mengandungi helaian data

Lihat contoh helaian data pada borang

Katakan anda ingin mencipta borang yang menunjukkan data tentang kategori produk dan juga semua produk dalam kategori tersebut. Data dalam Jadual kategori mewakili bahagian "satu" dalam perhubungan dan data dalam Jadual produk mewakili bahagian "banyak" dalam perhubungan. Setiap kategori boleh mempunyai banyak produk.

Borang dengan subborang

1. Borang utama menunjukkan data daripada bahagian "satu" dalam perhubungan.

2. helaian data menunjukkan data daripada bahagian "banyak" dalam perhubungan.

Halaman Atas

Mewujudkan perhubungan antara Jadual

Sebelum anda mereka bentuk borang yang mengandungi helaian data, anda perlu menyemak semula perhubungan antara jadual anda dan menambah sebarang perhubungan yang hilang. Melakukan ini membolehkan capaian secara automatik mencipta pautan antara helaian data dan borang utama. Untuk melihat, menambah atau mengubah suai perhubungan antara Jadual dalam pangkalan data anda, pada tab Alat lanjutan , dalam Kumpulan analisis , klik perhubungan. Untuk maklumat lanjut tentang mencipta perhubungan, lihat pautan dalam seksyen Lihat juga .

Halaman Atas

Mencipta borang yang mengandungi helaian data dengan menggunakan alat borang

Apabila anda menggunakan alat borang untuk membina borang yang berdasarkan Jadual yang berada pada bahagian "satu" perhubungan satu ke banyak tunggal, Access secara automatik menyelitkan helaian data yang memaparkan data pada bahagian "banyak" dalam perhubungan.

Contohnya, jika syarat yang berikut adalah benar, Access menyelitkan helaian data yang menunjukkan semua pesanan untuk pelanggan setiap:

  • Anda mencipta borang ringkas yang berdasarkan Jadual pelanggan.

  • Anda mentakrifkan perhubungan satu ke banyak dalam Jadual pesanan yang menentukan satu rekod dalam Jadual pelanggan boleh berkaitan dengan banyak rekod dalam Jadual pesanan.

  • Jadual pelanggan tidak berada pada bahagian "satu" perhubungan satu ke banyak lain.

  • Dalam anak tetingkap navigasi, klik jadual yang berada pada bahagian "satu" perhubungan satu ke banyak.

  • Pada tab Cipta , dalam Kumpulan borang , klik borang. Imej Butang

Access mencipta borang dengan helaian data di bahagian bawah borang. Jika Access mencipta helaian data, ini bermakna bahawa jadual yang anda gunakan untuk borang yang bukan sebahagian daripada perhubungan satu ke banyak, atau jadual yang merupakan sebahagian daripada lebih daripada satu perhubungan satu ke banyak.

Nota: 

  • Selain mencipta borang utama, proses ini mencipta objek borang lain. Helaian Data ialah pandangan langsung Jadual.

  • Untuk menyembunyikan lajur dalam helaian data    Klik kanan pada lajur dan kemudian klik Sembunyikan lajur. Seting ini disimpan; Jika anda simpan dan tutup borang tersebut dan kemudian membukanya semula, lajur masih boleh disembunyikan.

  • Untuk memulihkan lajur tersembunyi dalam helaian data    Klik kanan mana-mana tajuk lajur dalam helaian data dan kemudian klik Peragakan lajur. Pilih kotak semak di sebelah setiap lajur yang anda ingin Pulihkan kepada pandangan, dan kemudian klik tutup.

Halaman Atas

Mencipta borang yang mengandungi helaian data menggunakan pandangan tataletak

Jika anda telah mentakrifkan perhubungan antara Jadual dalam pangkalan data anda, anda boleh mencipta borang yang mengandungi helaian data dengan menggunakan pandangan tataletak cepat. Apabila anda menambah medan daripada bahagian "banyak" perhubungan pada borang yang berdasarkan pada bahagian "satu" dalam perhubungan, Access secara automatik mencipta helaian data untuk memaparkan rekod berkaitan.

  1. Pada tab Cipta , dalam Kumpulan borang , klik Borang kosong. Imej Butang

    Access membuka borang kosong dalam pandangan tataletak dan memaparkan anak tetingkap Senarai medan .

    Nota: Jika anda secara tidak sengaja menutup anak tetingkap Senarai medan , anda boleh membukanya semula dengan melakukan salah satu perkara berikut:

    • Tekan ALT+F8.

      —atau—

      Pada tab Format , dalam Kumpulan kawalan , klik Tambah medan sedia ada. Imej Butang

  2. Klik tanda tambah di sebelah jadual yang berada pada bahagian "satu" perhubungan satu ke banyak, dan kemudian seret medan pertama yang anda inginkan pada borang.

    Anak tetingkap Senarai medan membahagikan Jadual ke dalam seksyen Nota: medan yang tersedia untuk pandangan ini dan, di bawah itu, medan yang tersedia dalam Jadual yang berkaitan. Di bahagian bawah anak tetingkap Senarai medan , Jadual lain yang tidak berkaitan terus pada jadual utama disenaraikan di bawah medan yang tersedia dalam Jadual lain.

  3. Dari seksyen medan yang tersedia untuk pandangan ini , seret medan lain yang anda inginkan pada borang utama.

  4. Dari seksyen medan yang tersedia dalam Jadual berkaitan , seret medan pertama yang anda inginkan dalam helaian data anda ke borang. Access mencipta helaian data dan menambah medan padanya.

  5. Untuk menambahkan medan tambahan helaian data baru, anda mesti terlebih dahulu klik helaian data untuk memilihnya. Perhatikan bahawa capaian rearranges anak tetingkap Senarai medan supaya medan yang tersedia untuk helaian data di atas. Dari seksyen medan yang tersedia untuk pandangan ini , seret medan lain yang anda inginkan pada helaian data. Semasa anda menyeret setiap medan ke dalam helaian data, Access melukis bar selitan untuk menunjukkan tempat medan akan diselitkan apabila anda melepaskan butang tetikus.

  6. Teruskan menambah medan ke borang utama atau helaian data dengan mengklik pertama borang utama atau helaian data untuk memilihnya, kemudian menyeret medan dari anak tetingkap Senarai medan .

Dalam seksyen anak tetingkap Senarai medanmedan yang tersedia dalam Jadual lain mengandungi jadual yang tidak berkaitan terus pada jadual atau pertanyaan yang dipilih borang atau helaian data berdasarkan. Jika anda telah menentukan semua perhubungan Jadual sah dalam tetingkap perhubungan, kemudian medan dalam seksyen medan yang tersedia dalam Jadual lain tidak mungkin pilihan yang sah untuk borang yang anda membina. Jika anda menyeret medan dari seksyen ini borang, Access memaparkan kotak dialog Perhubungan Tentukan . Anda mesti memasukkan medan atau medan-medan yang berkait dua Jadual dengan satu sama lain sebelum anda meneruskan. Jika anda berbuat demikian, anak tetingkap Senarai medan tidak lagi akan Seksyen Diisih mengikut perhubungan yang dipratentukan. Mungkin pilihan yang terbaik klik Batalkan dalam kotak dialog ini dan mengisu perhubungan jadual anda sebaliknya. Untuk maklumat lanjut tentang perhubungan, lihat artikel mencipta, mengedit atau memadamkan perhubungan.

Halaman Atas

Menyelitkan helaian data ke dalam borang sedia ada menggunakan pandangan tataletak

Jika anda telah mentakrifkan perhubungan antara Jadual dalam pangkalan data anda, anda boleh menambah dengan cepat helaian data borang sedia ada menggunakan pandangan tataletak. Apabila anda menambah medan daripada bahagian "banyak" perhubungan pada borang yang berdasarkan pada bahagian "satu" dalam perhubungan, Access secara automatik mencipta helaian data untuk memaparkan rekod berkaitan.

  1. Buka borang sedia ada dalam pandangan tataletak dengan mengklik kanan padanya dalam anak tetingkap navigasi, kemudian mengklik Pandangan tataletak pada menu pintas.

    Jika anak tetingkap Senarai medan tidak dipaparkan:

    • Tekan ALT+F8.

      —atau—

      Pada tab Format , dalam Kumpulan kawalan , klik Tambah medan sedia ada. Imej Butang

      Anak tetingkap Senarai medan membahagikan Jadual ke dalam seksyen Nota: medan yang tersedia untuk pandangan ini dan, di bawah itu, medan yang tersedia dalam Jadual yang berkaitan. Di bahagian bawah anak tetingkap Senarai medan , Jadual lain yang tidak berkaitan terus pada jadual utama disenaraikan di bawah medan yang tersedia dalam Jadual lain.

  2. Dalam seksyen medan yang tersedia dalam Jadual berkaitan , kembangkan jadual yang mengandungi medan pertama yang anda inginkan pada helaian data anda dan seret medan ke borang. Access mencipta helaian data dan menambah medan padanya.

  3. Untuk menambahkan medan tambahan helaian data baru, anda mesti terlebih dahulu klik helaian data untuk memilihnya. Perhatikan bahawa capaian rearranges anak tetingkap Senarai medan supaya medan yang tersedia untuk helaian data di atas. Dari seksyen medan yang tersedia untuk pandangan ini , seret medan lain yang anda inginkan pada helaian data. Semasa anda menyeret setiap medan ke dalam helaian data, Access melukis bar selitan untuk menunjukkan tempat medan akan diselitkan apabila anda melepaskan butang tetikus.

  4. Teruskan menambah medan ke borang utama atau helaian data dengan mengklik pertama borang utama atau helaian data untuk memilihnya, kemudian menyeret medan dari anak tetingkap Senarai medan .

Dalam seksyen anak tetingkap Senarai medanmedan yang tersedia dalam Jadual lain mengandungi jadual yang tidak berkaitan terus pada jadual atau pertanyaan yang dipilih borang berdasarkan. Jika anda telah menentukan semua perhubungan Jadual sah dalam tetingkap perhubungan, kemudian medan dalam seksyen medan yang tersedia dalam Jadual lain tidak mungkin pilihan yang sah untuk borang yang anda membina. Jika anda menyeret medan dari seksyen ini borang, Access memaparkan kotak dialog Perhubungan Tentukan . Anda mesti memasukkan medan atau medan-medan yang berkait dua Jadual dengan satu sama lain sebelum anda meneruskan. Jika anda berbuat demikian, anak tetingkap Senarai medan tidak lagi akan Diisih ke dalam seksyen mengikut perhubungan yang dipratentukan. Mungkin pilihan yang terbaik klik Batalkan dalam kotak dialog ini dan mengisu perhubungan jadual anda sebaliknya. Untuk maklumat lanjut tentang perhubungan, lihat artikel mencipta, mengedit atau memadamkan perhubungan.

Halaman Atas

Menyelitkan helaian data ke dalam borang sedia ada menggunakan pandangan Reka bentuk

Gunakan prosedur ini untuk menambahkan helaian data yang berdasarkan terus pada jadual atau pertanyaan pada borang sedia ada dalam pandangan Reka bentuk.

  1. Buka borang dalam pandangan Reka bentuk dengan mengklik kanan borang dalam anak tetingkap navigasi, kemudian klik Pandangan Reka bentuk.

  2. Pada tab Reka bentuk , dalam Kumpulan kawalan jika alat Gunakan Bestari kawalan dipilih, klik ia agar ia tidak dipilih.

    Imej Butang

    Mengapa?

    Jika digunakan, subborang Bestari kawalan membina objek borang berasingan dan asas kawalan subborang pada borang objek. Sebaliknya, prosedur ini mencipta helaian data yang berdasarkan terus pada jadual atau pertanyaan daripada borang.

  3. Pada tab Reka bentuk , dalam Kumpulan kawalan , klik butang Imej Butang Subborang/Sublaporan. Imej Butang

  4. Dalam grid Reka bentuk borang, klik tempat yang anda inginkan helaian data untuk diselitkan.

  5. Menempatkan semula dan mensaiz semula kawalan subborang dengan menyeret pemegang pada sisi dan penjuru kawalan.

  6. Mengedit label dilampirkan untuk kawalan subborang dengan mengklik pertama label, mendwikliknya untuk memilih Teksnya, kemudian menaipkan label baru. Jika anda lebih suka untuk memadamkan label, klik label sekali dan kemudian tekan DELETE.

  7. Jika helaian sifat belum lagi dipaparkan, tekan F4 untuk memaparkannya.

  8. Jika kawalan subborang tidak buat masa ini dipilih, klik padanya sekali untuk memilihnya.

  9. Pada tab Data helaian sifat, klik senarai juntai bawah Sumber objek , dan kemudian klik Jadual atau pertanyaan yang anda ingin paparkan dalam helaian data. Contohnya, jika anda ingin memaparkan data daripada jadual pesanan, klik Table.Orders.

  10. Jika anda menyediakan perhubungan dengan betul sebelum anda memulakan prosedur ini, Access secara automatik akan mengeset Pautkan medan anak dan sifat Pautkan medan induk dengan nilai yang betul yang akan memautkan borang utama ke helaian data.

    Sifat pautkan medan anak dan pautkan medan induk saya adalah kosong

    Jika Access tidak pasti cara untuk memautkan kawalan subborang ke borang utama, ia membiarkan sifat Pautkan medan anak dan Pautkan medan induk kawalan subborang kosong. Anda perlu mengesetkan sifat ini secara manual dengan melakukan yang berikut:

    1. Buka borang utama dalam pandangan Reka bentuk.

    2. Klik kawalan subborang sekali untuk memilihnya.

    3. Jika helaian sifat tidak dipaparkan buat masa ini, tekan F4.

    4. Pada tab Data helaian sifat, klik () di sebelah kotak sifat Pautkan medan anak .

      Kotak dialog Pemaut Medan Subborang muncul.

    5. Dalam Medan induk dan Anak Medan juntai bawah senarai, pilih medan yang anda ingin pautkan borang dengan. Jika anda tidak pasti medan yang digunakan, klik mewakili capaian yang menentukan medan memautkan. Apabila anda selesai, klik OK.

      Jika anda tidak melihat medan yang anda ingin gunakan untuk memautkan borang, anda mungkin perlu mengedit sumber rekod borang induk atau kanak-kanak untuk pastikan medan yang terdapat padanya. Contohnya, jika borang berdasarkan pada pertanyaan, pastikan medan memautkan hadir dalam hasil pertanyaan.

    6. Simpan borang utama dan Tukar kepada pandangan borang untuk mengesahkan yang borang berfungsi seperti jangkaan anda.

  11. Simpan borang dengan mengklik Simpan Imej Butang pada Bar alat capaian segera atau dengan menekan CTRL + S.

  12. Tukar kepada Pandangan borang dan sahkan bahawa helaian data berfungsi seperti yang anda jangkakan.

Halaman Atas

Memahami perbezaan antara borang pisah dan borang yang mengandungi helaian data

Borang yang mengandungi helaian data memaparkan data daripada sumber data yang berbeza (tetapi biasanya berkaitan). Contohnya, borang mungkin menunjukkan pekerja, dan ia mungkin mempunyai helaian data yang menunjukkan semua tugas yang diperuntukkan kepada setiap pekerja. Helaian Data mempunyai sumber data yang berbeza daripada borang yang mengandunginya. Sebaliknya, borang pisah mempunyai dua Seksyen (Borang dan helaian data), tetapi data yang sama akan dipaparkan dalam kedua-dua Seksyen. Dua Seksyen menjejaki dengan satu sama lain dan memberikan anda dua pandangan berbeza data anda sekali gus.

Untuk maklumat lanjut tentang mencipta dan bekerja dengan borang pisah, lihat artikel mencipta borang pisah.

Halaman Atas

Nota: Notis Penafian Penterjemahan Mesin: Artikel ini telah diterjemah oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan penterjemahan mesin ini untuk membantu pengguna-pengguna yang tidak bertutur dalam Bahasa Inggeris supaya dapat menikmati kandungan mengenai produk, perkhidmatan dan teknologi Microsoft. Artikel ini mungkin mengandungi ralat perbendaharaan kata, sintaks atau tatabahasa kerana ia diterjemahkan oleh mesin.

Kembangkan kemahiran anda
Jelajahi latihan
Dapatkan ciri baru terlebih dahulu
Sertai Office Insiders

Adakah maklumat ini membantu?

Terima kasih atas maklum balas anda!

Terima kasih atas maklum balas anda! Nampaknya ia mungkin akan membantu untuk menyambungkan anda kepada salah seorang daripada ejen sokongan Office kami.

×