Mencipta laporan terkumpul atau laporan ringkasan

Penting: Artikel ini diterjemahkan oleh mesin, lihatlah notis penafian. Sila dapatkan versi Bahasa Inggeris artikel ini di sini sebagai rujukan anda

Maklumat biasanya lebih mudah difahami apabila ia dibahagikan kepada Kumpulan. Contohnya, laporan yang mengumpulkan jualan mengikut rantau boleh menyerlahkan aliran yang jika tidak mungkin pergi diperhatikan. Selain itu, meletakkan jumlah di penghujung setiap Kumpulan dalam laporan anda boleh menggantikan banyak manual interaksi dengan kalkulator yang.

Microsoft Office Access 2007 menjadikan bekerja dengan laporan terkumpul mudah. Anda boleh mencipta laporan terkumpul asas menggunakan Bestari laporan, anda boleh menambah perkumpulan dan isihan pada Laporan sedia ada atau anda boleh menyemak perkumpulan dan isihan opsyen yang telah ditentukan.

Dalam artikel ini

Memahami perkumpulan, Seksyen laporan dan kawalan

Membina laporan terkumpul baru menggunakan Bestari Laporan

Memperhalusi laporan anda

Menambah medan atau kawalan lain pada Laporan sedia ada

Menambah atau mengubah suai perkumpulan dan isihan dalam laporan sedia ada

Menyimpan, mencetak atau menghantar laporan anda

Catatan

Memahami perkumpulan, Seksyen laporan dan kawalan

Jika anda pengguna baru laporan terkumpul, ia membantu mempunyai beberapa latar pada perkumpulan dan isihan, serta Seksyen laporan yang berlainan dan jenis kawalan. Jika anda berasa selesa dengan konsep ini telah, anda boleh langkau seksyen ini dan pergi ke seksyen membina laporan terkumpul baru menggunakan Bestari laporan.

Tentang perkumpulan dan isihan

Apabila anda mencetak laporan, anda biasanya ingin mengatur rekod dalam tertib tertentu. Contohnya, jika anda mencetak Senarai pembekal, anda mungkin ingin Mengisih rekod mengikut abjad mengikut nama Syarikat.

Untuk banyak laporan, mengisih rekod tidak cukup. Anda juga mungkin ingin membahagikan mereka kepada Kumpulan. Kumpulan ialah koleksi rekod, bersama-sama dengan sebarang maklumat pengenalan dan ringkasan yang dipaparkan dengan rekod, seperti pengepala. Kumpulan terdiri daripada pengepala Kumpulan, tersarang Kumpulan (jika ada), terperinci rekod dan pengaki Kumpulan.

Perkumpulan membenarkan anda untuk memisahkan Kumpulan rekod secara visual dan untuk memaparkan data pengenalan dan ringkasan untuk setiap Kumpulan. Contohnya, laporan berikut Kumpulan jualan mengikut tarikh yang dihantar dan mengira jumlah jualan untuk setiap hari.

Laporan terkumpul dengan jumlah

1. tarikh memperkenalkan Kumpulan.

2. Jumlah meringkaskan Kumpulan.

Anda boleh melihat cara perkumpulan berfungsi dengan membandingkan senarai produk mengikut kategori Laporan (ditunjukkan dalam ilustrasi berikut) untuk helaian data untuk pertanyaan dasar, senarai produk. Laporan dan pertanyaan Isih produk mengikut kategori, tetapi laporan juga mencetak nama setiap kategori pada baris berasingan pada permulaan setiap Kumpulan (dalam pengepala Kumpulan) dan nombor produk untuk setiap kategori pada baris berasingan di penghujung setiap Kumpulan (dalam pengaki Kumpulan).

Laporan Produk mengikut Kategori

1. nama kategori muncul dalam setiap baris dalam helaian data.

2. nama kategori muncul sekali untuk setiap Kumpulan dalam laporan, dalam pengepala Kumpulan.

3. Jumlah untuk kategori yang muncul di penghujung setiap Kumpulan, dalam Kumpulan pengaki.

4. rekod muncul sebagai satu kumpulan yang besar dalam helaian data.

5. rekod bagi setiap kategori muncul sebagai seksyen berasingan dalam laporan, didahului dengan pengepala Kumpulan dan diikuti oleh pengaki Kumpulan.

Anda boleh mengumpulkan pada medan dan ungkapan anda Mengisih (sehingga 10). Anda boleh mengumpulkan pada medan atau ungkapan yang sama lebih daripada sekali. Apabila anda mengumpulkan pada lebih daripada satu medan atau ungkapan, sarang Office Access 2007 Kumpulan mengikut aras Kumpulan mereka. Medan pertama kumpulan anda pada merupakan aras Kumpulan pertama dan paling besar; medan kedua Kumpulan anda pada ialah aras Kumpulan berikut; dan sebagainya. Ilustrasi berikut menunjukkan cara Office Access 2007 nests Kumpulan.

Hierarki Pengepala Pengaki

1. setiap pengepala Kumpulan berpasangan dengan pengaki Kumpulan.

Anda biasanya menggunakan pengepala Kumpulan untuk memaparkan data yang mengenal pasti Kumpulan dalam seksyen berasingan pada permulaan Kumpulan. Anda biasanya menggunakan pengaki Kumpulan untuk meringkaskan data dalam Kumpulan dalam seksyen berasingan di hujung Kumpulan.

Halaman Atas

Mengenai Seksyen Laporan

Dalam Access, Reka bentuk laporan dibahagikan kepada Seksyen. Untuk mencipta laporan yang berguna, anda perlu memahami cara setiap seksyen berfungsi. Contohnya, Seksyen yang anda pilih untuk menempatkan kawalan terhitung menentukan cara Access mengira hasil. Senarai berikut menunjukkan ringkasan jenis Seksyen dan menggunakan mereka.

  • Pengepala laporan    Dicetak sekali pada permulaan laporan. Menggunakan pengepala laporan untuk maklumat yang mungkin biasanya akan muncul pada halaman depan, seperti logo, atau tajuk dan tarikh. Pengepala laporan mencetak sebelum pengepala halaman. Apabila anda meletakkan kawalan terhitung dalam pengepala laporan, nilai dikira untuk keseluruhan laporan. Contohnya, meletakkan kawalan yang menggunakan fungsi agregat Sum dalam pengepala laporan mengira jumlah untuk keseluruhan laporan.

  • Pengepala halaman    Dicetak di atas setiap halaman. Gunakan pengepala halaman, contohnya, untuk mengulangi tajuk laporan pada setiap halaman.

  • Pengepala Kumpulan    Dicetak pada permulaan setiap Kumpulan rekod yang baru. Menggunakan pengepala Kumpulan untuk mencetak nama Kumpulan. Contohnya, dalam laporan yang dikumpulkan mengikut produk, gunakan pengepala Kumpulan untuk mencetak nama produk. Apabila anda meletakkan kawalan terhitung yang menggunakan fungsi agregat Sum dalam pengepala Kumpulan, hasil ialah kumpulan semasa.

  • Butiran    Dicetak sekali untuk setiap baris dalam sumber rekod. Seksyen butiran adalah tempat anda meletakkan kawalan yang membentuk isi utama laporan.

  • Pengaki Kumpulan    Dicetak di penghujung setiap Kumpulan rekod. Gunakan pengaki Kumpulan untuk mencetak maklumat ringkasan untuk Kumpulan.

  • Pengaki halaman    Dicetak di hujung setiap halaman. Gunakan pengaki halaman untuk mencetak nombor halaman atau maklumat bagi setiap halaman.

  • Pengaki laporan    Dicetak sekali di penghujung laporan. Gunakan pengaki laporan untuk mencetak jumlah laporan atau maklumat ringkasan lain untuk keseluruhan laporan.

    Nota: Dalam pandangan Reka bentuk, pengaki laporan muncul di bawah pengaki halaman. Walau bagaimanapun, apabila laporan dicetak atau dipratonton, pengaki laporan muncul di atas pengaki halaman, hanya selepas Kumpulan pengaki atau butiran baris terakhir pada halaman terakhir.

Halaman Atas

Tentang kawalan

Kawalan adalah objek yang memaparkan data, melaksanakan tindakan dan membolehkan anda melihat dan bekerja dengan maklumat yang meningkatkan antara muka pengguna, seperti label dan imej. Access menyokong tiga jenis kawalan: terikat, tidak terikat dan dikira. Senarai berikut menunjukkan ringkasan kawalan ini dan menggunakan mereka.

  • Kawalan terikat    Kawalan sumber data yang merupakan medan dalam Jadual atau pertanyaan. Anda menggunakan kawalan terikat untuk memaparkan nilai daripada medan dalam pangkalan data anda. Nilai boleh menjadi teks, tarikh, nombor, nilai ya/tidak, gambar atau graf. Kotak teks adalah jenis kawalan terikat yang paling biasa. Contohnya, kotak teks dalam borang yang memaparkan nama terakhir pekerja yang mungkin Dapatkan maklumat ini daripada medan nama akhir dalam jadual pekerja.

  • Kawalan Unbound    Kawalan yang tidak mempunyai sumber data. Anda menggunakan kawalan tidak terikat untuk memaparkan maklumat, garis, segi empat tepat dan gambar. Contohnya, label yang memaparkan tajuk laporan adalah kawalan tidak terikat.

  • Kawalan terhitung    Kawalan yang sumber data adalah ungkapan dan bukannya medan. Anda menentukan nilai yang anda inginkan dalam kawalan dengan mentakrifkan ungkapan sebagai sumber data untuk kawalan. Ungkapan ialah gabungan operator (seperti = dan + ), kawalan nama, nama medan, fungsi yang mengembalikan nilai tunggal dan nilai pemalar. Contohnya, ungkapan berikut mengira harga item dengan diskaun 25 peratus dengan mendarab nilai dalam medan harga Unit dengan nilai pemalar (. 75).

= [Unit Price] * .75

Ungkapan yang boleh menggunakan data daripada medan dalam laporan dasar Jadual atau pertanyaan atau daripada kawalan pada Laporan.

Apabila anda mencipta laporan, ia adalah mungkin paling berkesan untuk menambah dan menyusun semua kawalan terikat pertama, terutamanya jika ia membentuk kebanyakan kawalan pada Laporan. Anda boleh menambah kawalan tidak terikat dan terhitung yang melengkapkan Reka bentuk menggunakan alat dalam Kumpulan kawalan pada tab Reka bentuk .

Imej Reben Access

Anda mengikat kawalan pada medan dengan mengenal pasti medan yang kawalan memperoleh datanya. Anda boleh mencipta kawalan yang diikat pada medan yang dipilih dengan menyeret medan dari anak tetingkap Senarai medan untuk laporan. (Anak tetingkap Senarai medan memaparkan medan dalam laporan dasar Jadual atau pertanyaan. Untuk memaparkan anak tetingkap Senarai medan , lakukan salah satu perkara berikut:

  • Pada tab Reka bentuk , dalam Kumpulan alat , klik Tambah medan sedia ada. Imej Butang

  • Tekan ALT+F8.

Apabila anda dwiklik medan atau seretnya dari anak tetingkap Senarai medan pada Laporan, anda mencipta kawalan terikat.

Secara alternatif, anda boleh mengikat medan kawalan dengan menaipkan nama medan dalam kawalan itu sendiri atau dalam kotak untuk nilai ControlSource dalam helaian sifat kawalan. Helaian sifat mentakrifkan ciri-ciri kawalan, seperti nama, sumber data dan format. Untuk memaparkan helaian sifat, tekan F4.

Menggunakan anak tetingkap Senarai medan ialah cara terbaik untuk mencipta kawalan terikat dua sebab:

  • Kawalan terikat mempunyai label yang dilampirkan dan label mengambil nama medan (atau kapsyen yang ditakrifkan untuk medan tersebut dalam Jadual atau pertanyaan dasar) sebagai kapsyen secara lalai, jadi anda tidak perlu taip kapsyen.

  • Kawalan terikat mewarisi banyak seting yang sama sebagai medan dalam Jadual atau pertanyaan (seperti untuk sifat Format, DecimalPlacesdan InputMask ) dasar. Oleh itu, anda boleh memastikan bahawa sifat ini untuk medan kekal sama apabila anda mencipta kawalan yang diikat medan tersebut.

Jika anda sudah mempunyai kawalan yang tidak terikat dan ingin mengikat pada medan, setkan sifat bagi kawalan ControlSource kepada nama medan.

Halaman Atas

Membina laporan terkumpul baru menggunakan Bestari Laporan

Bestari Laporan mempersembahkan kepada anda satu siri soalan dan kemudian menjana laporan berdasarkan jawapan anda. Antara soalannya adalah soalan yang meminta medan atau medan-medan yang akan digunakan untuk mengumpulkan laporan anda. Selepas laporan dicipta, anda boleh menggunakannya seadanya atau mengubah suai agar lebih memenuhi keperluan anda. Sebelum anda bermula dengan Bestari Laporan, anda perlu memilih satu sumber data.

Pilih sumber rekod

Laporan terdiri daripada maklumat yang ditambahkan dari jadual atau pertanyaan dan maklumat yang disimpan dengan reka bentuk laporan, seperti label, tajuk dan grafik. Jadual atau pertanyaan yang menyediakan data dasar adalah juga dikenali sebagai sumber rekod dalam laporan. Sebelum anda mula mencipta laporan anda, anda terlebih dahulu perlu memikir tentang maklumat yang anda ingin sertakan. Antara medan yang anda pilih mesti yang anda ingin mengumpulkan pada atau Ringkaskan. Jika medan yang anda ingin masukkan semua tersedia dalam satu jadual, gunakan jadual tersebut sebagai sumber rekod. Jika medan ditarik dari lebih daripada satu jadual, anda akan ingin menggunakan pertanyaan sebagai sumber rekod. Pertanyaan tersebut mungkin telah wujud dalam pangkalan data anda, atau anda mungkin perlu mencipta pertanyaan khusus untuk memenuhi keperluan laporan anda.

Untuk mengetahui lebih lanjut mengenai pertanyaan, ikuti pautan dalam seksyen Lihat juga artikel ini.

Memulakan Bestari Laporan

  1. Pada tab Cipta , dalam Kumpulan laporan , klik Bestari laporan. Imej Butang

    Access memulakan Bestari Laporan.

    Pemilihan medan dalam bestari laporan

  2. Klik senarai juntai bawah Jadual/Pertanyaan dan pilih jadual atau pertanyaan yang mengandungi medan yang anda inginkan pada laporan anda.

  3. Dwiklik medan dalam senarai Medan Tersedia untuk memilihnya.

    Access mengalihkannya ke senarai Medan Terpilih. Selain itu, anda boleh klik butang yang terletak di antara kotak Medan Tersedia dan kotak Medan Terpilih untuk menambah atau mengalih keluar medan terpilih atau menambah semua atau mengalih keluar semua medan.

  4. Jika terdapat medan dalam jadual atau pertanyaan lain yang anda juga ingin letakkan pada laporan anda, klik senarai juntai bawah Jadual/Pertanyaan sekali lagi dan pilih jadual atau pertanyaan lain, kemudian teruskan menambah medan.

  5. Selepas anda selesai menambah medan, klik Berikut.

Rekod kumpulan dalam Bestari Laporan

Perkumpulan membolehkan anda mengatur dan menyusun rekod mengikut kumpulan, seperti mengikut Rantau atau Jurujual. Kumpulan boleh disarangkan supaya anda boleh mengenal pasti perhubungan antara kumpulan dengan mudah dan mencari maklumat yang anda ingini dengan cepat. Anda juga boleh menggunakan perkumpulan untuk mengira maklumat ringkasan, seperti jumlah dan peratusan.

Apabila anda memasukkan lebih daripada satu jadual dalam laporan, bestari memeriksa perhubungan antara jadual dan menentukan cara anda mungkin ingin melihat maklumat.

  1. Pada halaman Bestari Laporan yang bertanya Adakah anda ingin menambah sebarang aras perkumpulan?, klik salah satu nama medan dalam senarai, kemudian klik Berikut.

  2. Untuk menambah aras perkumpulan, dwiklik sebarang nama medan dalam senarai untuk menambahkannya pada laporan anda.

    Anda juga boleh mengalih keluar aras perkumpulan dengan mendwikliknya dalam paparan halaman di sebelah kanan kotak dialog. Gunakan butang anak panah untuk menambah dan mengalih keluar aras perkumpulan, laraskan keutamaan aras perkumpulan dengan memilihnya dan mengklik butang keutamaan ke atas atau ke bawah. Access menambah setiap aras perkumpulan dan menunjukkan ia disarangkan dalam aras perkumpulan induknya.

    Menambah aras perkumpulan dalam bestari laporan

  3. Klik Opsyen Perkumpulan untuk memaparkan kotak dialog Selang Perkumpulan.

    Selang Perkumpulan dalam bestari laporan

  4. Secara pilihan, untuk setiap medan aras kumpulan, pilih satu selang perkumpulan.

    Selang perkumpulan membolehkan anda menyesuaikan cara rekod dikumpulkan. Dalam ilustrasi sebelumnya, rekod dikumpulkan pada medan ShippedDate, iaitu data tarikh/masa jenis. Bestari laporan menawarkan pilihan yang sesuai untuk jenis medan dalam senarai selang perkumpulan . Oleh itu, oleh sebab ShippedDate adalah jenis tarikh/masa, anda boleh memilih untuk mengumpulkan mengikut nilai sebenar (Normal), tahun, suku tahun, bulan, minggu, hari, jam dan minit. Jika medan jenis data teks, anda boleh memilih untuk Kumpulan dengan seluruh medan (Normal), atau mungkin dengan pertama satu untuk lima aksara. Untuk jenis data berangka, anda boleh memilih untuk Kumpulan dengan nilai (Normal) atau dengan julat dalam kenaikan yang dipilih.

    Selepas memilih selang perkumpulan, klik OK.

  5. Klik Berikut untuk menavigasi ke halaman bestari yang berikutnya.

Mengisih dan meringkaskan rekod

Anda boleh mengisih rekod sehingga empat medan, sama ada dalam tertib menaik atau menurun.

  1. Klik senarai juntai bawah pertama dan pilih medan untuk mengisih.

    Anda boleh mengklik butang di bahagian kanan senarai untuk togol antara tertib menaik atau menurun (Menaik adalah tertib lalai). Secara pilihan, klik senarai juntai bawah kedua, ketiga dan keempat untuk memilih medan isih tambahan.

    Tertib isihan dalam bestari laporan

  2. Klik Opsyen Ringkasan jika anda ingin meringkaskan sebarang medan berangka.

    Perhatikan bahawa butang Opsyen Ringkasan hanya akan kelihatan jika anda mempunyai satu atau lebih medan berangka dalam seksyen Butiran laporan anda. Bestari memaparkan medan berangka yang tersedia.

    Opsyen ringkasan dalam bestari laporan

  3. Pilih kotak semak mengikut pilihan anda bagi Hasil Tambah, Purata, Min atau Maks untuk memasukkan pengiraan tersebut dalam kumpulan pengaki.

    Anda juga boleh memilih untuk menunjukkan butiran dan ringkasan atau ringkasan sahaja. Dalam kes yang kemudian, jumlah bagi setiap nilai ShippedDate ditunjukkan (jika anda memilih kotak semak untuk Hasil Tambah, sebagai contoh), tetapi butiran pesanan dikeluarkan. Anda juga boleh memilih untuk menunjukkan peratus jumlah pengiraan bagi hasil tambah.

  4. Klik OK.

  5. Ikuti arahan pada baki halaman Bestari Laporan. Pada halaman terakhir, anda boleh mengedit tajuk laporan. Tajuk ini akan dipaparkan pada halaman pertama laporan dan Access juga akan menyimpan laporan itu, menggunakan tajuk sebagai nama dokumen. Anda boleh mengedit kedua-dua tajuk dan nama dokumen kemudian.

  6. Klik Selesai. Access secara automatik menyimpan laporan dan memaparkannya dalam Pratonton Cetak, yang menunjukkan anda rupa laporan apabila ia dicetak.

Anda boleh menggunakan butang navigasi di bahagian bawah anak tetingkap pratonton untuk melihat halaman laporan secara berjujukan atau melompat ke sebarang halaman dalam laporan itu. Klik salah satu butang navigasi atau taipkan nombor halaman yang anda ingin lihat dalam kotak nombor halaman, kemudian tekan ENTER.

Dalam Pratonton Cetak, anda boleh zum masuk untuk melihat butiran atau zum keluar untuk melihat sejauh mana data diletakkan pada halaman. Dengan penuding tetikus diletakkan di atas laporan, klik sekali. Untuk menyongsangkan kesan zum, klik sekali lagi. Anda juga boleh menggunakan kawalan zum dalam bar status.

Halaman Atas

Memperhalusi laporan anda

Ia adalah berkemungkinan Bestari laporan akan menghasilkan hasil yang tepat yang anda Cari dalam laporan anda. Contohnya, anda mungkin ingin menambah teks, Laraskan lebar lajur, menambah logo, dll. Access menyediakan dua pandangan yang anda boleh membuat perubahan kepada laporan anda: pandangan tataletak dan pandangan Reka bentuk. Ini dibincangkan secara ringkas dalam seksyen ini.

Tentang pandangan tataletak

Pandangan tataletak pandangan paling mudah untuk digunakan untuk membuat perubahan laporan dan menyediakan kebanyakan alat yang anda perlukan untuk memperhalusi laporan anda. Anda boleh melaraskan lebar lajur, menyusun semula lajur, dan menambah atau mengubah suai aras perkumpulan dan jumlah. Anda boleh meletakkan medan baru pada reka bentuk laporan dan mengesetkan sifat untuk kawalan kerjanya dan laporan. Kelebihan pandangan tataletak adalah anda boleh melihat data anda semasa membuat perubahan kepada format laporan, supaya anda boleh terus melihat cara perubahan anda mempengaruhi paparan data.

Untuk membuka laporan dalam pandangan tataletak, klik kanan laporan dalam anak tetingkap navigasi, dan kemudian klik pandangan tataletak Imej Butang .

Anda boleh menggunakan helaian sifat untuk mengubah suai sifat untuk laporan dan kawalan dan Seksyen. Untuk memaparkan helaian sifat, tekan F4.

Anda boleh menggunakan anak tetingkap Senarai medan untuk menambah medan daripada jadual atau pertanyaan dasar Reka bentuk laporan anda. Untuk menunjukkan anak tetingkap Senarai medan :

  1. Pada tab Format , dalam Kumpulan kawalan , klik Tambah medan sedia ada Imej Butang .

    Petua: Access 2010 termasuk baru ciri pemformatan bersyarat yang boleh meningkatkan kebolehbacaan laporan.

Tentang pandangan Reka bentuk

Jika anda tidak dapat membuat perubahan khusus pada laporan dalam pandangan tataletak, cuba pandangan Reka bentuk. Pandangan Reka bentuk menunjukkan struktur dasar laporan dan menyediakan beberapa lebih Reka bentuk alat dan kemampuan daripada pandangan tataletak. Contohnya, anda boleh meletakkan berbagai-bagai kawalan pada Laporan, anda boleh melaraskan penjajaran kawalan lebih tepat dan anda mempunyai keupayaan untuk mengeset sifat lebih daripada yang anda lakukan dalam pandangan tataletak.

Untuk membuka laporan dalam pandangan Reka bentuk, klik kanan laporan dalam anak tetingkap navigasi, kemudian klik Pandangan Reka bentuk Imej Butang .

Halaman Atas

Menambah medan atau kawalan lain pada Laporan sedia ada

Setiap medan, label, baris atau gambar yang anda lihat pada laporan anda akan dicipta menggunakan beberapa jenis kawalan. Kawalan yang paling kerap digunakan pada Laporan adalah kotak teks. Inilah apa yang biasa digunakan untuk memaparkan data daripada sumber rekod dasar dalam laporan. Anda boleh mencipta kotak teks yang telah terikat pada medan dalam sumber rekod dengan menambah medan daripada anak tetingkap Senarai medan , atau anda boleh menambah mereka pada Laporan semasa bekerja dalam pandangan Reka bentuk (tetapi kemudian anda mesti "mengikat" mereka pada medan dalam sumber rekod anda sendiri). Kelebihan Reka bentuk pandangan yang anda boleh menambah pelbagai jenis kawalan selain terikat kotak teks, seperti segi empat tepat, pemisah halaman dan carta. Seksyen ini menerangkan kedua-dua kaedah menambah kawalan pada Laporan.

Menambah medan pada Laporan sedia ada

Pandangan tataletak pandangan yang disyorkan untuk menambahkan medan pada Laporan, tetapi ia juga boleh dilakukan dalam pandangan Reka bentuk. Untuk menambah medan, terlebih dahulu pastikan anak tetingkap Senarai medan dipaparkan. Anak tetingkap Senarai medan mengandungi senarai semua medan yang tersedia untuk diletakkan pada Laporan. Untuk memaparkan anak tetingkap Senarai medan , tekan ALT + F8.

Menambah medan daripada anak tetingkap Senarai medan

  • Untuk menambah medan tunggal, seret medan dari anak tetingkap Senarai medan ke seksyen pada laporan yang anda ingin ia dipaparkan.

  • Untuk menambah beberapa medan sekali gus, klik medan pertama yang anda inginkan, dan kemudian tekan dan tahan CTRL dan klik setiap medan tambahan yang anda inginkan. Kemudian, seret medan terpilih pada Laporan.

Apabila anda memutuskan medan, Access mencipta kawalan kotak teks terbatas untuk setiap medan dan secara automatik menempatkan kawalan label di sebelah setiap medan.

Nota: 

  • Jika anda menambah medan daripada jadual berkaitan, Access akan menambah aras perkumpulan yang sesuai untuk anda.

  • Jika anda menambah medan daripada jadual lain (bukan berkaitan), Access akan memaparkan kotak dialog yang anda boleh tentukan cara untuk mengaitkan Jadual sumber data sedia ada untuk laporan.

Untuk melihat perhubungan Jadual Apakah telahpun ditentukan untuk pangkalan data anda atau untuk menambah yang baru:

  1. Pada tab Alat pangkalan data , dalam Kumpulan Tunjukkan/Sembunyikan , klik perhubungan. Imej Butang

Untuk maklumat lanjut, lihat artikel mencipta, mengedit atau memadamkan perhubungan.

Menambah kawalan lain pada Laporan sedia ada

Apabila anda menambah medan daripada anak tetingkap Senarai medan pada Laporan, kawalan kotak teks terbatas untuknya dicipta secara automatik. Kawalan lain seperti label, garis dan imej boleh ditambah dengan bertukar kepada pandangan Reka bentuk menggunakan alat dalam Kumpulan kawalan pada tab Reka bentuk .

Imej Reben Access

Menentukan nama alat

  • Letakkan penuding tetikus pada alat.

    Access memaparkan nama alat.

Mencipta kawalan menggunakan alat dalam Kumpulan kawalan

  • Klik alat untuk jenis kawalan yang anda ingin tambah. Contohnya, untuk mencipta kotak semak, klik kotak semak alat Imej Butang .

  • Klik Reka bentuk laporan yang anda ingin letakkan di penjuru atas kiri kawalan. Klik sekali untuk mencipta kawalan bersaiz lalai atau klik dan seret dalam laporan untuk mencipta kawalan saiz yang anda inginkan.

  • Jika anda tidak menempatkan kawalan betul-betul pada mula-mula cuba, anda boleh mengalihkannya menggunakan prosedur berikut:

    • Klik kawalan untuk memilihnya.

    • Letakkan penuding di atas kawalan sehingga ia bertukar kepada anak panah berkepala empat Penuding alih , dan kemudian seret kawalan ke lokasi yang diinginkan.

Proses ini mencipta kawalan ada "tidak terikat". Jika kawalan ialah jenis yang boleh memaparkan data (kotak teks atau kotak semak, contohnya), anda perlu memasukkan nama medan atau ungkapan dalam sifat Sumber kawalan bagi kawalan sebelum ia akan memaparkan sebarang data.

Memaparkan helaian sifat

  • Tekan F4.

Nota: Apabila laporan baru anda selesai, pastikan anda menyimpan kerja anda.

Halaman Atas

Menambah atau mengubah suai perkumpulan dan isihan dalam laporan sedia ada

Jika anda mempunyai laporan sedia ada dan anda ingin menambah isihan atau perkumpulan padanya atau jika anda ingin mengubah suai laporan isihan atau perkumpulan sedia ada, seksyen ini akan membantu anda bermula.

Menambah perkumpulan, isihan dan jumlah dalam pandangan tataletak

Anda boleh melaksanakan ringkas Mengisih, mengumpulkan dan berjumlah operasi dengan mengklik kanan medan dalam pandangan tataletak dan kemudian memilih operasi yang anda inginkan daripada menu pintasan. Untuk bertukar kepada pandangan tataletak, klik kanan laporan dalam anak tetingkap navigasi dan kemudian klik pandangan tataletak Imej Butang .

Nota: Walaupun arahan dalam seksyen ini tidak menggunakan anak tetingkap Kumpul, Isih dan Jumlah secara terus, adalah digalakkan untuk membuka anak tetingkap dan memerhatikan cara ia berubah semasa anda bekerja. Anda akan mendapat idea yang lebih baik tentang apa Access lakukan dan, apabila anda semakin selesa bekerja dengan anak tetingkap Kumpul, Isih dan Jumlah, anda boleh menggunakannya untuk membuat pelarasan tambahan pada laporan anda. Untuk memaparkan anak tetingkap Kumpul, Isih dan Jumlah:

  1. Pada tab Format , dalam Kumpulan pengumpulan & jumlah , klik kumpul & Isih. Imej Butang

Mengisih pada medan tunggal

  • Klik kanan sebarang nilai dalam medan yang anda ingin Isih.

  • Pada menu pintas, klik Opsyen isihan yang anda inginkan. Contohnya, untuk mengisih medan teks dalam tertib menaik, klik Isih A hingga Z Imej Butang . Untuk mengisih medan berangka dalam tertib menurun, klik Isih paling besar ke paling kecil Imej Butang .

Access mengisih laporan seperti yang anda tentukan. Jika anak tetingkap Kumpul, Isih dan Jumlah terbuka, anda boleh melihat baris baru Isih mengikut untuk medan yang telah ditambah.

Mengisih pada berbilang medan

Nota: Apabila anda menggunakan isihan dengan mengklik kanan medan dalam pandangan tataletak, anda boleh Mengisih satu medan sahaja pada satu masa. Menggunakan isihan ke medan lain mengalih keluar Mengisih pada medan pertama. Ini berbeza daripada kelakuan pengisihan dalam borang, yang berbilang tertib isihan boleh diwujudkan dengan mengklik kanan setiap medan seterusnya dan pilih tertib isihan yang anda inginkan. Untuk mencipta berbilang aras isihan, lihat seksyen Tambah perkumpulan, isihan, dan jumlah menggunakan kumpul, Isih, dan tetingkap jumlah.

Mengumpulkan pada medan

  • Klik kanan sebarang nilai dalam medan yang anda ingin kumpulkan.

  • Pada menu pintas, klik Kumpulan pada Imej Butang .

Access menambah aras perkumpulan dan mencipta pengepala kumpulan untuknya. Jika anak tetingkap Kumpul, Isih dan Jumlah terbuka, anda boleh melihat baris baru Kumpul pada untuk medan telah ditambahkan.

Menambah jumlah pada medan

Opsyen ini membolehkan anda mengira hasil tambah, purata, kiraan atau agregat lain untuk medan. Jumlah besar ditambah ke hujung laporan dan jumlah kumpulan ditambah pada sebarang kumpulan yang wujud pada laporan itu.

  • Klik kanan sebarang nilai dalam medan yang anda ingin jumlahkan.

  • Klik Jumlah.

  • Klik pengendalian yang anda ingin jalankan: Hasil Tambah, Purata, Kira Rekod (untuk mengira semua rekod), Kira Nilai (untuk mengira rekod dengan nilai dalam medan ini sahaja), Maks, Min, Sisihan Piawai atau Varians.

Access menambah kawalan kotak teks terhitung pada pengaki laporan yang kemudiannya mencipta jumlah besar. Juga, jika laporan anda mempunyai sebarang aras perkumpulan, Access menambah pengaki kumpulan (jika belum ada) dan meletakkan jumlah dalam setiap pengaki.

Anda boleh juga menambah jumlah dengan mengklik medan yang anda ingin jumlahkan dan kemudian, pada tab Format , dalam Kumpulan pengumpulan & jumlah , klik jumlah Imej Butang .

Menambah perkumpulan, isihan dan jumlah menggunakan anak tetingkap Kumpul, Isih dan Jumlah

Bekerja dalam anak tetingkap Kumpul, Isih, dan Jumlah memberikan anda kefleksibelan apabila anda ingin menambah atau mengubah suai opsyen kumpulan, tertib isihan atau jumlah pada laporan. Sekali lagi, pandangan Tataletak adalah pandangan yang diutamakan untuk bekerja kerana lebih mudah untuk melihat bagaimana perubahan anda mempengaruhi paparan data.

Memaparkan anak tetingkap Kumpul, Isih dan Jumlah

  • Dalam pandangan tataletak:

    Pada tab Format , dalam Kumpulan pengumpulan & jumlah , klik kumpul & Isih. Imej Butang

  • Dalam pandangan Reka bentuk:

    Pada tab Reka bentuk , dalam Kumpulan pengumpulan & jumlah , klik kumpul & Isih. Imej Butang

Access memaparkan anak tetingkap kumpul, Isih, dan jumlah .

Anak tetingkap Kumpul, Isih dan Jumlah

Untuk menambah aras isihan atau perkumpulan baru, klik Tambah kumpulan atau Tambah isihan.

Satu baris baru ditambah pada anak tetingkap Kumpul, Isih dan Jumlah, dan senarai medan yang tersedia dipaparkan.

Senarai medan dalam anak tetingkap Kumpul, Isih dan Jumlah

Anda boleh klik salah satu nama medan ini atau anda boleh klik ungkapan di bawah senarai medan untuk memasukkan ungkapan. Sebaik sahaja anda pilih medan atau memasukkan ungkapan, Access menambah aras perkumpulan pada Laporan. Jika anda berada dalam pandangan tataletak, paparan berubah serta-merta untuk menunjukkan perkumpulan yang atau tertib isihan.

Nota: 

  • Jika terdapat beberapa aras isihan atau perkumpulan yang sudah ditakrifkan, anda mungkin perlu skrol ke bawah dalam anak tetingkap Kumpul, Isih dan Jumlah sebelum anda boleh melihat butang Tambah kumpulan dan Tambah isih.

  • Anda boleh mentakrifkan sehingga 10 aras perkumpulan dan isihan dalam satu laporan.

Mengubah opsyen perkumpulan

Setiap aras isihan atau perkumpulan mempunyai beberapa opsyen yang boleh disetkan untuk mendapatkan hasil yang anda inginkan.

Opsyen perkumpulan

  • Untuk memaparkan semua opsyen bagi aras perkumpulan atau isihan, klik Lain pada aras yang anda ingin ubahkan.

    Opsyen perkumpulan (dikembangkan)

  • Untuk sembunyikan opsyen, klik Kurang.

Tertib isihan    Anda boleh mengubah tertib isihan dengan mengklik senarai juntai bawah tertib isihan, kemudian klik opsyen yang anda inginkan.

Selang kumpulan    Seting ini menentukan cara rekod dikumpulkan bersama. Contohnya, anda boleh kumpulkan pada aksara pertama medan teks supaya semua yang bermula dengan "A" dikumpulkan bersama, semua yang bermula dengan "B" dikumpulkan bersama dan seterusnya. Bagi medan tarikh, anda boleh kumpulkan mengikut hari, minggu, bulan dan suku atau anda boleh masukkan selang tersuai.

Jumlah    Untuk menambah jumlah, klik opsyen ini. Anda boleh menambah jumlah pada berbilang medan dan anda boleh melakukan berbilang jenis penjumlahan pada medan yang sama.

Tetingkap timbul Jumlah

  • Klik anak panah juntai bawah Jumlah Pada dan pilih medan yang anda ingin ada ringkaskan.

  • Klik anak panah juntai bawah Jenis dan pilih jenis pengiraan untuk dijalankan.

  • Pilih Tunjuk Jumlah Besar untuk menambah jumlah besar ke hujung laporan (dalam pengaki laporan).

  • Pilih Tunjuk jumlah kumpulan sebagai % daripada Jumlah Besar untuk menambah kawalan pada pengaki kumpulan yang mengira peratusan jumlah besar setiap kumpulan.

  • Pilih Tunjuk dalam pengepala kumpulan atau Tunjuk dalam pengaki kumpulan untuk memaparkan jumlah di lokasi yang diinginkan.

Setelah semua opsyen untuk medan telah dipilih, anda boleh mengulang proses tersebut dan meringkaskan medan yang lain dengan memilih medan lain dari senarai juntai bawah Jumlah Pada. Jika tidak, klik di luar tetingkap timbul Jumlah untuk menutupnya.

Tajuk    Ini membolehkan anda mengubah tajuk medan yang diringkaskan. Ini digunakan untuk tajuk lajur dan untuk melabelkan medan ringkasan dalam pengepala dan pengaki.

Untuk menambah atau mengubah suai tajuk:

  • Klik teks biru berikutan dengan tajuk.

    Kotak dialog Zum muncul.

  • Taip tajuk baru dalam kotak dialog, dan kemudian klik OK.

Dengan/tanpa seksyen pengepala    Gunakan seting ini untuk menambah atau mengalih keluar seksyen pengepala yang mendahului setiap kumpulan. Apabila menambah seksyen pengepala, Access mengalihkan medan perkumpulan kepada pengepala untuk anda. Apabila anda mengalih keluar seksyen pengepala yang mengandungi kawalan selain daripada medan perkumpulan, Access meminta pengesahan untuk memadam kawalan tersebut.

Dengan/tanpa seksyen pengaki    Gunakan seting ini untuk menambah atau mengalih keluar seksyen pengaki yang mengikuti setiap kumpulan. Apabila anda mengalih keluar seksyen pengaki yang mengandungi kawalan, Access meminta pengesahan untuk memadam kawalan tersebut.

Simpan kumpulan bersama    Seting ini menentukan cara kumpulan dipaparkan pada halaman apabila laporan dicetak. Anda mungkin ingin menyimpan kumpulan bersama seberapa banyak yang mungkin untuk mengurangkan jumlah selakan halaman yang diperlukan untuk melihat seluruh kumpulan. Walau bagaimanapun, ini biasanya meningkatkan jumlah kertas yang diperlukan untuk mencetak laporan, kerana kebanyakan halaman akan mempunyai sedikit ruang kosong di bahagian bawah.

  • Jangan simpan kumpulan bersama dalam satu halaman    Gunakan opsyen ini jika anda tidak bimbang tentang kumpulan yang dipecahkan oleh pemisah halaman. Contohnya, satu kumpulan 30 item mungkin mempunyai 10 item di bahagian bawah satu halaman dan baki 20 item pada bahagian atas halaman berikutnya.

  • Simpan seluruh kumpulan bersama dalam satu halaman    Opsyen ini membantu meminimumkan bilangan pemisah halaman dalam kumpulan. Jika satu kumpulan tidak boleh dimuatkan dalam baki ruang pada halaman, Access meninggalkan ruang kosong itu dan memulakan kumpulan pada halaman berikut. Kumpulan besar masih boleh merentangi berbilang halaman, tetapi opsyen ini meminimumkan sebanyak mungkin bilangan pemisah halaman dalam kumpulan.

  • Pastikan pengepala dan rekod pertama bersama dalam satu halaman    Bagi kumpulan dengan pengepala kumpulan, ini memastikan pengepala kumpulan tidak dicetak berasingan di bahagian bawah halaman. Jika Access menentukan bahawa tiada ruang mencukupi untuk sekurang-kurangnya satu baris data dicetak selepas pengepala, kumpulan bermula pada halaman berikutnya.

Mengubah keutamaan aras perkumpulan dan isihan

Untuk mengubah keutamaan aras perkumpulan atau isihan, klik baris dalam anak tetingkap Kumpul, Isih dan Jumlah dan kemudian klik anak panah ke atas atau ke bawah di sebelah kanan baris.

Memadam aras perkumpulan dan isihan

Untuk memadam aras perkumpulan atau isihan, klik baris yang anda ingin padam dalam anak tetingkap Kumpul, Isih dan Jumlah, dan kemudian tekan DELETE atau klik butang Padam di sebelah kanan baris. Apabila anda memadam aras perkumpulan, jika medan perkumpulan berada dalam pengepala atau pengaki kumpulan, Access mengalihkannya ke seksyen Butiran laporan. Sebarang kawalan lain yang berada dalam kumpulan pengepala atau pengaki kumpulan dipadam.

Halaman Atas

Mencipta laporan ringkasan (tanpa butiran rekod)

Jika anda ingin menunjukkan jumlah sahaja (iaitu, hanya maklumat dalam baris pengepala dan pengaki), pada Format tab (atau pada tab Reka bentuk dalam pandangan Reka bentuk), dalam Kumpulan pengumpulan & jumlah , klik Sembunyikan butiran. Melakukan ini menyembunyikan rekod di tahap seterusnya yang lebih rendah perkumpulan, menghasilkan persembahan lebih padat data ringkasan. Walaupun rekod tersembunyi, kawalan dalam seksyen tersembunyi tidak dipadamkan. Klik Sembunyikan butiran sekali lagi untuk memulihkan baris butiran laporan.

Cipta kesan perkumpulan tanpa menggunakan pengepala

Anda boleh mencapai kesan perkumpulan pada laporan anda tanpa menggunakan pengepala. Mengalih keluar pengepala mencipta laporan lebih padat kerana kurang Ruang menegak digunakan oleh baris pengepala.

Prosedur umum melibatkan mengalih keluar pengepala untuk setiap kumpulan yang memasuki medan perkumpulan setiap seksyen butiran laporan. Untuk memulihkan kesan visual perkumpulan, anda mengesetkan sifat Menyembunyikan pendua bagi setiap medan perkumpulan kepada Ya.

Contoh

Pertimbangkan laporan terkumpul lazim ini yang menggunakan pengepala Kumpulan:

Laporan terkumpul dengan pengepala kumpulan

Seperti yang anda boleh lihat, setiap nama Syarikat mengambil garis seluruh seperti tidak setiap perintah ID.

Dalam contoh ini, anda akan mengedit laporan agar ia kelihatan seperti ilustrasi berikut:

Laporan terkumpul dengan pengepala kumpulan dialih keluar

  1. Buka laporan dalam pandangan tataletak dengan mengklik kanan padanya dalam anak tetingkap navigasi, kemudian mengklik Pandangan tataletak Imej Butang .

  2. Pada tab Format , dalam Kumpulan pengumpulan & jumlah , klik kumpul & Isih. Imej Butang

    Nota: Ia merupakan idea yang baik untuk memulakan dengan Kumpulan terendah aras dan bekerja cara Jika tidak, paparan laporan boleh menjadi mengelirukan semasa anda bekerja.

  3. Klik aras perkumpulan terendah dalam senarai, dan kemudian klik lanjut.

  4. Daripada senarai juntai bawah seksyen pengepala, pilih tanpa seksyen pengepala.

    Apabila anda mengalih keluar pengepala, Access mengekalkan kotak teks untuk pengumpulan medan dengan mengalihkannya ke seksyen butiran. Walau bagaimanapun, kawalan lain dalam pengepala Kumpulan mungkin dipadamkan. Capaian mengingatkan anda jika sebarang kawalan akan dipadamkan sebagai hasil tindakan ini. Jika terdapat kawalan dalam pengepala Kumpulan yang anda ingin mengekalkan, pastikan anda mengalihkannya ke seksyen laporan lain sebelum menjalankan langkah ini. Anda perlu bertukar kepada pandangan Reka bentuk untuk mengalihkan kawalan pada seksyen yang lain.

    Laporan yang terhasil ditunjukkan dalam ilustrasi berikut. Perhatikan bahawa OrderID pertama yang berada pada baris yang sama sebagai rekod butiran pertama, bukannya pada baris sendiri.

    Laporan terkumpul dengan pengepala IDPesanan dialih keluar

    Malangnya, OrderID yang mengulangi pada setiap baris butiran, dan ini menjadikan sukar untuk dilihat tepat bilangan pesanan terdapat. Pada ketika ini, seting sifat Menyembunyikan pendua kawalan kotak teks adalah berguna. Ikuti langkah berikut untuk mengeset sifat ini:

    • Pilih salah satu nilai berulang.

    • Jika helaian sifat tidak dipaparkan buat masa ini, tekan F4 untuk memaparkannya.

    • Pada tab Format helaian sifat, klik senarai juntai bawah untuk Menyembunyikan pendua dan kemudian klik Ya.

      ID pesanan pendua tersembunyi. Perhatikan bahawa anda boleh melihat bilangan pesanan terdapat, dan berapa banyak produk terdapat adalah setiap pesanan.

      Laporan Terkumpul dengan IDPesanan pendua tersembunyi

  5. Untuk contoh ini, kami ulangi langkah 4 untuk aras perkumpulan nama Syarikat. Laporan akhir kelihatan seperti ilustrasi berikut:

    Laporan terkumpul dengan pengepala kumpulan dialih keluar

    Nilai nama syarikat sekarang pada baris yang sama sebagai rekod butiran pertama dan sifat Menyembunyikan pendua menghalang nilai nama Syarikat daripada berulang pada setiap baris. Untuk laporan panjang yang menggunakan beberapa aras perkumpulan, ini boleh menyebabkan penjimatan kertas ketara.

Halaman Atas

Menyimpan, mencetak atau menghantar laporan anda

Selepas anda menyimpan Reka bentuk laporan anda, anda boleh menggunakannya berbilang kali. Reka bentuk laporan yang kekal sama, tetapi anda melihat data semasa setiap kali anda mencetak laporan. Jika keperluan pelaporan anda berubah, anda boleh mengubah suai Reka bentuk laporan atau mencipta laporan baru, serupa yang berdasarkan pada asal.

Simpan laporan anda

  1. Klik Butang Microsoft Office Imej butang , kemudian klik Simpan, atau tekan CTRL + S Imej Butang .

    Secara alternatif, anda boleh klik Simpan Imej Butang pada Bar alat capaian segera.

  2. Jika laporan tidak bertajuk, taipkan nama dalam kotak Nama laporan dan kemudian klik OK.

Menyimpan Reka bentuk laporan anda di bawah nama baru

  1. Klik Butang Microsoft Office Imej butang , dan kemudian klik Simpan sebagai Imej butang .

  2. Di dalam kotak dialog Simpan sebagai , taipkan nama dalam kotak Simpan laporan untuk , klik laporan dalam kotak sebagai , dan kemudian klik OK.

Mencetak laporan anda

Anda boleh mencetak laporan daripada pratonton cetakan, pandangan tataletak, pandangan Reka bentuk, pandangan laporan, atau daripada anak tetingkap navigasi. Sebelum anda mencetak, anda perlu semak dua halaman seting, seperti Jidar dan orientasi halaman. Access menyimpan seting halaman dengan laporan, jadi anda perlu menyediakan hanya sekali. Anda boleh menyimpan seting kemudian, jika mengubah keperluan anda.

Mengubah seting halaman

  1. Buka laporan dalam sebarang pandangan.

  2. Pada tab Tataletak halaman , dalam Kumpulan halaman , klik Opsyen:

    • Saiz Imej butang membenarkan anda untuk memilih daripada beberapa saiz kertas, atau untuk memasukkan saiz kertas tersuai.

    • Potret Imej butang orients halaman secara menegak.

    • Landskap Imej Butang orients halaman secara mendatar.

    • Jidar Imej Butang membenarkan anda untuk memilih daripada beberapa lebar Jidar yang dipratentukan, atau anda boleh klik lanjutan untuk masukkan lebar Jidar tersuai menggunakan kotak dialog Persediaan halaman .

    • Tunjukkan Jidar Togol paparan Jidar dan mematikan (pandangan tataletak sahaja).

    • Lajur memaparkan kotak dialog Persediaan halaman . Masukkan bilangan lajur yang anda inginkan, setkan saiz lajur yang diinginkan anda dan kemudian klik OK.

    • Cetak Data sahaja menyekat pencetakan sebarang label yang anda telah diletakkan pada laporan anda. Kawalan yang terikat kepada data dalam Jadual atau pertanyaan dasar akan dicetak. Ciri ini mungkin berguna pada laporan yang anda kadangkala cetak pada borang pracetak. Anda boleh menyekat mencetak label dalam situasi tersebut, dan kemudian mendayakan mencetak label apabila anda mencetak laporan pada kertas kosong.

Nota: Untuk menggunakan seting halaman yang lebih terperinci, klik butang Persediaan halaman di penjuru bawah kanan Kumpulan Tataletak halaman untuk memaparkan kotak dialog Persediaan halaman . Anda boleh menggunakan kotak dialog Persediaan halaman untuk melaraskan seting yang tersedia pada tab Tataletak halaman , dan juga untuk memilih pencetak khusus untuk laporan.

Menghantar laporan anda ke pencetak

  1. Buka laporan dalam sebarang pandangan, atau hanya pilih laporan dalam anak tetingkap navigasi.

  2. Klik Butang Microsoft Office Imej butang , dan kemudian klik Cetak. Butang Cetak

  3. Dalam kotak dialog Cetak , masukkan pilihan anda untuk opsyen seperti pencetak, cetak julat dan bilangan salinan.

  4. Klik OK.

Halaman Atas

Menghantar laporan anda sebagai mesej e-mel

Anda boleh menghantar laporan anda kepada pengguna sebagai mesej e-mel dan bukannya mencetak salinan kertas.

  1. Dalam anak tetingkap navigasi, klik laporan untuk memilihnya, klik Butang Microsoft Office Imej butang , dan kemudian klik e-mel Imej Butang .

  2. Dalam Hantar objek sebagai kotak dialog, klik format fail yang anda ingin gunakan.

    Kotak dialog Hantar Objek Sebagai

  3. Lengkapkan sebarang kotak dialog yang selebihnya.

  4. Apabila program e-mel anda muncul, taipkan butiran mesej dan menghantar mesej.

Halaman Atas

Catatan

Masalah boleh timbul jika anda mempunyai laporan dalam fail .accdb yang Mengisih atau Kumpulan pada medan carian, dan anda ingin mengimport laporan tersebut ke dalam fail .mdb dan kemudian membukanya dengan versi terdahulu Access.

Kaedah dalaman yang medan carian Diisih dan dikumpulkan dalam fail .accdb tidak serasi dengan fail .mdb. Jika anda mencipta laporan dalam fail .accdb yang menggunakan perkumpulan atau isihan pada carian medan, dan anda kemudian eksport ke fail .mdb (atau gunakan perintah Simpan sebagai untuk menyimpan pangkalan data sebagai fail .mdb) dan kemudian cuba untuk membuka laporan dengan versi terdahulu capaian, laporan akan gagal untuk memuatkan.

Untuk menyemak laporan agar anda boleh mengimportnya ke dalam fail .mdb dan membukanya dalam versi terdahulu Access, lakukan yang berikut:

  1. Dalam fail .accdb, mencipta salinan laporan.

  2. Buka salinan laporan dalam pandangan tataletak.

  3. Jika anak tetingkap kumpul, Isih, dan jumlah tidak dipaparkan:

    1. Pada tab Format , dalam Kumpulan pengumpulan & jumlah , klik kumpul & Isih. Imej Butang

  4. Padam Semua baris dalam anak tetingkap kumpul, Isih, dan jumlah dengan mengklik butang padam di sebelah kanan setiap baris.

  5. Klik Butang Microsoft Office Imej butang , kemudian klik Simpan, atau tekan CTRL + S Imej Butang .

  6. Klik Butang Microsoft Office Imej butang , dan kemudian klik Tutup pangkalan data. Imej butang

  7. Klik Butang Microsoft Office Imej butang , dan kemudian klik Buka. Imej Butang

  8. Semak lalu ke fail .mdb yang anda ingin import laporan, dan kemudian klik Buka.

  9. Mengimport Salin laporan ke dalam fail .mdb.

    Bagaimana?

    1. Pada tab Data luaran , dalam Kumpulan Import , klik Access. Imej butang

    2. Klik Semak Lalu.

    3. Semak lalu ke fail .accdb yang mengandungi laporan dan klik Buka.

    4. Anda tidak mengimport sebarang Jadual pada masa ini, agar ia tidak kira sama ada anda memilih untuk mengimport atau memaut ke data sumber. Klik OK untuk teruskan.

    5. Dalam kotak dialog Import objek , klik tab laporan .

    6. Klik laporan yang anda ingin import, dan kemudian klik OK.

    7. Jika pengendalian import berjaya, Access meminta jika anda ingin menyimpan langkah import untuk kegunaan kemudian. Jika anda ingin menyimpan langkah, pilih kotak semak Simpan import langkah , masukkan maklumat yang diminta, dan klik Simpan Import. Jika anda tidak ingin menyimpan langkah, klik tutup.

      Capaian import laporan dan memaparkannya dalam anak tetingkap navigasi.

  10. Buka laporan dalam pandangan tataletak.

  11. Jika anak tetingkap Senarai medan tidak dipaparkan:

    1. Pada tab Format , dalam Kumpulan kawalan , klik Tambah medan sedia ada Imej Butang .

  12. Dalam anak tetingkap medan yang tersedia dalam Jadual berkaitan , mencari jadual yang mengandungi medan yang anda ingin paparkan pada Laporan. Medan ini akan mengandungi nilai yang sama yang anda sedang lihat dipaparkan dengan medan carian pada Laporan.

  13. Seret medan untuk laporan.

    Anda kini mempunyai dua lajur yang memaparkan maklumat yang sama.

  14. Klik kanan medan paparan yang baru sahaja anda tambah, dan klik Opsyen isihan yang anda ingin gunakan.

  15. Padam medan paparan yang anda baru sahaja Tambah dan Diisih.

  16. Jika anak tetingkap kumpul, Isih, dan jumlah tidak dipaparkan:

    1. Pada tab Format , dalam Kumpulan pengumpulan & jumlah , klik kumpul & Isih. Imej Butang

  17. Klik Tambah Kumpulan.

  18. Dalam tetingkap timbul Medan/ungkapan , klik nama medan carian pada Laporan.

Laporan sekarang Diisih dan dikumpulkan kerana ia telah dalam fail .accdb. Simpan dan tutup laporan.

Halaman Atas

Nota: Notis Penafian Penterjemahan Mesin: Artikel ini telah diterjemah oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan penterjemahan mesin ini untuk membantu pengguna-pengguna yang tidak bertutur dalam Bahasa Inggeris supaya dapat menikmati kandungan mengenai produk, perkhidmatan dan teknologi Microsoft. Artikel ini mungkin mengandungi ralat perbendaharaan kata, sintaks atau tatabahasa kerana ia diterjemahkan oleh mesin.

Kembangkan kemahiran anda
Jelajahi latihan
Dapatkan ciri baru terlebih dahulu
Sertai Office Insiders

Adakah maklumat ini membantu?

Terima kasih atas maklum balas anda!

Terima kasih atas maklum balas anda! Nampaknya ia mungkin akan membantu untuk menyambungkan anda kepada salah seorang daripada ejen sokongan Office kami.

×