Mencipta dan menggunakan sublaporan

Penting: Artikel ini diterjemahkan oleh mesin, lihatlah notis penafian. Sila dapatkan versi Bahasa Inggeris artikel ini di sini sebagai rujukan anda

Apabila anda bekerja dengan data hubungan (tempat data berkaitan disimpan dalam Jadual berasingan), anda biasanya perlu melihat maklumat daripada lebih daripada satu jadual atau pertanyaan pada laporan yang sama. Contohnya, anda ingin melihat data pelanggan, tetapi anda juga ingin melihat maklumat tentang pesanan pelanggan pada masa yang sama. Sublaporan yang ialah alat yang berguna untuk melakukan ini kerana ia membenarkan anda untuk memaparkan maklumat pesanan pada laporan dengan maklumat pelanggan, dengan cara yang logik dan mudah dibaca. Microsoft Office Access 2007 menyediakan banyak cara untuk membantu anda mencipta sublaporan dengan pantas.

Apakah yang anda ingin lakukan?

Memahami sublaporan

Mencipta sublaporan yang

Membuat perubahan Reka bentuk untuk sublaporan yang

Memahami sublaporan

Sublaporan yang merupakan laporan yang diselitkan dalam laporan yang lain. Apabila anda menggabungkan laporan, salah satu daripadanya mesti bertindak sebagai utama laporan yang mengandungi laporan lain. Laporan utama ialah terikat atau tidak terikat. Laporan terikat ialah sesuatu yang boleh memaparkan data dan mempunyai jadual, pertanyaanatau penyata SQL yang ditentukan dalam sifat Sumber rekod . Laporan tidak terikat ada ialah sesuatu yang tidak berdasarkan pada jadual, pertanyaan atau kenyataan SQL (iaitu, sifat Sumber rekod laporan adalah kosong).

Petua: Dalam Access 2010, laporan mempunyai kawalan tataletak, yang membantu memastikan perkara dibariskan dan Cari baik!

Contoh laporan utama tidak terikat dengan dua sublaporan yang tidak berkaitan   

Laporan utama tidak terikat ada tidak memaparkan sebarang data sendiri, tetapi ia masih boleh dijadikan sebagai laporan utama untuk tidak berkaitan sublaporan yang anda ingin gabungkan.

Laporan utama tidak terikat dengan dua sublaporan memaparkan data yang tidak berkaitan

1 laporan utama tidak terikat mengandungi dua sublaporan.

2. satu sublaporan meringkaskan jualan mengikut pekerja.

3. sublaporan lain meringkaskan jualan mengikut kategori.

Contoh laporan utama dan sublaporan yang terikat kepada sumber rekod yang sama   

Anda boleh menggunakan laporan utama untuk menunjukkan butiran rekod, seperti setiap jualan dalam tahun, dan kemudian gunakan sublaporan yang untuk menunjukkan maklumat ringkasan, seperti jumlah jualan untuk setiap suku.

Laporan utama dan sublaporan yang terikat kepada sumber rekod yang sama

1. sublaporan meringkaskan dalam tahun jualan mengikut suku.

2 laporan utama. menyenaraikan jualan harian.

Contoh laporan utama dan sublaporan yang terikat kepada sumber rekod yang berkaitan   

Laporan utama boleh mengandungi data yang biasa untuk satu atau lebih sublaporan. Dalam kes ini, sublaporan yang mengandungi data yang berkaitan dengan data dalam laporan utama.

Laporan utama dengan dua sublaporan memaparkan data berkaitan

1 laporan utama. menyenaraikan nama dan bandar pameran setiap.

2. sublaporan menyenaraikan wakil yang akan hadir pameran setiap.

Subborang pada Laporan

Laporan utama boleh memasukkan subborang selain sublaporan, dan ia boleh memasukkan sebanyak subborang dan sublaporan seperti yang anda inginkan. Selain itu, laporan utama boleh mengandungi sehingga tujuh aras subborang dan sublaporan. Contohnya, laporan boleh mengandungi sublaporan yang dan sublaporan yang boleh mengandungi subborang atau sublaporan dan sebagainya, sehingga tujuh tahap manusia.

Jika anda menambah subborang laporan dan kemudian buka laporan dalam pandangan laporan, anda boleh menggunakan subborang untuk menapis dan menavigasi melalui rekod. Visual Basic for Applications (VBA) kod dan terbenam makro yang dilampirkan pada borang dan kawalan yang akan masih berjalan, walaupun peristiwa beberapa dinyahdayakan dalam konteks ini. Anda tidak boleh menambah, mengedit atau memadamkan rekod menggunakan subborang pada Laporan.

Memautkan laporan subborang atau sublaporan

Apabila anda menyelitkan subborang atau sublaporan yang mengandungi maklumat yang berkaitan dengan data dalam laporan utama, kawalan sublaporan mesti dikaitkan dengan laporan utama. Pautan memastikan bahawa rekod yang dipaparkan dalam subborang atau sublaporan yang sepadan dengan betul dengan rekod yang dicetak dalam laporan utama.

Apabila anda mencipta subborang atau sublaporan menggunakan Bestari atau dengan menyeret objek daripada anak tetingkap Navigasi ke laporan, Access secara automatik pautan subborang atau sublaporan laporan utama jika salah satu syarat berikut dipenuhi.

  • Anda mentakrifkan perhubungan untuk jadual yang anda pilih, atau anda mentakrifkan perhubungan untuk jadual yang mendasari pertanyaan yang anda pilih.

    Untuk maklumat lanjut tentang mencipta perhubungan, lihat pautan dalam seksyen Lihat juga .

  • Laporan utama berdasarkan Jadual dengan kunci primerdan subborang atau sublaporan yang berdasarkan Jadual yang mengandungi medan dengan nama yang sama seperti yang kunci primer dan mempunyai sama atau serasi jenis data. Contohnya, jika kunci primer jadual yang mendasari laporan utama adalah medan Autonombor, dan sifat FieldSize disetkan kepada Integer panjang, medan yang sepadan dalam Jadual yang mendasari subborang atau sublaporan mesti medan nombor dengan sifat FieldSize yang disetkan kepada Integer panjang. Jika anda memilih pertanyaan atau pertanyaan sebagai sumber rekod subborang atau sublaporan, Jadual dasar dalam pertanyaan atau pertanyaan mesti memenuhi syarat yang sama.

Halaman Atas

Mencipta sublaporan yang

Jika sublaporan yang akan dipautkan ke laporan utama, pastikan sumber rekod dasar berkaitan sebelum menggunakan prosedur berikut. Untuk maklumat lanjut tentang mencipta perhubungan, lihat pautan dalam seksyen Lihat juga .

Menggunakan Bestari Sublaporan untuk mencipta sublaporan yang

  1. Buka laporan yang anda ingin gunakan sebagai laporan utama dalam Pandangan Reka Bentuk.

  2. Pada tab Reka bentuk , dalam Kumpulan kawalan , pastikan Gunakan Bestari kawalan Imej butang dipilih. Imej Butang

  3. Pada tab Reka bentuk , dalam Kumpulan kawalan , klik Subborang/Sublaporan Imej butang .

  4. Pada Laporan, klik di mana anda ingin letakkan sublaporan yang.

  5. Pada halaman pertama Bestari Sublaporan, jika anda ingin mencipta subborang baru atau sublaporan dan mengasaskan pada jadual atau pertanyaan, klik gunakan sedia ada jadual dan pertanyaan. Jika terdapat borang yang anda ingin gunakan sebagai sublaporan yang atau laporan sedia ada, klik gunakan laporan atau borang sedia ada, pilih laporan atau borang dalam senarai dan kemudian klik berikut.

    Memilih sumber data dalam Bestari Sublaporan

  6. Jika anda memilih menggunakan laporan atau borang sedia ada pada halaman Bestari yang sebelumnya, langkau langkah ini dan pergi terus ke langkah 7. Jika tidak, dari senarai Jadual/pertanyaan , pilih Jadual atau pertanyaan yang mengandungi medan yang anda inginkan dimasukkan pada sublaporan yang, dan kemudian dwiklik medan yang anda inginkan dalam Medan tersedia senarai untuk menambahkannya pada sublaporan yang.

    Memilih medan dalam Bestari Sublaporan

    Jika anda merancang untuk pautan sublaporan yang laporan utama, pastikan anda memasukkan medan atau medan yang akan digunakan untuk mencipta pautan, walaupun jika anda tidak ingin mereka akan dipaparkan. Lazimnya, medan memautkan adalah medan ID. Dalam ilustrasi sebelumnya, Jadual pesanan adalah sumber rekod sublaporan yang dan jadual pelanggan sumber rekod untuk laporan utama. Kerana Jadual pesanan berkaitan dengan jadual pelanggan mengikut medan ID pelanggan, medan yang ditambahkan pada senarai Medan terpilih .

    Nota: Anda boleh memasukkan medan daripada berbilang jadual dan pertanyaan pada sublaporan anda. Apabila anda selesai menambah medan daripada satu jadual, pilih Jadual atau pertanyaan yang berikut daripada senarai Jadual/pertanyaan dan kemudian menambah medan yang anda inginkan.

    Klik berikut untuk meneruskan.

  7. Pada halaman ini Bestari, anda menentukan cara untuk memautkan sublaporan yang laporan utama. Jika Access menemui medan yang kelihatan sesuai untuk memautkan sublaporan yang laporan utama, Bestari memaparkan senarai cadangan pautan yang mungkin.

    Access mencadangkan medan untuk dipautkan dalam Bestari Sublaporan

    Anda boleh memilih cadangan memautkan yang kelihatan paling sesuai untuk situasi anda atau, jika anda tidak ingin sublaporan untuk dipautkan ke laporan utama, pilih tiada. Jika anda ingin pautkan sublaporan yang laporan utama, tetapi tiada cadangan kelihatan sesuai, klik takrifkan saya sendiri.

    Nota: Jika Bestari tidak dapat mencari medan yang sesuai untuk dipautkan, ia tidak menyediakan senarai pautan cadangan dan memilih opsyen mentakrifkan saya secara automatik.

    Mentakrifkan pautan anda sendiri dalam Bestari Sublaporan

    Apabila opsyen mentakrifkan saya dipilih, Bestari memaparkan dua set senarai.

    • Di bawah medan borang/Laporan, pilih medan daripada laporan utama yang anda ingin gunakan untuk memautkan laporan utama ke subborang atau sublaporan. Anda boleh memilih sehingga tiga medan dan setiap medan yang anda pilih mesti sepadan dengan medan berkaitan dalam subborang tersebut atau sublaporan pada sumber data.

    • Di bawah medan Subborang/sublaporan, pilih medan yang sepadan daripada subborang atau sublaporan yang memaut ke medan laporan utama yang anda pilih.

    • Untuk meninggalkan subborang atau sublaporan dinyahpautkan laporan utama, pastikan bahawa semua senarai kosong.

      Klik berikut untuk meneruskan.

  8. Pada halaman terakhir Bestari, taipkan nama untuk subborang atau sublaporan atau hanya klik selesai untuk menerima lalai.

    Menyediakan nama dalam Bestari Sublaporan

Access menambah kawalan sublaporan laporan anda dan mengikatkannya pada (iaitu, mengeset sifat bagi kawalan Objek sumber ) seperti berikut:

  • Jika anda memilih menggunakan laporan atau borang sedia ada pada halaman pertama Bestari, Access mengikatkannya pada sublaporan laporan atau borang yang anda tentukan.

  • Jika anda memilih menggunakan Jadual sedia ada dan pertanyaan pada halaman pertama Bestari, Access mencipta objek laporan baru dalam anak tetingkap navigasi dan kemudian mengikatkannya pada sublaporan ia. Nama objek laporan baru adalah sama dengan nama yang anda taipkan pada halaman terakhir Bestari.

Menambahkan Jadual, pertanyaan, borang atau laporan laporan sebagai sublaporan yang

Cara yang pantas untuk menambah sublaporan yang laporan adalah untuk membuka laporan utama dalam pandangan Reka bentuk dan kemudian seret objek daripada anak tetingkap navigasi padanya. Jika anda ingin subborang atau sublaporan untuk dipautkan ke laporan utama, pastikan sumber rekod dasar yang berkaitan dan sumber rekod termasuk medan yang akan digunakan untuk memautkan subborang atau sublaporan ke laporan utama. Untuk maklumat lanjut tentang mencipta perhubungan, lihat pautan dalam seksyen Lihat juga .

  1. Dalam anak tetingkap navigasi, klik kanan laporan yang anda ingin gunakan sebagai laporan utama dan kemudian klik Pandangan Reka bentuk pada menu pintas.

  2. Seret Jadual, pertanyaan, borang atau laporan lain daripada anak tetingkap Navigasi ke seksyen laporan utama yang anda ingin sublaporan muncul.

Access melakukan salah satu yang berikut:

  • Jika Access boleh menentukan cara untuk memautkan dua objek, Access menambah kawalan sublaporan laporan. Jika anda menambah borang atau laporan, Access mengikatkannya pada sublaporan objek. Jika anda menambah Jadual atau pertanyaan, Access mula-mula mencipta objek laporan dan kemudian mengikatkannya pada sublaporan objek baru.

  • Jika Access tidak boleh menentukan cara untuk memautkan dua objek, Bestari Sublaporan muncul. Untuk meneruskan, ikuti prosedur dalam seksyen mencipta sublaporan yang, bermula dengan langkah 7.

    Selepas anda melengkapkan Bestari, Access menambah sublaporan yang laporan.

Gunakan prosedur berikut untuk semak semula bahawa subborang atau sublaporan dengan betul dipautkan ke laporan utama.

  1. Klik sublaporan kawalan untuk memilihnya.

  2. Jika helaian sifat belum lagi dipaparkan, tekan F4 untuk memaparkannya.

  3. Pada tab Data helaian sifat, periksa sifat Pautkan medan induk dan Pautkan medan anak .

    • Untuk subborang dinyahpautkan atau sublaporan, kedua-dua sifat ini sepatutnya kosong.

    • Bagi subborang terpaut atau sublaporan, sifat Pautkan medan induk dan Pautkan medan anak sepatutnya memaparkan medan atau medan yang mengaitkan dua objek bersama-sama. Contohnya, jika laporan utama memaparkan maklumat daripada jadual pekerja dan subborang atau sublaporan memaparkan maklumat daripada jadual pesanan, sifat Pautkan medan induk sepatutnya memaparkan medan ID dari jadual pekerja dan sifat Pautkan medan anak sepatutnya memaparkan medan ID pekerja dari jadual pesanan.

Anda mungkin menemui sifat ini perlu diedit untuk subborang atau sublaporan berfungsi dengan baik. Gunakan prosedur berikut.

  1. Pada tab Data helaian sifat, klik kotak sifat Pautkan medan induk dan kemudian klik Butang Pembina .

    Kotak dialog Pemaut medan Sublaporan muncul.

    Kotak dialog Pemaut Medan Sublaporan

  2. Dalam Medan induk dan senarai Medan anak , pilih medan yang anda ingin pautkan laporan dengan. Jika anda tidak pasti medan yang digunakan, klik mewakili untuk membuat capaian cuba menentukan medan memautkan. Apabila anda selesai, klik OK.

    Jika anda tidak melihat medan yang anda ingin gunakan untuk memaut laporan, anda perlu mengedit sumber rekod laporan utama atau subborang atau sublaporan untuk memastikan bahawa ia mengandungi medan memautkan. Contohnya, jika laporan berdasarkan pada pertanyaan, anda harus memastikan bahawa medan memautkan hadir dalam hasil pertanyaan.

  3. Menyimpan laporan utama dan bertukar kepada pandangan laporan, dan kemudian sahkan laporan berfungsi seperti yang anda jangkakan.

Menambah Jadual atau pertanyaan pada Laporan sebagai helaian data

Helaian Data adalah mudah penampilan visual data, serupa dengan hamparan. Setiap lajur dalam helaian data mewakili medan dalam Jadual atau pertanyaan dan setiap baris mewakili rekod. Anda boleh menggunakan kawalan Subborang/Sublaporan untuk memaparkan helaian data pada Laporan. Ini ialah teknik yang baik untuk digunakan dalam situasi yang anda inginkan paparan padat data tetapi tidak memerlukan kemampuan pemformatan objek borang atau laporan. Untuk menambahkan helaian data laporan:

  1. Dalam anak tetingkap navigasi, klik kanan laporan yang anda ingin gunakan sebagai laporan utama dan kemudian klik Pandangan Reka bentuk pada menu pintas.

  2. Pada tab Reka bentuk , dalam Kumpulan kawalan , pastikan Gunakan Bestari kawalan tidak dipilih. Imej Butang

  3. Pada tab Reka bentuk , dalam Kumpulan kawalan , klik alat Subborang/Sublaporan Imej butang .

  4. Pada Laporan, klik di mana anda ingin letakkan sublaporan yang.

  5. Jika Bestari Sublaporan bermula, klik Batal untuk menutupnya.

  6. Jika helaian sifat belum lagi dipaparkan, tekan F4 untuk memaparkannya.

  7. Pada Laporan, klik kawalan sublaporan yang baru untuk memilihnya.

  8. Pada tab Data helaian sifat, klik anak panah dalam kotak sifat Sumber objek , dan kemudian klik Jadual atau pertanyaan yang anda ingin paparkan dalam kawalan sublaporan. Contohnya, untuk memaparkan Jadual pesanan, klik Table.Orders.

    Capaian cuba pautan helaian data untuk laporan utama, berdasarkan perhubungan yang ditakrifkan dalam pangkalan data.

  9. Pada tab Data helaian sifat, periksa sifat Pautkan medan induk dan Pautkan medan anak .

    • Untuk helaian data yang tidak terpaut, pastikan bahawa kedua-dua sifat ini adalah kosong.

    • Untuk helaian data terpaut, pastikan sifat Pautkan medan induk dan Pautkan medan anak memaparkan medan atau medan yang berkait laporan utama dengan helaian data. Contohnya, jika laporan utama memaparkan maklumat daripada jadual pekerja dan helaian data memaparkan maklumat daripada jadual pesanan, sifat Pautkan medan induk sepatutnya memaparkan medan ID dari jadual pekerja dan sifat Pautkan medan anak sepatutnya memaparkan medan ID pekerja dari jadual pesanan.

Dalam sesetengah kes, anda mungkin perlu mengesetkan pautan sifat medan diri anda. Anda boleh melakukannya dengan menggunakan prosedur berikut.

  1. Pada tab Data helaian sifat, klik kotak sifat Pautkan medan induk dan kemudian klik Butang Pembina .

    Kotak dialog Pemaut medan Sublaporan muncul.

    Kotak dialog Pemaut Medan Sublaporan

  2. Dalam Medan induk dan senarai Medan anak , pilih medan yang anda ingin gunakan untuk memaut laporan utama ke helaian data. Jika anda tidak pasti medan yang menggunakan, klik mewakili untuk membuat capaian cuba menentukan medan memautkan. Apabila anda selesai, klik OK.

    Jika anda tidak melihat medan yang anda ingin gunakan untuk dipautkan, anda perlu mengedit sumber rekod laporan induk atau helaian data untuk memastikan bahawa ia mengandungi medan memautkan. Contohnya, jika helaian data berdasarkan pada pertanyaan, anda harus memastikan bahawa medan memautkan hadir dalam hasil pertanyaan.

  3. Menyimpan laporan utama dan bertukar kepada pandangan laporan, dan kemudian sahkan laporan berfungsi seperti yang anda jangkakan.

Halaman Atas

Membuat perubahan Reka bentuk untuk sublaporan yang

Selepas anda menambah sublaporan pada Laporan, anda mungkin ingin membuat perubahan Reka bentuk untuk sublaporan yang, atau anda mungkin ingin merujuk kepada data sublaporan pada laporan utama. Seksyen berikut menyediakan Petua mengenai cara untuk menyiapkan tugas ini.

Buka subborang atau sublaporan dalam tetingkap baru dalam pandangan Reka bentuk

Untuk membuat perubahan Reka bentuk subborang atau sublaporan semasa anda bekerja pada laporan utama dalam pandangan Reka bentuk, anda boleh membuka subborang atau sublaporan dalam tetingkapnya sendiri.

  1. Klik subborang atau sublaporan untuk memilihnya.

  2. Pada tab Reka bentuk , dalam Kumpulan alat , klik Sublaporan dalam tetingkap baru Imej Butang .

Nota: Perintah ini kini tidak tersedia jika kawalan subborang/sublaporan yang terikat kepada jadual atau pertanyaan.

Paparkan jumlah daripada sublaporan yang pada laporan utama

Katakan anda menggunakan sublaporan yang dinamakan pesanan sublaporan yang mengandungi kotak teks yang bernama penghantaran yuran jumlah dan kotak teks tersebut mengira jumlah lajur yuran penghantaran. Untuk memaparkan jumlah daripada sublaporan yang pada laporan utama, anda mesti menambah kotak teks laporan utama dan kemudian menggunakan ungkapan untuk merujuk kepada kotak teks penghantaran yuran jumlah pada sublaporan yang. Anda boleh melakukannya dengan menggunakan prosedur berikut.

  1. Klik kanan laporan utama dalam anak tetingkap navigasi, dan kemudian klik pandangan Reka bentuk pada menu pintas.

  2. Pada tab Reka bentuk , dalam Kumpulan kawalan , klik Kotak teks. Imej Butang

  3. Pada laporan utama, klik di mana anda ingin tempatkan kotak teks baru.

  4. Jika helaian sifat belum lagi dipaparkan, tekan F4 untuk memaparkannya.

  5. Pada tab Data helaian sifat, dalam kotak sifat Sumber kawalan , taipkan ungkapan berikut.

    = IIf (IsError ([sublaporan pesanan]. [ Laporan]! [Penghantaran jumlah yuran]), 0, [sublaporan pesanan]. [Laporan]! [Jumlah yuran penghantaran])

    Nota: 

    • Dalam contoh ini, anda boleh menggunakan ungkapan lebih ringkas = [pesanan sublaporan]. [ Laporan]! [Jumlah yuran penghantaran] tetapi kemudian, jika sublaporan yang tidak mengandungi sebarang data, kawalan pada laporan utama memaparkan #Error. Menggunakan fungsi IsError dalam fungsi IIf , seperti yang ditunjukkan dalam ungkapan pertama, memastikan kotak teks pada laporan utama memaparkan sifar (0) jika sublaporan yang tidak mengembalikan sebarang data.

    • Anda boleh menggunakan pembina ungkapan untuk mencipta ungkapan dengan mengklik Butang Pembina dalam kotak sifat Sumber kawalan .

  6. Pada tab Format helaian sifat, setkan sifat Format kepada nilai yang sesuai (dalam kes ini, Mata Wang).

  7. Menyimpan laporan, dan kemudian Tukar kepada pandangan laporan untuk mengesahkan pengiraan berfungsi seperti jangkaan anda.

Halaman Atas

Nota: Notis Penafian Penterjemahan Mesin: Artikel ini telah diterjemah oleh sistem komputer tanpa campur tangan manusia. Microsoft menawarkan penterjemahan mesin ini untuk membantu pengguna-pengguna yang tidak bertutur dalam Bahasa Inggeris supaya dapat menikmati kandungan mengenai produk, perkhidmatan dan teknologi Microsoft. Artikel ini mungkin mengandungi ralat perbendaharaan kata, sintaks atau tatabahasa kerana ia diterjemahkan oleh mesin.

Kembangkan kemahiran anda
Jelajahi latihan
Dapatkan ciri baru terlebih dahulu
Sertai Office Insiders

Adakah maklumat ini membantu?

Terima kasih atas maklum balas anda!

Terima kasih atas maklum balas anda! Nampaknya ia mungkin akan membantu untuk menyambungkan anda kepada salah seorang daripada ejen sokongan Office kami.

×