×
Angliski
Diemžēl šis raksts jūsu valodā nav pieejams.

Check spelling and grammar in Office for Mac

Office for Mac applications automatically check for potential spelling and grammatical errors as you type. If you’d rather wait to check spelling and grammar until you're done writing, you can turn off automatic checking, or you can check spelling and grammar all at once.

Note: For information about checking spelling and grammar in Office for Windows, see Check spelling and grammar in Office.

Word

Check spelling and grammar automatically as you type

Word automatically checks for and marks potential spelling errors with a red squiggly line.

Spelling error marked with a red squiggly line

Word also checks for and marks potential grammatical errors with a green squiggly line.

Grammatical error marked by a green squiggly line

Tip: If spelling or grammatical errors aren't marked, you might need to turn on automatic spelling and grammar checking, which is explained in the next procedure.

When you see a spelling or grammatical error, Control click the word or phrase and choose one of the options.

Grammatical error with contextual menu showing options for correcting it

If Word has incorrectly flagged a word as misspelled and you want to add that word to your dictionary so that Word will properly recognize it in the future see Add words to your spell check dictionary in Word 2016 for Mac.

  1. On the Word menu, click Preferences > Spelling & Grammar.

  2. In the Spelling & Grammar dialog box, under Spelling, check or clear the Check spelling as you type box.

  3. Under Grammar, check or clear the Check grammar as you type box.

  4. Close the dialog box to save your changes.

  1. On the Review tab, click Spelling & Grammar.

  2. If Word finds a potential error, the Spelling & Grammar dialog box will open, spelling errors will be shown as red text, and grammatical errors will be shown as green text.

  3. To fix an error, do one of the following:

    • Type the correction in the box and then click Change.

    • Under Suggestions, click the word you want to use, and then click Change.

    To skip the error, do one of the following:

    • Click Ignore to skip only that instance of the error.

    • Click Ignore All to skip all instances of the error.

    • For a grammatical error, click Next Sentence to skip that instance of the error and move to the next error.

    To skip a misspelled word in all documents, click Add to add it to the dictionary. This only works for misspelled words. You can’t add custom grammar to the dictionary.

  4. After you correct, ignore, or skip an error, Word moves to the next one. When Word finishes reviewing the document, you’ll see a message that the spelling and grammar check is complete.

  5. Click OK to return to your document.

You can clear or reset the list of Ignored Words and Grammar so Word will check for spelling and grammar issues you previously told it to ignore.

Note: When you reset the list of Ignored Words and Grammar, the list is cleared only for the currently open document. Any spelling or grammar issues you told Word to ignore in other documents won't be affected.

  1. Open the document that needs to be checked.

  2. On the Tools menu, point to Spelling and Grammar, and then click Reset Ignored Words and Grammar.

    To clear the lists of words and grammar that Word ignores, click Reset Ignored Words and Grammar.

    Word displays a warning about the operation resetting the spelling checker and the grammar checker.

    Cause Word to check for spelling and grammar that you told Word to ignore earlier by clicking Yes.
  3. Click Yes to proceed.

  4. Click the Review tab, and then click Spelling & Grammar to check spelling and grammar.

Outlook

Check spelling and grammar automatically as you type

By default, Outlook checks for spelling errors as you type. Outlook uses a dashed red underline to indicate possible spelling errors and a dashed green line to indicate possible grammatical errors.

Spelling error marked with dashed red underline

  1. When you see a word with a dashed underline, Control click the word or phrase and choose one of the options.

    Spelling error with menu showing options for correcting it

  2. On the shortcut menu, do one of the following:

    • Click one of the guesses at the top of the shortcut menu.

    • Click Ignore Spelling to ignore one instance of the word.

    • Click Learn Spelling to add the word to the spelling dictionary.

After opening an email message:

  • To have Outlook correct spelling mistakes automatically, on the Outlook menu, click Preferences. Click on Spelling and Grammar under Personal Settings. Click box next to Checkspelling as you type.

  • To turn automatic grammar checking on or off, on the Outlook menu, click Preferences. Click on Spelling and Grammar under Personal Settings. Click box next to Check grammar as you type.

Check spelling as your type preference

You can correct all the spelling and grammar issues at the same time after you finish composing a message or other items.

  1. On the Edit menu, point to Spelling and Grammar, and then click Spelling and Grammar...

  2. Do any of the following:

    • In the list of suggestions, click the word that you want to use, or enter a new spelling in the box at the top, and then click Change.

    • Click Ignore to ignore this word and move on to the next misspelled word.

    • Click Add to add the word to the spelling dictionary.

Tip: The keyboard shortcut for skipping to the next spelling or grammar error is COMMAND + ; .

PowerPoint

You can check spelling in PowerPoint, but you can't check grammar.

Check spelling automatically as you type

PowerPoint automatically checks for and marks potential spelling errors with a wavy, red underline:

Spelling error marked with a red squiggly line

Tip: If spelling errors aren't marked, you might need to turn on automatic spell checking, which is explained in the next procedure.

When you see a spelling error, Ctrl+click or right-click the word or phrase and choose one of the suggested options.

  1. On the PowerPoint menu, click Preferences > Spelling.

  2. In the Spelling dialog box, select or clear the Check spelling as you type box.

  1. On the Review tab, click Spelling.

  2. If PowerPoint finds a potential error, the Spelling pane opens and spelling errors are shown.

  3. To fix an error, do one of the following:

    • Correct the error on your slide.

    • Click one of the suggested words in the Spelling pane, and then click Change.

    To skip the error, do one of the following:

    • Click Ignore to skip only that instance of the error.

    • Click Ignore All to skip all instances of the error.

    • click Add to skip a misspelled word in all documents and add it to the dictionary.

  4. After you correct, ignore, or skip an error, PowerPoint moves to the next one. When PowerPoint finishes reviewing the presentation, you’ll see a message that the spelling check is complete.

  5. Click OK to return to your presentation.

Excel

You can check spelling in Excel, but you can't check grammar.

Check spelling all at once

  1. On the Review tab, click Spelling.

    Note: The Spelling dialog box will not open if no spelling errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following.

    To

    Do this

    Change the word

    Under Suggestions, click the word that you want to use, and then click Change.

    Change every occurrence of this word in this document

    Under Suggestions, click the word that you want to use, and then click Change All.

    Ignore this word and move on to the next misspelled word

    Click Ignore Once.

    Ignore every occurrence of this word in this document and move on to the next misspelled word

    Click Ignore All.

See also

Check spelling and grammar in a different language in Office 2016 for Mac

Spelling or grammar checker flags text I don't want or expect it to flag in Word 2016 for Mac

Use a custom dictionary in Office for Mac

Paplašiniet savas Office prasmes
Iepazīties ar apmācību
Esiet pirmais, kas saņem jaunās iespējas
Pievienoties Office Insider programmai

Vai šī informācija bija noderīga?

Paldies par jūsu atsauksmēm!

Paldies par atsauksmēm! Šķiet, ka varētu būt noderīgi sazināties ar kādu no mūsu Office atbalsta aģentiem.

×