XML 데이터 내보내기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

가져온된 XML 데이터 매핑된 셀 워크시트에 데이터를한 후 데이터를 변경 하는 경우가 내보내기 또는 XML 파일에 데이터를 저장 합니다.

중요: 때 내보낼 수 있는 행의 수를 제한은 XML 맵을 만드는 하 고 Excel에서 데이터를 XML 데이터 파일로 내보내기 합니다. Excel에서 XML로 내보내기 65, 536 행의 최대를 저장 됩니다. 파일에 65, 536 개 행을 Excel 첫 번째 (#ROWS mod 65, 537) 행 내보냅니다. 예를 들어 워크시트 70, 000 행에 있으면 Excel 70000 mod 65, 537 = 4464 행 내보냅니다. 1) xlsx를 대신 사용 또는 2) XML 스프레드시트 2003 (.xml)로 파일을 저장 하는 것이 좋습니다 매핑, 손실 되거나 3) 65536 후 모든 행을 삭제 합니다를 한 매핑 유지 하지만 파일의 끝에 있는 데이터가 손실 됩니다를 다시 내보냅니다.

워크시트에서 XML 데이터 내보내기 방법은 다음과 같습니다.

  1. 개발자 를 클릭 > 내보냅니다.

    개발 도구 탭이 표시되지 않을 경우 개발 도구 탭 표시를 참조하세요.

  2. 작은 XML 내보내기 대화 상자가 나타나면 사용할 XML 맵을 클릭 하 고 확인 을 클릭 합니다.

    이 대화 상자는 XML 표가 선택 되지 및 통합 문서에 여러 개의 XML 맵이 포함 하는 경우에 표시 됩니다.

  3. XML 내보내기 대화 상자의 파일 이름 상자에 XML 데이터 파일의 이름을 입력합니다.

  4. 내보내기를 클릭합니다.

    참고: 제목 또는 레이블이 있는 XML 맵의 XML 요소 이름과 다른 워크시트에 있으면 Excel 내보내거나 워크시트에서 XML 데이터를 저장 하면 XML 요소 이름이 사용 됩니다 합니다.

65, 536 개 이상의 행이 포함 된 작업 하는 경우 워크시트에서 XML 데이터를 내보내는 방법에는 다음과 같습니다.

  1. 파일에 있는 행의 총 수에서 65, 537을 뺍니다. 이렇게 하면 행 수가 x 있습니다.

  2. Excel 워크시트의 시작 부분에서 행 x 삭제 합니다.

  3. 워크시트를 XML 데이터 파일로 내보냅니다.

  4. Excel 워크시트를 닫았다가 다시 합니다.

  5. 총 x 개, 다음의 모든 행 삭제 및 XML 데이터 파일로 내보냅니다.

    이 절차에서는 줍니다 행의 나머지를 반환 합니다. 두 개의 XML 내보내기 주어 지점 파일과 결합은 at 원래의 워크시트를 총 됩니다.

매핑된 셀의 XML 데이터를 XML 데이터 파일로 저장

전 버전의 XML 기능과 호환성을 유지하기 위해 내보내기 명령을 사용하지 않고 파일을 XML 데이터 파일(.xml)로 저장할 수 있습니다.

  1. Ctrl+S를 눌러 파일을 저장합니다.

    이 단계를 사용하면 통합 문서를 XML 데이터 파일로 저장할 때 통합 문서의 변경 내용이 소실되지 않습니다.

  2. Excel 2010 및 2013 클릭 파일 > 다른 이름 으로 저장 한 파일을 저장할 위치를 선택 합니다.

    Excel 2007에서 Office 단추 이미지 Microsoft Office 단추 클릭 하 고 다른 이름 으로 저장 옆의 화살표를 가리킨 다음 기타 표시 형식을 지정 을 클릭 합니다.

  3. 파일 이름 상자에 XML 데이터 파일의 이름을 입력 합니다.

  4. 파일 형식 목록에서 XML 데이터를 클릭 하 고 저장 을 클릭 합니다.

  5. XML 데이터 기능이 소실 될 수 있는 파일을 저장 하 라는 메시지가 나타나면 계속을 클릭 합니다.

  6. 작은 XML 내보내기 대화 상자가 나타나면 사용할 XML 맵을 클릭 하 고 확인 을 클릭 합니다.

    이 대화 상자는 XML 표가 선택 되지 및 통합 문서에 여러 개의 XML 맵이 포함 하는 경우에 표시 됩니다.

  7. XML 내보내기 대화 상자의 파일 이름 상자에 XML 데이터 파일의 이름을 입력 합니다.

  8. 내보내기를 클릭합니다.

참고: 제목 또는 레이블이 있는 XML 맵의 XML 요소 이름과 다른 워크시트에 있으면 Excel 내보내거나 워크시트에서 XML 데이터를 저장 하면 XML 요소 이름이 사용 됩니다 합니다.

XML 데이터를 내보낼 때 발생할 수 있는 일반적인 문제

XML 데이터를 내보낼 때 아래와 같은 메시지가 나타날 수 있습니다.

XML 맵을 내보낼 수 있지만 일부 필수 요소가 매핑되지 않습니다.

이 메시지가 표시되는 원인으로는 여러 가지가 있습니다.

  • 이 XML 표와 연결 된 XML 맵을 하나 이상의 필수 요소가 XML 표에 매핑되지 않은 있습니다.

    XML 원본 작업창의 계층적 요소 목록에서 각 요소의 왼쪽에 관련 아이콘이 표시됩니다. 필수 요소의 경우에는 해당 아이콘의 오른쪽 위 모서리에 빨간색 별표가 표시됩니다. 필수 요소를 매핑하려면 워크시트에서 이를 표시할 위치로 해당 요소를 끕니다.

  • 요소가 재귀 구조입니다.

    재귀 구조의 일반적인 예로는 동일한 XML 요소가 여러 수준으로 중첩된 직원 및 관리자 계층 구조를 들 수 있습니다. XML 원본 작업창에서 모든 요소를 매핑하더라도 Excel에서 지원하는 재귀 구조는 한 수준까지이므로 요소 전체를 매핑할 수 없습니다.

  • XML 표에 혼합된 콘텐츠가 포함되어 있습니다.

    혼합된 콘텐츠는 요소에 자식 요소가 있고 자식 요소 외부에 간단한 텍스트가 있는 경우 발생합니다. 굵은 글꼴 태그 등의 서식 태그를 사용하여 요소 내의 데이터를 표시하는 경우를 예로 들 수 있습니다. Excel에서 자식 요소를 지원하는 경우 자식 요소를 표시할 수 있더라도 데이터를 가져오면 텍스트 내용이 소실되고 데이터를 내보내면 텍스트 내용을 사용할 수 없으므로 이러한 자식 요소는 상호 전환될 수 없습니다.

통합 문서의 XML 맵은 내보낼 수 없음

다른 요소와 매핑된 요소의 관계 보존할 수 없는 경우 XML 맵은 내보낼 수 없습니다. 이 관계는 다음과 같은 이유로 소실 될 수 있습니다.

  • 매핑된 요소의 스키마 정의가 다음 특성의 시퀀스에 포함되어 있습니다.

    • maxoccurs 특성이 1이 아닙니다.

    • 시퀀스에 직계 자식 요소가 여러 개 정의 또는 직계 자식으로 다른 합니다.

  • 같은 반복 부모 요소의 반복되지 않는 형제 요소들이 다른 XML 표에 매핑되어 있습니다.

  • 여러 반복 요소가 XML 표에 매핑되어 있고 조상 요소에서 정의 하지 합니다.

  • 다른 부모의 자식 요소들이 같은 XML 표에 매핑되어 있습니다.

또한, 다음 XML 스키마 구문 중 하나에 XML 맵은 내보낼 수 없습니다.

  • 목록의 목록    한 항목 목록에 다른 항목 목록이 들어 있습니다.

  • 비정규화된 데이터    XML 표에는 maxoccurs 특성을 1로 설정하여 한 번만 발생하도록 스키마에 정의된 요소가 있습니다. 이러한 요소를 XML 표에 추가하면 Excel에서 요소의 여러 인스턴스로 해당 표의 열이 채워집니다.

  • 선택    매핑된 요소가 <choice> 스키마 구문의 일부입니다.

통합 문서에 매핑된 범위가 없어 Excel에서 저장할 수 없음

하나 이상의 매핑된 범위를 만들지 Excel 통합 문서를 XML 데이터 파일로 저장할 수 없습니다.

통합 문서에 XML 맵을 추가 했으면 다음 단계 워크시트에 XML 요소를 매핑합니다.

  1. 개발 도구 > 원본을 클릭합니다.

    개발 도구 탭의 XML 명령

    개발 도구 탭이 표시되지 않을 경우 개발 도구 탭 표시를 참조하세요.

  2. XML 원본 작업창에서 워크시트로 매핑하려는 요소를 선택 합니다.

    인접하지 않은 여러 요소를 선택하려면 요소 하나를 클릭하고 Ctrl 키를 누른 채로 다른 요소를 클릭합니다.

  3. 워크시트에서 표시할 위치로 선택한 요소를 끕니다.

통합 문서에 XML 맵을 아직 추가 하지 않았다면 또는 XML 표에 데이터가 없는 경우 excel 매크로 사용 통합 문서 파일 형식 (.xlsm) 통합 문서를 저장 합니다.

개발 도구 탭 표시

개발 도구 탭이 나타나지 않는 경우 다음을 실행하여 표시합니다.

  • Excel 2013 및 Excel 2010:

    1. 파일 > 옵션을 클릭합니다.

    2. 리본 사용자 지정 범주를 클릭합니다.

    3. 기본 탭에서 개발 도구 확인란을 선택한 다음 확인을 클릭합니다.

  • Excel 2007:

    1. Microsoft Office 단추 Office 단추 이미지 > Excel 옵션을 클릭합니다.

    2. 기본 설정 범주를 클릭합니다.

    3. Excel에서 가장 많이 사용하는 옵션에서 리본 메뉴에 개발 도구 탭 표시 확인란을 선택한 다음 확인을 클릭합니다.

참고 항목

보기의 Excel에서 XML 통해

셀에 XML 맵을 맵의 XML 요소

XML 파일 (파워 쿼리)에 연결

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×