XML 데이터 가져오기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

경우 하면 이전에 XML 맵을 만들수는 매핑된 셀에 XML 데이터를 가져올 수 있지만 여러 가지 방법와 XML 맵을 없이 XML 데이터 가져오기에 대 한 명령입니다.

XML 맵을 사이트가 있는 경우 매핑된 셀에 XML 데이터를 가져오려면 다음을 실행.

  1. XML 맵을에서 매핑된 셀 중 하나를 선택 합니다.

  2. 개발자 를 클릭 > 가져오기를 합니다.

    개발 도구 탭이 보이지 않으면 개발 도구 탭 표시를 참조 하십시오.

  3. XML 가져오기 대화 상자에서 찾아 가져올, XML 데이터 파일 (.xml)을 선택 하 고 가져오기 를 클릭 합니다.

XML 데이터 가져오기 하는 다른 방법

문제에 대 한 자세한 내용은이 문서의 뒷부분에서 XML 데이터를 가져오는 일반적인 문제 참조 합니다.

XML 표를 XML 데이터 파일 가져오기

  1. 개발자 를 클릭 > 가져오기를 합니다.

    개발 도구 탭이 보이지 않으면 개발 도구 탭 표시를 참조 하십시오.

  2. XML 가져오기 대화 상자에서 찾아 가져올, XML 데이터 파일 (.xml)을 선택 하 고 가져오기 를 클릭 합니다.

    XML 데이터 파일에서 스키마를 참조 하지 않는 경우 Excel에서 XML 데이터 파일의 스키마를 유추한 합니다.

  3. 데이터 가져오기 대화 상자에서 다음 중 하나를 실행 합니다.

    1. 기존 워크시트에 XML 표 를 선택 합니다. 지정 된 셀 위치에서 워크시트에 XML 표에 XML 데이터 파일의 내용을 가져옵니다.

    2. 새 워크시트에서 XML 표 를 선택 합니다. A1 셀부터 새 워크시트에 XML 테이블에 파일의 내용을 가져옵니다. XML 데이터 파일의 스키마를 XML 원본 작업창에 표시 됩니다.

  4. XML 데이터 파일에서 스키마를 참조 하지 않는 경우 Excel에서 XML 데이터 파일의 스키마를 유추한 합니다.

  5. XML 데이터 (예: 데이터 바인딩, 형식 및 레이아웃)의 동작을 제어 하려면 속성 을 클릭 XML 맵을 속성 대화 상자를 표시 합니다. 예를 들어 기본적으로 데이터를 가져올 수 있지만이 변경할 수 있습니다 매핑된 범위 내에서 기존 데이터를 덮어쓰게 됩니다.

여러 개의 XML 데이터 파일 가져오기

  1. 단일 매핑된 셀 집합에 여러 XML 파일을 가져올 매핑된 셀을 선택 합니다.

    매핑된 셀의 여러 집합에 여러 XML 파일을 가져올 하려면 매핑되지 않은 워크시트에서 아무 곳 이나 셀을 클릭 합니다.

  2. 개발자 를 클릭 > 가져오기를 합니다.

    개발 도구 탭이 보이지 않으면 개발 도구 탭 표시를 참조 하십시오.

  3. XML 가져오기 대화 상자에서 찾아 가져올 XML 데이터 파일 (.xml)을 선택 합니다.

    • 연속 된 파일의 경우 Shift 키를 누르고 첫 번째 및 마지막 파일 목록에서를 클릭 합니다. 모든 XML 파일의에서 데이터를 가져오고 매핑된 셀에 추가 합니다.

    • 파일에 인접 하지 않으면 키를 누릅니다 및 Ctrl 키를 누른 상태 하 고 목록에서 가져오려는 각 파일을 클릭 합니다.

  4. 가져오기를 클릭합니다.

    인접 하지 않은 파일을 선택한 경우 가져오기 < 파일 이름 >.xml 대화 상자가 나타납니다. 가져오려는 각 파일에 대해 XML 데이터 파일에 해당 하는 XML 맵을 선택 합니다.

    모든 가져온 아직 없는 선택한 파일의 단일 지도 사용 하려면 이 스키마 선택한 모든 파일에 대 한이 XML 맵을 사용 하 여선택 합니다.

외부 데이터를 여러 개의 XML 데이터 파일 가져오기

서로 다른 XML 스키마를 제외한 동일한 네임 스페이스를 사용 하는 여러 개의 XML 파일을 가져올 XML에서 데이터 가져오기 명령을 사용할 수 있습니다. Excel에서 가져온 각 XML 데이터 파일에 대 한 고유한 XML 맵을 만듭니다.

참고: 네임 스페이스 정의 되지 않는 여러 개의 XML 파일을 가져오는 경우 동일한 네임 스페이스를 사용 하는 경우 이러한 XML 파일 처리 됩니다.

  1. Office 365 구독으로 Excel을 사용 중인 경우 클릭 데이터 > 데이터 가져오기 > 파일에서 > 에서 XML 합니다.

    Excel 2016을 사용 중인 또는 이전 버전에서 데이터 를 클릭 하면 > 기타 원본에서 > XML 데이터 가져오기.

  2. 드라이브, 폴더 또는 인터넷 위치에는 가져올 XML 데이터 파일 (.xml)로 이동 합니다.

  3. 파일을 선택하고 열기를 클릭합니다.

  4. 데이터 가져오기 대화 상자에서 다음 중 하나를 실행 합니다.

    • 기존 워크시트에 XML 표    새 워크시트에 새 XML 표로 파일의 내용은 가져옵니다. XML 데이터 파일에서 스키마를 참조 하지 않는 경우 Excel에서 XML 데이터 파일의 스키마를 유추한 합니다.

    • 기존 워크시트    2 차원으로 구성 된 표에 행과 열의 열 머리글 및 열 제목 아래 행에 데이터를 XML 태그를 보여 주는 XML 데이터를 가져옵니다. 첫 번째 요소 (루트 노드) 제목 등 사용 되 고 지정 된 셀 위치에 표시 됩니다. 태그의 나머지 두 번째 행에서 사전순으로 정렬 됩니다. 이 경우 Excel에서 스키마를 유추한 하지 및 XML 맵을 사용할 수 없습니다.

    • 새 워크시트    Excel 통합 문서에 새 워크시트를 추가 하 고 자동으로 새 워크시트의 왼쪽 위 모서리에서 XML 데이터를 넣습니다. XML 데이터 파일에서 스키마를 참조 하지 않는 경우 Excel에서 XML 데이터 파일의 스키마를 유추한 합니다.

  5. XML 데이터를 데이터 바인딩, 서식, 레이아웃 등의 동작을 제어 하려면 속성 을 클릭 XML 맵을 속성 대화 상자를 표시 합니다. 예를 들어 기본적으로 데이터를 가져올 수 있지만이 변경할 수 있습니다 매핑된 범위 내에서 기존 데이터를 덮어씁니다.

데이터를 가져오는를 XML 데이터 파일 열기

  1. 파일 > 열기를 클릭합니다.

    Excel 2007을 사용 중인 경우 클릭 Office 단추 이미지 Microsoft Office 단추 > 열기.

  2. 열기 대화 상자에서 드라이브, 폴더 또는 열려는 파일이 있는 인터넷 위치를 클릭 합니다.

  3. 파일을 선택하고 열기를 클릭합니다.

  4. XML 가져오기 대화 상자가 나타나는 경우 다음 옵션 중 하나를 클릭할 수 있도록 열었던 파일을 하나 이상의 언어 변형 XSLT (Extensible Stylesheet) 스타일 시트를 참조 합니다.

    • 스타일 시트 적용 하지 않고 파일을 열고    2 차원으로 구성 된 표에 행과 열의 열 머리글 및 열 제목 아래 행에 데이터를 XML 태그를 보여 주는 XML 데이터를 가져올 합니다. 첫 번째 요소 (루트 노드) 제목 등 사용 되 고 지정 된 셀 위치에 표시 됩니다. 태그의 나머지 두 번째 행에서 사전순으로 정렬 됩니다. 이 경우 Excel에서 스키마를 유추한 하지 및 XML 맵을 사용할 수 없습니다.

    • 적용 된 다음 스타일 시트 (하나 선택)를 사용 하 여 파일 열기    을 적용 하려면 스타일 시트를 선택 하 고 확인 을 클릭 합니다. XML 데이터는 선택한 스타일 시트에 따라 서식이 지정 되어 있습니다.

      참고: XML 데이터는 excel 매크로 사용 통합 문서 파일 형식 (.xlsm) 실수로 원래 원본 파일을 저장 하지 않으면 Excel의 읽기 전용으로 열립니다. 이 경우 Excel에서 스키마를 유추한 하지 및 XML 맵을 사용할 수 없습니다.

  5. XML 열기 대화 상자가 나타나면 XML 파일의 모든 XSLT 스타일 시트 참조는 없습니다. 파일을 열려면 다음 옵션 중 하나를 클릭 합니다.

    • 새 통합 문서에 XML 표를 만들려면 XML 표 클릭 합니다.

      파일의 내용은 XML 테이블로 가져옵니다. XML 데이터 파일에서 스키마를 참조 하지 않는 경우 Excel에서 XML 데이터 파일의 스키마를 유추한 합니다.

    • 읽기 전용으로 통합 문서를 를 클릭 합니다.

      2 차원으로 구성 된 표에 행과 열의 열 머리글 및 열 제목 아래 행에 데이터를 XML 태그를 보여 주는 XML 데이터를 가져옵니다. 첫 번째 요소 (루트 노드) 제목 등 사용 되 고 지정 된 셀 위치에 표시 됩니다. 태그의 나머지 두 번째 행에서 사전순으로 정렬 됩니다. 이 경우 Excel에서 스키마를 유추한 하지 및 XML 맵을 사용할 수 없습니다.

      XML 데이터는 excel 매크로 사용 통합 문서 파일 형식 (.xlsm) 실수로 원래 원본 파일을 저장 하지 않으면 Excel의 읽기 전용으로 열립니다. 이 경우 Excel에서 스키마를 유추한 하지 및 XML 맵을 사용할 수 없습니다.

    • XML 원본 작업창 사용 을 클릭 합니다.

      XML 데이터 파일의 스키마를 XML 원본 작업창에 표시 됩니다. 워크시트에 해당 요소를 매핑합니다 워크시트에 스키마 요소를 끌어 놓을 수 있습니다.

      XML 데이터 파일에서 스키마를 참조 하지 않는 경우 Excel에서 XML 데이터 파일의 스키마를 유추한 합니다.

XML 데이터를 가져오는 일반적인 문제

Excel은 XML 맵을 따라 데이터 유효성을 검사할 수 없는 XML 가져오기 오류 대화 상자가 표시 됩니다. 이 대화 상자에서 각 오류에 대 한 추가 정보에 대 한 세부 정보 를 클릭 합니다. 다음 표에서 몇 가지 일반적인 가져오기 오류:

오류

무슨 일이 있었나요

오류가 발생 한 스키마 유효성 검사

XML 맵 속성 대화 상자에서 데이터 가져오기 및 내보내기에 대 한 스키마 유효성 검사 클릭할 때 데이터를 가져온 되지만 데이터의 지정 된 XML 맵을 유효성이 되지 않았습니다.

일부 데이터를 텍스트 파일로 가져온

가져온 데이터의 일부 또는 전부 선언 된 데이터 형식에서 텍스트로 변환 되었습니다. 계산에서이 데이터를 사용 하 여 텍스트 숫자 또는 날짜 데이터 변환 해야 합니다. 예를 들어 텍스트로 변환 되는 날짜 값 날짜 데이터 형식으로 변환 될 때까지 YEAR 함수에서 의도 한 대로 작동 하지 않습니다. Excel 데이터를 텍스트로 변환 경우:

  • 데이터가 형식으로 Excel을 지원 하지 않습니다.

  • 데이터가는 Excel 내부 표현 XSD 데이터 형식의 호환 되지 않습니다. 이 문제를 해결 하려면 각 데이터 형식 선언 XML 데이터를 XML 스키마에 따라 유효한 있는지 확인 합니다.

XML 구문 분석 오류

XML 파서 지정된 된 XML 파일을 열 수 없습니다. XML 파일 없는 구문 오류 및 XML 제대로 구성 되어 있는지 확인 합니다.

데이터에 해당 하는 XML 맵을 찾을 수 없는 경우

가져올, 여러 개의 XML 데이터 파일을 선택 하 고 Excel 파일 중 하나에 대 한 일치 하는 XML 맵을 찾을 수 없는 경우이 문제가 발생할 수 있습니다. 대화 상자의 제목 표시줄에 명명 된 파일에 대 한 적절 한 스키마를 먼저, 가져오고 파일 가져오기를 다시 시도 하세요.

데이터에 맞게 XML 표 크기를 조정할 수 없는 경우

가져오기 또는 XML 표에 데이터를 추가 하 여 행을 추가 하려는 경우 하지만 확장 하려면 테이블에 대 한 공간이 있습니다. XML 표를 아래로 아래에서만 확장할 수 있습니다. 예를 들어, 그림 또는 XML 표에 XML 표를 확장 하는 것을 방지 하는 바로 아래 다른 테이블 같은 개체를 있을 수 있습니다. 또는 XML 표가 확장, 1048576 Excel 행 제한 초과 합니다 것입니다. 이 문제를 해결 하려면 테이블 및 XML 표를 아래로 아래에서 확장을 포함 하도록 워크시트에 있는 개체 다시 정렬 합니다.

지정 된 XML 파일이 스키마를 참조 하지 않는

XML 파일을 열려고 하는 XML 스키마를 참조 하지 않습니다. XML 데이터 파일에는 작업, Excel에서 스키마를 XML 파일의 내용을 기반으로 제공 해야 합니다. 해당 스키마가 올바르지 않거나 부족, 통합 문서에서 제거 합니다. 다음 XML 스키마 파일 만들기 및 스키마를 XML 데이터 파일의 참조를 XML 데이터 파일을 편집 합니다. 자세한 내용은 셀에 XML 맵을 맵의 XML 요소를 참조 합니다.

참고: 별도 XML 스키마 데이터 파일 (.xsd)로 Excel 유추 된 스키마를 내보낼 수 없습니다. XML 스키마 편집기 및 XML 스키마 파일을 만드는 다른 방법을 있지만 수에 편리 하 게 액세스할 수 있는 없거나 사용 하는 방법을 알고 있습니다.

Excel에서 통합 문서에서 만든 스키마를 제거 하려면 다음이 단계를 따릅니다.

  1. 개발 도구 > 원본을 클릭합니다.

    개발 도구 탭의 XML 명령

    개발 도구 탭이 보이지 않으면 개발 도구 탭 표시를 참조 하십시오.

  2. XML 원본 작업창에 XML 맵 을 클릭 합니다.

  3. XML 맵 대화 상자에서 만든, XML 맵을 Excel 및 삭제 를 클릭 합니다.

예상 대로 작동 하지 않는 다른 스키마 있지만 동일한 네임 스페이스를 사용 하는 여러 개의 XML 파일 가져오기

여러 개의 XML 데이터 파일 및 XML 스키마를 사용 하 여 작업할 때 일반적으로 각 스키마를 XML 맵을, 요소를 매핑할 만들고 후 적절 한 XML 맵에 각 XML 데이터 파일을 가져옵니다. 가져오기 명령을 사용 하 여 네임 스페이스가 같은 여러 개의 XML 파일을 열 수를 XML 스키마가 둘만 사용할 수 있습니다. 이 명령을 사용 하 여 서로 다른 스키마 있지만 동일한 네임 스페이스를 사용 하는 여러 개의 XML 파일을 열 때 예기치 않은 결과가 발생할 수 있습니다. 예를 들어 데이터 덮어쓸 수 있습니다를 또는 파일이 열리지 않습니다.

서로 다른 XML 스키마를 제외한 동일한 네임 스페이스를 사용 하는 여러 개의 XML 파일을 가져올 XML에서 데이터 가져오기 명령을 사용 하 여 시도 ( 데이터 를 클릭 > 기타 원본에서 ). 이 명령을 네임 스페이스가 같은 여러 개의 XML 스키마를 사용 하 여 여러 개의 XML 파일을 사용 하면 됩니다. Excel에서 가져올 각 XML 데이터 파일에 대 한 고유한 XML 맵을 만듭니다.

참고: 네임 스페이스 정의 되지 않는 여러 개의 XML 파일을 가져오는 경우 동일한 네임 스페이스를 사용 하는 경우 이러한 XML 파일 처리 됩니다.

개발 도구 탭 표시

개발 도구 탭이 나타나지 않는 경우 다음을 실행하여 표시합니다.

  • Excel 2013 및 Excel 2010:

    1. 파일 > 옵션을 클릭합니다.

    2. 리본 사용자 지정 범주를 클릭합니다.

    3. 기본 탭에서 개발 도구 확인란을 선택한 다음 확인을 클릭합니다.

  • Excel 2007:

    1. Microsoft Office 단추 Office 단추 이미지 > Excel 옵션을 클릭합니다.

    2. 기본 설정 범주를 클릭합니다.

    3. Excel에서 가장 많이 사용하는 옵션에서 리본 메뉴에 개발 도구 탭 표시 확인란을 선택한 다음 확인을 클릭합니다.

참고 항목

보기의 Excel에서 XML 통해

셀에 XML 맵을 맵의 XML 요소

XML 내보내기 데이터

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×