SQL Server 데이터베이스에서 값을 사용 하 여 목록 상자, 드롭다운 목록 상자 또는 콤보 상자 채우기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

목록 상자, 드롭다운 목록 상자 또는 콤보 상자 Microsoft SQL Server 데이터베이스에 쿼리 데이터 연결의 데이터로 채울 수 있습니다.

이 문서의 내용

개요

시작 하기 전에

1 단계: 쿼리 데이터 연결 추가

2 단계: 컨트롤 구성

개요

목록 상자, 드롭다운 목록 상자 또는 콤보 상자 사용자 양식 서식 파일에 기반 하는 양식에 데이터를 입력할 때 선택할 수 있는 항목을 표시 합니다. 이러한 종류의 Microsoft SQL Server 데이터베이스에 대 한 보조 데이터 연결의 데이터를 표시 하려면 컨트롤을 구성할 수 있습니다. 보조 데이터 연결 하지 않는 경우이 양식 서식 파일에 기초한 양식을 작성 하는 사용자 데이터를 가져올 수 있거나 웹 서비스 등의 외부 데이터 원본에 데이터를 전송할 수 있도록 양식 서식 파일에 추가 하는 외부 데이터 원본에 대 한 데이터 연결

에 해당 하는 방식으로 데이터 쿼리 데이터를 Microsoft Office InfoPath 양식 서식 파일을 데이터 필드와 그룹 보조 데이터 원본 를 만들고 보조 데이터 연결을 추가 하면 데이터베이스에 저장 됩니다. 쿼리 데이터 연결 웹 서비스에서 데이터를 가져옵니다 및 폼의 보조 데이터 원본에 해당 데이터를 저장 합니다. 기본적으로 사용자가 네트워크에 연결 되어 있는 동안에 보조 데이터 원본에서 데이터를 사용할 수 있습니다. 양식이 네트워크에 연결 되지 않은 경우 데이터에 액세스할 수 있도록 사용자의 컴퓨터에서 쿼리 결과 저장 하려면 보조 데이터 연결을 구성할 수 있습니다.

보안 정보: 보조 데이터 연결을 외부 데이터 원본에서 중요 한 데이터를 검색을 사용 하는 경우 경우에 컴퓨터를 분실 하거나 유출 무단으로 사용할 수 없도록에서 데이터를 보호 하려면이 기능을 사용 하지 않도록 설정 하는 것이 좋습니다. 이 기능을 해제 하는 경우 데이터는 사용자가 네트워크에 연결 하는 경우에 사용할 수 있습니다.

보조 데이터 원본에서 데이터 구조 데이터 데이터베이스에 저장 되는 방식과 일치 해야 하므로 기존 필드 또는 그룹의 보조 데이터 원본에 수정할 수 없습니다. 참고 항목 섹션에서 데이터 연결 및 데이터 원본에 대 한 자세한 정보에 대 한 링크를 찾습니다.

맨 위로 이동

시작하기 전에

SQL Server 데이터베이스의 값은 양식 서식 파일에서 컨트롤을 채우려면를 사용 하려면 먼저 데이터베이스 관리자에 게에서 다음과 같은 정보가 필요 합니다.

  • 이 양식 서식 파일에 사용할 데이터베이스를 사용 하 여 서버 이름입니다.

  • 이 양식 서식 파일에 사용할 데이터베이스의 이름입니다.

  • 데이터베이스에 필요한 인증 합니다. 데이터베이스는 사용자가 데이터베이스에 액세스할 수 있는 방법을 확인 하려면 Microsoft Windows 인증 또는 SQL Server 인증을 사용할 수 있습니다.

  • 폼에 보낼 데이터가 들어 있는 테이블의 이름입니다. 기본 테이블입니다. 데이터베이스에서 둘 이상의 테이블을 사용 하려는 경우 다른 이름, 하위 테이블 필요 합니다. 기본 테이블의 필드와 관계가 있는 하위 테이블의 필드 이름 할 수도 있습니다.

  • 여부 오프 라인 사용에 대 한 사용자의 컴퓨터에 안전 하 게 쿼리 결과 저장할 수 있습니다.

맨 위로 이동

1 단계: 쿼리 데이터 연결 추가

양식 서식 파일에 사용할 수 있는 기존 쿼리 데이터 연결이 없는 경우 데이터를 쿼리 하 여 양식 서식 파일을 보조 데이터 연결을 추가 하려면 다음이 단계를 따릅니다. 양식 서식 파일에 사용할 수 있는 보조 데이터 연결을 이미 있으면 하면이 섹션을 건너뛰고 이동 2 단계: 컨트롤 구성합니다.

  1. 도구 메뉴에서 데이터 연결 을 클릭 합니다.

  2. 데이터 연결 대화 상자에서 추가 클릭 합니다.

  3. 데이터 연결 마법사에서 에 대 한 새 연결 만들기 를 클릭 하 고 데이터 받기 클릭 후 다음 을 클릭 합니다.

  4. 마법사의 다음 페이지에서 데이터베이스 (Microsoft SQL Server 또는 Microsoft Office Access에만 해당)를 클릭 한 후 다음 을 클릭 합니다.

  5. 마법사의 다음 페이지에서 데이터베이스 선택을 클릭 합니다.

  6. 데이터 원본 선택 대화 상자에서 새 출처 를 클릭 합니다.

  7. 데이터 원본의 종류에 연결 하 시겠습니까 목록에서 마법사의 다음 페이지에서 Microsoft SQL Server 를 클릭 한 후 다음 을 클릭 합니다.

  8. 서버 이름 상자에 SQL Server 데이터베이스를 포함 하는 서버 이름을 입력 합니다.

  9. 로그온 자격 증명 에서 다음 중 하나를 수행 합니다.

    • 데이터베이스는 Microsoft Windows 네트워크에 사용 되는 자격 증명에 따라 액세스 권한이 있는 사용자를 결정 하는 경우 Windows 인증 사용을 클릭 합니다.

    • 데이터베이스 지정 된 사용자 이름 및 데이터베이스 관리자 로부터 얻을 수 있는 암호를 기반으로 액세스 권한이 있는 사용자를 결정 하는 경우 다음 사용자 이름 및 암호를 사용 하 여 클릭 한 다음 사용자 이름에서 사용자 이름 및 암호를 입력 암호 상자입니다.

  10. 다음을 클릭합니다.

  11. 원하는 데이터가 들어 있는 데이터베이스 선택 목록에서 사용 하 여 특정 테이블에 연결 을 클릭 하면 기본 테이블의 이름을 클릭 하 고 다음 을 클릭 한 다음 추가할 데이터베이스의 이름을 클릭 합니다.

  12. 파일 이름 상자에 마법사의 다음 페이지에서 데이터 연결 정보를 저장 하는 파일에 대 한 이름을 입력 한 다음이 설정을 저장 하려면 완료 를 클릭 합니다.

    쿼리 데이터 연결의 다른 테이블을 사용 하려는 경우 다른 테이블 마법사의이 페이지에 추가할 수 있습니다.

    다른 테이블 추가

    1. 테이블 추가 클릭 합니다.

    2. 테이블 또는 쿼리 추가 대화 상자에서 자식 테이블의 이름을 클릭 한 후 다음 을 클릭 합니다. InfoPath에서 두 테이블에서 필드 이름과 일치 하는 관계를 설정 하려고 합니다. 제안된 된 관계를 사용 하려면 관계를 선택 하 고 관계 제거 를 클릭 합니다. 관계를 추가 하려면 관계 추가 클릭 합니다. 관계 추가 대화 상자에서 각 열에 관련 된 각 필드의 이름을 클릭 한 다음 확인 을 클릭 합니다.

    3. 마침을 클릭합니다.

    4. 하위 테이블을 더 추가 하려면 다음이 단계를 반복 합니다.

  13. 다음을 클릭합니다.

  14. 양식 서식 파일을 사용 하 여 쿼리 결과 저장 하기 위해 양식 서식 파일에서 데이터의 복사본을 저장 확인란을 선택 합니다. 이 확인란을 선택 하 여 쿼리 결과 양식 서식 파일에 저장 됩니다. 되므로 데이터 양식 서식 파일에 저장 됩니다. 데이터는 자신의 컴퓨터 네트워크에 연결 되지 않은 경우에 사용자가 작성 하는 양식에서 사용할 수 있습니다.

    보안 정보: 이 확인란을 선택 하 여 쿼리 결과 양식 서식 파일에 저장 됩니다. 데이터 양식 서식 파일에 저장 되므로, 자신의 컴퓨터 네트워크에 연결 되지 않은 경우에 사용자가 작성 한 형태로 제공 됩니다. 이 데이터 연결에서 중요 한 데이터를 가져오는 경우 컴퓨터 손실 되거나 유출 경우에 데이터를 보호 하는 데 도움이 되도록이 기능을 사용 하지 않도록 설정 하는 것이 좋습니다.

  15. 다음을 클릭합니다.

  16. 마법사의 다음 페이지에서이 보조 데이터 연결에 대해 설명 하는 이름을 입력 합니다. 자동으로 데이터를 받기 위한 양식이 열릴 때 폼 폼을 열 때 데이터를 자동으로 검색 확인란을 선택 합니다.

맨 위로 이동

2 단계: 컨트롤 구성

  1. 양식 서식 파일 뷰를 여러 개 있으면 보조 데이터 원본에서 데이터를 표시 하려는 컨트롤이 적용 된 보기로 이동 하려면 보기 메뉴의 보기 이름 을 클릭 합니다.

  2. 목록 상자, 드롭다운 목록 상자 또는 콤보 상자 컨트롤을 채울을 두 번 클릭 합니다.

  3. 데이터 탭을 클릭합니다.

  4. 목록 상자 항목 외부 데이터 원본에서 값 조회 를 클릭 합니다.

  5. 데이터 원본 목록에서 사용 하려는 데이터 원본을 클릭 합니다.

  6. 항목 상자 옆에 있는 데이터 원본 단추 XPath 선택을 클릭 합니다.

  7. 필드 또는 그룹 선택 대화 상자에서 사용자에 게 표시 될 데이터 및 다음 중 하나를 실행 하 여 외부 데이터 원본에 어떤 데이터를 제출할 수를 지정 합니다.

    사용자에 게 표시 하 여 데이터를 사용자가 전송할 동일한 데이터 지정

    • 필드를 클릭 한 다음 확인 을 클릭 합니다.

    사용자에 게 표시 하 여 데이터를 다른 사용자가 전송할 데이터 지정

    참고: 이 시나리오에서는 사용자에 게 표시 되는 데이터 그룹에서 필드 중 하나에서 오고 같은 그룹에 있는 다른 필드에는 사용자가 전송할 데이터는 합니다.

    1. 그룹을 클릭 한 다음 확인 을 클릭 합니다.

    2. 컨트롤 속성 대화 상자에서 상자 옆에 있는 데이터 원본 단추 XPath 선택을 클릭 합니다.

    3. 필드 또는 그룹 선택 대화 상자에서 사용자 외부 데이터 원본에 제출 하 고 다음 확인 을 클릭 합니다 데이터가 들어 있는 필드를 클릭 합니다.

    4. 컨트롤 속성 대화 상자에서 표시 이름 상자 옆에 있는 데이터 원본 단추 XPath 선택을 클릭 합니다.

    5. 필드 또는 그룹 선택 대화 상자에서 컨트롤을 표시 하 고 확인 을 클릭 한 다음가 있는 데이터를 포함 하는 필드를 클릭 합니다.

  8. 표시 이름 상자에서 원하는 필드와 비슷한 표시 이름 사용 하 여 값에는 고유한 이름만 표시 하려는 경우 고유한 표시 이름이 있는 항목만 표시 확인란을 선택 합니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×