Project 데스크톱에서 프로젝트를 연결 하 여 마스터 프로젝트 만들기

Project 데스크톱에서 프로젝트를 연결 하 여 마스터 프로젝트 만들기

Office 365 구독, Project Professional 2019, Project Professional 2016, Office 2013, Office 2010

대규모 프로젝트를 더욱 체계적으로 정리 하기 위해 여러 프로젝트 파일을 하나로 연결 하 여 마스터 프로젝트/하위 프로젝트 정렬 (외부 종속성이 라고도 함)을 만들 수 있습니다. 예를 들어 건축 마스터 프로젝트에는 배관, 전기, carpentry 작업을 위한 하위 프로젝트 파일이 있을 수 있습니다.

프로젝트 파일 연결

  1. 각 하위 프로젝트에 대해 별도의 Project 파일을 만든 다음 마스터 프로젝트로 지정할 프로젝트를 열거나 만듭니다.

  2. 마스터 프로젝트에서 Gantt 차트보기 > 클릭 합니다.

  3. 작업 이름 필드에서 하위 프로젝트를 삽입할 아래 행을 클릭 합니다. 마스터 프로젝트의 작업 목록에서 원하는 위치에 하위 프로젝트를 삽입할 수 있습니다.

  4. Project > 하위프로젝트를 클릭 합니다.

    하위 프로젝트 삽입 명령이 표시된 Project 리본 메뉴 탭

  5. 프로젝트 삽입 상자에서 삽입 하려는 하위 프로젝트를 선택 합니다.

    • 여러 하위 프로젝트를 삽입 하려면 Ctrl 키를 누른 채 삽입할 순서 대로 하위 프로젝트를 클릭 합니다.

    • 대부분의 경우에는 프로젝트에 대 한 링크 확인란을 선택 하 여 하위 프로젝트의 변경 내용이 마스터 프로젝트에 반영 되도록 하 고 그 반대의 경우를 할 수 있습니다. 그러나 파일을 동적으로 연결 하지 않고 하위 프로젝트를 마스터 프로젝트로 복사 하려는 경우에는 확인란의 선택을 취소 합니다.

  6. 삽입을 클릭 하거나 읽기 전용 형식으로 프로젝트를 삽입 하려면 삽입 단추에 있는 화살표를 클릭 한 다음 읽기 전용으로 삽입을 클릭 합니다. 프로젝트를 읽기 전용으로 삽입 하면 두 프로젝트 간에 링크가 만들어지지만 마스터 프로젝트 내에서 하위 프로젝트를 업데이트할 수는 없습니다. 그러나 하위 프로젝트 파일을 직접 업데이트 하면 해당 변경 내용이 마스터 프로젝트에 반영 됩니다. 읽기 전용으로 삽입 옵션은 프로젝트에 연결 확인란을 선택한 경우에만 사용할 수 있습니다.

연결 된 프로젝트에서 자원 이름 중복 방지

동일한 이름의 자원이 있는 프로젝트를 연결 하는 경우 중복 되는 자원 이름이 생성 되므로 혼란 스 러 울 수 있습니다. 이를 방지 하려면 프로젝트 삽입 대화 상자에서 프로젝트에 연결 상자를 선택 취소 합니다. 이렇게 하면 마스터 프로젝트의 자원 정보 (예: 급여, 자원 달력)가 하위 프로젝트 자원 정보를 사용할 수 있게 됩니다.

참고: 마스터 프로젝트 내에서 연결 되지 않은 하위 프로젝트를 업데이트 하는 경우 원본 하위 프로젝트 파일에는이 변경 내용이 표시 되지 않습니다.

마스터 프로젝트의 서브 프로젝트 재구성

마스터 프로젝트 에 하위 프로젝트 을 삽입 하 고 작업 목록을 다시 정렬 하려는 경우 작업 목록을 삽입된 프로젝트 위나 아래로 이동할 수 있습니다.

  1. Gantt 차트 보기 > 선택 합니다.

  2. 이동 하려는 삽입 프로젝트를 나타내는 요약 작업ID 번호 를 선택 합니다.

  3. 마우스 오른쪽 단추를 클릭 하 고 잘라내기를 선택 하 여 삽입 된 프로젝트를 제거 합니다.

    참고: 작업을 잘라내어 붙여넣어 다른 위치에 있는 작업 목록에 다시 붙여 넣을 때 작업의 고유 ID (입력 테이블의 맨 왼쪽에 있는 작업 ID 와 다름)을 변경 합니다. 고유 ID를 변경 하지 않고 작업을 이동 하려면 작업 목록의 새 위치로 작업을 끕니다. 작업을 끌려면 ID 필드의 작업 ID 위에 포인터를 놓습니다. 4 방향 화살표로 바뀌면 작업을 새 위치로 끕니다. 정보는 다시 붙여 넣을 때까지 삭제 되지 않고 프로젝트 계획 에서만 제거 됩니다.

  4. 작업 목록에서 프로젝트를 표시할 위치 아래에 있는 작업의 ID 번호를 선택 합니다.

    참고: 프로젝트 요약 작업 만 표시 된 다른 삽입 프로젝트 아래에 프로젝트를 삽입 하거나 붙여 넣는 경우 삽입 하거나 붙여 넣는 프로젝트는 그 위에 삽입 된 프로젝트와 같은 수준으로 추가 됩니다. 그러나 모든 작업이 표시 된 삽입 프로젝트 아래에 삽입 하거나 붙여 넣는 경우 삽입 하거나 붙여 넣는 프로젝트는 해당 프로젝트가 위에 삽입 된 프로젝트의 하위 프로젝트가 됩니다.

  5. 붙여넣기 를 클릭 하 여 선택한 행 위에 프로젝트를 붙여 넣습니다.

해당 지침은 Microsoft Project 2007에 적용됩니다.

프로젝트 간 의존 관계 대신 교차 프로젝트 링크를 사용 해야 하는 경우

프로젝트에 다른 프로젝트의 특정 작업에 따라 달라 지는 특정 작업이 있는 경우 교차 프로젝트 링크를 사용 하 여 작업 날짜를 서로 연결할 수 있습니다. 이 방법으로, 의존 하는 작업이 지연 되는 경우 새 날짜는 자신의 작업에 반영 됩니다. 프로젝트가 다른 프로젝트의 일부 측면에 의존 하는 경우 종속성이 특정 작업에 연결 되어 있지 않은 경우 프로젝트 간 종속성을 사용 하 여 각 프로젝트가 관계에 제공 하는 내용을 정확 하 게 식별 합니다.

  1. 연결 하려는 작업을 포함 하는 프로젝트와 연결할 작업이 포함 된 프로젝트를 모두 엽니다.

    프로젝트 중 하나의 메뉴에서 모두 정렬을클릭 합니다.

  2. 외부 선행 작업에 대 한 종속성을 만들려는 작업을 클릭 합니다.

  3. 작업 정보 단추 이미지 클릭 한 다음 선행 작업 탭을 클릭 합니다.

  4. ID 열에서 외부 선행 작업의 프로젝트 이름과 id 번호를 백슬래시로 구분 하 여 입력 합니다. 예를 들어 Project1 이라는 파일에 작업 ID 1에 대 한 Project1\1 를 입력 합니다.

기본적으로 외부 연결 프로젝트의 데이터가 변경 되 면 알림 메시지가 표시 됩니다. 외부 연결을 사용 하 여 프로젝트를 열 때 외부 선행 작업 및 후속 작업 및 일정에 미치는 영향이 표시 되므로 변경 내용 중 일부 또는 모두를 수락 하도록 선택할 수 있습니다.

  • 외부 작업에 연결 하려면 두 프로젝트를 모두 저장 해야 합니다.

  • Microsoft Office Project Server에 저장 된 여러 프로젝트에서 작업을 연결 하는 경우 선행 작업 ID의 서식을 올바르게 지정 해야 합니다. 작업 정보 대화 상자의 선행 작업 탭에 있는 ID 열에 작업 id를 <> \project1\42. 같이 다음 예제에 표시 된 대로 서식 지정 해야 합니다. 이 예제에서 project1는 선행자를 포함 하는 프로젝트의 이름이 고, 42는 선행 작업의 작업 ID입니다.

  • 외부에서 연결 된 작업은 작업 목록에서 흐리게 표시 됩니다. 프로젝트를 사용할 수 있는 경우 외부 후속 작업이 나 외부 선행 작업을 사용 하 여 작업을 두 번 클릭 하면 외부 작업을 포함 하는 프로젝트가 열립니다.

프로젝트 간에 작업을 연결 했는데 데이터가 일치 하지 않는 경우

선택 하 여 붙여넣기 대화 상자 (편집 메뉴)의 연결 하 여 붙여넣기 옵션을 사용 하 여 작업을 연결 하면 Project에서 OLE (개체 연결 및 포함)를 사용 하 여 연결을 설정 합니다. 선택한 필드만 연결 됩니다. 그러나 작업에는 작업 일정이 조정 되는 방식에 영향을 주는 정보에 대 한 많은 필드가 포함 될 수 있으며, 분할 된 화면 보기를 사용 하는 경우에는 이러한 필드가 숨겨질 수 있습니다.

서로 다른 프로젝트의 작업 간에 의존 관계를 만들어야 하는 경우에는 링크를 붙여 넣는 대신 외부 의존 관계를 만들어 정확한 일정을 유지 해야 합니다.

연결 하 여 붙여넣기 옵션을 사용 하는 경우 전체 행 대신 개별 필드를 선택 하 고 일정 정보의 충돌을 방지 하기 위해 필요한 만큼의 정보만 연결 합니다.

자세한 정보

계획 내의 계획: 마스터 프로젝트와 하위 프로젝트

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×