Outlook으로 가져올 .csv 파일을 만들거나 편집

Outlook으로 가져올 .csv 파일을 만들거나 편집

CSV(쉼표로 구분된 값) 파일은 Excel에서 만들거나 편집할 수 있는 특수한 유형의 파일입니다. CSV 파일은 정보를 열에 저장하지 않고 쉼표로 구분된 정보를 저장합니다. 텍스트와 숫자를 CSV 파일에 저장하면 프로그램 간에 이동하기가 쉽습니다. 예를 들어, Google에서 CSV 파일로 연락처를 내보낸 다음 Outlook으로 가져올 수 있습니다.

일정 항목 목록을 Outlook으로 가져오는 데 도움이 필요한 경우 Outlook 전자 메일, 연락처 및 일정 가져오기 및 내보내기를 참조하세요.

다른 프로그램 또는 전자 메일 공급자에서 .csv 파일 만들기

다른 프로그램(예: Gmail)에서 연락처를 내보낼 때 일반적으로 여러 가지 형식 중 하나를 선택할 수 있습니다. Gmail의 경우 Google CSV 파일, Outlook CSV 파일 또는 vCard를 선택할 수 있습니다. 한 Outlook 프로파일에서 내보내고 다른 프로파일로 가져올 때는 쉼표로 구분된 값 파일 또는 Outlook 데이터 파일(.pst)로 내보내도록 선택할 수 있습니다.

Outlook에 연락처를 가져오기 위해 샘플 .csv 파일을 다운로드하여 열기

연락처에 대한 CSV 파일을 수동으로 만들려는 경우 다음 두 가지 방법 중 하나를 수행할 수 있습니다.

Excel 파일을 만들어 CSV 파일로 저장

정보를 내보낼 수 없는 프로그램에 연락처 정보가 있는 경우에는 수동으로 입력할 수 있습니다.

  1. Excel에서 새 문서를 만듭니다.

  2. 기록할 정보의 각 항목에 대해 열 머리글(예: 이름, 성, 전자 메일 주소, 전화 번호 및 생일)을 추가한 다음 해당 열에 정보를 입력합니다.

  3. 완료된 Excel 파일은 다음과 같이 보여야 합니다.

    다음은 Excel에서 샘플 .csv 파일이 표시되는 방식입니다.

  4. 파일 > 다른 이름으로 저장을 선택합니다.

  5. 드롭다운 상자를 사용하여 CSV(쉼표로 분리)(*.csv)를 선택하고 파일 이름을 지정한 다음 저장을 선택합니다.

    Excel 파일을 CSV 파일로 저장합니다.

  6. 이제 이 새로운 CSV 파일을 사용하여 연락처를 Outlook으로 가져올 수 있습니다.

서식 파일 CSV 파일 다운로드

빈 CSV 파일로 시작하는 경우 아래 샘플 파일을 다운로드할 수 있습니다.

  1. 다운로드합니다. 확인 메시지가 표시되면 파일을 CSV 파일로 컴퓨터에 저장하도록 선택합니다. Excel 파일(.xls 또는 .xlsm)로 저장하면 모든 데이터가 한 열에 입력됩니다.

    샘플 .csv 파일을 다운로드할 때 .csv 파일 유형으로 컴퓨터에 저장합니다.

  2. 컴퓨터에서 Excel을 엽니다.

  3. Excel에서 파일 > 열기 >로 이동한 다음 방금 컴퓨터에 다운로드한 .csv 파일로 이동합니다. .csv 파일을 찾으려면 모든 파일을 확인해야 합니다. .csv 파일을 클릭하여 엽니다.

    csv 파일을 찾으려면 모든 파일을 검색해야 합니다.

이 샘플 CSV 파일을 사용하는 경우 다음 몇 가지 사항에 주의해야 합니다.

  • Outlook에서는 첫 번째 행에 열 머리글이 있어야 하므로 다른 내용으로 바꾸면 안 됩니다.

    다음은 Excel에서 샘플 .csv 파일이 표시되는 방식입니다.

  • 2~6행의 데이터를 삭제할 수 있습니다(샘플 이름, 전화 번호, 전자 메일 주소 등).

  • 모든 열 값을 입력하지 않아도 됩니다. 원하는 정보만 입력합니다.

  • 파일을 CSV 파일 형식(.csv)의 새 이름으로 저장합니다. Excel에서 파일 작업을 하는 경우 저장할 때 Excel에서 "CSV 형식으로 저장하시겠습니까?"라는 메시지가 몇 번 표시됩니다. 항상 예를 선택합니다. 아니요를 선택하면 파일이 Excel의 고유 형식(.xlsx)으로 저장되어 Outlook이 이 형식을 사용하여 데이터를 가져올 수 없게 됩니다.

  • 몇 개의 연락처가 포함된 CSV 파일로 가져오기를 연습하여 결과가 만족스러운지 확인합니다. 그런 다음 가져온 연락처를 삭제하고 CSV 파일에 연락처를 더 추가한 후 다시 가져올 수 있습니다.

    샘플 CSV 파일에 데이터를 가져오려는 경우 Office 365용 웹의 Outlook에서 다음과 같이 표시됩니다.

    연락처를 가져온 후에 웹용 Outlook에 표시되는 내용

Outlook에 가져올 연락처의 .csv 파일 편집

Outlook에서 내보낸 .csv 파일을 편집한 다음 Outlook 또는 다른 전자 메일 공급자로 가져온다고 가정합니다. Excel을 사용하여 쉽게 .csv 파일을 편집할 수 있습니다.

.csv 파일을 편집할 때 다음과 같은 사항을 기억해야 합니다.

  • 첫 번째 행에 열 제목을 유지합니다.

  • 파일을 저장할 때 Excel에서 "CSV 형식으로 저장하시겠습니까?"라는 메시지가 몇 번 표시됩니다. 항상 예를 선택합니다. 아니요를 선택하면 파일은 Excel의 기본 형식(.xlsx)으로 저장되며 Outlook으로 가져오기를 할 수 없습니다.

문제 첫 번째 열에 모든 데이터 표시

.xls 형식으로 저장된 .csv 파일의 예.

이 문제가 발생하는 원인과 이 문제를 해결하기 위해 시도할 수 있는 방법은 다음과 같습니다.

  • CSV 파일을 .xls, xlsx 또는 .xlm과 같은 다른 형식으로 저장하면 모든 데이터가 첫 번째 열에 표시됩니다. 다시 원래 CSV 파일로 돌아가 .csv 유형으로 저장해야 합니다.

  • CSV 파일을 만드는 프로그램에서 데이터에 따옴표를 추가할 수 있습니다. 따라서 Excel에서 데이터를 하나의 단위로 처리합니다. 예를 들어 다음과 같은 데이터가 있다고 가정합니다.

    a, b, c, d - Excel에서 각 문자를 고유 열에 둡니다.

    "a, b, c, d", e - Excel에서 a,b,c,d를 하나의 열에 두고 e는 다른 열에 둡니다.

    파일의 문제인지 알아보려면 메모장에서 파일을 엽니다. Windows에서 CSV 파일을 마우스 오른쪽 단추로 클릭한 다음 연결 프로그램 > 메모장을 선택합니다. 추가 따옴표를 검색합니다.

    추가 따옴표가 있으면 다음과 같이 파일을 수정합니다.

    1. Excel을 사용하여 CSV 파일을 엽니다. 모든 데이터가 열 A에 있고 따옴표는 제거됩니다.

    2. 이제 텍스트 나누기 마법사를 사용하여 열 A의 데이터를 개별 열로 나눕니다. 메뉴 모음에서 데이터 > 텍스트 나누기를 선택합니다.

      데이터 > 텍스트 나누기를 선택합니다.

    3. 분리 > 다음을 선택합니다. 그런 다음 쉼표 > 완료를 선택합니다.

    4. 여전히 Outlook으로 가져올 수 있도록 파일을 .cvs 형식으로 저장합니다.

참고 항목

Outlook으로 연락처 가져오기

Outlook에서 연락처 내보내기

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×