Microsoft SQL Server 데이터베이스에 대 한 데이터 연결 추가

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Microsoft SQL Server 데이터베이스 쿼리 하는 양식 서식 파일에 대 한 보조 데이터 연결을 추가할 수 있습니다. 데이터베이스에 양식 데이터 전송 하 여 양식 서식 파일에 대 한 보조 데이터 연결을 추가할 수 없습니다. 보조 데이터 연결을 사용 하 여 데이터베이스에 양식 데이터 전송 하려는 경우 해당 데이터베이스를 사용 하는 웹 서비스에 대 한 보조 데이터 연결을 사용 합니다. 참고 항목 섹션에서 웹 서비스에 보조 데이터 연결을 추가 하는 방법에 대 한 자세한 내용은에 대 한 링크를 찾습니다.

데이터베이스에 보조 데이터 연결을 추가 하려면 다음을 수행 해야 합니다.

1 단계: 양식 서식 파일에 보조 데이터 연결 추가    이 단계에서는 적절 한 필드와 그룹 데이터베이스의 데이터가 저장 되는 방식을 기준으로 보조 데이터 원본을 만듭니다. 양식 서식 파일 폼을 처음 열 때이 데이터 연결을 사용 하 여 폼을 구성할 수 있습니다.

2 단계: 데이터 연결을 사용 하 여 양식 서식 파일 구성    사용자가 열린 후이 데이터 연결을 사용 하도록 하려는 경우 사용자가이 데이터 연결에서 데이터를 가져올 수 있도록 양식 서식 파일을 규칙 또는 단추를 추가할 수 있습니다.

이 문서의 내용

개요

시작 하기 전에

1 단계: 보조 데이터 연결 추가

2 단계: 데이터 연결을 사용 하 여 양식 서식 파일 구성

개요

외부 데이터 원본에 기반 하는 양식 서식 파일을 만들 때 Microsoft Office InfoPath 주 데이터 연결 해당 외부 데이터 원본으로 만듭니다. 외부 데이터 원본의 데이터가 저장 되는 방식을 기준 양식 서식 파일에 대 한 기본 데이터 원본이 다음 만들어집니다. 단, 기본 데이터 연결에 사용 되는 외부 데이터 원본 양식 서식 파일에서 컨트롤에 넣을 값 없을 수 있습니다. 이러한 값은 다른 SQL Server 데이터베이스와 같은 다른 외부 데이터 원본에 있을 수 있습니다. 다른 외부 데이터 원본에서 값을 가져오려면 양식 서식 파일에 보조 데이터 연결을 추가할 수 있습니다.

보조 데이터 연결이 양식 서식 파일에 추가 하는 데이터 연결 합니다. 쿼리 데이터 연결 또는 전송 데이터 연결이 데이터 연결 될 수 있습니다. SQL Server 데이터베이스에 대 한 보조 데이터 연결으로만 쿼리 데이터 연결 양식 서식 파일에 추가할 수 있습니다. 기본 데이터 연결 제외한 다른 외부 데이터 원본의 데이터를 해야 하는 경우에이 데이터 연결을 추가 합니다. 보조 데이터 연결으로 SQL Server 데이터베이스에 전송 데이터 연결을 추가할 수 없습니다.

데이터베이스에 쿼리 데이터 연결을 추가 하는 경우 InfoPath 보조 데이터 원본 데이터 필드 및 데이터베이스의 데이터가 저장 되는 방식과에 해당 하는 그룹으로 만듭니다. 보조 데이터 원본에서 데이터 구조 데이터 데이터베이스 테이블에 저장 된 방식으로 일치 해야 하므로 필드 또는 그룹의 보조 데이터 원본에 수정할 수 없습니다. 양식이 네트워크에 연결 되지 않은 경우 사용자가 데이터에 액세스할 수 있도록 결과 저장 하려면 각 쿼리 데이터 연결을 구성할 수 있습니다. 데이터의 특성에 따라 사용자가 네트워크에 연결 되어 있을 때만 쿼리 결과 표시 하는 것이 좋습니다.

보안 정보: 보조 데이터 연결을 외부 데이터 원본에서 중요 한 데이터를 검색을 사용 하는 경우 경우에 컴퓨터를 분실 하거나 유출 무단으로 사용할 수 없도록에서 데이터를 보호 하려면이 기능을 사용 하지 않도록 설정 하는 것이 좋습니다. 이 기능을 해제 하는 경우 데이터는 사용자가 네트워크에 연결 하는 경우에 사용할 수 있습니다.

양식 서식 파일에 쿼리 데이터 연결을 추가할 때 기본적으로이 양식 서식 파일에 기초한 양식 사용 하 여 데이터 연결 사용자가 열리면 합니다. 다음 방법 중 하나로 쿼리 데이터 연결을 사용 하 여 양식 서식 파일을 구성할 수 있습니다.

  • 규칙 추가    규칙의 조건이 발생할 때마다 쿼리 데이터 연결을 사용 하는 규칙을 구성할 수 있습니다.

  • 추가 단추    사용자가 쿼리 데이터 연결을 사용 하 여 데이터를 가져오기 위해 클릭할 수 있는 양식 서식 파일 단추를 추가할 수 있습니다.

  • 사용 하 여 사용자 지정 코드    규칙 또는 단추를 추가할 수 없습니다를 경우 데이터를 가져오는 쿼리 데이터 연결을 사용 하 여 사용자 지정 코드를 사용할 수 있습니다. 사용자 지정 코드를 사용 하 여 사용자 지정 코드를 만들려면 개발자가 필요 합니다.

맨 위로 이동

시작하기 전에

보조 데이터 연결을 SQL Server 데이터베이스에 양식 서식 파일에 추가 하기 전에 데이터베이스 관리자에 게에서 다음과 같은 정보가 필요 합니다.

  • 이 양식 서식 파일에 사용할 데이터베이스를 사용 하 여 서버 이름입니다.

  • 이 양식 서식 파일에 사용할 데이터베이스의 이름입니다.

  • 데이터베이스에 필요한 인증 합니다. 데이터베이스는 사용자가 데이터베이스에 액세스할 수 있는 방법을 확인 하려면 Microsoft Windows 인증 또는 SQL Server 인증을 사용할 수 있습니다.

  • 폼에 보낼 데이터가 들어 있는 테이블의 이름입니다. 기본 테이블입니다. 데이터베이스에서 둘 이상의 테이블을 사용 하려는 경우 다른의 이름, 하위 테이블 필요 합니다. 기본 테이블의 필드와 관계가 있는 하위 테이블의 필드 이름 할 수도 있습니다.

  • 여부 오프 라인으로 사용할 양식에서 쿼리 결과 안전 하 게 저장할 수 있습니다.

맨 위로 이동

1 단계: 보조 데이터 연결 추가

  1. 도구 메뉴에서 데이터 연결 을 클릭 합니다.

  2. 데이터 연결 대화 상자에서 추가 클릭 합니다.

  3. 데이터 연결 마법사에서 에 대 한 새 연결 만들기 를 클릭 하 고 데이터 받기 클릭 후 다음 을 클릭 합니다.

  4. 마법사의 다음 페이지에서 데이터베이스 (Microsoft SQL Server 또는 Microsoft Office Access에만 해당)를 클릭 한 후 다음 을 클릭 합니다.

  5. 마법사의 다음 페이지에서 데이터베이스 선택을 클릭 합니다.

  6. 데이터 원본 선택 대화 상자에서 새 출처 를 클릭 합니다.

  7. 데이터 원본의 종류에 연결 하 시겠습니까 목록에서 Microsoft SQL Server 를 클릭 한 후 다음 을 클릭 합니다.

  8. 서버 이름 상자에 데이터베이스를 사용 하 여 서버 이름을 입력 합니다.

  9. 로그온 자격 증명 에서 다음 중 하나를 수행 합니다.

    • 데이터베이스는 Microsoft Windows 네트워크에 사용 되는 자격 증명에 따라 액세스 권한이 있는 사용자를 결정 하는 경우 Windows 인증 사용을 클릭 합니다.

    • 데이터베이스 지정 된 사용자 이름 및 데이터베이스 관리자 로부터 얻을 수 있는 암호를 기반으로 액세스 권한이 있는 사용자를 결정 하는 경우 다음 사용자 이름 및 암호를 사용 하 여 클릭 한 다음 사용자 이름에서 사용자 이름 및 암호를 입력 암호 상자입니다.

  10. 다음을 클릭합니다.

  11. 원하는 데이터가 들어 있는 데이터베이스 선택 목록에서 마법사의 다음 페이지에서 데이터베이스를 사용 하 여 특정 테이블에 연결 확인란을 선택 하면 기본 테이블의 이름을 클릭합니다 하 고 다음 을 클릭합니다 합니다를 클릭합니다 .

  12. 파일 이름 상자에 마법사의 다음 페이지에서 데이터 연결 정보를 저장 하는 파일의 이름을 입력 합니다.

  13. 이러한 설정을 저장 하려면 완료 를 클릭 합니다.

  14. 쿼리 데이터 연결에 사용 하려는 다른 테이블을 추가 합니다.

    방법

    1. 테이블 추가 클릭 합니다.

    2. 테이블 또는 쿼리 추가 대화 상자에서 자식 테이블의 이름을 클릭 한 후 다음 을 클릭 합니다. InfoPath에서 두 테이블에서 필드 이름과 일치 하는 관계를 설정 하려고 합니다. 제안된 된 관계를 사용 하려면 관계를 선택 하 고 관계 제거 를 클릭 합니다. 관계를 추가 하려면 관계 추가 클릭 합니다. 관계 추가 대화 상자에서 각 열에 관련 된 각 필드의 이름을 클릭 한 다음 확인 을 클릭 합니다.

    3. 마침을 클릭합니다.

    4. 하위 테이블을 더 추가 하려면 다음이 단계를 반복 합니다.

  15. 다음을 클릭합니다.

  16. 폼 네트워크에 연결 되지 않은 경우 쿼리 데이터 연결의 결과 사용할 수 있도록 하려면 양식 서식 파일에 있는 데이터의 복사본 저장 확인란을 선택 합니다.

    보안 정보: 폼이 데이터 연결을 사용 하는 경우 사용자의 컴퓨터에서 데이터를 저장이 확인란을 선택 합니다. 폼 방해가 되는 경우 중요 한 데이터가 데이터 연결에서 컴퓨터 손실 되거나 유출 경우에 데이터를 보호 하는 데 도움이 되도록이 기능을 사용 하지 않도록 설정 하는 것이 좋습니다.

  17. 다음을 클릭합니다.

  18. 마법사의 다음 페이지에서이 보조 데이터 연결에 대해 설명 하는 이름을 입력 합니다. 자동으로 데이터를 받기 위한 양식이 열릴 때 폼 폼을 열 때 데이터를 자동으로 검색 확인란을 선택 합니다.

맨 위로 이동

2 단계: 데이터 연결을 사용 하 여 양식 서식 파일 구성

사용자가 양식을 열 후이 데이터 연결을 사용 하 여이 양식 서식 파일에 기초한 양식, 원하는 경우 특정 조건에서이 데이터 연결을 사용 하는 양식 서식 파일에 규칙을 추가할 수 있습니다. 또는 사용자에 게 cli 수 양식 서식 파일에 단추를 추가할 수 있습니다. 이 데이터 연결을 사용 하 여 ck 합니다.

규칙 추가

규칙의 조건이 충족 될 때마다 쿼리 데이터 연결의 데이터를 가져올 수 양식 서식 파일에 규칙을 추가할 수 있습니다. 다음 절차에 따라 사용자 양식 서식 파일에 대 한 쿼리 데이터 연결을 만든 하 고 해당 데이터 연결의 데이터를 표시 하 여 양식 서식 파일에서 컨트롤 구성 가정 합니다.

  1. 양식 서식 파일 뷰를 여러 개 있으면 보조 데이터 원본에서 데이터를 표시 하려는 컨트롤이 적용 된 보기로 이동 하려면 보기 메뉴의 보기 이름 을 클릭 합니다.

  2. 규칙을 추가 하려면 추가할 컨트롤을 두 번 클릭 합니다.

  3. 데이터 탭을 클릭합니다.

  4. 유효성 검사 및 규칙에서 규칙 을 클릭 합니다.

  5. 규칙 대화 상자에서 추가 클릭 합니다.

  6. 이름 상자에 규칙의 이름을 입력 합니다.

  7. 조건을 규칙이 실행 되도록 하는 경우를 지정 하려면 조건 설정 을 클릭 한 다음 조건을 입력 합니다. 문제가 발생 하는 경우 규칙이 실행 됩니다. 조건이 설정 하지 않으면 사용자의 컨트롤 값을 변경 하 고 다음 해당 컨트롤에서 먼 방향 자신의 커서를 이동 될 때마다 규칙이 실행 됩니다.

  8. 작업 추가 클릭 합니다.

  9. 작업 목록에서 데이터 연결을 사용 하 여 쿼리를 클릭 합니다.

  10. 데이터 연결 목록에서 쿼리 데이터 연결을 사용 하려면을 클릭 한 다음 각 열기 대화 상자를 닫고 확인 클릭 합니다.

  11. 변경 내용을 테스트하려면 표준 도구 모음에서 미리 보기를 클릭하거나 Ctrl+Shift+B를 누릅니다.

단추 추가

사용자가 쿼리 데이터 연결에서 데이터 가져오기 위해 클릭할 수 있는 양식 서식 파일에 단추 컨트롤을 추가할 수 있습니다.

  1. 양식 서식 파일 뷰를 여러 개 있으면 보조 데이터 원본에서 데이터를 표시 하려는 컨트롤이 적용 된 보기로 이동 하려면 보기 메뉴의 보기 이름 을 클릭 합니다.

  2. 컨트롤 작업창이 표시되지 않으면 삽입 메뉴에서 기타 컨트롤을 클릭하거나 ALT+I, C 키를 누릅니다.

  3. 단추 컨트롤을 양식 서식 파일에 끌어다 놓습니다.

  4. 양식 서식 파일에 방금 추가한 단추 컨트롤을 두 번 클릭 합니다.

  5. 일반 탭을 클릭합니다.

  6. 작업 목록에서 새로 고침 을 클릭 합니다.

  7. 레이블 상자에서 양식 서식 파일에 있는 단추에 표시할 이름을 입력 합니다.

  8. 설정을 클릭합니다.

  9. 새로 고침 대화 상자에서 보조 데이터 원본이 두 개 를 클릭 합니다.

  10. 보조 데이터 원본 선택 목록에서 보조 데이터 원본 연결 된 쿼리 데이터 연결을 클릭 합니다.

  11. 확인을 클릭하여 열린 대화 상자를 닫습니다.

  12. 변경 내용을 테스트하려면 표준 도구 모음에서 미리 보기를 클릭하거나 Ctrl+Shift+B를 누릅니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×