Microsoft Access 2010의 새로운 기능

Microsoft Access 2010에서 웹 데이터베이스를 작성 하 고 SharePoint 사이트에 게시할 수 있습니다. SharePoint 방문자는 웹 브라우저에서 데이터베이스 응용 프로그램을 사용 하 고 SharePoint 권한을 사용 하 여 내용을 볼 수 있는 사용자를 결정할 수 있습니다. 서식 파일로 시작 하 여 바로 공동 작업을 시작할 수 있습니다.

또한 Access 사용자 인터페이스도 변경 되었습니다. Access 2010 의 새로운 Backstage 보기에서는 전체 데이터베이스에 적용 되는 압축 및 복구 등의 모든 명령 또는 파일 메뉴에서 가져온 명령에 대 한 액세스 권한을 부여 합니다.

이 문서에서는 Access 2010 에 도입 된 기능에 대해 설명 합니다. Access에 대 한 일반적인 설명이 필요한 경우에는 access 2010 시작문서를 참조 하세요.

이 문서의 내용

개요

새 사용자 인터페이스

더욱 강력한 개체 만들기 도구

새 데이터 형식 및 컨트롤

향상 된 데이터 프레젠테이션

향상 된 보안

문제를 해결 하는 더 좋은 방법

향상 된 맞춤법 검사

개요

Access 서비스를 구성한 SharePoint 사이트에 대 한 액세스 권한이 있는 경우 Access 2010 를 사용 하 여 웹 데이터베이스를 만들 수 있습니다. SharePoint 사이트의 계정이 있는 사용자는 웹 브라우저에서 데이터베이스를 사용할 수 있지만 디자인을 변경 하려면 Access 2010 를 사용 해야 합니다. 일부 데스크톱 데이터베이스 기능은 웹으로 번역 되지 않지만, 계산 필드 및 데이터 매크로와 같은 새로운 기능을 사용 하 여 여러 가지 같은 작업을 수행할 수 있습니다.

웹에서 데이터베이스 공유

  • 서식 파일 사용    다섯 개의 서식 파일에는 연락처, 자산, 프로젝트, 이벤트, 자선 기부에 대 한 Access 2010 포함 됩니다. 게시 하기 전이나 후에 서식 파일을 수정할 수도 있습니다.

  • 처음부터 만들기    빈 새 데이터베이스를 만들 때 일반 데이터베이스와 웹 데이터베이스 중 하나를 선택 합니다. 이 옵션을 선택 하면 응용 프로그램이 웹에 호환 되는지 쉽게 확인할 수 있도록 디자인 기능과 명령에 영향을 줍니다.

  • 기존 데이터베이스를 웹 데이터베이스로 변환    기존 응용 프로그램을 웹에 게시할 수 있습니다. 일부 데스크톱 데이터베이스 기능은 웹에서 지원 되지 않으므로 응용 프로그램의 일부 기능을 조정 해야 할 수 있습니다.

    새 웹 호환성 검사를 실행 하 여 호환성 문제를 식별 하 고 해결 하는 데 도움이 될 수 있습니다.

  • 인트라넷 또는 인터넷    SharePoint 서버에 게시 하거나 호스팅된 SharePoint 솔루션을 사용할 수 있습니다.

    참고: 웹 데이터베이스를 사용하려면 사용자 계정이 필요합니다. 익명 액세스는 지원되지 않습니다.

웹 데이터베이스에 대 한 자세한 내용은 웹에서 공유할 데이터베이스 빌드문서를 참고 하세요.

새 매크로 작성기

Access 2010 는 IntelliSense와 깨끗 하 고 간편한 인터페이스를 제공 하는 새로운 매크로 작성기를 제공 합니다.

매크로 작성기

1. 목록에서 작업을 선택 합니다.

2. 또는 함수 카탈로그에서 함수를 두 번 클릭 하 여 매크로에 추가 합니다.

3. 매크로 작업을 할 때 디자인 탭이 나타납니다.

작업을 추가 하면 매크로 작성기에 추가 옵션이 나타납니다. 예를 들어 "If" 작업을 추가 하는 경우 다음이 표시 됩니다.

If 매크로 함수가 포함된 매크로

다음 비디오를 시청 하 여 새 매크로 작성기의 작동 방식을 확인 하세요.

브라우저가 비디오를 지원하지 않습니다. Microsoft Silverlight, Adobe Flash Player 또는 Internet Explorer 9을 설치하세요.

기존 매크로 외에도 새 매크로 작성기를 사용 하 여 데이터 매크로, 새 기능을 만들 수 있습니다.

데이터 매크로: 이벤트를 기반으로 데이터 변경

데이터 매크로는 웹 데이터베이스의 집계를 지원 하 고 Access 2010 데이터베이스에서 "트리거"를 구현 하는 방법도 제공 합니다.

예를 들어 완료율 필드와 상태 필드가 있다고 가정 합니다. 상태를 완료로 설정할 때 데이터 매크로를 사용 하 여 완료율을 100 로 설정 하 고, 상태를 시작 안 함으로 설정 하면 0 으로 설정할 수 있습니다.

다음 비디오에서는 데이터 매크로 함수를 볼 수 있습니다.

브라우저가 비디오를 지원하지 않습니다. Microsoft Silverlight, Adobe Flash Player 또는 Internet Explorer 9을 설치하세요.

향상 된 식 작성기

이제 식 작성기가 IntelliSense를 제공 하므로 입력 하는 옵션을 볼 수 있습니다. 또한 식 작성기 창에서 현재 선택한 식 값에 대 한 도움말을 표시 합니다. 예를 들어 Trim 함수를 선택 하면 식 작성기에 다음이 표시 됩니다.

Trim (string) 선행 및 후행 공백 없이 지정 된 문자열의 복사본을 포함 하는 Variant string 형식을 반환 합니다.

자세한 내용은 식 작성기 사용문서를 참조 하세요.

계산 필드

계산 결과를 표시 하는 필드를 만들 수 있습니다. 계산은 같은 테이블의 다른 필드를 참조해야 합니다. 식 작성기를 사용 하 여 계산을 만들 수 있습니다.

새 데이터베이스 서식 파일

Access 2010 에는 연락처, 작업, 이벤트, 학생 및 자산을 추적 하기 위한 전문적으로 디자인 된 데이터베이스 서식 파일 모음이 포함 되어 있습니다 (다른 유형의 데이터 중). 이를 바로 사용 하거나 개선 하 고 조정 하 여 원하는 방식으로 정보를 추적할 수 있습니다.

Backstage 보기에서 사용 가능한 서식 파일

각 서식 파일은 미리 정의 된 테이블, 양식, 보고서, 쿼리, 매크로, 관계를 포함 하는 완전 한 추적 응용 프로그램입니다. 서식 파일은 즉시 바로 사용할 수 있도록 디자인 되어 있으며, 빠르게 시작 하 고 실행할 수도 있습니다. 서식 파일 디자인이 사용자의 요구에 부합 하는 경우에는 준비가 완료 된 것입니다. 그렇지 않은 경우에는 서식 파일을 사용 하 여 특정 요구 사항을 충족 하는 데이터베이스를 만들 때 시작 하는 방법을 선택할 수 있습니다.

자산 웹 데이터베이스

Access 2010 에 포함 된 서식 파일 외에도 Office.com 에 연결 하 고 더 많은 서식 파일을 다운로드할 수 있습니다.

기존 데이터베이스에 기능을 추가 하기 위한 응용 프로그램 요소

응용 프로그램 파트를 사용 하 여 기존 데이터베이스에 손쉽게 기능을 추가할 수 있습니다. Access 2010의 새로운 기능으로, 응용 프로그램 파트는 미리 서식이 지정 된 테이블 또는 연결 된 폼과 보고서가 있는 테이블 등 데이터베이스의 일부로 이루어진 서식 파일입니다. 예를 들어 작업 응용 프로그램 파트를 데이터베이스에 추가 하 고 작업 테이블, 작업 폼, 작업 테이블을 데이터베이스의 다른 테이블에 연결 하는 옵션을 가져옵니다.

만들기 탭의 응용 프로그램 요소

자세한 내용은 데이터베이스 디자인 요소 저장 및 다시 사용문서를 참조 하세요.

향상 된 데이터 시트 보기

테이블을 만들고 앞에 필드를 정의 하지 않고 사용할 수 있으므로 만들기 탭의 테이블 을 클릭 한 다음 나타나는 새 데이터 시트에 데이터를 입력 하면 됩니다. Access 2010 에서는 각 필드에 대해 가장 적합 한 데이터 형식을 자동으로 결정 하 여 시간 없이 실행 되도록 합니다. 열 을 추가 하려면 클릭 하세요. 새 필드를 추가할 위치를 표시 하 고, 새 필드나 기존 필드의 데이터 형식 또는 표시 형식을 변경 해야 하는 경우 리본 메뉴의 필드 탭에서 명령을 사용할 수 있습니다. Microsoft Excel 표의 데이터를 새 데이터 시트에 붙여 넣으면 모든 필드를 만들고 데이터 형식을 자동으로 인식 Access 2010 수 있습니다.

데이터시트 보기의 추가하려면 클릭

필드 목록 창

필드 목록 창에서 다른 테이블의 필드를 추가할 수 있습니다. 테이블의 필드를 레코드 원본, 관련 테이블 또는 데이터베이스의 관련 되지 않은 테이블에서 끌어올 수 있습니다. 테이블 간의 관계가 필요한 경우 자동으로 만들어지거나 프로세스를 통해 메시지가 표시 됩니다.

필드 목록 창

레이아웃 보기를 사용 하 여 폼 및 보고서 디자인 속도 향상

레이아웃 보기를 사용 하 여 폼 또는 보고서에서 데이터를 보는 동안 디자인을 변경할 수 있습니다.

레이아웃 보기는 여러 가지 향상 된 기능을 제공 하며 웹에 대 한 폼 이나 보고서를 디자인 하는 경우에 필요 합니다.

라이브 데이터가 표시되어 있는 레이아웃 보기의 폼

컨트롤 레이아웃을 사용 하 여 항목 정리

레이아웃은 단위로 이동 하 고 크기를 조정할 수 있는 컨트롤 그룹입니다. Access 2010 에서 레이아웃은 폼 및 보고서에서 컨트롤을 보다 유연 하 게 배치할 수 있도록 향상 되었습니다. 셀을 가로나 세로로 분할 하거나 병합 하 여 필드, 열 또는 행을 쉽게 다시 정렬할 수 있습니다.

웹 데이터베이스를 디자인할 때는 레이아웃 보기를 사용 해야 하지만 데스크톱 데이터베이스 디자인 작업에서는 디자인 보기를 계속 사용할 수 있습니다.

새 사용자 인터페이스

Access 2010 에서 향상 된 새 사용자 인터페이스는 이전에는 복잡 한 메뉴 및 도구 모음에 덮여 있는 명령과 기능을 쉽게 찾을 수 있도록 설계 되었습니다.

리본 메뉴

리본 메뉴는 기능 및 기능으로 구성 된 명령 그룹을 포함 하는 탭의 컬렉션입니다. 리본 메뉴는 이전 버전의 Access에 있는 메뉴 및 도구 모음의 레이어를 대체 합니다. 다음 그림에서는 탭이 선택 된 리본 메뉴를 보여 줍니다.

Access 2010의 리본 메뉴

리본 메뉴의 주요 기능은 다음과 같습니다.

  • 명령 탭-필요한 명령을 찾을 수 있도록 일반적으로 함께 사용 되는 명령을 표시 하는 탭입니다.

  • 상황별 명령 탭-컨텍스트 (즉, 작업 중인 개체) 또는 수행 중인 작업에 따라 표시 되는 명령 탭입니다. 상황별 명령 탭에는 수행 중인 작업에 적용 될 수 있는 명령이 포함 되어 있습니다.

  • 갤러리-스타일 또는 옵션의 미리 보기를 표시 하는 새 컨트롤로, 선택 항목에 커밋하기 전에 결과를 볼 수 있습니다.

Backstage 보기

Access 2010 의 새로운 Backstage 보기에는 전체 데이터베이스 (예: 압축 및 복구)에 적용 하거나 새 데이터베이스를 여는 명령이 포함 되어 있습니다. 명령은 화면 왼쪽의 탭에 정렬 되며 각 탭에는 관련 명령 또는 링크 그룹이 포함 됩니다. 예를 들어 새로만들기를 클릭 하면 새 데이터베이스를 처음부터 만들거나 전문적으로 디자인 된 데이터베이스 서식 파일의 라이브러리에서 선택 하 여 단추 집합을 볼 수 있습니다.

Backstage 보기의 새로 만들기 탭

Backstage 보기에서 검색 하는 대부분의 명령은 이전 버전의 Access의 파일 메뉴에서 사용할 수 있으며, 최근에 연 데이터베이스 및 인터넷에 연결 된 경우에는 office.com 문서에 대 한 링크를 사용 하는 것이 좋습니다.

Backstage 보기에 액세스 하려면 파일 탭을 클릭 합니다.

탐색 창

탐색 창은 현재 열려 있는 데이터베이스의 모든 개체를 나열 하 고 쉽게 액세스할 수 있도록 합니다.

탐색 창의 개체

탐색 창을 사용 하 여 개체 유형별, 만든 날짜, 수정한 날짜, 관련 테이블 (개체 종속 관계 기반) 또는 사용자 지정 그룹을 기준으로 개체를 구성할 수 있습니다. 양식 디자인에서 작업 하려면 공간이 더 필요 합니다. 탐색 창은 공간을 조금 차지 하지만 여전히 사용할 수 있는 상태로 유지 되도록 쉽게 축소할 수 있습니다.

탭 개체

기본적으로 테이블, 쿼리, 폼, 보고서, 매크로가 Access 창에 탭 개체로 표시 됩니다.

데이터베이스 별로이 설정을 변경 하 고 탭 대신 개체 창을 사용할 수 있습니다.

개체 탭을 클릭 하 여 Access 2007의 탭 개체 다양 한 개체를 쉽게 전환할 수 있습니다.

도움말 창

Access 2010 에서는 Access 도움말 및 Access 개발자 참조 콘텐츠를 모두 동일한 도움말 창에 제공 합니다. 두 시스템에는 서로 다른 유형의 지원 콘텐츠가 포함 되어 있습니다. 도움말 뷰어를 사용 하 여 표시할 콘텐츠를 선택할 수 있습니다. 예를 들어 검색 범위를 Access 개발자 참조 콘텐츠만 변경할 수 있습니다. 도움말 창에서 설정한 설정에 관계 없이 모든 Access 도움말 및 Access 개발자 참조 콘텐츠는 Office.com 또는 MSDN에서 항상 온라인으로 제공 됩니다.

더욱 강력한 개체 만들기 도구

Access 2010 는 데이터베이스 개체를 만들기 위한 직관적인 환경을 제공 합니다.

만들기 탭

만들기 탭을 사용 하 여 새 폼, 보고서, 테이블, 쿼리 및 기타 데이터베이스 개체를 빠르게 만들 수 있습니다. 탐색 창에서 테이블 또는 쿼리를 선택 하는 경우 또는 보고서 명령을 사용 하 여 한 번의 클릭으로 해당 개체를 기반으로 하는 새 폼 이나 보고서를 만들 수 있습니다.

Access의 리본 메뉴에 있는 만들기 탭

이 한 번 클릭 프로세스를 통해 만든 새 폼과 보고서에는 업데이트 된 디자인을 사용 하 여 시각적으로 더욱 흥미롭고 유용한 기능을 제공할 수 있습니다. 자동으로 생성 된 양식과 보고서에서는 로고와 제목을 포함 하는 머리글을 사용 하 여 전문가 수준의 디자인을 얻을 것입니다. 또한, 자동 생성 된 보고서에는 날짜 및 시간 뿐만 아니라 정보 바닥글과 요약도 포함 됩니다.

보고서 보기 및 레이아웃 보기

Access 2010 에서 향상 된 이러한 보기를 사용 하 여 폼과 보고서를 대화형으로 사용할 수 있습니다. 보고서 보기를 사용 하 여 인쇄 하거나 인쇄할 필요 없이 보고서의 정확한 렌더링을 찾아볼 수 있습니다. 특정 레코드에 초점을 맞추기 위해 필터 기능을 사용 하거나 찾기 작업을 사용 하 여 일치 하는 텍스트를 검색 합니다. 복사 명령을 사용 하 여 텍스트를 클립보드에 복사 하거나, 보고서에 표시 된 활성 하이퍼링크를 클릭 하 여 브라우저의 링크를 따라갈 수 있습니다.

레이아웃 보기를 사용 하 여 데이터를 검색 하는 동안 디자인을 변경할 수 있습니다. 레이아웃 보기를 사용 하 여 폼 또는 보고서에서 데이터를 보는 동안 여러 가지 일반적인 디자인을 변경할 수 있습니다. 예를 들어 새 필드 목록 창에서 필드 이름을 끌어 필드를 추가 하거나 속성 시트를 사용 하 여 속성을 변경 합니다.

레이아웃 보기에서는 필드, 열, 행 또는 전체 레이아웃을 쉽게 다시 정렬할 수 있도록 하나로 조정할 수 있는 컨트롤 그룹 이라는 향상 된 디자인 레이아웃을 제공 합니다. 레이아웃 보기에서 필드를 제거 하거나 서식을 쉽게 추가할 수도 있습니다. 레이아웃 보기의 보고서

보고서에서 효율적으로 그룹화 및 정렬 만들기

Access에는 보고서에서 데이터를 그룹화 하 고 정렬 하 고 합계를 추가 하는 새로운 방법이 있습니다. 인터페이스는 쉽게 탐색 하 고 이해할 수 있으며 새 레이아웃 보기와 함께 사용 되는 경우 변경 내용이 즉시 반영 되는 것을 볼 수 있습니다.

그룹, 정렬 및 요약 창

보고서에 지역별 총 판매량을 표시 하려는 경우를 예로 들어 보겠습니다. 레이아웃 보기와 그룹, 정렬 및 요약 창을 사용 하 여 그룹 수준을 추가 하 고 합계를 요청 하 고 변경 내용을 보고서에 표시 합니다. 요약 행을 사용 하면 보고서 머리글 또는 바닥글에 합계, 평균, 개수, 최대값 또는 최소값을 쉽게 추가할 수 있습니다. 단순 합계는 더 이상 계산 필드를 수동으로 만들지 않아도 됩니다. 이제 가리킵니다.

보고서에서 요약 만들기

향상 된 폼과 보고서를 만들기 위해 개선 된 컨트롤 레이아웃

폼과 보고서에는 고객 이름 또는 고객에 대 한 모든 필드가 포함 된 행이 포함 된 열과 같은 테이블 형식 정보가 포함 되는 경우가 많습니다. 레이블을 포함 하 여 간단 하 게 조작할 수 있는 레이아웃으로 이러한 컨트롤을 그룹화 할 수 있습니다.

정렬 탭의 컨트롤 레이아웃 그룹에 있는 명령

섹션 머리글 또는 바닥글의 레이블과 같은 다른 섹션의 컨트롤을 선택할 수 있으므로 상당한 유연성이 있습니다. 다음과 같은 작업을 쉽게 할 수 있습니다.

  • 레이아웃을 이동 하거나 크기를 조정 합니다. 예를 들어 열을 왼쪽 또는 오른쪽으로 이동 합니다.

  • 레이아웃의 서식을 지정 합니다. 예를 들어 고객 이름 열을 굵게로 설정 하 여이를 의미 합니다.

  • 레이아웃에 열 (필드)을 추가 합니다.

  • 레이아웃에서 열 (필드)을 삭제 합니다.

  • 셀 병합 또는 분할

레이아웃 보기에서의 열 이동

레이아웃은 디자인에 저장 되므로 계속 사용할 수 있습니다. 다음 비디오에서는 폼 및 보고서에서 레이아웃이 작동 하는 방식을 보여 줍니다.

브라우저가 비디오를 지원하지 않습니다. Microsoft Silverlight, Adobe Flash Player 또는 Internet Explorer 9을 설치하세요.

데이터 빠른 검색을 위한 폼 분할

분할 표시 폼을 사용 하 여 데이터 시트 보기와 폼 보기를 결합 하는 폼을 만듭니다. 속성을 설정 하 여 위쪽, 아래쪽, 왼쪽 또는 오른쪽에 데이터 시트를 추가할 수 있습니다.

분할 폼

참고: 웹 데이터베이스에서는 분할 된 폼을 사용할 수 없습니다.

폼 및 보고서의 포함 된 매크로

코드를 작성할 필요가 없도록 포함 된 매크로를 사용 합니다. 포함 된 매크로는 속성에 저장 되며 속성이 속한 개체의 일부입니다. 매크로를 사용할 수 있는 다른 컨트롤에 대해 걱정할 필요 없이 포함 된 매크로의 디자인을 변경할 수 있습니다. 포함 된 매크로는 안전 하지 않은 작업을 수행할 때 자동으로 허용 되지 않으므로 신뢰할 수 없습니다.

On Dbl Click 이벤트에 포함된 매크로 지정

새 데이터 형식 및 컨트롤

Access 2010 의 새로운 계산 필드를 사용 하 여 계산 결과를 저장할 수 있습니다.

  • 다중값 필드

  • 첨부 파일 데이터 형식

  • 향상 된 메모 필드

  • 날짜/시간 필드에 대 한 기본 제공 일정 컨트롤

계산 필드

동일한 테이블의 다른 데이터에서 계산 되는 값을 표시 하는 필드를 만들 수 있습니다. 식 작성기를 사용 하 여 계산을 만들면 IntelliSense에서 식 값에 대 한 도움말에 쉽게 액세스할 수 있습니다.

다른 테이블의 데이터를 계산 데이터의 원본으로 사용할 수는 없습니다. 일부 식은 계산 필드에서 지원되지 않습니다.

다중값 필드

다중값 필드에는 레코드 마다 값을 두 개 이상 저장할 수 있습니다. 직원 또는 계약자 중 한 명에 게 작업을 배정 했지만 두 명 이상의 사람에 게 배정 해야 한다고 가정 합니다. 대부분의 데이터베이스 관리 시스템 및 Office Access 2007 보다 이전 버전의 Access에서는 이러한 작업을 올바르게 수행 하기 위해 다대다 관계를 만들어야 했습니다.

참고: Access에서는 숨겨진 테이블이 만들어져서 각 다중값 필드에 대해 필요한 다대다 관계를 유지 합니다.

다중값 필드는 Windows SharePoint Services 에 사용 되는 다중값 필드 형식 중 하나가 포함 된 SharePoint 목록 작업을 수행 하는 경우에 특히 적합 합니다. Access 2010 는 이러한 데이터 형식과 호환 됩니다.

다중값 필드

파일의 첨부 파일 필드

첨부 파일 데이터 형식을 사용 하면 데이터베이스 크기를 불필요 하 게 증가 시 키 지 않고 데이터베이스에 모든 종류의 문서와 바이너리 파일을 쉽게 저장할 수 있습니다. 가능 하면 Access에서 첨부 파일을 자동으로 압축 하 여 공간 사용량을 최소화 합니다. 레코드에 Word 문서를 첨부 하거나 데이터베이스에 일련의 디지털 사진을 저장 하 시겠습니까? 첨부 파일을 사용 하면 이러한 작업을 훨씬 쉽게 수행할 수 있습니다. 단일 레코드에 여러 개의 첨부 파일을 추가할 수도 있습니다.

첨부 파일 대화 상자

참고: 웹 데이터베이스에 첨부 파일 필드를 사용할 수 있지만 각 웹 테이블에는 하나의 첨부 파일 필드가 있을 수 있습니다.

이제 메모 필드에 서식 있는 텍스트를 저장 하 고 수정 기록을 지원 합니다.

서식 있는 텍스트 메모 필드는 더 이상 레코드의 일반 텍스트로 제한 되지 않는다는 의미입니다. 굵게, 기울임꼴 등의 옵션을 사용 하 여 텍스트에 서식을 지정 하 고, 다른 글꼴 및 색 외에 다른 일반적인 서식 옵션을 적용 하 고, 데이터베이스에 텍스트를 저장할 수 있습니다. 서식 지정 된 텍스트는 Windows SharePoint Services 에서 서식 있는 텍스트 데이터 형식과 호환 되는 HTML 기반 서식의 메모 필드에 저장 됩니다. 새 TextFormat 속성을 RichText 또는 일반 텍스트로설정 하면 텍스트 상자 컨트롤 및 데이터 시트 보기에서 해당 정보 형식이 올바르게 지정 됩니다.

메모 필드는 많은 양의 정보를 저장 하는 데 유용 합니다. 메모 필드에 대 한 모든 변경 기록을 유지 하려면 추가 전용 속성을 구성할 수 있습니다. 그러면 해당 변경 내용에 대 한 기록을 볼 수 있습니다. 또한이 기능은 Access를 사용 하 여 SharePoint 목록 콘텐츠 기록을 볼 수 있도록 Windows SharePoint Services 의 추적 기능을 지원 합니다.

날짜 선택 일정

날짜/시간 데이터 형식을 사용 하는 필드 및 컨트롤은 기본 제공 대화형 달력에 대 한 지원을 자동으로 획득 합니다. 날짜 오른쪽에 달력 단추가 자동으로 나타납니다. 이 금요일의 날짜를 알고 싶으신가요? 단추를 클릭 하면 날짜가 자동으로 표시 되어 날짜를 찾아 선택할 수 있습니다. 속성을 사용 하 여 필드나 컨트롤의 일정을 해제할 수 있습니다.

향상 된 데이터 프레젠테이션

새 데이터 프레젠테이션 기능을 사용 하 여 데이터베이스 개체를 더 빠르게 만든 다음 데이터를 보다 쉽게 분석할 수 있습니다.

향상 된 정렬 및 필터링 도구

일치 하는 값을 빠르게 찾거나 데이터 열을 정렬 해야 하는 경우를 예로 들어 보겠습니다. 자동 필터 기능은 이미 강력한 필터링 기능을 보강 하 여 필요한 데이터를 빠르게 강조할 수 있습니다. 열에서 고유한 값을 쉽게 선택할 수 있으며,이는 필요한 이름을 기억할 수 없는 상황에 유용 하거나, 상황에 맞는 메뉴 옵션을 일반 언어로 오름차순 정렬 또는 내림차순 정렬 중에서 가장 큰 값으로 정렬을 사용 하 여 정렬할 수 있습니다.

자동 필터

가장 일반적인 필터 옵션은 메뉴 명령에 쉽게 표시 되거나, 빠른 필터를 사용 하 여 입력 한 데이터에 따라 정보를 제한할 수 있습니다. 빠른 필터 옵션은 데이터 형식에 따라 자동으로 변경 되므로 텍스트, 날짜, 숫자 정보에 대 한 적절 한 선택 항목이 표시 됩니다.

날짜 필터 메뉴

데이터 시트의 합계 및 교대로 반복 되는 배경 색

데이터 시트 보기는 합계, 개수, 평균, 최대값, 최소값, 표준 편차 또는 분산을 표시할 수 있는 요약 행을 제공 합니다. 요약 행을 추가한 후에는 열의 셀에 있는 화살표를 가리켜 원하는 계산을 선택 합니다.

데이터시트의 요약 행

데이터 시트, 보고서, 연속 폼은 기본 배경색과 독립적으로 구성할 수 있는 행의 교대로 반복 되는 배경색을 지원 합니다. 행을 번갈아 음영 처리 하 고 원하는 색을 선택할 수 있습니다.

대체 행 색을 사용하는 데이터시트

조건부 서식

Access 2010 새 조건부 서식 기능을 추가 하 여 Excel에서 사용할 수 있는 것과 동일한 서식 스타일을 구현할 수 있도록 합니다. 예를 들어 다음 그림에 표시 된 대로 데이터 막대를 추가 하 여 숫자 열을 보다 읽기 쉽게 만들 수 있습니다.

Access 보고서의 조건부 서식

참고: 웹 데이터베이스에서는 조건부 서식을 사용할 수 없습니다.

향상 된 보안

향상 된 보안 기능 및 Windows SharePoint Services 와의 강력한 통합을 통해 보다 효과적으로 관리 하 고 이전 보다 더 안전한 정보 추적 응용 프로그램을 만들 수 있습니다. Windows SharePoint Services 의 목록에 추적 응용 프로그램 데이터를 저장 하 여 수정 기록을 감사 하 고, 삭제 된 정보를 복구 하 고, 데이터 액세스 권한을 구성할 수 있습니다.

Office Access 2007 는 Access 2010 에 전달 및 향상 된 새로운 보안 모델을 도입 했습니다. 통합 신뢰 결정은 Microsoft Office 보안 센터와 통합 됩니다. 신뢰할 수 있는 위치를 통해 안전한 폴더의 모든 데이터베이스를 쉽게 신뢰 할 수 있습니다. 더 안전한 기능을 제공 하는 코드 또는 매크로를 포함 하는 Office Access 2007 응용 프로그램 (안전 하지 않은 명령 실행 불가) 환경을 로드할 수 있습니다. 신뢰할 수 있는 매크로는 Sandbox 모드에서 실행 됩니다.

InfoPath 양식 및 Outlook을 사용 하 여 데이터 수집

데이터 수집 기능을 사용 하면 Outlook과 선택적으로 InfoPath를 통해 피드백을 수집할 수 있습니다. InfoPath 양식 또는 HTML 양식을 자동으로 생성 하 여 전자 메일 메시지의 본문에 포함할 수 있습니다. 그런 다음 Outlook 연락처에서 선택한 받는 사람 또는 Access 데이터베이스의 필드에 저장 된 받는 사람 이름에 양식을 보낼 수 있습니다.

전자 메일 메시지를 사용하여 데이터 수집

새 정보를 수집할지 기존 정보를 업데이트할지 선택 합니다. 그러면 받는 사람이 폼을 완성 하 여 반환 합니다. Outlook에서 수신 되는 양식을 인식 하 고 데이터를 자동으로 Access 데이터베이스에 저장 합니다-다시 입력 하지 않아도 됩니다.

PDF 및 XPS로 내보내기

Access 2010 에서 PDF 또는 XPS로 게시 추가 기능을 먼저 설치 하면 데이터를 PDF (이식 가능 문서 형식) 또는 XPS (XML 용지 사양) 파일 형식으로 내보내 인쇄, 게시, 전자 메일 배포에 사용할 수 있습니다. 폼, 보고서 또는 데이터 시트를 .pdf 또는 .xps 파일로 내보내면 모든 서식 특성을 유지 하는 배포 하기 쉬운 양식으로 정보를 캡처할 수 있지만, 출력을 인쇄 하거나 검토 하기 위해 다른 사용자가 컴퓨터에 Access를 설치 하지 않아도 됩니다.

  • 이동식 문서 형식    PDF는 문서 서식을 유지 하 고 파일을 공유 하는 데 도움이 되는 고정 레이아웃 전자 파일 형식입니다. PDF 형식을 사용 하면 파일을 온라인으로 보거나 인쇄할 때 의도 한 서식이 그대로 유지 되며 파일의 데이터를 쉽게 복사 하거나 변경할 수 없습니다. 또한 상업용 인쇄 방법을 사용하여 복제되는 문서에도 PDF 형식이 유용합니다.

  • XML 용지 사양    XPS는 문서 서식을 유지 하 고 파일을 공유 하는 데 도움이 되는 전자 파일 형식입니다. XPS 형식을 사용 하면 파일을 온라인으로 보거나 인쇄할 때 의도 한 서식이 그대로 유지 되며 파일의 데이터를 쉽게 복사 하거나 변경할 수 없습니다.

손쉬운 외부 데이터 작업

이제 외부 데이터 원본으로 웹 서비스에 연결할 수 있습니다. 웹 서비스 관리자가 제공 하는 웹 서비스 정의 파일이 필요 합니다. 정의 파일을 설치한 후에는 웹 서비스 데이터를 연결 된 테이블로 연결할 수 있습니다.

새 기능을 통해 데이터를 쉽게 가져오고 내보낼 수 있습니다. 가져오기 또는 내보내기 작업을 저장 한 후 다음에 같은 작업을 수행할 때 저장 된 작업을 다시 사용할 수 있습니다. 스프레드시트 가져오기 마법사를 사용 하 여 Access에서 선택한 데이터 형식을 재정의 하 고 파일 형식이 최소한 Office Excel 2007 인 파일을 가져오고, 내보내고, 연결할 수 있습니다.

문제를 해결 하는 더 좋은 방법

Microsoft Office 진단은 컴퓨터가 충돌 하는 이유를 찾는 데 도움이 되는 일련의 진단 테스트입니다. 진단 테스트를 통해 일부 문제를 직접 해결할 수 있으며 다른 문제를 해결할 수 있는 방법을 확인할 수 있습니다. Microsoft Office 진단은 검색 및 복구와 Microsoft Office 응용 프로그램 복구의 Microsoft office 2003 기능을 대체 합니다.

향상 된 맞춤법 검사

다음은 맞춤법 검사기의 몇 가지 새로운 기능입니다.

  • 맞춤법 검사는 Office 프로그램에서 더 일관 되 게 작동 합니다. 이러한 변경의 예는 다음과 같습니다.

    • 일부 맞춤법 검사 옵션은 이제 전역적으로 진행 됩니다. 한 Office 프로그램에서 이러한 옵션 중 하나를 변경 하면 다른 모든 Office 프로그램 에서도 해당 옵션이 변경 됩니다.

    • 동일한 사용자 지정 사전을 공유 하는 것 외에도, 모든 프로그램에서 동일한 대화 상자를 사용 하 여 항목을 관리할 수 있습니다. 자세한 내용은 사용자 지정 사전을 사용 하 여 맞춤법 검사기에 단어 추가문서를 참고 하세요.

  • 맞춤법 검사기에는 개정 후 프랑스어 사전이 포함 되어 있습니다. Microsoft Office 2003에서이는 별도로 설치 해야 하는 추가 기능 이었습니다.

  • 해당 언어를 처음 사용할 때 해당 언어에 대 한 제외 사전이 자동으로 만들어집니다. 제외 사전을 사용 하 여 맞춤법 검사기에서 사용 하지 않을 단어에 플래그를 지정할 수 있습니다. 제외 사전은 외설적 또는 스타일 가이드와 일치 하지 않는 단어를 피하는 데 유용 합니다. 자세한 내용은 제외 사전을 사용 하 여 단어에 대 한 기본 맞춤법 지정문서를 참조 하세요.

참고:  이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 정보가 도움이 되는지 알려주세요. 참조할 수 있는 영문 문서가 여기 있습니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×