Microsoft Access 데이터베이스에 데이터 연결 추가

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

폼에 보조 데이터 연결을 추가 사용자에 게는 Microsoft Office Access 2007 (.accdb 형식) 데이터베이스 또는 Microsoft Office InfoPath 양식 서식 파일에 기초한 양식 작성을 이전 버전 (.mdb 형식)에 저장 된 Access 데이터베이스에서 데이터를 해야 하는 경우 Access 데이터베이스를 쿼리 하는 서식 파일입니다.

보조 데이터 연결을 추가할 수 있지만 해당 데이터 연결 Access 데이터베이스 쿼리할 수 있습니다. Access 데이터베이스에 양식 데이터 전송 보조 데이터 연결을 추가할 수 없습니다.

Access 데이터베이스에 양식 데이터를 전송할 하도록 하려는 경우 Access 데이터베이스에 기반 하는 양식 서식 파일 디자인 한 다음 기본 데이터 연결에 전송 데이터 연결을 사용 하도록 설정 수 있습니다. 또는 Access 데이터베이스를 사용할 수 있는 웹 서비스에 보조 데이터 연결을 추가할 수 있습니다.

Access 데이터베이스에 기초한 양식 서식 파일을 디자인 하 고 보조 데이터 연결을 참고 항목 섹션에서 웹 서비스를 추가 하는 방법에 대 한 자세한 내용은에 대 한 링크를 찾습니다.

이 문서의 내용

개요

호환성 고려 사항

시작 하기 전에

1 단계: 보조 데이터 연결 추가

2 단계: 데이터 연결을 사용 하 여 양식 서식 파일 구성

개요

보조 데이터 연결 양식 서식 파일에 추가 하는 데이터 연결입니다. 보조 데이터 연결은 데이터베이스 또는 웹 서비스에 기반 하는 새 양식 서식 파일을 디자인할 때 만드는 기본 데이터 연결 다릅니다. 양식 서식 파일의 기본 데이터 연결 외부 데이터 원본에서 데이터를 받을 수 및 외부 데이터 원본에 양식 데이터 전송 수도 있습니다. 그러나 양식 서식 파일 기본 데이터 연결을 하나만 있을 수 있습니다.

가능한 한 많은 보조 데이터 연결 양식 서식 파일을 원하는 만큼 추가할 수 있습니다. 예를 들어 직원 데이터가 저장 되는 테이블 및 고객 데이터를 저장 하는 다른 테이블이 포함 된 Access 데이터베이스 있다고 가정 합니다. 직원 테이블의 데이터를 검색 하는 보조 데이터 연결을 추가할 수 있으며 같은 Access 데이터베이스에서 고객 테이블의 데이터를 검색 하는 다른 보조 데이터 연결을 추가할 수 있습니다.

보조 데이터 연결 Access에서 데이터를 검색만 사용할 수는 보조 데이터 연결 웹 서비스 또는 Windows SharePoint Services 라이브러리 등의 외부 데이터 원본에 양식 데이터 전송 수 있는 양식 서식 파일에 추가할 수는 있지만 데이터베이스입니다. Access 데이터베이스에 양식 데이터 전송 보조 데이터 연결을 추가할 수 없습니다.

데이터베이스에 쿼리 데이터 연결을 추가 하면 데이터 필드와 데이터는 데이터베이스에 저장 하는 방법에 해당 하는 그룹 있는 보조 데이터 원본 만들어집니다. 보조 데이터 원본에서 데이터 구조 데이터 데이터베이스 테이블에 저장 된 방식으로 일치 해야 하므로 필드 또는 그룹의 보조 데이터 원본에 수정할 수 없습니다.

양식이 네트워크에 연결 되지 않은 경우 사용자가 데이터에 액세스할 수 있도록 해당 결과 저장 하려면 각 쿼리 데이터 연결을 구성할 수 있습니다. 데이터의 특성에 따라 사용자가 네트워크에 연결 되어 있을 때만 쿼리 결과 표시 하는 것이 좋습니다.

보안 정보: 보조 데이터 연결을 외부 데이터 원본에서 중요 한 데이터를 검색을 사용 하는 경우 경우에 컴퓨터를 분실 하거나 유출 무단으로 사용할 수 없도록에서 데이터를 보호 하려면이 기능을 사용 하지 않도록 설정 하는 것이 좋습니다. 이 기능을 해제 하는 경우 데이터는 사용자가 네트워크에 연결 하는 경우에 사용할 수 있습니다.

양식 서식 파일에 쿼리 데이터 연결을 추가할 때 기본적으로이 양식 서식 파일에 기초한 양식 사용 하 여 데이터 연결 사용자가 열리면 합니다. 다음 방법 중 하나로 쿼리 데이터 연결을 사용 하 여 양식 서식 파일을 구성할 수 있습니다.

  • 규칙 추가    규칙의 조건이 발생할 때마다 쿼리 데이터 연결을 사용 하는 규칙을 구성할 수 있습니다.

  • 추가 단추    사용자가 쿼리 데이터 연결을 사용 하 여 데이터를 가져오기 위해 클릭할 수 있는 양식 서식 파일 단추를 추가할 수 있습니다.

  • 사용 하 여 사용자 지정 코드    규칙 또는 단추를 추가할 수 없습니다를 경우 데이터를 가져오는 쿼리 데이터 연결을 사용 하 여 사용자 지정 코드를 사용할 수 있습니다. 사용자 지정 코드를 사용 하 여 사용자 지정 코드를 만들려면 개발자가 필요 합니다.

맨 위로 이동

호환성 고려 사항

브라우저 호환 양식 서식 파일 에 Access 데이터베이스에 데이터 연결을 추가할 수 없습니다.

맨 위로 이동

시작하기 전에

양식 서식 파일에 Access 데이터베이스에 보조 데이터 연결을 추가 하기 전에 다음과 같은 정보가 필요 합니다.

  • 이름 및 데이터베이스의 위치입니다.

    참고: Access 데이터베이스 t 네트워크 위치에 저장 하는 경우 데이터베이스 사용자에 게 액세스할 수 있는지 확인 합니다.

  • 테이블이 나 쿼리의 해당 양식 서식 파일을 기반으로 하는 폼에 데이터를 제공 하는 이름입니다. 쿼리 데이터 연결을 구성 하는 경우 해당 테이블 또는 쿼리에서 기본 테이블 또는 쿼리를 사용 합니다.

  • 다른 테이블 또는 쿼리의 기본 테이블 또는 쿼리 추가 데이터를 제공 하는 이름입니다. 대부분의 경우에서 테이블 관계 데이터베이스에 이미 설정 됩니다. 기본 테이블 또는 쿼리 및 다른 테이블이 나 쿼리 간의 관계를 수동으로 설정 해야 할 경우 관련된 필드 이름의 테이블이 나 쿼리의 할 수 있습니다.

맨 위로 이동

1 단계: 보조 데이터 연결 추가

  1. 도구 메뉴에서 데이터 연결 을 클릭 합니다.

  2. 데이터 연결 대화 상자에서 추가 클릭 합니다.

  3. 데이터 연결 마법사에서 에 대 한 새 연결 만들기 를 클릭 하 고 데이터 받기 클릭 후 다음 을 클릭 합니다.

  4. 마법사의 다음 페이지에서 데이터베이스 (Microsoft SQL Server 또는 Microsoft Office Access에만 해당)를 클릭 한 후 다음 을 클릭 합니다.

  5. 마법사의 다음 페이지에서 데이터베이스 선택을 클릭 합니다.

  6. 데이터 원본 선택 대화 상자에서 데이터베이스의 위치로 이동 합니다.

    참고: 데이터베이스 t 네트워크 위치에 저장 하는 경우 위치의 범용 명명 규칙 (UNC) 경로를 찾습니다. 연결된 된 네트워크 드라이브를 통해 네트워크 위치를 찾아 실행 합니다. 연결된 된 네트워크 드라이브를 사용 하는 경우이 양식 서식 파일에 기초한 양식 만드는 사용자는 연결된 된 네트워크 드라이브에서 데이터베이스 검색 됩니다. 연결된 된 네트워크 드라이브 없으면 양식에서 데이터베이스를 찾지 않습니다.

  7. 데이터베이스의 이름을 클릭 한 다음 열기 를 클릭 합니다.

  8. 테이블 선택 대화 상자에서 기본 테이블 또는 쿼리를 사용 하려면를 클릭 한 다음 확인 을 클릭 합니다.

  9. 마법사의 다음 페이지에서 표 열 표시 확인란을 선택 합니다.

    기본적으로 모든 테이블이 나 쿼리의 필드 양식 서식 파일의 기본 데이터 원본에 추가 됩니다.

  10. 보조 데이터 원본에 포함 하지 않을 필드에 대 한 확인란의 선택을 취소 합니다.

    데이터 연결에 다른 테이블이 나 쿼리를 추가 합니다.

    방법

    1. 테이블 추가 클릭 합니다.

    2. 테이블 또는 쿼리 추가 대화 상자에서 자식 테이블의 이름을 클릭 한 후 다음 을 클릭 합니다. InfoPath에서 두 테이블에서 필드 이름과 일치 하는 관계를 설정 하려고 합니다. 제안된 된 관계를 사용 하려면 관계를 선택 하 고 관계 제거 를 클릭 합니다. 관계를 추가 하려면 관계 추가 클릭 합니다. 관계 추가 대화 상자에서 각 열에 관련 된 각 필드의 이름을 클릭 한 다음 확인 을 클릭 합니다.

    3. 마침을 클릭합니다.

    4. 하위 테이블을 더 추가 하려면 다음이 단계를 반복 합니다.

  11. 다음을 클릭합니다.

  12. 폼 네트워크에 연결 되지 않은 경우 쿼리 데이터 연결의 결과 사용할 수 있도록 하려면 양식 서식 파일에 있는 데이터의 복사본 저장 확인란을 선택 합니다.

    보안 정보: 폼이 데이터 연결을 사용 하는 경우 사용자의 컴퓨터에서 데이터를 저장이 확인란을 선택 합니다. 폼이 데이터 연결에서 중요 한 데이터를 검색 하를 사용 하는 경우에 컴퓨터 손실 되거나 유출 경우에 데이터를 보호 하는 데 도움이 되도록이 기능을 사용 하지 않도록 설정 합니다.

  13. 다음을 클릭합니다.

  14. 마법사의 다음 페이지에서이 보조 데이터 연결에 대해 설명 하는 이름을 입력 하 고 요약 섹션의 정보가 올바른지 확인 합니다.

  15. 자동으로 데이터를 받기 위한 양식이 열릴 때 폼을 구성 하려면 폼을 열 때 데이터를 자동으로 검색 확인란을 선택 합니다.

맨 위로 이동

2 단계: 데이터 연결을 사용 하 여 양식 서식 파일 구성

사용자가 양식을 열 후이 데이터 연결을 사용 하 여이 양식 서식 파일을 기반으로 하는 폼을 하려는 경우 규칙 특정 조건에서이 데이터 연결을 사용 하는 양식 서식 파일에 추가할 수 있습니다 또는 양식 서식 파일에 있는 단추를 추가할 수 있습니다를 이 데이터 연결을 사용 하 여 사용자가 클릭할 수 합니다.

규칙 추가

양식 서식 파일에서 데이터를 검색 쿼리 데이터 연결 규칙의 조건이 충족 될 때마다 구현 하는 규칙을 추가할 수 있습니다. 예를 들어 사용자가 외부 데이터 원본에서 특정 데이터를 가져오려면 채울 수 있는 양식 서식 파일에 텍스트 상자를 추가할 수 있습니다. 그런 다음 텍스트 상자에 데이터를 입력할 때마다 데이터 연결을 사용 하는 규칙을 추가할 수 있습니다.

다음 절차에 따라 해당 데이터 연결의 데이터를 표시 하 여 양식 서식 파일의 사용자 양식 서식 파일에 대 한 쿼리 데이터 연결을 만든 및 컨트롤 (아님 단추)를 구성 했는지 가정 합니다.

  1. 양식 서식 파일 뷰를 여러 개 있으면 보조 데이터 원본에서 데이터를 표시 하려는 컨트롤이 적용 된 보기로 이동 하려면 보기 메뉴의 보기 이름 을 클릭 합니다.

  2. 규칙을 추가 하려면 추가할 컨트롤을 두 번 클릭 합니다.

  3. 데이터 탭을 클릭합니다.

  4. 유효성 검사 및 규칙에서 규칙 을 클릭 합니다.

  5. 규칙 대화 상자에서 추가 클릭 합니다.

  6. 이름 상자에 규칙의 이름을 입력 합니다.

  7. 조건을 규칙이 실행 되도록 하는 경우를 지정 하려면 조건 설정 을 클릭 한 다음 조건을 입력 합니다. 문제가 발생 하는 경우 규칙이 실행 됩니다. 조건이 설정 하지 않으면 사용자의 컨트롤 값을 변경 하 고 다음 해당 컨트롤에서 먼 방향 자신의 커서를 이동 될 때마다 규칙이 실행 됩니다.

  8. 작업 추가 클릭 합니다.

  9. 작업 목록에서 데이터 연결을 사용 하 여 쿼리를 클릭 합니다.

  10. 데이터 연결 목록에서 쿼리 데이터 연결을 사용 하려면을 클릭 한 다음 각 열기 대화 상자를 닫고 확인 클릭 합니다.

  11. 변경 내용을 테스트하려면 표준 도구 모음에서 미리 보기를 클릭하거나 Ctrl+Shift+B를 누릅니다.

단추 추가

사용자가 쿼리 데이터 연결에서 데이터 가져오기 위해 클릭할 수 있는 양식 서식 파일에 단추 컨트롤을 추가할 수 있습니다.

  1. 양식 서식 파일 뷰를 여러 개 있으면 보조 데이터 원본에서 데이터를 표시 하려는 컨트롤이 적용 된 보기로 이동 하려면 보기 메뉴의 보기 이름 을 클릭 합니다.

  2. 컨트롤 작업창이 표시되지 않으면 삽입 메뉴에서 기타 컨트롤을 클릭하거나 ALT+I, C 키를 누릅니다.

  3. 단추 컨트롤을 양식 서식 파일에 끌어다 놓습니다.

  4. 양식 서식 파일에 방금 추가한 단추 컨트롤을 두 번 클릭 합니다.

  5. 일반 탭을 클릭합니다.

  6. 작업 목록에서 새로 고침 을 클릭 합니다.

  7. 레이블 상자에서 양식 서식 파일에 있는 단추에 표시할 이름을 입력 합니다.

  8. 설정을 클릭합니다.

  9. 새로 고침 대화 상자에서 다음 중 하나를 실행 합니다.

    • 최신 데이터를 보조 데이터 연결 된 모든 외부 데이터 원본에서이 양식 서식 파일을 받으려면 모든 보조 데이터 원본 을 클릭 합니다.

    • 양식 서식 파일에 보조 데이터 연결을 사용 하는 한 외부 데이터 원본에서 최신 데이터를 받을 수 있는 단추를 구성 하려면 하나의 보조 데이터 연결 을 클릭합니다 한 다음 보조 데이터 원본 선택 보조 데이터 원본에서를 클릭합니다 목록입니다.

  10. 확인을 클릭하여 열린 대화 상자를 닫습니다.

  11. 변경 내용을 테스트하려면 표준 도구 모음에서 미리 보기를 클릭하거나 Ctrl+Shift+B를 누릅니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×