Excel, SQL Server, SharePoint 사이트 및 기타 외부 원본에서 데이터 가져오기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

신속 하 게 가져오고 수 Microsoft Office Visio Professional 2007 를 사용 하 여 도형에 직접 데이터를 표시 합니다. 드로잉으로 데이터 가져오기 및 데이터 원본에 연결 하는 첫 번째 단계가입니다. 가져온된 데이터를 셰이프에 연결 하는 두 번째 단계가입니다.

데이터를 가져오지 않고 데이터를 셰이프에 추가 하는 방법에 대 한 내용은 셰이프에 데이터 추가참조 합니다.

이 문서의 내용

1 단계: 데이터 가져오기

2 단계: 드로잉의 셰이프에 데이터 행 연결

1 단계: 데이터 가져오기

첫 번째 단계에서는 데이터 선택 마법사를 사용하여 데이터를 외부 데이터 창으로 가져옵니다.

외부 데이터 창에 표시 되는 데이터 원본 데이터의 스냅숏을 가져오는 시간입니다. 원본 데이터의 변경 내용과 일치 하도록 드로잉의 데이터를 업데이트할 수 있습니다. 그러나 드로잉에서 데이터를 변경 하 여 데이터 원본을 새로 고칠 수 없습니다. 가져온된 데이터 새로 고침을 참조 합니다.

  1. 데이터 메뉴에서 셰이프에 데이터 연결을 클릭합니다.

  2. 데이터 선택 마법사의 첫 번째 페이지에 표시되는 다음과 같은 데이터 원본 형식 중에서 사용할 형식을 선택합니다.

    • Microsoft Office Excel 통합 문서

    • Microsoft Office Access 데이터베이스

    • Microsoft Windows SharePoint Services 목록

    • Microsoft SQL Server 데이터베이스

    • 기타 OLEDB 또는 ODBC 데이터 원본

    • 이전에 만든 연결

  3. 마법사의 나머지 단계를 완료합니다.

    참고: 마법사의 첫 번째 페이지에서 Excel 통합 문서, Access 데이터베이스 또는 SharePoint 목록 이외의 다른 옵션을 선택하면 데이터 선택 마법사를 진행하는 도중에 일시적으로 데이터 연결 마법사가 나타날 수 있습니다.

    대부분의 마법사 페이지에서 특정 도움말을 사용할 수 있습니다. 도움말에 액세스하려면 F1 키를 누르거나 도움말 단추를 클릭합니다.

데이터 연결 마법사의 마지막 페이지에서 완료 를 클릭 한 후 외부 데이터 창이 나타나고 가져온된 데이터가 표에 표시 됩니다.

맨 위로 이동

2 단계: 드로잉의 셰이프에 데이터 행 연결

데이터 행을 드로잉의 셰이프에 연결하는 데는 세 가지 방법이 있습니다. 한 번에 하나씩 기존 셰이프에 행을 연결하거나, 셰이프에 행을 자동으로 연결하거나, 데이터를 사용하여 셰이프를 만들 수 있습니다.

한 번에 하나씩 기존 셰이프에 행 연결

이 방법은 셰이프 수가 비교적 적은 기존 드로잉에 사용하는 것이 가장 좋습니다.

  • 외부 데이터 창에서 드로잉의 셰이프로 행을 끌어 놓습니다.

    셰이프에 데이터가 나타나고 외부 데이터 창의 행 왼쪽에 연결 아이콘이 나타납니다.

    셰이프로 행 끌어다 놓기

    참고 사항: 

    • 행 하나를 여러 셰이프에 연결할 수는 있지만 여러 행을 셰이프 하나에 연결할 수는 없습니다.

    • 를 변경 하거나 셰이프 및 데이터의 모양을 개선 하려면 데이터 그래픽을 사용 하 여 데이터 개선을 참고 합니다.

    • 이때 외부 데이터 창을 표시하려면 보기 메뉴에서 외부 데이터 창을 클릭합니다.

기존 셰이프에 자동으로 행 연결

이 방법은 셰이프 수가 기존 드로잉에 가장 적합 합니다. 셰이프 데이터가 이미에 있는 데이터를 데이터 원본에 일치 시킬 수 있는 경우에 작동 합니다.

  1. 데이터 메뉴에서 자동으로 연결을 클릭합니다.

  2. 자동 연결 마법사의 단계를 따릅니다.

    셰이프에 데이터가 표시 됩니다. 를 변경 하거나 셰이프 및 데이터의 모양을 개선 하려면 데이터 그래픽을 사용 하 여 데이터 개선을 참고 합니다.

대부분의 마법사 페이지에서 관련 도움말을 볼 수 있습니다. 도움말을 보려면 F1 키를 누르거나 도움말 아이콘을 클릭합니다.

데이터를 사용하여 셰이프 만들기

이 방법은 드로잉에서 셰이프를 아직 없는 특정 셰이프를 사용 하 여 필요 하지 않은 경우에 가장 적합 합니다.

  1. 셰이프 창에서 셰이프를 클릭합니다.

  2. 행 또는 행 집합을 외부 데이터 창에서 드로잉의 빈 셰이프로 끌어 놓습니다.

    드로잉에 끌어 놓은 각 행에 대해 사용자가 클릭한 셰이프의 인스턴스 하나가 표시됩니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×