Excel, Access, SharePoint 사이트, SQL Server 및 기타 외부 원본에서 데이터 가져오기

참고: 사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서가 여기 있습니다.

Visio에서 셰이프에 직접 데이터를 빠르게 가져오고 표시할 수 있습니다. 첫 번째 단계는 데이터 원본에 연결 하 고 데이터를 드로잉으로 가져오는 것입니다. 두 번째 단계는 가져온 데이터를 셰이프에 연결 하는 것입니다.

1 단계: 데이터 가져오기

첫 번째 단계에서는 데이터 선택 마법사를 사용 하 여 데이터를 가져옵니다.

외부 데이터 창에 표시 되는 데이터는 가져올 때 원본 데이터의 스냅숏입니다. 원본 데이터의 변경 내용과 일치 하도록 드로잉의 데이터를 업데이트할 수 있습니다. 그러나 드로잉에서 데이터를 변경 하 여 데이터 원본을 새로 고칠 수는 없습니다. 가져온 데이터 새로 고침을 참고 하세요.

  1. 데이터 탭의 외부 데이터 그룹에서 셰이프에 데이터 연결을 클릭합니다.

  2. 데이터 선택 마법사의 첫 번째 페이지에서 다음 중 사용 하려는 데이터 원본 유형 중에서 선택 합니다.

    • Microsoft Excel 통합 문서

    • Microsoft Access 데이터베이스

    • Microsoft SharePoint Foundation 목록

    • Microsoft SQL Server 데이터베이스

    • 기타 OLEDB 또는 ODBC 데이터 원본

    • 이전에 만든 연결

  3. 마법사의 나머지 단계를 완료 합니다.

    참고: 마법사의 첫 페이지에서 Excel 통합 문서, Access 데이터베이스 또는 SharePoint 목록 이외의 옵션을 선택 하면 데이터 선택 마법사를 완료 하는 과정에서 데이터 연결 마법사가 일시적으로 전환 될 수 있습니다.

데이터 연결 마법사의 마지막 페이지에서 마침을 클릭 하면 외부 데이터 창이 나타나고 가져온 데이터가 표에 표시 됩니다.

2 단계: 드로잉의 셰이프에 데이터 행 연결

드로잉의 셰이프에 데이터 행을 연결 하는 방법에는 세 가지 방법이 있습니다. 한 번에 하나씩 기존 셰이프에 행을 연결할 수 있으며, 행을 셰이프에 자동으로 연결 하거나, 데이터에서 셰이프를 만들 수 있습니다.

방법 1: 한 번에 하나씩 기존 셰이프에 행 연결

이 방법은 비교적 소수의 도형이 있는 기존 그리기에 가장 적합 합니다.

  • 외부 데이터 창 에서 행을 끌어 드로잉의 셰이프 위에 놓습니다.

    참고: 외부 데이터 창이 표시 되지 않는 경우 데이터 탭으로 이동 하 고 표시/숨기기 그룹에서 외부 데이터 창옆에 있는 확인란을 선택 합니다.

    데이터는 셰이프에 표시 되 고 외부 데이터 창의행 왼쪽에 연결 아이콘이 나타납니다.

    셰이프로 행 끌어다 놓기

    참고 사항: 

    • 단일 행을 여러 도형에 연결할 수 있지만 한 도형에 여러 행을 연결할 수는 없습니다.

    • 도형 및 데이터의 모양을 변경 하거나 향상 하려면 데이터 그래픽을 사용 하 여 데이터 개선을참고 하세요.

    • 외부 데이터 창을 표시 하려면 보기 메뉴에서 외부 데이터 창을클릭 합니다.

방법 2: 기존 셰이프에 행을 자동으로 연결

이 방법은 셰이프가 많은 기존 드로잉에 가장 적합 합니다. 이 작업은 셰이프에 데이터 원본의 데이터와 일치 하는 데이터가 이미 있는 경우에만 사용할 수 있습니다.

  1. Visio 2016 이상 버전: 데이터 메뉴에서 모두 새로 고침을 클릭 하 고 새로 고침을 실행 한 후 자동 연결을 선택 합니다 (아직 선택 되지 않은 경우).

    Visio 2013 및 이전 버전: 데이터 메뉴에서 자동으로 연결을 클릭 합니다.

  2. 자동 연결 마법사의 단계를 따릅니다.

    셰이프에 데이터가 표시 됩니다. 도형 및 데이터의 모양을 변경 하거나 향상 하려면 데이터 그래픽을 사용 하 여 데이터 개선을참고 하세요.

방법 3: 데이터에서 셰이프 만들기

이 방법은 드로잉에 아직 셰이프가 없고 특정 셰이프를 사용할 필요가 없는 경우에 가장 적합 합니다.

  1. 셰이프 창에서 셰이프를 클릭 합니다.

  2. 외부 데이터 창에서 행 또는 행 집합을 드로잉의 빈 공간으로 끌어다 놓습니다.

    클릭 한 셰이프의 인스턴스가 드로잉으로 끌어다 놓은 각 행에 대해 나타납니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×