Excel에서 외부 데이터 연결 새로 고침

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Excel 통합 문서를 SQL Server 데이터베이스, OLAP 큐브 또는 다른 Excel 통합 문서와 같은 외부 데이터 원본에 연결할 수 있습니다. 이 연결은 통합 문서에 표, 피벗 테이블 보고서 또는 피벗 차트로 표시될 수 있습니다.

원본에 대한 링크를 "새로 고치면" 통합 문서의 데이터를 최신 상태로 유지할 수 있습니다. 연결을 새로 고칠 때마다 새로운 내용이나 삭제된 내용을 포함하여 최신의 데이터가 표시됩니다.

Microsoft Query, 데이터 연결 마법사 또는 웹 쿼리 데이터 새로 고침

  1. 범위 또는 표에서 외부 데이터에 대한 링크를 포함하는 임의의 셀을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭합니다.

    데이터 연결 새로 고침

  3. 선택한 데이터만 업데이트하려면 새로 고침을 클릭합니다.

    범위 또는 표에서 셀을 마우스 오른쪽 단추로 클릭하고 새로 고침을 클릭해도 됩니다.

  4. 통합 문서의 모든 데이터 연결을 업데이트하려면 모두 새로 고침을 클릭합니다.

    참고: 열려 있는 통합 문서가 여러 개이면 각 통합 문서에서 작업을 반복해야 합니다.

가져온 텍스트 파일의 데이터 새로 고침

  1. 범위 또는 표에서 가져온 텍스트 파일에 대한 링크를 포함하는 임의의 셀을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭합니다.

    데이터 연결 새로 고침

  3. 선택한 데이터만 업데이트하려면 새로 고침을 클릭합니다.

  4. 통합 문서의 모든 데이터 연결을 업데이트하려면 모두 새로 고침을 클릭합니다.

    범위 또는 표에서 셀을 마우스 오른쪽 단추로 클릭하고 새로 고침을 클릭해도 됩니다.

  5. 텍스트 파일 가져오기 대화 상자에서 텍스트 파일을 찾은 다음 가져오기를 클릭합니다.

파워 피벗 데이터 새로 고침

  1. 데이터 탭의 연결 그룹에서 연결을 클릭합니다.

    데이터 연결

  2. 통합 문서 연결 대화 상자에서 파워 피벗 데이터에 대한 연결을 선택한 다음 새로 고침을 클릭합니다.

오프라인 큐브 파일 새로 고침

오프라인 큐브 파일을 새로 고치면 서버 큐브의 최신 데이터를 사용하여 오프라인 큐브 파일이 다시 생성되기 때문에 시간이 오래 걸리고 임시 디스크 공간이 많이 필요할 수 있습니다. 따라서 이 작업은 Excel의 다른 파일을 바로 액세스하지 않아도 될 때 시작해야 하며, 파일을 다시 저장할 디스크 공간이 충분한지 확인해야 합니다.

  1. 오프라인 큐브 파일에 연결된 피벗 테이블을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭한 다음 새로 고침을 클릭합니다.

    데이터 연결 새로 고침

가져온 XML 파일의 데이터 새로 고침

  1. 워크시트에서 매핑된 셀을 클릭하여 새로 고칠 XML 맵을 선택합니다.

  2. 개발 도구 탭이 보이지 않으면 다음을 실행하여 표시합니다.

    1. 파일, 옵션을 차례로 클릭한 다음 리본 사용자 지정을 클릭합니다.

    2. 기본 탭에서 개발 도구 확인란을 선택한 다음 확인을 클릭합니다.

  3. 개발 도구 탭의 XML 그룹에서 데이터 새로 고침을 클릭합니다.

    XML 데이터 새로 고침

통합 문서를 열 때 자동으로 데이터 새로 고침

통합 문서를 열 때 외부 데이터 범위를 자동으로 새로 고칠 수 있습니다. 필요한 경우 파일의 크기를 줄이기 위해 외부 데이터를 저장하지 않고도 통합 문서를 저장할 수 있습니다.

  1. 외부 데이터 범위에서 셀을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭한 다음 연결 속성을 클릭합니다.

    연결 속성

  1. 사용 현황 탭을 클릭합니다.

  2. 새로 고침 옵션에서 파일을 열 때 데이터 새로 고침 확인란을 선택합니다.

  3. 외부 데이터는 제외하고 쿼리 정의와 함께 통합 문서를 저장하려면 외부 데이터 범위에서 데이터 제거 후 통합 문서 저장 확인란을 선택합니다.

규칙적인 간격으로 자동으로 데이터 새로 고침

  1. 외부 데이터 범위에서 셀을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭한 다음 연결 속성을 클릭합니다.

    연결 속성

  3. 사용 현황 탭을 클릭합니다.

  4. 다음 간격으로 새로 고침 확인란을 선택하고 새로 고침 작업을 실행할 간격을 분 단위로 입력합니다.

외부 데이터 범위를 새로 고칠 때 암호 요구

저장된 암호는 암호화되지 않으므로 사용하지 않는 것이 좋습니다. 데이터 원본 연결에 암호가 필요한 경우에는 사용자가 암호를 입력해야만 외부 데이터 범위를 새로 고칠 수 있도록 요구할 수 있습니다. 다음 절차는 텍스트 파일(.txt)이나 웹 쿼리(.iqy)에서 가져온 데이터에는 적용되지 않습니다.

대문자를 결합 하는 강력한 암호 및 소문자, 숫자 기호를 사용 합니다. 이러한 요소가 포함 되지 않은 암호입니다. 예를 들어 강력한 암호: Y6dh! et5 합니다. 약한 암호: House27 합니다. 암호 길이에 8 개 이상의 문자 이어야 합니다. 14 이상의 문자를 사용 하는 암호 구문을 더 좋습니다.

암호는 반드시 기억해야 합니다. 암호를 잊은 경우 Microsoft에서 사용자의 암호를 다시 찾을 수 없습니다. 따라서 암호를 따로 기록한 후 안전한 장소에 보관해 두세요.

  1. 외부 데이터 범위에서 셀을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭한 다음 연결 속성을 클릭합니다.

    연결 속성

  3. 정의 탭을 클릭한 다음 암호 저장 확인란의 선택을 취소합니다.

참고: 각 Excel 세션에서 외부 데이터 범위를 처음으로 새로 고칠 때만 암호를 입력하라는 메시지가 나타납니다. 이후 Excel을 시작할 때 쿼리가 있는 통합 문서를 열고 새로 고침 작업을 실행하려고 하면 암호를 입력하라는 메시지가 나타납니다.

쿼리를 백그라운드로 실행하거나 기다리는 동안 실행

매우 큰 데이터 집합의 경우 다른 작업하면서 새로 고침을 실행하는 것이 좋습니다. 이렇게 하면 새로 고침이 완료될 때까지 몇 분 이상을 기다릴 필요 없이 바로 Excel을 제어할 수 있습니다.

  1. 외부 데이터 범위에서 셀을 클릭합니다.

  2. 데이터 탭의 연결 그룹에서 모두 새로 고침을 클릭한 다음 연결 속성을 클릭합니다.

    연결 속성

    참고: OLAP 쿼리는 백그라운드에서 실행할 수 없습니다.

    참고: 데이터 모델에 대한 데이터를 검색하는 연결 형식에 대해서는 쿼리를 실행할 수 없습니다.

  3. 사용 현황 탭을 클릭합니다.

  4. 쿼리를 백그라운드에서 실행하려면 다른 작업하면서 새로 고침 확인란을 선택합니다. 쿼리가 실행되는 동안 기다리려면 이 확인란의 선택을 취소합니다.

    쿼리가 포함된 매크로를 기록하는 동안에는 쿼리가 백그라운드에서 실행되지 않습니다. 쿼리를 백그라운드에서 실행하도록 기록한 매크로를 변경하려면 Visual Basic Editor에서 매크로를 편집합니다. QueryTable 개체의 새로 고침 방법을 BackgroundQuery := False에서 BackgroundQuery := True로 변경합니다.

새로 고침 취소 또는 새로 고침 상태 확인

통합 문서가 대규모 데이터 원본에 연결되어 있는 경우 새로 고치는 데 예상보다 시간이 오래 걸릴 수 있습니다. 새로 고침을 확인하거나 취소하려면 다음 중 하나를 실행합니다.

  • 쿼리 상태 확인    쿼리가 실행 중임을 나타내는 메시지가 Excel 상태 표시줄에 나타납니다. 쿼리 상태를 확인하려면 메시지를 두 번 클릭합니다.

  • 다른 작업하면서 새로 고침 중지    백그라운드에서 실행 중인 쿼리를 중지하려면 상태 표시줄에서 쿼리 상태 메시지를 두 번 클릭하여 외부 데이터 새로 고침 상태 대화 상자를 연 다음 새로 고침 중지를 클릭합니다.

  • 쿼리 중지    다른 작업하면서 새로 고침을 해제한 상태에서 실행 중인 쿼리를 중지하려면 Esc 키를 누릅니다.

맨 위로 이동

관련 콘텐츠

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×