Access 2010의 기본 작업

참고: 사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서가 여기 있습니다.

다음은 Microsoft Access 2010 를 사용 하는 방법을 배울 수 있도록 하기 위해 수행할 수 있는 몇 가지 기본적인 데이터베이스 작업입니다.

 

이 문서의 내용

Access란?

Access에서 관계형 데이터베이스

Access를 열 때

Find and apply a template

처음부터 데이터베이스 새로 만들기

기존 Access 데이터베이스 열기

새 데이터베이스를 사용 하 여 시작

테이블 추가

Access 테이블에 다른 원본에서 데이터를 붙여 넣습니다.

가져오기 또는 다른 원본에서 데이터에 연결

다음 단계

스프레드시트 또는 다른 프로그램에서 데이터 가져오기

Excel 워크시트를 Access로 가져오기

Excel 워크시트에 새 데이터베이스의 테이블로 가져오기

테이블 분석 마법사를 사용 하 여 데이터를 구성 하려면

다른 프로그램에서 데이터 작업

여러 버전의 Access에서 데이터베이스를 이전 버전을 사용 하 여

여러 버전의 Access에서 Access 데이터베이스 파일 사용

1 단계: 기존 데이터베이스를 복사 하 고 새로운 형식으로 저장

2 단계: 복사 데이터베이스 분할 및 백 엔드 데이터베이스로 원본 파일 사용

3 단계: 새 연결 원본 데이터베이스를 프런트 엔드

프런트 엔드/백 엔드 응용 프로그램을 사용 하 여 여러 버전의 Access에서

Access란?

Access 2010 데이터베이스 응용 프로그램 디자인 및 배포 도구는 중요 한 정보를 추적 하는 데 사용할 수 있는입니다. 컴퓨터에서 데이터를 그대로 사용 하거나 웹에 게시할 수 등 다른 웹 브라우저와 데이터베이스를 사용할 수 있도록 합니다.

여러 사용자 작업에 대 한 추적 하 고 내용을 점진적으로 사용 하는 프로그램에 맞게 덜가 되 면 경우 Access를 사용 하 여 시작 합니다. 예를 들어 이벤트 플래너 되며 이벤트를 성공적으로 관리 하는 데 필요한 모든 정보를 추적 하려면 원하는 합니다. 이 작업을 수행 하려면 word 프로세서 또는 스프레드시트 프로그램을 사용 하는 경우에 문제가 있는 중복 및 일관성 없는 데이터를 쉽게 실행할 수 있습니다. 일정 관리 소프트웨어를 사용할 수 있지만 없는 좋은 맞게 달력의 금융 정보를 추적 합니다.

Access에서 관계형 데이터베이스

이러한 정보를 추적 하는 관계형 데이터베이스 고치-정보 (필드 라고 함)의 일반적인 비트를 기반으로 중복을 제거 하려면 작은 각종 데이터 (테이블)로 구분 되 고 서로 관련 된 데이터의 지식 저장소 . 예를 들어 고객 정보가 들어 있는 표, 공급 업체 정보를 사용 하 여 테이블 및 이벤트 정보로 표는 이벤트 관계형 데이터베이스 계획 포함 될 수 있습니다. 고객 테이블을 관계 필드와 공급 업체 테이블을 관계 필드 이벤트 정보가 포함 된 테이블이 있을 수 있습니다. 이 방법은 예를 들어 공급 업체의 전화 번호 변경 된 경우 정보 수으로 변경할 수 한 번 공급 업체 테이블에서 대신 공급 업체와 관련 된 모든 이벤트입니다.

액세스 정보를 관리할 수를 신속 하 게 사용할 수 있으며 쉽게 데 도움이 되는 관계형 데이터베이스 응용 프로그램을 개발 하는 도구입니다. 거의 모든 종류의 재고, 전문적인 연락처 또는 비즈니스 프로세스와 같은 정보를 추적 하는 데 도움이 데이터베이스를 만들 수 있습니다. 실제로 사용할 수 있는 즉시 다양 한 정보를 추적 한 기본 설명에 대해서도 가지 쉽게 서식 파일 액세스 제공 합니다.

Access를 열 때

Access 2010 을 시작 하면 Microsoft Office Backstage 보기, 갖춘 Office.com 의 콘텐츠 보기는 현재 데이터베이스에 대 한 정보, 새 데이터베이스 만들기, 기존 데이터베이스를 열 수 및 위치 표시 합니다.

Access 2010의 Backstage 보기

Backstage 보기에 조정, 유지 관리 하거나 데이터베이스를 공유 하는 데 사용할 수 있는 많은 명령을 포함 되어 있습니다. Backstage 보기의 명령을 안에 데이터베이스 개체를 아닌 전체 데이터베이스에 일반적으로 적용 됩니다.

참고: 파일 탭을 클릭 하 여 언제 든 지 Backstage 보기에 액세스할 수 있습니다.

맨 위로 이동

Find and apply a template

Access에서는 다양 한 속도 향상 시키기 위해 데이터베이스 만들기 프로세스를 사용할 수 있는 서식 파일을 제공 합니다. 서식 파일은 즉시 사용 하 여 데이터베이스의 테이블, 쿼리, 폼 및 보고서를 특정 작업을 수행 하는 데 필요한 모든 포함입니다. 예를 들어 문제를 추적 하거나, 연락처를 관리 하거나 경비의 기록을 유지 하려면 사용할 수 있는 서식 파일입니다. 일부 서식 파일 사용 방법을 보여 위해 몇 가지 예제 레코드가 포함 합니다. 데이터베이스 서식 파일을 사용 하는 그대로 하거나 사용자 지정할 수 있습니다에 맞게 필요 합니다.

찾아 데이터베이스에 서식 파일을 적용 하려면 다음을 실행 합니다.

  1. 파일 탭에서 새로 만들기를 클릭합니다.

  2. 사용 가능한 서식 파일다음 중 하나를 실행 합니다.

    • 최근에 사용한 서식 파일을 다시 사용 하려면 최근에 사용한 서식 파일을 클릭 한 다음 원하는 서식 파일을 선택 합니다.

    • 이미 설치 되어 있는 서식 파일을 사용 하려면 내 서식 파일을 클릭 한 다음 원하는 서식 파일을 선택 합니다.

    • Office.com, Office.com 서식 파일에서 서식 파일을 찾으려면 서식 파일 범주를 클릭 하 고 원하는 서식 파일을 선택 컴퓨터에 Office.com에서 서식 파일을 다운로드 하려면 다운로드 를 클릭 합니다.

      Access 내에서 Office.com의 서식 파일을 검색할 수도 있습니다. Office.com 서식 파일 검색 상자에 하나 이상의 검색어를 입력 한 다음 검색 하려면 화살표 단추를 클릭 합니다.

  3. 필요에 따라 데이터베이스를 만들 위치를 탐색 하려면 파일 이름 상자 옆에 있는 폴더 아이콘을 클릭 합니다. 특정 위치를 표시 되지 않는 경우 Access에서 파일 이름 상자 아래에 표시 되는 기본 위치에 데이터베이스를 만듭니다.

  4. 만들기를 클릭합니다.

Access 데이터베이스를 만들고 사용 하기 위해 엽니다.

맨 위로 이동

처음부터 데이터베이스 새로 만들기

Access 데이터베이스를 만드는 데 사용 하는 개념에 대 한 자세한 소개 데이터베이스 디자인의 기초문서를 참조 하세요.

사용자의 필요에 맞는 서식 파일이 없는 경우 Access에서 사용 하 여 원하는 다른 프로그램의 데이터가 있는 경우 결정할 수 있습니다를 처음부터 데이터베이스를 만드는 것이 좋습니다. Access 2010에서 선택할 수 있습니다: 표준 데스크톱 데이터베이스 또는 웹 데이터베이스입니다.

웹 데이터베이스에 대 한 자세한 내용은 웹에서 공유할 데이터베이스 작성문서를 참고 하세요.

새 데이터베이스를 만들려면 다음을 실행 합니다.

  1. Access를 시작 합니다.

  2. Backstage 보기의 새로 만들기 탭에서 새 데이터베이스 또는 새 웹 데이터베이스를 클릭 합니다.

    중요: 여기서는 항목은 데이터베이스에서 사용할 수 있는 기능을 결정 합니다. 데스크톱 데이터베이스를 웹에 게시할 수 없습니다 및 웹 데이터베이스 요약 쿼리 등 데스크톱 일부 기능을 지원 하지 않습니다.

  3. 오른쪽의 파일 이름 상자에 데이터베이스의 이름을 입력 합니다.

    파일을 만들 수 있는 위치를 변경 하려면 파일 이름 상자 옆에 있는 찾아보기 단추 이미지 클릭 이동 하 고 새 위치를 선택한 다음 확인을 클릭 합니다.

  4. 만들기를 클릭합니다.

    데이터베이스를 만들어져 데이터시트 보기 에서 빈 테이블 (표 1 이라는)를 엽니다.

  5. Access의 새 테이블 추가를 클릭 열에서 첫 번째 빈 셀에 커서를 놓습니다.

    데이터를 추가 하려면 입력을 시작-하거나이 문서의 뒷부분에 나오는 Access 테이블에 다른 원본에서 데이터를 붙여 넣을섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수 있습니다.

    참고 사항: 

    • 데이터 시트 보기에서 데이터를 입력 하도록 매우 유사 Excel 워크시트의 데이터를 입력 합니다. 주 제한은 연속 된 행과 열을 시작 하 고 데이터 시트의 왼쪽 위 모서리에 있는 데이터를 입력 해야 한다는 것입니다. 빈 행을 포함 하 여 데이터에 서식을 지정 하지 마십시오 또는 테이블에 공간이 낭비 됩니다 때문에 Excel 워크시트에서 열 때 수행할 수 있습니다. 표는 단순히 데이터가 들어 있습니다. 해당 데이터의 모든 시각적 프레젠테이션은 양식 및 보고서를 나중에 디자인에서 수행 됩니다.

    • 표 구조 데이터를 입력 하는 동안 만들어집니다. 데이터 시트에 새 열을 추가 하면 언제 든 지 새 필드를 테이블에 정의 되어 있습니다. 입력 하는 데이터 형식에 따라 필드의 데이터 형식 으로 설정 됩니다. 예를 들어 날짜 값만 입력 되어 있는 열이 있는 경우 Access가 해당 필드의 데이터 형식을 날짜/시간을 설정 합니다. 나중에 하려고 하면 해당 필드에 날짜가 아닌 값 (예: 이름 또는 전화 번호)를 입력 하는 경우 값 열의 데이터 형식과 일치 하지 않는 됨을 알리는 메시지가 표시 됩니다. 가능 하면 계획 해야 표의 각 열에 동일한 유형의 데이터를 포함 되도록 텍스트, 날짜, 숫자 또는 기타 형식 인지 합니다. 이렇게 하면 훨씬 더 쉽게 쿼리, 폼 및 원하는 데이터만 선택 하는 보고서를 작성할 수 있습니다.

아직 데이터를 입력 하려면 단추 이미지 닫기를클릭 합니다.

참고: Access 저장 하지 않고 닫은 경우 표 1 삭제 됩니다.

맨 위로 이동

기존 Access 데이터베이스 열기

팁: 메시지를 열고 파일 탭에서 사용 했던 마지막 여러 데이터베이스 중 하나를 빠르게 열려면 최근에 사용한 항목을 클릭 한 다음 파일 이름을 클릭 합니다.

  1. 파일 탭에서 열기를 클릭합니다.

  2. 열기 대화 상자에서 바로 가기를 클릭-하거나 찾는 위치 상자에서 원하는 데이터베이스가 있는 폴더나 드라이브를 클릭 합니다.

  3. 폴더 목록에서 데이터베이스 들어 있는 폴더를 열 때까지 폴더 두 번 클릭 합니다.

  4. 데이터베이스를 찾을 때 다음 중 하나를 수행 합니다.

    • 기본 열기 모드에서 데이터베이스를 열을 두 번 클릭 합니다.

    • 데이터베이스를 공유 권한 다중 사용자 환경에서 현재 사용자와 다른 사용자가 모두 읽고 쓸 수 있는 데이터베이스에 동시에 있도록를 열려면 열기를 클릭 합니다.

    • 데이터베이스의 읽기 전용 액세스를 볼 수 있지만 편집할 수 있도록 열려면 열기 단추 옆의 화살표를 클릭 하 고 읽기 전용으로 열기를 클릭 합니다.

    • 데이터베이스를 단독 액세스를 열어 놓은 동안 열 수 있는 다른 사람이 있도록 열려면 열기 단추 옆의 화살표를 클릭 한 다음 단독으로 열기를 클릭 합니다.

    • 읽기 전용 액세스 데이터베이스를 열려면 열기 단추 옆의 화살표를 클릭 하 고 단독 읽기 전용으로 열기 를 클릭 합니다 다른 사용자가 데이터베이스를 열 여전히 수 있지만 읽기 전용으로 액세스할 수만 있어야 합니다.

열려는 데이터베이스를 찾을 수 없는 경우    

  1. 열기 대화 상자에서 내 컴퓨터 바로 가기를 클릭-하거나 찾는 위치 상자에서 내 컴퓨터를 클릭 합니다.

  2. 드라이브 목록을 생각 하 고 드라이브를 마우스 오른쪽 단추로 데이터베이스를 포함 하 고 검색을 클릭 될 수 있습니다.

  3. 검색 조건을 입력 하 고 enter 키를 눌러 데이터베이스를 검색 합니다.

  4. 데이터베이스를 발견 하는 경우 검색 결과 대화 상자에서 두 번 클릭 하 여 엽니다.

    열기 대화 상자에서 검색 시작 되었으므로 눌러야 취소 대화 상자에서 데이터베이스를 열기 전에 합니다.

외부 파일 형식 (예: dBASE, Paradox, Microsoft Exchange 또는 Excel)에서 데이터 파일을 직접 열 수 있습니다. 모든 ODBC 데이터 원본, Microsoft SQL Server 또는 Microsoft FoxPro 같은 직접 열 수 있습니다. 자동으로 새 Access 데이터베이스를 데이터 파일로 같은 폴더에 만들어져 외부 데이터베이스의 각 테이블에 대 한 링크를 추가 합니다.

맨 위로 이동

새 데이터베이스를 사용 하 여 시작

사용 하는 서식 파일에 따라 새 데이터베이스를 시작 하려면 다음 중 하나 이상을 수행 해야 할 수 있습니다.

  • Access 사용자 목록이 비어 있는 로그인 대화 상자를 표시 되 면 시작 하려면 다음 절차를 따르십시오.

    1. 새 사용자를 클릭 합니다.

    2. 사용자 정보 양식에 정보를 입력 합니다.

    3. 저장 후 닫기를 클릭합니다.

    4. 방금 입력 한 사용자 이름을 선택한 다음 로그인을 클릭 합니다.

  • Access 빈 데이터 시트를 표시 하는 경우에 해당 데이터 시트에 직접 데이터 입력을 시작 하거나 다른 단추 및 데이터베이스를 탐색 하려면 탭을 클릭 수 있습니다.

  • Access 시작 페이지가 표시 되는 경우 데이터베이스에 대 한 자세한 내용을 보려면 해당 페이지의 링크를 누르거나 다른 단추 및 데이터베이스를 탐색 하려면 탭을 클릭 합니다.

  • Access 메시지 표시줄에 보안 경고 메시지가 표시 서식 파일의 원본을 신뢰할 수 콘텐츠 사용을 클릭 합니다. 데이터베이스에 로그인을 사용 해야 하는 경우 다시 로그인 해야 합니다.

데스크톱 및 웹 데이터베이스에 대 한도 원하는 시작 해 방법을 다음 중 하나:

맨 위로 이동

테이블 추가

만들기 탭의 그룹에서 도구를 사용 하 여 기존 데이터베이스에 새 테이블을 추가할 수 있습니다.

만들기 탭의 테이블 그룹

참고: 웹 데이터베이스에서 테이블 명령을의 그룹에서 사용할 수 있는 경우

시작 하는 보기에 관계 없이 전환할 수 있습니다 언제 든 지 다른 보기로 Access 창의 상태 표시줄에 있는 보기 단추를 사용 하 여.

데이터 시트 보기에서 빈 테이블 만들기    데이터 시트 보기에서 바로 데이터를 입력 한 액세스 하 여 문서의 표 구조를 만들 수 있습니다. (Field1, Field2, 및 등) 필드 이름은 숫자로 지정 되 고 입력 하는 데이터 형식에 따라 필드 데이터 형식으로 설정 됩니다.

  1. 만들기 탭의 그룹에서 단추 이미지 를 클릭 합니다.

  2. 표를 만들어져 추가를 클릭 하 여 열에서 첫 번째 빈 셀에 커서를 놓습니다.

  3. 데이터를 추가 하려면 첫 번째 빈 셀에 입력을 시작-하거나이 문서의 뒷부분에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수 있습니다.

    • 열 (필드)의 이름을 바꾸려면 열 머리글을 두 번 클릭 한 다음 새 이름을 입력 합니다.

      팁: 포함 된 데이터를 확인 하려면 필요 없이 알 수 있도록 각 필드에 의미 있는 이름을 지정 합니다.

    • 열을 이동 하려면 해당 열 머리글을 클릭 하 여 선택 하 고 원하는 위치로 끌어 놓습니다. 여러 개의 인접 한 열을 선택 하 고 함께 모든 새 위치로 끕니다 수도 있습니다.

      필드를 추가 하려면 더 많은 테이블을 데이터 시트 보기에서 추가 하려면 클릭 열에 입력을 시작 하거나 또는 필드 탭의 추가 & 삭제 그룹의 명령을 사용 하 여 새 필드를 추가할 수 있습니다.

디자인 보기에서 시작 테이블 만들기    디자인 보기에서 먼저 새 테이블의 구조를 만듭니다. 다음 중 하나 보기로 전환 하면 데이터 시트, 데이터 입력 하거나 폼과 같은 몇 가지 다른 방법을 사용 하 여 데이터를 입력 합니다.

디자인 보기는 웹 데이터베이스의 테이블에서에서 사용할 수 없습니다.

  1. 만들기 탭의 테이블 그룹에서 테이블 디자인을 클릭합니다. 단추 이미지

  2. 테이블에서 각 필드에 대 한 필드 이름 열에 이름을 입력 하 고 데이터 형식 목록에서 데이터 형식을 선택 합니다.

  3. 설명 열에서 각 필드에 대 한 추가 정보를 입력할 수 있습니다. 삽입 포인터를 해당 필드에는 필드 목록 창에서 폼 이나 보고서에 필드를 끌어 만든 컨트롤에 대 한 상태 표시줄 텍스트로 사용 때 설명은 입력 하는 상태 표시줄에 표시 된 및 폼 마법사 또는 보고서 마법사에서 해당 필드에 대해 만든 컨트롤에 대 한 합니다.

  4. 모든 필드를 추가한 후 테이블을 저장 합니다.

    • 파일 탭에서 저장을 클릭합니다.

  5. 데이터 시트 보기로 전환 하는 첫 번째 빈 셀을 클릭 하 고 입력 언제 든 지 테이블에 데이터 입력을 시작할 수 있습니다. 다음 섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수도 있습니다.

SharePoint 목록에 따라 테이블 만들기    SharePoint 목록을 사용 하 여 데이터에 액세스 권한이 없는 사용자가 사용할 수 있습니다. 또한 목록 데이터는 일반적으로 데스크톱 컴퓨터에 저장 된 파일을 보다 데이터 손실에 대해 더 나은 보호 기능을 제공 하는 서버에 저장 됩니다. 새 목록 사용 하 여 시작 하거나 기존 목록에 연결할 수 있습니다. 목록, 만들려는 SharePoint 사이트에서 충분 한 권한이 있어야 합니다. 사이트 문의 옵션에 대 한 세부 정보 SharePoint 관리자에 게 문의 하 여 다를 수 있습니다.

이 기능은 웹 데이터베이스에서 사용할 수 없습니다.

  1. 만들기 탭의 테이블 그룹에서 SharePoint 목록을 클릭합니다.

  2. 연락처 또는 이벤트와 같은 표준 SharePoint 목록을 만들려면 목록 서식 파일 중 하나를 사용할 수 있습니다.

    사용자 지정 목록 만들기 또는 연결 하거나 기존 목록을 가져올를 선택할 수 있습니다. 원하는 옵션을 클릭합니다.

  3. 목록 서식 파일 중 하나를 선택할 경우 사용자 지정 목록을 만들려면 프로세스를 안내 하는 새 목록 만들기 대화 상자가 열립니다. 기존 목록 사용을 선택 하기 위해 외부 데이터 가져오기 대화 상자가 열립니다.

테이블에 대한 자세한 내용은 Introduction to tables(테이블 소개) 문서를 참조하세요.

맨 위로 이동

Access 테이블에 다른 원본에서 데이터를 붙여 넣습니다.

데이터에 현재 Excel과 같은 다른 프로그램에 저장 되어 복사 하 Access 테이블에 데이터를 붙여 넣습니다. 일반적으로이 작업은 데이터 열을 분할할 이미 Excel 워크시트에 있는. 데이터가 word 처리 프로그램 경우 먼저 탭을 사용 하 여 데이터의 열을 구분 해야 하거나 워드 프로세서 프로그램의 테이블로 데이터를 변환 및 데이터를 복사 합니다. 데이터 편집 또는 조작 (예를 들어 구분 전체 이름 이름과 성으로)을 필요한 경우이 작업을 수행 데이터를 복사 하기 전에 Access에 잘 알고 있다면 하는 경우에 특히 좋습니다.

빈 테이블에 데이터를 붙여 넣으면 Access 데이터의 종류 찾는다는 점을 있는지에 따라 각 필드의 데이터 형식을 설정 합니다. 예를 들어 붙여 넣은 필드 날짜 값만 포함, Access에서 날짜/시간 데이터 적용 해당 필드에 입력 합니다. 붙여 넣은 필드에 단어 "예"와 "없음", Access에서 예를 적용/데이터가 없는 필드에 입력 합니다.

Access 발견 붙여 넣은 데이터의 첫 번째 행에서에 따라 필드의 이름을 지정 합니다. 붙여 넣은 데이터의 첫 번째 행을 따라 행 글꼴로 유사한 경우 첫 번째 행 데이터의 일부 이며 (Field1, Field2, 등에) 일반 이름이 필드가 지정 액세스 결정 합니다. 붙여 넣은 데이터의 첫 번째 행을 팔 로우 하는 행에 비슷하지 없는 경우 Access 필드 이름으로 첫 번째 행을 사용 하 고 실제 데이터에 첫 번째 행 제외 합니다.

Access에서 일반적인 필드 이름이 할당을 혼동을 방지 하려면 가능한 한 빨리 필드 바꿔야 합니다. 다음 절차를 사용합니다.

  1. 파일 탭에서 테이블을 저장 하려면 저장 을 클릭 합니다.

  2. 데이터 시트 보기에서 각 열 머리글을 두 번 클릭 한 다음 열에 대 한 이름을 입력 합니다.

  3. 테이블을 다시 저장 합니다.

맨 위로 이동

가져오기 또는 다른 원본에서 데이터에 연결

Access에서 사용 하 여 원하는 다른 프로그램에서 수집한 후 데이터를 할 수도 있습니다. 다른 프로그램에서 해당 데이터를 저장 하는 사람과 작업: 품목이 Access에서 해당 데이터를 사용 하려고 합니다. 또는 미정 여러 서로 다른 원본의 데이터를 있으며 필요를 가져올 수 있습니다 모두 함께 보다 세부적으로 분석에 대 한 "방문 패드"입니다.

Access로 쉽게 가져오거나 다른 프로그램에서 데이터를 연결 합니다. Excel 워크시트, 다른 Access 데이터베이스에서 테이블, SharePoint 목록 또는 다양 한 다른 원본에서 데이터를 가져올 수 있습니다. 프로세스 약간 데이터 원본에 따라 다르지만 다음이 지침 시작할 수 있습니다.

  1. 외부 데이터 탭의 가져오기 & 링크 그룹에서 가져올 파일 형식에 대 한 명령을 클릭 합니다.

    예를 들어 Excel 워크시트에서 데이터를 가져오는 경우 Excel을 클릭 합니다. 올바른 프로그램 종류가 보이지 않으면 자세히를 클릭 합니다.

    참고: 가져오기 & 링크 그룹에서 올바른 형식을 찾을 수 없는 경우에는 원래 데이터를가 만든 프로그램을 시작 하 고 다음 해당 프로그램을 사용 하 여 데이터 (예: 분리된 텍스트 파일 ) Access에서 지 원하는 파일 형식으로 저장 해야 할 수 있습니다. 후 가져오거나 데이터에 연결 합니다.

  2. 외부 데이터 가져오기 대화 상자에서 원본 데이터 파일을 찾아를 찾아 클릭 하거나 파일 이름 상자에 원본 데이터 파일의 전체 경로 입력 합니다.

  3. 현재 데이터베이스에서 데이터를 저장 하는 방법과 위치를 지정아래에서 원하는 옵션을 클릭 합니다. 가져온된 데이터를 사용 하 여 새 테이블을 만들 수도 있고 데이터 원본에 대 한 링크를 유지 하는 연결 된 테이블을 만들 수 있습니다.

  4. 확인을 클릭합니다.

    선택한 항목, 링크 개체 대화 상자 또는 개체 가져오기에 따라 대화 상자가 열립니다.

  5. 대화 상자를 사용 하 여 프로세스를 완료 합니다. 팔 로우 하는 정확한 절차는 선택한 가져오기 또는 연결 옵션에 따라 다릅니다.

  6. 마법사의 마지막 페이지에서 마침을 클릭합니다.

    가져오도록 선택한 경우 방금 완료 된 가져오기 작업의 세부 정보를 저장할 것인지 여부를 묻는 메시지가 나타납니다.

  7. 실행 해야 할 것으로 생각 경우 동일한 가져오기 작업을 다시, 가져오기 단계 저장을 클릭 한 다음 세부 정보를 입력 합니다.

    그런 다음 가져오기 작업 외부 데이터 탭의 가져오기 그룹에서 저장 된 데이터 가져오기를 클릭 하 여, 가져오기 설정을 클릭 한 다음 실행을 클릭 하 여 쉽게 재현할 수 있습니다.

  8. 작업의 세부 정보를 저장 하지 않으려면 닫기를 클릭 합니다.

Access에서 데이터를 새 테이블에 가져온 한 다음 탐색 창에서 테이블 에서 테이블을 표시 합니다.

Access로 데이터를 가져오는 방법에 대 한 자세한 내용은이 문서의 참고 항목 섹션의 링크를 따릅니다.

맨 위로 이동

다음 단계

디자인 프로세스의 나머지 사용자 목표에 따라 달라 집니다를 사용할 수도 있지만 해야 쿼리, 폼, 보고서 및 매크로 만드는 것이 좋습니다. 이 문서는 추가 데이터베이스 개체를 만드는 방법에 대 한 정보를 제공 하지 않습니다.

자세한 내용은 다음이 문서를 참고 합니다.

맨 위로 이동

스프레드시트 또는 다른 프로그램에서 데이터 가져오기

다른 데이터베이스 또는 스프레드시트 프로그램에 익숙한 경우 다음과 같은 응용이 프로그램 작동 및 데이터베이스에 사용 되는 기본 사항을 파악 합니다. 관계형 데이터베이스를 만들 수 있도록 함으로써 여러 다른 데이터베이스 응용 프로그램에서와 다른 access와는 더 이상 다릅니다 대부분 스프레드시트 프로그램 정교한 쿼리, 폼 및 보고서 개발을 위한 도구를 제공 하 여 합니다. Access는 SQL Server 등의 다른 데이터베이스 프로그램을 사용 하기 위한 다양 한 옵션을 제공 합니다.

Excel 워크시트를 Access로 가져오기

많은 사람들이 첫 번째 Excel에서 목록을 만드는 후 Access 탐색 하기 시작 합니다. Excel에는 목록, 시작 하지만 목록 커지면서 언어가 구성 하 고 업데이트 된 상태로 유지 하기 어렵습니다. 목록에 액세스 하려면 이동은 일반적으로 다음 논리적 단계입니다.

데이터베이스 테이블이 비슷합니다 구조에서 워크시트를 해당 데이터 행과 열에 저장 됩니다. 따라서 일반적으로 쉽게 데이터베이스 테이블에 워크시트를 가져올 수입니다. 주요 차이점 워크시트에서 데이터를 저장 하 고 데이터베이스에 저장 된 데이터 구성 방법에입니다. 데이터베이스의 새 테이블로 전체 워크시트를 가져오는 단순히 워크시트에 중복 데이터를 포함 하는 경우에 특히 구성 및 업데이트 하 여 데이터와 관련 된 문제가 해결 되지 않습니다. 이러한 문제를 해결 하기 위해 분할 해야 스프레드시트 데이터 개별 테이블로 각 하나 관련된 데이터를 포함 합니다. 테이블에 데이터를 정렬 하는 방법에 대 한 자세한 내용은 데이터베이스 디자인의 기초문서를 참고 하세요.

이 과정을 완료 하는 데 도움이 되는 테이블 분석 마법사 기능에 액세스 합니다. 테이블에 데이터를 가져온 후 마법사는 다른 테이블에서 중복 되지 않은 데이터를 포함 되는 개별 테이블로 분할 하는 수 있습니다. 또한 마법사는 테이블 간의 관계를 만듭니다.

맨 위로 이동

Excel 워크시트에 새 데이터베이스의 테이블로 가져오기

  1. 파일 탭에서 새로만들기를 클릭 한 다음 새 데이터베이스를 클릭 합니다.

  2. 파일 이름 상자에 새 데이터베이스의 이름을 입력 한 다음 만들기를 클릭 합니다.

    새 데이터베이스 열리고 비어 있는 새 테이블이 표 1 만들어집니다.

  3. 표 1을 닫습니다.

    표 1의 디자인 변경 내용을 저장 하려면을 묻는 메시지가 나타나면 아니요를 클릭 합니다.

  4. 외부 데이터 탭의 가져오기 & 링크 그룹에서 Excel을 클릭 합니다. 단추 이미지

  5. 외부 데이터 가져오기 대화 상자에서 찾아보기를클릭 합니다.

  6. 파일 열기 대화 상자를 사용 하 여 파일을 찾습니다.

  7. 파일을 선택한 다음 열기를 클릭합니다.

  8. 외부 데이터 가져오기 대화 상자에서 현재 데이터베이스의 새 테이블로 원본 데이터 가져오기 옵션이 선택 되어 있는지 확인 합니다.

  9. 확인을 클릭합니다.

    스프레드시트 가져오기 마법사를 시작 하 고 데이터에 대 한 몇 가지 질문에 메시지가 표시 됩니다.

  10. 다음 뒤로 또는 페이지 사이 이동 하려면을 클릭 하 고 화면의 지시를 따릅니다. 마법사의 마지막 페이지에서 마침을 클릭합니다.

    참고: 방금 완료 된 가져오기 작업의 세부 정보를 저장할 것인지 여부를 묻는 메시지가 나타납니다. 실행 해야 할 것으로 생각 경우 동일한 가져오기 작업을 다시, 를 클릭 하 고 세부 정보를 입력 합니다. 다음 작업을 나중에 외부 데이터 탭의 가져오기 그룹에서 저장 된 데이터 가져오기를 클릭 하 여 쉽게 재현할 수 있습니다. 작업의 세부 정보를 저장 하지 않으려면 닫기를 클릭 합니다.

Access에서 데이터를 새 테이블에 가져온 다음 탐색 창에서 모든 테이블 표시 합니다.

맨 위로 이동

테이블 분석 마법사를 사용 하 여 데이터를 구성 하려면

Access 테이블에 데이터를 가져온 후 중복 데이터를 신속 하 게 식별 하는 테이블 분석 마법사를 사용할 수 있습니다. 마법사의 개별 테이블로 데이터를 구성 하 고, 가장 효율적으로에 저장할 수 있도록 하는 간단한 방법을 제공 합니다. Access는 원래 테이블을 백업으로 유지 하 고 데이터베이스 응용 프로그램의 기준으로 사용할 수 있는 새 테이블을 만듭니다.

  1. 분석할 테이블이 포함 된 Access 데이터베이스를 엽니다.

  2. 데이터베이스 도구 탭의 분석 그룹에서 분석 표를 클릭 합니다.

    테이블 분석 마법사가 시작 됩니다.

    마법사의 처음 두 페이지에 대 한 간단한 자습서 포함-완성 된 예제를 보려면 클릭할 수 있는 단추가 있습니다. 안내 페이지 표시 되지 않지만 대신 이라는 확인란을 참조 하는 경우 안내 페이지 표시?확인란을 선택한 다음 다시 소개를 참조를 두 번 클릭 합니다. 페이지를 보려면 소개 소개 내용을 읽은 후에 다시 않으려면를 지울 수 있습니다를 안내 페이지 표시? 확인란 합니다.

  3. 여러 레코드에서 반복 되는 값이 있는 필드가 포함 된 테이블? 페이지, 분석, 테이블을 선택 하 고 다음을 클릭 합니다.

  4. 어떤 테이블에 필드 이동 결정 마법사 하거나 결정을 직접 만들 수 있습니다. 마법사의 추천 단어를 수행 하는 경우 마법사의 다음 페이지에서 표 레이아웃으로 변경 내용을 만들 수 있습니다.

    참고: 마법사가 테이블에 배치 하려면 필드를 결정할 수 있도록 하는 경우 해당 선택 항상 수도 많은 데이터 작업에 없는 경우에 특히 데이터에 적합 한. 마법사의 결과 주의 깊게 확인 해야 합니다. 반면에 마법사 적어도 마법사의 의사 결정을 한 번 시도 하는 것이 좋습니다 되므로, 생각 하는 항목 보다 효율적으로 조직을 것이 좋습니다 될 수 있습니다. 제안 내용이 마음에 들지 않으면 수동으로 필드를 다시 정렬할 수 및 언제 든 지 뒤로 클릭 하 고 직접 모든 필드를 정렬할 수 있습니다.

  5. 다음을 클릭합니다. 이 페이지에서는 테이블 포함할 필드 지정 합니다. 결정 하도록 선택한 경우 여러 테이블 관계 선으로 연결 되어 표시 됩니다. 그렇지 않은 경우 모든 필드가 포함 된 테이블을 하나만 만들어집니다. 두 경우 모두이 페이지에서 변경할 수 있습니다.

    • 테이블에서 해당 필드가 포함 된 새 테이블 만들기 페이지의 빈 영역으로 필드를 끌 수 있습니다. Access는 테이블 이름에 대 한 표시 됩니다.

    • 가 저장 될 보다 효율적으로 생각 되는 경우 다른 테이블에 한 테이블의 필드를 끌 수 있습니다.

    • 대부분의 테이블 ID 또는 생성 된 고유 ID 필드 제공 됩니다. ID 필드에 대 한 자세한 마법사의 오른쪽 위 모서리에서 클릭 합니다.

    • 변경 내용 취소 하려면 실행 취소 단추를 클릭 합니다.

    • 테이블의 이름을 바꾸려면 제목 표시줄을 두 번 클릭의 새 이름을 입력 한 다음 확인을 클릭 합니다.

  6. 필드를 원하는 방식으로 정렬 된를 만든 후 다음을 클릭 합니다.

  7. 마법사에서 매우 유사한 값이 포함 된 레코드를 찾으면 가능한 오타가으로 해당 값을 식별 하 고 사람들에 대해 수행할 작업을 확인할 수 있는 화면이 표시 됩니다. 찾고 수정 열에서 값이 있는 드롭다운 목록에서 해당 항목을 클릭 한 다음 목록을 스크롤하십시오. 선택 (그대로-은) 마법사의 값을 변경 하지 못하도록 합니다. 완료 되 면 다음을 클릭 합니다.

  8. 마법사의 원본 테이블과 비슷한 쿼리를 만드는 데 사용할 여부를 지정 합니다. 폼과 보고서 원본 테이블을 기반으로 하는 이미 작성 된 경우 이러한 쿼리를 만드는 것이 좋습니다. 예, 쿼리 만들기를 선택 하면 마법사 원래 테이블 테이블 이름에 "_old"으로 바꾸고 원래 테이블의 이름을 사용 하 여 새 쿼리 이름을 지정 합니다. 양식 및 보고서 이제 테이블에 기반한를 해당 데이터에 대 한 쿼리를 사용 하 고 이전 처럼 작동을 계속 합니다.

  9. 마침을 클릭합니다.

    마법사에 설명 된 대로 새 테이블이 만들어지고 열립니다. 검사 결과 마치면 닫습니다.

맨 위로 이동

다른 프로그램에서 데이터 작업

Access 2010에서는 다른 프로그램에 저장 된 데이터로 작업 하기 위한 기능을 제공 합니다.

다른 파일 형식으로 데이터에 연결 하는 새 Access 데이터베이스 만들기    텍스트나 dBASE, 스프레드시트와 같은 다른 파일 형식으로 파일을 열에 대 한 액세스를 사용할 수 있습니다. 자동으로 Access 데이터베이스 만들어져 하면 파일에 연결 합니다.

  1. Access를 시작 합니다.

  2. 파일 탭에서 열기를 클릭합니다.

  3. 열기 대화 상자에서 목록에서 열려는 파일 형식을 클릭 합니다. 파일 유형을 확실히 알지 못하는 경우 클릭 모든 파일 (*. *)합니다.

  4. 필요한 경우 열려는 파일이 포함 된 폴더로 이동 합니다. 파일을 찾을 때 열을 두 번 클릭 합니다.

  5. 마법사의 지시를 따릅니다. 마법사의 마지막 페이지에서 마침을 클릭합니다.

기존 Access 데이터베이스로 데이터 가져오기 또는 연결    Access 파일 내 데이터에 포함 하거나 연결할 수 있습니다 데이터를 Access에서 Access 파일) (외부 원본 파일의 데이터가 하 게 유지 되도록 되도록 Access 테이블에 다른 원본 및 프로그램에서 데이터 가져오기 중 하나입니다.

  1. 외부 데이터 탭의 가져오기 & 링크 그룹에서 데이터 저장 된 형식을 클릭 합니다.

    가져오기 또는 다음 원본에서 데이터를 연결 수 있습니다.

    • Excel    워크시트 또는 Excel 통합 문서에서 명명된 된 범위에서 데이터를 가져올 수 있습니다. 각 워크시트 또는 명명 된 범위를 가져온 하거나 별도로 연결 해야 합니다.

    • Access    분할 데이터베이스를 만드는 데이터에서 프로세스를 구분 하는 경우 매우 유용 합니다. 즉, 모든 폼, 보고서 및 매크로 포함 하도록 하나의 데이터베이스를 사용할 수 있으며 다른 데이터베이스에 데이터를 유지. 그런 다음 누군가의 작업을 중단 없이 향상 된 기능을 개발할 수 있습니다. 하나를 손쉽게 데이터를 요약 하 부서 또는 비즈니스 파트너 사이 여러 다른 Access 데이터베이스에서 데이터를 결합할 수 있습니다.

    • ODBC 데이터베이스    많은 프로그램 많은 데이터베이스 서버 제품을 포함 하 여이 형식에서 지원 됩니다. 이렇게 하면 서로 다른 시스템에서 데이터를 결합 하면 "방문 패드" 데이터베이스를 만들 수 있습니다.

    • 텍스트 파일    간단한 텍스트 파일에 연결할 수 있으며 해당 파일의 내용을 변경 하려면 Access 사용할 수도 있습니다. 데이터에 액세스 하는 다양 한 프로그램에서 사용 하기 쉬운 확인 하는 데 도움이 됩니다.

    • XML 파일    또한이 형식 일부 웹 서버를 포함 하 여 다른 프로그램의 다양 한와의 호환성을 제공 합니다.

    • SharePoint 목록    이렇게 하면 데이터를 웹 브라우저에서 SharePoint 목록을 사용 하 여 표준 방식으로 사용할 수 없습니다.

    • 데이터 서비스    회사 내부 웹 데이터 서비스에 연결할 수 있습니다.

    • HTML 문서    

    • Outlook 폴더    데이터의 나머지 부분과 연락처 정보를 보다 쉽게 통합 되므로 Outlook 폴더에 연결할 수 있습니다.

    • dBase 파일    dBase은 Access에서 지원 되는 인기 대체 데이터베이스 시스템

      외부 데이터 가져오기 대화 상자가 나타납니다.

  2. 대화 상자에서 지침을 따릅니다.

    Access 가져오거나 데이터베이스에 연결 됩니다. 대부분의 형식에 대 한 데이터의 위치를 지정 하 고 원하는 데이터베이스에 저장 될 데이터를 선택 합니다.

맨 위로 이동

여러 버전의 Access에서 데이터베이스를 이전 버전을 사용 하 여

Access 데이터베이스 또는 Access 프로젝트 Access 2000 이상에서 만든 데이터베이스 또는 프로젝트 버전의 Access에서 만들어진 또는 그 이상 버전에서 사용할 수 등의 파일 보안 기능을 사용할 경우에 있습니다. 예를 들어, Access 2000 파일 Access 2000, Access 2002, Access 2003, Access 2007과 Access 2010에서 사용할 수 있습니다.

이전 버전의 Access에서 데이터를 유지 하려고 하는데 해당 데이터에 연결 되지만 여전히 활용 이후 버전의 기능 중 일부를 최신 버전의 Access에서 사용자가 있는 상황을 할 수 있습니다. 솔루션 (폼, 보고서, 쿼리, 매크로, 하지만 테이블이 포함) 이상 버전에서 새 "프런트 엔드" 데이터베이스를 만들고 이전 버전 파일의 테이블에 연결 하는 것입니다. 데이터베이스 파일 하나에 포함 되어 있는지 아니면 프런트 엔드/백 엔드 응용 프로그램 으로 분할 이미 있는지 여부에 따라 다음 절차 중 하나를 사용 합니다.

여러 버전의 Access에서 Access 데이터베이스 파일 사용

모든 테이블, 폼 및 기타 개체에 이전 버전의 Access 데이터베이스의 한 파일에 포함 된 여러 버전의 Access에서 데이터베이스를 사용 하려는 경우 이후 버전에서 새 프런트 엔드 데이터베이스를 만들 수 있으며 원본 파일에 연결. 사용자가 이전 버전의 Access 원래 데이터베이스를 사용할 수 있습니다. 이후 버전 수 있는 사용자 동일한 데이터에 연결 하려면 새 프런트 엔드 데이터베이스를 사용할 수 있습니다. 여러 버전의 Access에 맞게 해야 할 경우 여러 개의 프런트 엔드 버전을 만들 수 있습니다.

맨 위로 이동

1 단계: 기존 데이터베이스를 복사 하 고 새로운 형식으로 저장

세 가지 최신 형식으로 된 데이터베이스를 변환 하려면 다음 절차를 사용 하 여: Access 2000, Access 2002-2003 또는 Access 2007 합니다. 이 명령은 원래 형식, 원본 데이터베이스를 유지 하 고 지정 된 형식으로 복사본을 만듭니다.

  1. Access 파일을 닫습니다. 공유 폴더에서 서버에 있는 다중 사용자 Access 데이터베이스 파일이 있는 경우 열려 있는 다른 사용자를 확인 합니다.

  2. Access 2010을 시작 합니다.

  3. 파일 탭에서 열기를 클릭합니다.

  4. 변환할 파일의 위치를 찾아 두 번 클릭 하 여 엽니다.

    데이터베이스 기능 향상 대화 상자가 나타나면 데이터베이스를 향상 시키기 위해 저장할지 묻는 아니요를 클릭 합니다.

  5. 폼의 데이터베이스를 시작할 때를 열면 폼을 닫습니다.

  6. 파일 탭에서 다른 이름으로 데이터베이스 저장을 클릭 합니다.

  7. 다른 이름으로 저장 대화 상자에서 새 데이터베이스의 이름을 입력 합니다.

    참고: 새 데이터베이스를 다른 위치를 저장 하는 경우가 아니면 해당 이름을 원래 데이터베이스의 것과 다른 여야 합니다. 두 경우 모두 됩니다 프런트 엔드 데이터베이스와 백 엔드 데이터베이스 간의 쉽게 구분할 수 있도록 다른 이름으로 사용 하는 것이 좋습니다. 그러나 Access 2007 형식으로 변환 하는 경우 파일 이름 확장명에서에서 변경.mdb.accdb에 같은 이름의 파일을 사용할 수 있도록 합니다.

  8. 저장을 클릭합니다.

맨 위로 이동

2 단계: 복사 데이터베이스 분할 및 백 엔드 데이터베이스로 원본 파일 사용

다음 절차를 사용 하 여 변환 된 데이터베이스를 분할 합니다.

  • 데이터베이스 도구 탭의 데이터 이동 그룹에서 Access 데이터베이스를 클릭 합니다. 단추 이미지

  • 데이터베이스 분할 대화 상자에서 클릭 데이터베이스 분할.

    원하는 있지만 원래 데이터베이스를 사용 하 여 복사본을 다시 만드는 해도 설치할 수 있는 경우 백업을 만들 수 있습니다.

  • 백 엔드 데이터베이스의 이름을 입력 한 다음 분할을 클릭 합니다.

맨 위로 이동

3 단계: 새 연결 원본 데이터베이스를 프런트 엔드

  1. 데이터베이스 분할 도구로 만든 백 엔드 데이터베이스를 삭제-하지 않도록 주의 해야 원래 데이터베이스를 삭제 합니다.

  2. 원래 데이터베이스의 테이블에 새 프런트 엔드 데이터베이스를 연결: 외부 데이터 탭의 가져오기 & 링크 그룹에서 연결 테이블 관리자를 클릭 합니다. 단추 이미지

  3. 모두 선택을 클릭 한 다음 새 위치 항상 확인 확인란을 선택 합니다.

  4. 확인을 클릭 하 고 이전 버전의 데이터베이스를 찾아 두 번 클릭 합니다.

    모든 것이 제대로 선택한 모든 연결 된 테이블 고쳤습니다 있다는 메시지가 표시 됩니다.

지금 최신 버전의 Access 보유 한 사용자에 대 한 새 기능을 지원 하도록 새 프런트 엔드 데이터베이스를 개선할 수 있습니다. 이전 버전을 보유 한 사용자 계속 이전 버전의 데이터베이스를 사용할 수 있습니다.

맨 위로 이동

프런트 엔드/백 엔드 응용 프로그램을 사용 하 여 여러 버전의 Access에서

Access 데이터베이스 프런트 엔드/백 엔드 응용 프로그램 이미 있으면 프런트 엔드 새 파일 형식으로 변환할 수 있습니다. 변경이 백 엔드 데이터베이스에 대 한 필요 하지 않은 합니다.

다음 절차에서는 세 가지 최신 형식 중 하나로 프런트 엔드 데이터베이스를 변환 하려면 다른 이름으로 데이터베이스 저장 명령을 사용 하는 방법을 보여 줍니다: Access 2000, Access 2002-2003 또는 Access 2007 합니다. 이 명령은 원래 형식에서 원래 데이터베이스를 유지 하 고 지정 된 형식으로 복사본을 만듭니다.

  1. 프런트 엔드 데이터베이스를 닫습니다. 공유 폴더에서 서버에 있는 다중 사용자 Access 데이터베이스 파일이 있는 다른 사용자가 열려 있는지 확인 합니다.

  2. Access 2010을 시작 합니다.

  3. 파일 탭에서 열기를 클릭합니다.

  4. 프런트 엔드 데이터베이스의 위치를 찾아 두 번 클릭 하 여 엽니다.

    데이터베이스 기능 향상 대화 상자가 나타나면 데이터베이스를 향상 시키기 위해 저장할지 묻는 아니요를 클릭 합니다.

  5. 데이터베이스를 열 때 나타나는 경우 폼, 폼을 닫습니다.

  6. 파일 탭에서 다른 이름으로 데이터베이스 저장을 클릭 합니다.

  7. 다른 이름으로 저장 대화 상자에서 새 데이터베이스의 이름을 입력 합니다.

  8. 저장을 클릭합니다.

이제 새 기능을 지 원하는 새 프런트 엔드 데이터베이스를 개선할 수 있습니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×