Access 2007 서식 파일 선택 및 사용

이 문서의 내용

개요

1단계: 서식 파일 선택

2단계: 서식 파일 사용자 지정

3단계: 새 데이터베이스에 데이터 추가

4단계: 레코드 찾기


개요

효율적인 데이터베이스를 만들려고 할 때 작업을 더 쉽게 시작할 수 있도록 Microsoft Office Access에서는 전문가 수준으로 디자인된 다양한 데이터베이스 서식 파일을 제공합니다. 각 서식 파일에서는 처음부터 끝까지 모든 것을 완벽하게 갖춘 솔루션을 제공하므로 서식 파일을 아무런 수정 없이 그대로 활용할 수도 있고 각자의 필요에 맞게 사용자 지정할 수도 있습니다. 각 서식 파일에는 테이블, 폼, 보고서, 쿼리, 매크로 및 관계가 미리 정의된 상태로 포함되어 있으므로 자신만의 데이터베이스를 사용자 지정하는 데 도움이 되는 아이디어를 얻을 수 있습니다.

또한 Access에서 링크를 클릭하여 Microsoft Office Online 웹 사이트에 액세스한 후 다른 Access 데이터베이스 서식 파일을 손쉽게 다운로드할 수 있습니다. 서식 파일을 선택하여 요구 사항에 맞게 사용자 지정한 다음 데이터를 추가하고 레코드 탐색을 시작할 수 있습니다.

1단계: 서식 파일 선택

Access와 함께 설치되는 서식 파일 중 하나를 선택하거나 온라인으로 제공되는 서식 파일을 찾아볼 수 있습니다.

설치된 서식 파일 선택

  1. Microsoft Office Access 시작 창의 서식 파일 범주 아래에서 로컬 서식 파일을 클릭합니다.

    사용할 수 있는 서식 파일 목록    

서식 파일

용도

자산

자산 정보와 소유자를 포함하여 자산 관련 내용을 관리합니다. 자산을 범주별로 분류하고 자산 상태, 취득일, 위치 및 소유자를 기록할 수 있습니다.

연락처

고객이나 파트너처럼 팀에서 업무를 추진하는 데 관여하는 사람들에 대한 정보를 관리합니다. 이름 및 주소 정보, 전화 번호, 전자 메일 주소 등을 추적할 수 있고 사진을 첨부할 수도 있습니다.

행사

앞으로 있을 모임, 마감일 및 기타 중요한 행사를 관리합니다. 행사 명칭, 위치, 시작 시간, 마치는 시간, 기타 설명 등을 기록할 수 있고 관련 이미지를 첨부할 수도 있습니다.

교직원

전화 번호, 주소, 비상 연락처 정보, 고용 기록 등 교직원에 대한 중요한 정보를 관리합니다.

문제점

여러 가지 문제점이나 과제를 관리하고 추적합니다. 해결할 문제를 할당하고, 우선 순위를 매기고, 그 진행 과정을 처음부터 끝까지 추적할 수 있습니다.

마케팅 프로젝트

마케팅 프로젝트 정보를 관리하고 프로젝트 결과물의 일정을 세우고 모니터링합니다.

프로젝트

작업을 관리하고 하나 이상의 프로젝트에 대한 예산을 관리합니다.

영업 라인

소규모 영업 전문 그룹 내에서 전망 있는 영업의 진행 상태를 모니터링할 수 있습니다.

학생

비상 연락처, 의료 관련 정보 및 보호자 관련 정보를 비롯하여 학생들에 대한 정보를 관리합니다.

작업

사용자나 사용자가 속한 팀에서 완료해야 하는 작업 항목 그룹을 관리합니다.

Northwind 2007

주문 추적 시스템을 만듭니다. 샘플로 포함되어 있는 데이터는 제거해야 합니다.

  1. 데이터베이스를 모델링하는 데 기반으로 삼을 서식 파일을 클릭합니다.

  2. 파일 이름 상자에 데이터베이스의 이름을 입력합니다.

  3. 새 데이터베이스의 위치를 따로 선택하려면 파일 이름 상자 옆에 있는 폴더 아이콘을 클릭합니다.

    팁: 데이터베이스를 Windows SharePoint Services 사이트에 연결하려면 데이터베이스를 만들어 Windows SharePoint Services 사이트에 연결 확인란을 선택합니다.

  4. 만들기를 클릭합니다.

이제 새 데이터베이스를 사용할 준비가 되었습니다. 원하는 경우 새 데이터베이스를 요구 사항에 맞게 사용자 지정할 수 있습니다.

온라인 서식 파일 선택

  1. Microsoft Office Access 시작 창에서 다음 중 하나를 실행합니다.

    • 모든 주요 온라인 서식 파일을 찾아보려면 서식 파일 범주 아래에서 주요 서식 파일을 클릭한 다음 원하는 서식 파일을 선택합니다.

    • 테마를 기준으로 온라인 서식 파일을 선택하려면 Microsoft Office Online 테마를 클릭한 다음 원하는 서식 파일을 선택합니다.

  2. 파일 이름 상자에 서식 파일의 새 이름을 입력한 다음 텍스트 상자 옆에 있는 파일 아이콘을 클릭하고 새 데이터베이스를 저장할 위치를 선택합니다.

  3. 다운로드를 클릭합니다.

팁: 데이터베이스를 Microsoft Windows SharePoint Services 사이트에 연결하려면 데이터베이스를 만들어 Windows SharePoint Services 사이트에 연결 확인란을 선택합니다.

이제 새 데이터베이스를 사용할 준비가 되었습니다. 원하는 경우 새 데이터베이스를 요구 사항에 맞게 사용자 지정할 수 있습니다.

맨 위로 이동

2단계: 서식 파일 사용자 지정

데이터베이스 서식 파일을 선택한 후 요구 사항에 맞게 해당 서식 파일을 사용자 지정할 수 있습니다. 서식 파일을 기반으로 하여 만든 데이터베이스에는 미리 정의하여 기본 제공되는 여러 가지 테이블, 폼 및 보고서가 포함되어 있으며 이러한 개체를 실제 작업에 곧바로 사용할 수도 있습니다. 서식 파일을 기반으로 데이터베이스를 만들면 해당 서식 파일의 용도에 맞게 필요한 기능을 지원하기 위한 테이블과 기타 개체가 자동으로 만들어집니다. 경우에 따라서는 서식 파일의 데이터베이스 구조가 복잡하여 그 구조를 어느 정도 사용자 지정해야 할 수도 있습니다. 기본 제공된 테이블의 디자인을 변경할 때는 기존의 관계가 무효화되지 않도록 주의를 기울여야 합니다. 서식 파일의 구조를 크게 변경해야 한다면 오히려 서식 파일을 사용하지 않고 빈 데이터베이스를 만들어 처음부터 새로 시작하는 편이 더 쉬울 수 있습니다.

서식 파일을 사용자 지정할 때는 필드나 테이블의 이름을 되도록이면 변경하지 않도록 해야 합니다. 이러한 필드와 테이블은 폼이나 보고서 같은 다른 데이터베이스 개체에 사용될 수 있으므로 그 필드 및 테이블 이름을 변경하면 해당 이름을 참조하거나 필요로 하는 다른 데이터베이스 개체가 애초에 의도한 대로 작동하지 않을 수 있습니다. 탐색 창에서 테이블의 이름을 바꾸거나 데이터시트 보기 또는 디자인 보기에서 필드의 이름을 바꿀 때는 먼저 이름 자동 고침 기능이 활성화되어 있는지 확인해야 합니다. 이름 자동 고침 기능을 사용하면 필드, 테이블, 폼 또는 보고서의 이름이 변경될 때 데이터베이스 전체의 다른 개체에도 변경 내용을 자동으로 전파할 수 있습니다. 새로 만드는 모든 데이터베이스에 대해서는 대개의 경우 이름 자동 고침 설정이 기본적으로 활성화되어 있습니다.

폼 또는 보고서 사용자 지정

여러 가지 방법으로 서식 파일 폼이나 보고서를 사용자 지정할 수 있습니다. 예를 들어 레이아웃 보기에서 폼을 연 다음 서식 탭의 자동 서식 그룹에서 새 서식을 선택하여 폼의 서식을 변경할 수 있습니다. 또는 새 필드를 추가하여 폼이나 보고서를 사용자 지정할 수도 있습니다. 폼이나 보고서에 필드를 추가하면 해당 폼이나 보고서에 컨트롤이 만들어집니다. 서식 파일의 기존 컨트롤을 사용자 지정하려면 해당 컨트롤의 속성을 변경하면 됩니다.

폼 또는 보고서에 새 컨트롤 추가

  1. 탐색 창에서 컨트롤을 추가할 폼이나 보고서를 마우스 오른쪽 단추로 클릭하고 디자인 보기를 클릭합니다.

  2. 디자인 탭을 클릭합니다.

  3. 컨트롤 그룹에서 추가할 컨트롤을 클릭한 다음 컨트롤 마법사 사용을 클릭합니다.

    컨트롤 그룹의 컨트롤 마법사 사용 명령

  4. 마법사의 단계에 따라 새 컨트롤을 만들고 사용자 지정합니다.

폼과 보고서를 만드는 방법에 대한 자세한 내용을 보려면 참고 항목 섹션에 나와 있는 링크를 클릭하십시오.

컨트롤 변경

폼이나 보고서에 기존 컨트롤이 표시되는 방식을 사용자 지정할 수 있습니다. 표시 형식을 변경하려면 필드의 형식/Format 속성을 변경하면 됩니다. 필드의 형식/Format 속성은 새 폼과 보고서를 만들 때 해당 필드를 기반으로 하는 컨트롤에 자동으로 상속됩니다.

데이터시트 보기에서 표시 형식 설정

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 변경할 컨트롤이 들어 있는 데이터베이스를 엽니다.

  3. 탐색 창에서 해당 서식을 설정하려는 필드가 들어 있는 테이블을 두 번 클릭합니다.

    데이터시트 보기에 테이블이 열립니다.

  4. 해당 표시 형식을 설정하려는 필드를 클릭합니다.

  5. 데이터시트 탭의 데이터 형식 및 서식 그룹에서 서식 옆에 있는 드롭다운 목록의 화살표를 클릭한 다음 서식을 선택합니다. 데이터 형식 및 서식 그룹 Access 리본 메뉴 이미지

    새 표시 형식을 적용한 필드가 표시됩니다.

디자인 보기에서 표시 형식 설정

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 변경할 컨트롤이 들어 있는 데이터베이스를 엽니다.

  3. 탐색 창에서 해당 표시 형식을 변경하려는 필드가 들어 있는 테이블을 마우스 오른쪽 단추로 클릭하고 디자인 보기를 클릭합니다.

    디자인 보기에 테이블이 열립니다.

  4. 해당 표시 형식을 설정하려는 필드를 클릭합니다.

  5. 필드 속성 아래에 있는 일반 탭의 형식 목록에서 표시 형식을 선택합니다.

  6. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

맨 위로 이동

3단계: 새 데이터베이스에 데이터 추가

서식 파일을 선택하고 필요한 부분을 사용자 지정한 다음 데이터를 가져오거나 외부 데이터에 연결하여 데이터베이스에 데이터를 추가할 수 있습니다.

데이터 가져오기

Excel 통합 문서, Windows SharePoint Services 3.0 목록, Outlook 주소록 또는 기타 Access 데이터베이스를 포함하여 여러 가지 형식의 데이터를 가져올 수 있습니다.

  • 데이터를 가져오려면 외부 데이터 탭의 가져오기 그룹에서 가져오려는 파일 형식에 해당하는 명령을 클릭합니다.

    가져오기 그룹의 명령 단추

    참고 사항: 

    • 가져오려는 데이터 형식에 해당하는 아이콘이 보이지 않으면 기타를 클릭한 다음 외부 데이터 가져오기 대화 상자의 지침을 따릅니다.

    • 그래도 여전히 외부 데이터를 가져오는 데 필요한 명령을 찾을 수 없으면 데이터를 만들 때 사용한 원래 프로그램을 Access 외부에서 별도로 시작한 후 해당 프로그램을 사용하여 데이터를 분리된 텍스트 파일 같은 일반적인 파일 형식으로 저장해야 합니다. 그런 다음 Access로 돌아와 외부 데이터 명령 중 하나를 사용하여 해당 데이터를 가져옵니다.

  • 마법사의 마지막 페이지에서 지금까지의 가져오기 단계에 대한 세부 정보를 저장할지 묻는 메시지가 나타날 수 있습니다. 이 세부 정보를 저장해 두면 나중에 동일한 데이터 원본에서 데이터를 가져올 때 작업을 편리하게 진행할 수 있습니다. 가져오기 단계 저장 확인란을 선택하고 세부 정보를 입력한 후 가져오기 저장을 클릭합니다. 앞으로는 언제든지 외부 데이터 탭의 가져오기 그룹에서 저장된 데이터 가져오기를 클릭하여 동일한 가져오기 과정을 반복할 수 있습니다. 이 가져오기 작업에 대한 세부 정보를 저장하지 않으려면 닫기를 클릭합니다.

데이터에 연결

데이터에 연결하면 데이터가 원래 위치에 계속 저장되어 있는 상태를 유지하면서 새 데이터베이스에는 연결된 테이블로 표시됩니다. 대부분의 파일 형식에 대해 Access를 사용하거나 데이터를 만드는 데 사용했던 원래 프로그램을 통해 데이터를 보고 수정할 수 있습니다. 두 프로그램 모두 동일한 실제 데이터를 대상으로 작업을 실행하기 때문입니다. 그러나 데이터가 Excel 통합 문서로 저장되어 있으면 Access에서는 연결된 데이터를 볼 수만 있고 수정할 수는 없습니다. 연결된 통합 문서의 데이터를 수정하려면 Excel을 사용해야 합니다.

    1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

    2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

    3. 외부 데이터 탭의 가져오기 그룹에서 연결할 파일의 형식에 해당하는 명령을 클릭합니다. 예를 들어 Excel 통합 문서의 데이터에 연결하려면 Excel을 클릭합니다. 연결하려는 데이터 형식에 해당하는 아이콘이 보이지 않으면 기타를 클릭합니다.

      외부 데이터 가져오기 대화 상자가 나타납니다.

      참고: 그래도 여전히 외부 데이터에 연결하는 데 필요한 명령을 찾을 수 없으면 데이터를 만들 때 사용한 원래 프로그램을 Access 외부에서 별도로 시작한 후 해당 프로그램을 사용하여 데이터를 분리된 텍스트 파일 같은 일반적인 파일 형식으로 저장해야 합니다. 그런 다음 Access로 돌아와 외부 데이터 명령 중 하나를 사용하여 해당 데이터에 연결합니다.

    4. 외부 데이터 가져오기 대화 상자에서 찾아보기를 클릭한 후 원본 데이터 파일을 찾거나 파일 이름 상자에 원본 데이터 파일의 전체 경로를 입력합니다.

    5. 현재 데이터베이스에서 데이터를 저장할 방법과 위치를 지정하십시오. 아래에서 원하는 옵션을 클릭합니다.

      대부분의 파일 형식에 대해 마법사가 시작됩니다. 그러나 Access 데이터베이스의 데이터에 연결하려는 경우에는 개체 가져오기 대화 상자가 열립니다. 테이블 연결 대화 상자에서 필요한 항목을 선택한 후 7단계를 진행합니다. 그렇지 않으면 6단계를 진행합니다.

    6. 마법사의 단계를 완료합니다. 마법사의 구체적인 진행 과정은 어떤 옵션을 선택하는가에 따라 달라질 수 있습니다.

맨 위로 이동

4단계: 레코드 찾기

데이터베이스로 데이터를 가져왔으면 특정 레코드를 찾는 데 어떤 방법이 효율적인지 검토해야 합니다. 데이터베이스 아래쪽에 있는 도구 모음을 사용하여 레코드를 찾을 수 있습니다.

탐색 단추

탐색 단추를 사용하여 테이블이나 보기(개체)의 레코드를 찾습니다.

탐색 단추

찾을 대상

1.

첫 레코드

2.

이전 레코드

3.

특정 레코드 - 텍스트 상자를 클릭하고 레코드 번호를 입력한 후 Enter 키를 눌러 해당 레코드를 표시합니다. 레코드 번호는 폼이나 데이터시트의 첫 항목부터 순차적으로 매겨집니다.

4.

다음 레코드

5.

마지막 레코드

6.

새 레코드(빈 레코드)

7.

필터 - 이 표시기는 필터가 적용되었는지 여부를 나타냅니다. 적용된 필터가 없거나 모든 필터를 해제한 경우에는 필터 없음 표시기가 나타납니다.

8.

검색 상자 - 검색 상자에 텍스트를 입력하면 각 문자를 입력할 때 검색 조건에 일치하는 첫째 값이 실시간으로 강조 표시됩니다. 이 기능을 사용하면 레코드를 신속하게 찾을 수 있습니다.

기타 레코드 검색 방법

다음 방법 중 하나를 사용하여 레코드를 찾을 수도 있습니다.

특정 레코드로 이동

특정 레코드 검색

특정 레코드 집합만 표시하도록 필터링

쿼리를 통해 사용자 지정 검색 실행

특정 레코드로 이동

일부 서식 파일에 들어 있는 폼에서는 특정 레코드를 쉽게 찾아 볼 수 있도록 이동 드롭다운 목록을 제공합니다. 예를 들어 연락처 서식 파일의 연락처 정보 폼과 마케팅 프로젝트 서식 파일의 프로젝트 및 작업 폼에서 이 옵션을 제공합니다. 이 방법을 사용하면 드롭다운 목록에서 특정 레코드를 볼 수 있습니다. 이 옵션을 사용할 수 있는 경우 폼의 왼쪽 상단 구역에 이동 상자가 배치됩니다.

  1. 이동 목록 옆에 있는 화살표를 클릭합니다.

    이동 상자

  2. 보려는 레코드를 클릭합니다.

특정 레코드 검색

찾기 및 바꾸기 대화 상자의 찾기 탭을 사용하여 특정 레코드를 검색할 수 있습니다. 특정 필드를 검색할 수도 있고 전체 테이블이나 보기를 검색할 수도 있습니다.

참고: 찾기 및 바꾸기 대화 상자는 현재 테이블이나 보기에 데이터가 표시되어 있는 경우에만 사용할 수 있습니다.

  1. 검색할 테이블을 연 다음 찾으려는 레코드가 들어 있는 필드를 클릭합니다.

  2. 탭의 찾기 그룹에서 찾기를 클릭합니다.

    찾기 명령 단추

  3. 찾기 및 바꾸기 대화 상자의 찾을 내용 상자에 검색 조건을 입력합니다.

  4. 찾을 방향 목록에서 모두를 선택한 후 다음 찾기를 클릭합니다.

찾기 및 바꾸기 대화 상자를 사용하는 데 대한 자세한 내용을 보려면 참고 항목 섹션에 나와 있는 링크를 클릭하십시오.

특정 레코드 집합만 표시하도록 필터링

필터를 설정하거나 해제하여 동일한 데이터에 대한 필터링된 보기와 필터링되지 않은 보기 사이를 손쉽게 전환할 수 있습니다.

필터를 적용하면 지정한 조건에 맞는 레코드만으로 표시 범위를 제한할 수 있습니다. 필터를 적용하면 필요한 레코드를 더 쉽게 찾을 수 있습니다. 예를 들어 표시되는 레코드의 범위를 간단하게 좁히려면 일치할 조건으로 사용할 값이 들어 있는 필드를 마우스 오른쪽 단추로 클릭한 다음 과(와) 같음, 과(와) 같지 않음, 을(를) 포함 또는 을(를) 포함하지 않음 선택 메뉴 옵션 중 하나를 클릭합니다.

  • 필터를 추가하려는 테이블이나 폼을 엽니다.

  • 테이블이나 폼을 필터가 적용되지 않은 상태로 만들려면 탭의 정렬 및 필터 그룹에서 고급을 클릭한 다음 모든 필터 해제를 클릭합니다. 이 명령이 흐리게 표시되어 사용할 수 없으면 적용된 필터가 없다는 의미입니다.

    정렬 및 필터 그룹

  • 필터를 적용하려면 필터를 설정할 필드를 클릭한 다음 탭의 정렬 및 필터 그룹에서 필터를 클릭하고 필터링 옵션을 선택합니다.

  • 선택 영역을 기준으로 하는 필터를 적용하려면 테이블이나 폼을 열고 필터에 포함하여 사용할 값이 들어 있는 레코드를 찾아 이동한 다음 필드를 클릭합니다. 탭의 정렬 및 필터 그룹에서 선택 영역을 클릭한 다음 적용할 필터를 클릭합니다.

  • 일부 선택 영역을 기준으로 하는 필터를 적용하려면 필요한 문자만 선택합니다. 탭의 정렬 및 필터 그룹에서 선택 영역을 클릭한 다음 적용할 필터를 클릭합니다.

필터 적용에 대한 자세한 내용을 보려면 참고 항목 섹션에 나와 있는 링크를 클릭하십시오.

쿼리를 통해 사용자 지정 검색 실행

쿼리를 사용하여 사용자 지정된 검색을 실행하고, 사용자 지정된 필터를 적용하고, 레코드를 정렬할 수 있습니다. 쿼리를 저장해 두고 다시 사용할 수도 있고 폼과 보고서를 작성하는 데 쿼리를 사용할 수도 있습니다. 쿼리를 사용하여 필요한 테이블 레코드만 찾을 수도 있습니다. 만들 수 있는 쿼리의 종류는 반환하여 얻으려는 레코드와 Access에서 그 결과에 대해 어떤 작업을 실행할 것인지에 따라 다를 수 있습니다.

  1. 만들기 탭의 기타 그룹에서 쿼리 마법사를 클릭합니다.

    기타 그룹의 쿼리 마법사 명령

  2. 쿼리 마법사에 표시되는 단계를 따릅니다.

쿼리 만들기에 대한 자세한 내용을 보려면 참고 항목 섹션에 나와 있는 링크를 클릭하십시오.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×