Access 응용 프로그램 배포

Access데이터베이스 응용 프로그램 개발을 위한 다양한 기능의 플랫폼을 제공합니다. 데이터베이스 응용 프로그램은 데이터를 저장하고 관리하는 방법과 비즈니스 작업(응용 프로그램 논리)의 논리를 따르는 사용자 인터페이스를 모두 제공하는 컴퓨터 프로그램입니다.

사용자 컴퓨터에 Access를 설치하지 않고 실행할 수있는 Access응용 프로그램을 배포하려면 Microsoft.com 다운로드 센터에서 무료로 제공되는 Access 런타임과 함께 배포할 수 있습니다.

이 문서에서는 기본적인 배포 계획, Access런타임의 기능 및 런타임 다운로드 방법에 대해 설명합니다. 이 문서에서는 Access을 사용하여 데이터베이스 응용 프로그램을 배포하는 방법에 대한 개요도 제공합니다.

실행할 작업

배포 계획

Access 런타임 이해

Access 런타임 다운로드

Access 응용 프로그램 배포

배포 계획

시작하기 전에 응용 프로그램을 배포하는 방법에 대해 스스로 다음과 같은 질문에 답해봐야 합니다.

데이터와 논리가 구분되어야 할까요?

하나의 파일에 데이터 관리와 응용 프로그램 논리를 결합한 Access응용 프로그램을 만들 수 있습니다. 이것이 Access의 기본 응용 프로그램 구조입니다. 데이터 관리 및 응용 프로그램 논리를 하나의 파일에 결합하면 가장 간단한 배포 방법이 제공되지만 이 방법은 한 번에 하나의 응용 프로그램을 사용하는 경우에만 적합하고 일부 위험이 따릅니다. 예를 들어 사용자가 실수로 응용 프로그램 파일을 삭제하거나 손상시켜 데이터 손실을 초래할 수 있습니다.

대부분의 경우 사용자는 데이터 관리와 응용 프로그램 논리를 구분해야 합니다. 이는 다음과 같은 사항을 개선합니다.

  • 보안    데이터 저장을 위해 서버를 사용하면 데이터를 안전하게 유지할 수 있습니다.

  • 성능    분할 데이터베이스 또는 데이터베이스 서버를 사용하면 네트워크 트래픽을 줄일 수 있습니다.

  • 사용자 지정 가능성    탐색 창에 대한 새로운 매크로 동작을 통해 누가 무엇을 보는지 제어할 수 있습니다. 서로 다른 응용 프로그램 논리 파일을 다른 사용자에게 배포 할 수 있습니다.

데이터 및 논리를 구분하는 방법

데이터와 로직을 분리하는 한 가지방법은 Access 데이터베이스 명령을 사용하는 것입니다(데이터 이동 그룹의 데이터베이스 도구 탭에서) Access 데이터베이스 명령은 데이터베이스 응용 프로그램을 두 개의 Access 파일(데이터용과 논리 용)로 나눕니다. Access 데이터베이스 명령을 사용하면 Access는 파일 이름에 "_be"("백엔드"를 의미)가 추가된 파일을 만듭니다. 예를 들어 원래 데이터베이스 파일 이름이 "Database1.accdb”인 경우, Access는 "Database1_be.accdb "라는 새 데이터베이스 파일을 만듭니다.

데이터 관리 및 응용 프로그램 논리를 분리하는 또 다른 방법은 데이터 관리에 데이터베이스 서버 프로그램(예 : Microsoft SQL Server)을 사용하고 응용 프로그램 논리에 Access를 사용하는 것입니다.

단일 Access 파일이 데이터 관리 및 응용 프로그램 논리 모두에 충분한지 여부를 결정하려면 다음 사항을 고려하십시오.

  • 데이터 무결성 및 보안    Access사용자가 응용 프로그램 논리를 포함하는 파일에 대한 읽기/쓰기 권한을 가져야 합니다. 하나의 파일에 데이터와 로직을 결합하면 데이터가 어플리케이션 로직과 동일한 위험에 노출됩니다.

    별도의 논리 및 데이터 파일을 사용하는 Access 응용 프로그램은 NTFS 보안 기능을 활용하여 데이터 무결성 및 보안을 보호할 수 있습니다. 사용자는 응용 프로그램 논리 파일에 대한 명시적 읽기/쓰기 액세스 만 필요로 하기 때문에 데이터 파일을 더욱 안전하게 만들 수 있습니다.

    응용 프로그램에는 특정 데이터에 대한 액세스 권한이 있는 사용자를 제어하는 기능과 같은 추가 보안 옵션이 필요할 수 있습니다. 이 경우 응용 프로그램 데이터를 저장 및 관리하고 Access를 사용하여 응용 프로그램 논리를 제공하려면 Windows SharePoint Services이 설치된 SQL Server 또는 Windows 서버 운영 체제와 같은 서버 제품을 사용해야합니다.

  • 확장성    Access 파일의 최대 크기는 2GB입니다. 2GB는 상당량의 텍스트 데이터이지만 일부 응용 프로그램, 특히 데이터베이스 레코드에 첨부 파일을 저장하는 응용 프로그램에는 충분하지 않을 수 있습니다. 데이터와 논리를 분리하면 응용 프로그램에서 더 많은 데이터를 수용할 수 있습니다. 사용자가 많은 양의 데이터를 저장할 것으로 예상되면 둘 이상의 Access 데이터 파일 사용을 고려할 수 있습니다.

    다른 확장성 정보에 대해서는 Access프로그램 사양도 검토해야 합니다. Access사양에 대한 자세한 내용은 액세스 사양 문서를 참조하십시오.

  • 네트워크 용량    여러 사용자가 네트워크를 통해 동시에 응용 프로그램을 사용해야 하는 경우 데이터와 논리가 하나의 파일에 결합된 경우 데이터 손상이 발생할 가능성이 큽니다. 또한 하나의 Access 파일에서 데이터와 논리를 결합하면 Access가 생성하는 네트워크 트래픽을 최적화 할 수 없습니다. 여러 사용자가 네트워크에서 응용 프로그램을 동시에 사용하는 경우, 둘 이상의 Access 파일을 사용하거나 응용 프로그램 논리에 대한 데이터 및 액세스를 위한 데이터베이스 서버 제품을 사용하여 데이터와 논리를 분리해야합니다.

네트워크 환경은 어떨까요?

사용자가 모두 같은 LAN에 있거나 네트워크를 통해 응용 프로그램을 사용하지 않는 경우 대부분의 경우 단일 응용 프로그램 파일이 잘 수행 될 수 있습니다.

데이터와 논리를 분리하면 네트워크 성능이 향상됩니다. 사용자가 동일한 LAN에 있지 않으면 서버를 사용하여 데이터를 저장 및 관리하고 응용 프로그램 논리에 대해 Access를 사용하십시오.

사용자가 Access을 보유할까요?

모든 사용자가 컴퓨터에 Access을 설치하면 Access데이터베이스 파일처럼 응용 프로그램을 열어서 사용할 수 있습니다.

일부 또는 모든 사용자가 자신의 컴퓨터에 Access을 설치하지 않은 경우 응용 프로그램을 배포할 때 Access런타임 소프트웨어를 해당 사용자에게 배포해야 합니다.

맨 위로 이동

Access 런타임 이해

Access런타임은 컴퓨터에 Access가 설치되지 않은 사람들이 Access데이터베이스 응용 프로그램을 사용할 수 있는 재배포 가능 프로그램입니다. Access런타임을 사용하여 Access 데이터베이스를 열면 데이터베이스가 런타임 모드로 열립니다.

런타임 모드는 무엇입니까?

런타임 모드는 특정 Access기능을 기본적으로 사용할 수 없는 Access운영 모드입니다. 이러한 사용할 수 없는 기능 중 일부는 런타임 모드에서 사용할 수 있습니다..

런타임 모드에서 사용할 수 없는 기능은 무엇입니까?

다음과 같은 Access기능은 런타임 모드에서 사용할 수 없습니다.

  • 탐색 창    탐색 창은 런타임 모드에서 사용할 수 없니다. 이렇게하면 사용자가 데이터베이스 응용 프로그램의 임의의 객에 액세스하는 것을 방지할 수 있습니다. 런타임 모드를 사용하는 동안 사용자에게 노출되는 개(예 : 스위치 보드 양식 제공)만 열 수 있습니다. 탐색 창을 타임 모드에서 사용 가능하게 할 수 없습니다.

  • 리본    기본적으로 런타임 모드에서 사용할 수 없습니다. 이렇게 하면 사용자가 데이터베이스 개체를 만들거나 수정하거나 데이터 원본에 연결하거나 원하지 않는 방식으로 데이터를 내보낼 때와 같은 잠재적으로 유해한 작업을 수행하는 것을 방지하는 데 도움이됩니다. 사용자 지정 리본을 만든 다음 해당 리본을 폼이나 보고서와 연결할 수 있습니다. 런타임 모드의 기본 리본 탭을 나타낼 수 없습니다.

  • 디자인 보기 및 레이아웃 보기    디자인보기 및 레이아웃 보기는 런타임 모드의 모든 데이터베이스 개체에 대해 사용할 수 없습니다. 이렇게 하면 사용자가 데이터베이스 응용 프로그램의 개체 디자인을 수정하는 것을 방지할 수 있습니다. 런타임 모드에서 디자인 보기 또는 레이아웃 보기를 사용할 수 없습니다.

  • 도움말    기본적으로 통합된 도움말을 런타임 모드에서 사용할 수 없니다. 런타임 모드 응용 프로그램에서 사용할 수 있는 기능을 제어하므로 표준 통합 Access도움말 중 일부는 응용 프로그램을 사용하는 사람들과 관련이 없으며 잠재적으로 혼동을 주거나 이들을 좌절시킬 수 있습니다. 런타임 모드 응용 프로그램을 보완하기 위해 사용자 지정 도움말 파일을 만들 수 있습니다.

Access런타임 소프트웨어를 사용하지 않고 런타임 모드에서 Access 데이터베이스를 열 수 있습니까?

Access의 전체 버전이 설치된 컴퓨터에서 런타임 모드로 임의의 Access 데이터베이스를 실행할 수 있습니다. Access런타임 모드에서 데이터베이스를 실행하려면 다음 중 하나를 수행합니다.

  • 데이터베이스 파일의 파일 이름 확장명을 .accdb에서 .accdr로 변경합니다.

  • 데이터베이스에 대한 바로 가기를 만들고 바로 가기에 /Runtime 명령 줄 스위치를 포함시킵니다.

런타임 모드로 데이터베이스를 보다 안전하게 만들 수 있습니까?

런타임 모드는 탐색 및 디자인 기능의 사용 가능성을 제한하지만 런타임 모드를 데이터베이스 응용 프로그램 보안의 기본 수단으로 사용해서는 안됩니다. Access의 정식 버전이 설치된 컴퓨터에서 런타임 데이터베이스 응용 프로그램을 일반 데이터베이스 응용 프로그램(즉 모든 기능을 사용할 수 있음)으로 연 다음 디자인을 변경하거나 기타 원치 않는 작업을 기능을 수행할 수 있습니다.

Access의 정식 버전이 설치되지 않은 컴퓨터에만 데이터베이스 응용 프로그램을 배포하는 경우에도 사용자가 풀 버전의 Access을 설치한 컴퓨터로 응용 프로그램을 전송할 수 있습니다. 그런 다음 런타임 데이터베이스 응용 프로그램을 일반 데이터베이스 응용 프로그램으로 엽니 다.

참고: 사용자가 폼, 보고서 또는 VBA (Visual Basic for Applications) 모듈의 디자인을 수정할 수 없도록 Access응용 프로그램을 배포하려는 경우 컴파일된 이진 파일 (.accde)을 사용하는 것을 고려하십시오. 컴파일된 이진 파일 사용에 대한 자세한 내용은 이 문서 뒷부분의 사용할 파일 형식 결정 섹션을 참조하십시오.

맨 위로 이동

Access런타임 다운로드

Microsoft 다운로드 센터에서 Access런타임을 다운로드하려면 해당 버전에 해당하는 링크를 클릭하십시오.

Access런타임을 다운로드, 사용 또는 재배포하기 위해 구매할 필요가 없으며 런타임을 배포할 수 있는 대상 사용자 수에는 제한이 없습니다.

맨 위로 이동

Access응용 프로그램 배포

Access응용 프로그램을 배포하려면 최소한 다음 작업을 수행해야 합니다.

  1. 응용 프로그램 만들기    응용 프로그램은 사용자가 데이터베이스 객체를 열고 사용할 수 있는 방법을 제공해야 합니다. 응용 프로그램에서 이러한 수단을 제공하지 않으면 사용자는 응용 프로그램을 사용하기 위해 컴퓨터에 Access이 설치되어 있어야 합니다. 또한 사용자가 응용 프로그램 내에서 탐색하는 방법을 예측할 수 없으며 완전한 응용 프로그램 문서를 제공하기가 더 어려워집니다. 또한 사용자가 Access런타임 소프트웨어를 사용하여 응용 프로그램을 열면 기본 제공 Access탐색 기능을 사용할 수 없게 됩니다.

    한 가지 방법은 데이터베이스 개체를 열거나 다른 작업을 수행하는 명령 단추가 있는 양식을 만든 다음 해당 양식을 응용 프로그램이 시작될 때 열리는 기본 양식으로 지정하는 것입니다.

    참고: 양식 만들기에 대한 도움말은 양식 도구를 사용하여 양식 만들기 주제를 참조하십시오.

    열려는 기본 서식을 지정하려면 어떻게 해야 합니까?

    1. 파일 > 옵션을 클릭합니다. Access 2007을 사용하는 경우 Microsoft Office 단추를 클릭한 다음 Access 옵션을 클릭합니다.

    2. Access 옵션 대화 상자의 왼쪽 창에서 현재 데이터베이스를 클릭합니다.

    3. 오른쪽 창의 응용 프로그램 옵션 아래에서 양식 표시 콤보 상자를 사용하여 원하는 기본 양식을 선택합니다.

    사용자 지정 리본을 만든 다음 해당 리본을 응용 프로그램이 시작될 때 열리는 양식과 연결할 수도 있습니다. 사용자 지정 리본을 만드는 방법에 대한 자세한 내용은 액세스에서 사용자 지정 리본 만들기를 참조하십시오.

  2. 응용 프로그램 설치하기    응용 프로그램을 설치하기 위한 몇 가지 옵션과 고려 사항이 있습니다. 사용자가 응용 프로그램을 사용하는 방법을 보다 잘 제어하기 위해 특정 파일 형식을 배포할 수 있습니다. 또는 응용 프로그램을 패키징하여 별도의 데이터 및 논리 구성 요소를 쉽게 설치하거나 배포할 수 있습니다.

    다음 섹션에서 이러한 옵션 및 고려사항에 대한 자세한 정보를 확인할 수 있습니다.

어떤 파일 형식을 사용할지 결정하기

응용 프로그램을 배포할 때 사용할 수 있는 Access파일 형식이 네 가지 있습니다.

  • .accdb    이것은 Access에 대한 기본 파일 형식입니다. 이 형식으로 응용 프로그램을 배포하면 사용자는 원하는대로 응용 프로그램을 사용자 지정하고 탐색할 수 있는 옵션을 대부분 갖게 됩니다. 사용자가 응용 프로그램의 디자인을 변경하지 않도록 하려면 .accde 파일 형식을 사용해야 합니다. 또한 사용자가 패키지를 작성한 후에 .accdb 파일이 변경되었는지 여부를 쉽게 알 수 없으므로 .accdc 파일 형식을 사용하십시오.

  • .accdc    이 형식은 Access 배포 파일로도 알려져 있습니다. Access 배포 파일은 응용 프로그램 파일과 해당 파일과 관련된 디지털 서명으로 구성됩니다. 이 파일 형식은 사용자가 응용 프로그램 파일을 패키지화한 후에 아무도 변경하지 못하도록 합니다. 이 형식을 기본 형식 Access파일 (.accdb) 또는 Access컴파일된 이진 파일(.accde)에 적용할 수 있습니다.

    하나의 응용 프로그램 파일만 Access 배포 파일에 저장할 수 있습니다. 응용 프로그램에 별도의 데이터 및 논리 파일이 있으면 이를 별도로 패키징할 수 있습니다.

  • .accde    이 형식은 컴파일된 이진 파일로도 알려져 있습니다. Access에서 컴파일된 이진 파일은 컴파일된 모든 VBA 코드와 함께 저장된 데이터베이스 응용 프로그램 파일입니다. VBA 소스 코드는 Access 컴파일된 이진 파일에 남아 있지 않습니다.

    Access런타임을 사용하여 Access컴파일된 이진 파일을 열 수 있습니다. 그러나 기본적으로 런타임은 .accde 파일 이름 확장명을 인식하지 못합니다. Access런타임을 사용하여 컴파일된 이진 파일을 열기 위해서는 런타임을 가리키는 바로 가기를 만들고 바로 가기를 열려고 하는 컴파일된 이진 파일의 경로를 포함시킵니다.

    중요: 사용자가 컴파일된 버전보다 이전 버전의 Access를 사용하여 컴파일 된 이진 파일을 열면 사용자는 컴파일된 이진 파일을 열 수 없습니다. 이 문제를 해결하려면 사용자가 설치한 Access 버전의 이진 파일을 컴파일해야 합니다.

    Access파일을 컴파일된 이진 파일로 저장하려면 어떻게 해야 합니까?

    1. Access에서 컴파일된 이진 파일(.accde)로 저장하려는 데이터베이스 (.accdb 파일)를 엽니다.

    2. 파일 탭을 클릭한 다음 다른 이름으로 저장을 클릭합니다.

    3. 데이터베이스 파일 형식에서 ACCDE 만들기를 클릭한 다음 다른 이름으로 저장을 클릭하십시오.

    4. 다른 이름으로 저장 대화 상자에서 파일을 저장할 폴더를 찾은 다음 파일 이름 상자에 파일 이름을 입력하고 저장을 클릭합니다.

    참고: Access 2007을 사용하는 경우 데이터베이스 도구 탭의 데이터베이스 도구 그룹에서 ACCDE 만들기를 클릭하십시오.

  • .accdr    이 형식을 사용하면 런타임 모드로 열리는 응용 프로그램을 배포할 수 있습니다. 런타임 응용 프로그램을 배포하는 것은 응용 프로그램 보안 방법이 아니지만 사용 방법을 제어하는 데 도움이 됩니다. 런타임 모드에 대한 자세한 내용은 Access 런타임 이해섹션을 참조하십시오.

Access데이터베이스 패키징 및 서명

Access을 사용하면 이전 버전보다 데이터베이스에 더 쉽고 빠르게 서명하고 배포할 수 있습니다. .accdb 파일 또는 .accde 파일을 만든 후 해당 파일을 패키지로 만들고 패키지에 디지털 서명을 적용한 다음 서명된 패키지를 다른 사용자에게 배포할 수 있습니다. 패키지 및 서명 기능은 데이터베이스를 Access 배포 (.accdc) 파일에 저장하고 패키지에 서명한 다음, 사용자가 결정한 사용자 컴퓨터의 위치에 코드 서명된 패키지를 저장합니다. 그러면 사용자들이 패키지에서 데이터베이스를 추출하여 패키지 파일이 아니라 데이터베이스에서 직접 작업할 수 있습니다.

참고: 이 절에서 설명하는 기능은 Access파일을 패키징하고 사용자에게 디지털 서명을 패키지에 적용하여 파일을 신뢰할 수 있음을 나타냅니다.

패키지를 만들고 서명할 때 다음 사실을 기억하십시오.

  • 데이터베이스를 패키지로 만들고 해당 패키지에 서명하는 것은 신뢰할 수 있음을 표시하는 방법입니다. 사용자 또는 사용자가 패키지를 받으면 서명을 통해 데이터베이스가 변경되지 않았음을 확인합니다. 만든 이를 신뢰할 수 있는 경우 해당 콘텐츠를 사용할 수 있습니다.

  • 패키지 및 서명 기능은 .accdb 파일 형식으로 저장된 데이터베이스에만 적용됩니다. Access은 이전 .mdb 파일 형식으로 작성된 데이터베이스에 서명하고 배포하는 데 사용할 수 있는 이전 버전의 Microsoft Office 도구를 제공합니다. 이전 버전의 Office 도구를 사용하여 최신 .accdb 파일 형식으로 만든 파일에 서명하고 배포할 수 없습니다.

  • 패키지 하나에는 데이터베이스 파일을 한 개만 추가할 수 있습니다.

  • 데이터베이스를 패키지하고 서명 할 때 데이터베이스 파일의 모든 개체는 매크로 또는 코드 모듈이 아닌 코드로 서명됩니다. 패키지 및 서명 프로세스는 패키지 파일을 압축하여 다운로드 시간을 줄입니다.

  • SharePoint 서버에 있는 패키지 파일에서 데이터베이스를 추출할 수 있습니다.

다음 섹션에서는 서명된 패키지 파일을 만들고 서명된 패키지 파일에서 데이터베이스를 사용하는 방법에 대해 설명합니다.

참고: 이 단계를 완료하려면 최소한 하나 이상의 보안 인증서가 있어야 합니다. 컴퓨터에 인증서가 설치되어 있지 않으면 SelfCert 도구를 사용하여 인증서를 만들 수 있습니다. 개인 보안 인증서 만들기에 대한 자세한 내용은 디지털 서명을 추가하여 신뢰 표시 문서를 참조하십시오.

서명된 패키지 만들기

  1. 패키징 및 서명할 데이터베이스를 엽니다.

  2. 파일 탭을 클릭한 다음 다른 이름으로 저장을 클릭합니다.

  3. 데이터베이스 파일 형식에서 패키징 및 서명을 클릭한 다음 다른 이름으로 저장을 클릭하십시오.

    참고: Access 2007을 사용하는 경우 Microsoft Office 버튼을 클릭하고 게시를 클릭한 다음 패키징 및 서명을 클릭합니다.

  4. 인증서 선택 대화 상자에서 디지털 인증서를 선택한 다음 확인을 클릭합니다.

    Microsoft Office Access 서명된 패키지 만들기 대화 상자가 나타납니다.

  5. 저장 위치 목록에서 서명된 데이터베이스 패키지를 저장할 위치를 선택합니다.

  6. 파일 이름 상자에 서명된 패키지의 이름을 입력한 다음 만들기를 클릭합니다.

    Access에서 .accdc 파일이 만들어지고 사용자가 선택한 위치에 이 파일이 배치됩니다.

서명된 패키지 추출 및 사용

  1. 파일 > 열기를 클릭합니다.

    참고: Access 2007을 사용하는 경우 Microsoft Office 버튼을 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 Microsoft Office Access 서명된 패키지(* .accdc)를 파일 유형으로 선택하십시오.

  3. 찾는 위치 목록에서 .accdc 파일이 있는 폴더를 찾아서 파일을 선택한 다음 열기를 클릭합니다.

  4. 다음 중 하나를 수행합니다.

    • 배포 패키지에 적용된 디지털 인증서를 신뢰하기로 선택하면 데이터베이스 추출 대화 상자가 나타납니다. 5단계로 이동합니다.

    • 디지털 인증서를 아직 신뢰하지 않기로 선택하면 알림 메시지가 나타납니다.

      1. 알림 메시지

      2. 데이터베이스를 신뢰할 수 있는 경우 열기를 클릭합니다. 해당 공급자가 제공한 모든 인증서를 신뢰할 수 있는 경우 게시자의 모든 내용 신뢰를 클릭합니다. 그러면 데이터베이스 추출 대화 상자가 나타납니다.

  5. 또는 저장 위치 목록에서 추출된 데이터베이스를 저장할 위치를 선택한 다음 파일 이름 상자에 추출된 데이터베이스의 다른 이름을 입력합니다.

인증서를 신뢰할 수 있는지 여부가 확실하지 않으면 디지털 서명이 신뢰할 수 있는 것인지 구별하는 방법 문서를 참조하세요. 이 문서에서는 인증서의 날짜 및 기타 항목이 올바른지 확인하는 일반적인 방법을 설명합니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×