SharePoint Designer 2010 시작

중요:  본 문서는 기계 번역된 문서이므로 고지 사항을 확인하십시오. 이 문서의 영문 버전은 여기서 확인할 수 있습니다.

Microsoft SharePoint Designer 2010 은 웹 및 응용 프로그램 디자인 프로그램 빌드를 디자인 하는 데 사용 하 고 SharePoint Foundation 2010 및 Microsoft SharePoint Server 2010 에서 실행 되는 웹 사이트를 사용자 지정 합니다. SharePoint Designer 2010 데이터 서식 있는 웹 페이지를 만들 강력한 워크플로 기반 솔루션 구축 한 사이트의 모양 및 느낌을 디자인할 수 있습니다.

문서, 비디오 및 기타 학습 리소스를 통해 SharePoint Designer 2010 대 한 자세한 내용은 다음 링크를 사용 합니다. 기본 작업 SharePoint Designer 2010 에서 수행 하는 방법에 대 한 자세한 내용은 다음 절차를 사용 합니다.

시작 로고

있는 wan t

G 수 있는 위치 o

변경된 내용을 알고 싶은 경우   

이 릴리스에서 새롭게 제공되는 기능과 새로운 기능을 최대한 활용하는 방법에 대해 알아봅니다.

SharePoint Designer 2010의 새로운 기능

2007 메뉴 및 명령 위치 확인   

2007 릴리스에서 제공되는 메뉴 및 도구 모음 명령 표를 확인하고 매핑 통합 문서에서 이러한 항목의 새로운 위치를 알아봅니다.

Microsoft Office 응용 프로그램 매핑 가이드

신규 SharePoint Designer 사용자   

어떤 SharePoint Designer 2010 에 대 한 모든 작업과 대부분의 조직에서 해당 하는 방법에 알아봅니다.

SharePoint Designer 2010 소개

개인 및 팀용 교육 자료 확인   

이 버전 SharePoint Designer 2010 에 대 한 교육 생산성 향상 됩니다.

Microsoft Office 교육

SharePoint Designer 2010 의 기본 작업

SharePoint 사이트 열기 및 만들기

목록/라이브러리 만들기 및 데이터 원본에 연결

사용자 지정 보기 및 양식 만들기

사용자 지정 워크플로 만들기

사이트 페이지, 마스터 페이지 및 페이지 레이아웃 디자인

서식 파일로 저장

SharePoint 사이트 열기 및 만들기

SharePoint Designer 2010 서버 및 사용자 지정을 시작에서 기존 SharePoint 사이트 열고 SharePoint 사이트 서식 파일 또는 처음부터 사용자 지정 하는 새, 빈 사이트에 따라 새 사이트를 만들 수 있습니다.

사이트 열기

기존 사이트를 열려면 파일 탭을 클릭하고 사이트를 선택한 후에 다음 중 하나를 수행합니다.

  • 사이트 열기를 클릭하여 서버에서 사용 가능한 사이트를 찾습니다.

  • 내 사이트 사용자 지정을 클릭하여 내 사이트를 열고 사용자 지정합니다.

  • 최근에 사용한 사이트에서 이전에 사용했던 사이트를 선택합니다.

사이트 만들기

새 사이트를 만들려면 파일 탭을 클릭하고 사이트를 선택한 후에 다음 중 하나를 실행합니다.

  • 새 웹 사이트를 클릭하여 새 SharePoint 사이트를 만듭니다.

  • 내 사이트에 하위 사이트 추가를 클릭하여 내 사이트 아래에 새 사이트를 만듭니다.

  • 사이트 서식 파일 에서 서식 파일을 기반으로 새 사이트 선택 SharePoint 서식 파일입니다.

참고: 열고 SharePoint Designer 2010 내에서 사이트를 만드는 것 외에도 브라우저를 사용 하 여 SharePoint 사이트 연 후 SharePoint Designer 2010사이트 작업 메뉴, 리본 메뉴 및 SharePoint의 다른 위치에서 사용할 수 있는 링크를 사용 하 여에서 해당 사이트를 엽니다.

맨 위로 이동

목록/라이브러리 만들기 및 데이터 원본에 연결

SharePoint Designer 2010 목록 및 라이브러리를 SharePoint 사이트에 대 한 데이터 원본으로 사용할 일반적으로 만들 수 및 XML 파일, 외부 데이터베이스 및 웹 서비스에 대 한 데이터 원본 연결을 만들 수 있습니다.

SharePoint 목록 및 라이브러리

SharePoint 목록 또는 라이브러리를 만들려면 탐색 창의 목록 및 라이브러리를 클릭한 다음 목록 및 라이브러리 탭에서 다음 옵션 중 하나를 선택합니다.

  • 새 목록을 처음부터 만들려면 사용자 지정 목록을 클릭합니다.

  • SharePoint 목록 서식 파일을 기반으로 목록을 만들려면 SharePoint 목록을 클릭합니다.

  • SharePoint 라이브러리 서식 파일을 기반으로 라이브러리를 만들려면 문서 라이브러리를 클릭합니다.

  • 외부 콘텐츠 형식을 기반으로 외부 목록을 만들려면 외부 목록을 클릭합니다. 외부 콘텐츠 형식에 대해서는 아래에서 설명합니다.

  • 가져온 스프레드시트를 기반으로 목록을 만들려면 스프레드시트에서 목록 만들기를 클릭합니다.

데이터 원본 연결

데이터 원본 연결을 만들려면 탐색 창에서 데이터 원본을 클릭한 다음 데이터 원본 탭에서 다음 옵션 중 하나를 선택합니다.

  • 여러 데이터 원본에 대한 데이터 연결을 만들려면 연결된 데이터 원본을 클릭합니다.

  • OLE DB 또는 ODBC 프로토콜을 지원하는 데이터베이스에 대한 데이터 연결을 만들려면 데이터베이스 연결을 클릭합니다.

  • SOAP(Simple Object Access Protocol)를 사용하는 XML 웹 서비스에 대한 연결을 만들려면 SOAP 서비스 연결을 클릭합니다.

  • REST(Representational State Transfer)를 사용하는 서버 측 스크립트에 대한 연결을 만들려면 REST 서비스 연결을 클릭합니다.

  • XML 원본 파일에 대한 연결을 만들려면 XML 파일 연결을 클릭합니다.

외부 콘텐츠 형식

외부 콘텐츠 형식을 사용하면 외부 비즈니스 데이터 원본에 연결하고 SharePoint 사이트 및 지원되는 클라이언트 응용 프로그램에 이러한 원본을 통합할 수 있습니다. 외부 콘텐츠 형식을 만들고 나면 SharePoint 목록 또는 라이브러리의 데이터와 같은 방식으로 사용자가 상호 작용할 수 있도록 외부 목록을 만들 수 있습니다.

외부 콘텐츠 형식을 만들려면 다음 단계를 수행합니다.

  1. 탐색 창에서 외부 콘텐츠 형식을 클릭합니다.

  2. 외부 콘텐츠 형식 탭에서 외부 콘텐츠 형식을 클릭하고 외부 콘텐츠 형식의 작업, 필드 등을 디자인합니다.

맨 위로 이동

사용자 지정 보기 및 양식 만들기

SharePoint Designer 2010 를 만들면 사용자 지정 보기 및 양식 데이터에 대 한 원본 데이터 읽기 및 쓰기 해당 데이터 원본에 대 한 인터페이스 정말 되기 합니다.

보기

보기는 SharePoint 페이지에 추가할 수 있는 데이터 원본의 라이브 사용자 지정할 수 있는 표시 됩니다. SharePoint Designer 2010 에서 목록 보기 (있음 XSLT 목록 보기 웹 파트를 사용 하 여) 및 (있음 데이터 양식 웹 파트를 사용 하 여) 데이터 뷰를 만들 수 있습니다. 목록이 나 데이터 보기를 만들려면 다음 단계 중 하나를 수행 합니다.

  • 탐색 창에서 목록 및 라이브러리를 클릭하고 보기를 만들 목록을 선택한 다음 목록 설정 탭에서 목록 보기를 클릭합니다.

    참고: 이렇게 하면 목록 또는 라이브러리와 연결되어 있는 보기가 만들어집니다. 그 결과 사용자는 SharePoint 리본 메뉴의 보기 관리 그룹을 사용하여 보기를 표시하고 사용자 지정할 수 있습니다.

  • 탐색 창에서 사이트 페이지를 클릭하고 보기를 만들 페이지를 편집합니다. 그런 다음 삽입 탭을 클릭하고 데이터 보기를 선택한 후에 보기에 사용할 SharePoint 목록 또는 라이브러리를 선택합니다.

양식

폼이를 제출 하려면 사용 하거나 데이터 원본에 다시 작성 하는 데이터 원본을 사용자 지정 가능한 표시 합니다. SharePoint Designer 2010 목록 양식 및 데이터 양식 (사용 하는 데이터 양식 웹 파트)를 만들 수 있습니다. 목록 또는 데이터 폼을 만들려면 다음 단계 중 하나를 수행 합니다.

  • 탐색 창에서 목록 및 라이브러리를 클릭하고 양식을 만들 목록을 선택한 다음 목록 설정 탭에서 목록 양식을 클릭합니다.

  • 탐색 창에서 사이트 페이지를 클릭하고 양식을 만들 페이지를 편집합니다. 그런 다음 삽입 탭을 클릭하고 새 항목 양식, 항목 편집 양식 또는 항목 표시 양식을 선택하고 양식에 사용할 데이터 원본을 선택합니다.

참고: SharePoint Designer 2010 에서 양식 디자인 도구를 사용 하는 것 외에도 만들 수 있으며 Microsoft InfoPath 2010 를 사용 하 여 SharePoint 양식 사용자 지정.

맨 위로 이동

사용자 지정 워크플로 만들기

SharePoint Designer 2010 높은 사용자 지정된 워크플로 사용 하 여 비즈니스 프로세스를 관리할 수 있습니다. 워크플로 휴먼 공동 작업 프로세스 뿐만 아니라 응용 프로그램 프로세스 관리에 사용할 수 있습니다. 워크플로 만들 때 다양 한 옵션 했습니다.

SharePoint Designer 2010 에서 워크플로 만들기

워크플로를 만들 때는 SharePoint 목록 또는 라이브러리를 기반으로 만들 수도 있고, 모든 목록 또는 라이브러리에 적용 가능한 다시 사용할 수 있는 워크플로를 만들 수도 있으며, 사이트 수준에서 작동하는 사이트 워크플로를 만들 수도 있습니다.

이러한 워크플로를 만들려면 탐색 창에서 워크플로를 클릭하고 워크플로 탭에서 다음 단계 중 하나를 수행합니다.

  • 목록형 워크플로를 클릭하고 워크플로를 연결할 목록을 선택합니다.

  • 다시 사용할 수 있는 워크플로를 클릭하여 모든 목록 또는 라이브러리에 연결 가능한 다시 사용할 수 있는 워크플로를 만듭니다.

  • 사이트 워크플로를 클릭하여 사이트 수준에서 적용할 수 있는 워크플로를 만듭니다.

워크플로를 만든 후에는 워크플로 디자이너를 사용하여 해당 워크플로의 조건, 작업 및 단계를 구성합니다. 작업 디자이너를 사용하여 각 작업과 연결된 이벤트를 관리합니다.

Microsoft Visio 2010 에서 워크플로 가져오기

SharePoint Designer 2010 에서 워크플로 만들어 외에도 워크플로 Microsoft Visio 2010 제공 된 워크플로 스텐실 및 템플릿을 사용 하 여에서 디자인을 가져올 수 있습니다.

워크플로를 가져오려면 탐색 창에서 워크플로를 클릭한 다음 워크플로 탭에서 다음 단계를 수행합니다.

  1. Visio에서 가져오기를 클릭하고 파일 시스템이나 SharePoint 문서 라이브러리에서 Visio 워크플로 교환 파일(.vwi)을 찾습니다.

  2. 워크플로를 목록과 연결하거나 다시 사용할 수 있는 워크플로로 지정하고 마침을 클릭합니다.

  3. SharePoint Designer에서 워크플로를 사용자 지정합니다.

맨 위로 이동

사이트 페이지, 마스터 페이지 및 페이지 레이아웃 디자인

SharePoint Designer 2010 만들기 및 사이트 페이지, 마스터 페이지 및 페이지 레이아웃을 사용자 지정할 수 있습니다. 다른 용도로 사용이 페이지의 각 동안 환경 편집 페이지는 비슷합니다. 추가 하 고 텍스트, 이미지, 링크, 테이블, 웹 파트, 서버 컨트롤 등을 제거할 수 있습니다. 스타일 정 및 스타일 시트 계단식 마스터 페이지 및 사이트의 디자인을 변경 하거나 회사 id와 일치 하도록 브랜드를 구성 하려면 페이지 레이아웃에 적용 됩니다.

사이트 페이지

사이트 페이지를 만들려면 탐색 창에서 사이트 페이지를 클릭하고 페이지 탭에서 다음 단계 중 하나를 수행합니다.

  • 웹 파트 페이지를 클릭하여 머리글과 본문 웹 파트가 있으며 사이트 마스터 페이지에 연결되는 페이지를 만듭니다.

  • 페이지를 클릭하고 ASPX 또는 HTML을 선택하여 사이트 마스터 페이지와 연결되지 않는 새 사이트 페이지를 만듭니다.

마스터 페이지

  • 탐색 창에서 마스터 페이지를 클릭한 다음 마스터 페이지 탭에서 새 마스터 페이지를 클릭합니다.

페이지 레이아웃

  • 탐색 창에서 페이지 레이아웃을 클릭하고 페이지 레이아웃 탭에서 새 페이지 레이아웃을 클릭한 다음 페이지 레이아웃의 기준으로 사용할 콘텐츠 형식 그룹 및 이름을 선택합니다.

참고: 마스터 페이지 및 페이지 레이아웃은 기본적으로 사이트 모음 관리자를 제외한 모든 사용자에 대해 사용할 수 없습니다. 보기 또는 마스터 페이지 또는 SharePoint Designer 2010 의 페이지 레이아웃 편집 하는 옵션이 보이지 않으면 다음이 옵션을 사용 하도록 설정 하는 방법에 대 한 사이트 관리자에 게 문의 합니다.

맨 위로 이동

서식 파일로 저장

사이트 사용자 지정을 완료한 후에 사이트 자체 또는 사이트의 일부분을 서식 파일로 저장하면 조직의 다른 사람이 목록, 보기, 워크플로, 사이트 페이지 등을 만드는 데 해당 서식 파일을 사용할 수 있습니다.

또한 서식 파일을 사용해 다른 환경의 사이트(예: 브라우저에 표시된 사이트, Microsoft Visual Studio의 사이트) 또는 다른 사용자의 사이트를 추가로 사용자 지정할 수도 있습니다.

이 기능을 활용할 수 SharePoint Designer 2010 에서 서식 파일로 저장 옵션을 찾습니다.

맨 위로 이동

참고: 기계 번역 고지 사항: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft에서는 비영어권 국가에 거주하는 사용자가 Microsoft 제품, 서비스 및 기술을 손쉽게 접할 수 있도록 이러한 기계 번역 내용을 제공하고 있습니다. 본 문서는 기계 번역된 문서이므로 어휘, 구문 또는 문법에 오류가 있을 수 있습니다.

이 정보가 유용한가요?

개선 사항에 대해 말씀해 주세요.

개선 사항에 대해 말씀해 주세요.

개인 정보를 보호하기 위해 사용자 의견에 연락처 정보를 포함하지 마세요. 검토 요망: 개인정보취급방침.

의견 주셔서 감사합니다!