Excel, Access, SharePoint 사이트, SQL Server 및 기타 외부 원본에서 데이터 가져오기

참고: 사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서가 여기 있습니다.

신속 하 게 가져오기 한 Visio에서 셰이프에 직접 데이터를 표시할 수 있습니다. 드로잉으로 데이터 가져오기 및 데이터 원본에 연결 하는 첫 번째 단계가입니다. 가져온된 데이터를 셰이프에 연결 하는 두 번째 단계가입니다.

1 단계: 데이터 가져오기

첫 번째 단계로, 데이터를 가져오는 데이터 선택 마법사를 사용 합니다.

외부 데이터 창에 표시 되는 데이터 원본 데이터의 스냅숏을 가져오는 시간입니다. 원본 데이터의 변경 내용과 일치 하도록 드로잉의 데이터를 업데이트할 수 있습니다. 그러나 드로잉에서 데이터를 변경 하 여 데이터 원본을 새로 고칠 수 없습니다. 가져온된 데이터 새로 고침을 참조 합니다.

  1. 데이터 탭의 외부 데이터 그룹에서 셰이프에 데이터 연결을 클릭합니다.

  2. 데이터 선택 마법사의 첫 번째 페이지에서 다음 형식의 데이터 원본 사용 하 여 원하는 중를 선택 합니다.

    • Microsoft Excel 통합 문서

    • Microsoft Access 데이터베이스

    • Microsoft SharePoint Foundation 목록

    • Microsoft SQL Server 데이터베이스

    • 기타 OLEDB 또는 ODBC 데이터 원본

    • 이전에 만든 연결

  3. 마법사의 나머지 단계를 완료 합니다.

    참고: 마법사의 첫 번째 페이지에서 Excel 통합 문서, Access 데이터베이스 또는 SharePoint 목록 외 다른 옵션을 선택 하면 있습니다 수 수 일시적으로 데이터 선택 마법사를 완료 하는 과정에서 데이터 연결 마법사입니다.

데이터 연결 마법사의 마지막 페이지에서 완료 를 클릭 한 후 외부 데이터 창이 나타나고 가져온된 데이터가 표에 표시 됩니다.

2 단계: 드로잉의 셰이프에 데이터 행 연결

드로잉의 셰이프에 데이터 행을 연결 하는 방법은 다음 세 가지가: 한 번에 하나씩 기존 셰이프에 행을 연결할 수, 셰이프에 행 자동으로 연결 또는 데이터의 셰이프를 만들 수 있습니다.

방법 1: 한 번에 하나씩 기존 셰이프에 행 연결

이 방법은 셰이프 수가 비교적 적은 기존 드로잉에 가장 적합 합니다.

  • 외부 데이터 창 에서 드로잉의 셰이프 끌어다 놓습니다.

    참고: 외부 데이터 창 보이지 않으면 데이터 탭으로 이동 하 고 표시/숨기기 그룹에서 외부 데이터 창옆에 있는 확인란을 선택 합니다.

    데이터 셰이프를와 링크 아이콘 외부 데이터 창에 있는 행의 왼쪽에 나타납니다.

    셰이프로 행 끌어다 놓기

    참고 사항: 

    • 여러 도형에 단일 행을 연결할 수 있지만 하나의 도형에 여러 행을 연결할 수 없습니다.

    • 를 변경 하거나 셰이프 및 데이터의 모양을 개선 하려면 데이터 그래픽을 사용 하 여 데이터 개선을 참고 합니다.

    • 보기 메뉴에서 외부 데이터 창을 표시 하려면 외부 데이터 창을 클릭 합니다.

방법 2: 기존 셰이프에 자동으로 행을 연결

이 방법은 셰이프 수가 기존 드로잉에 가장 적합 합니다. 셰이프 데이터가 이미에 있는 데이터를 데이터 원본에 일치 시킬 수 있는 경우에 작동 합니다.

  1. Visio 2016 및 최신 버전의: 데이터 메뉴 클릭 모두 새로 고침 하 고 있지 하는 경우 자동 연결 새로 고침 후 선택이 선택 됩니다.

    Visio 2013 및 이전 버전의: 데이터 메뉴에서 자동으로 링크를 클릭 합니다.

  2. 자동 연결 마법사의 단계를 따릅니다.

    셰이프에 데이터가 표시 됩니다. 를 변경 하거나 셰이프 및 데이터의 모양을 개선 하려면 데이터 그래픽을 사용 하 여 데이터 개선을 참고 합니다.

방법 3: 데이터에서 셰이프 만들기

이 방법은 드로잉에서 셰이프를 아직 없는 특정 셰이프를 사용 하 여 필요 하지 않은 경우에 가장 적합 합니다.

  1. 셰이프 창에서 도형을 클릭 합니다.

  2. 드로잉의 빈 공간으로 외부 데이터 창에서 행 또는 행 집합을 끕니다.

    드로잉에 끌어 놓은 각 행에 대해 클릭 하 여 셰이프의 인스턴스 하나가 표시 됩니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×