Excel에서 데이터 모델 만들기

데이터 모델을 사용 하면 여러 테이블의 데이터를 통합 하 여 Excel 통합 문서 내에서 관계형 데이터 원본을 효율적으로 작성할 수 있습니다. Excel 내에서 데이터 모델은 피벗 테이블 및 피벗 차트에 사용 되는 테이블 형식 데이터를 제공 하 여 투명 하 게 사용 됩니다. 데이터 모델은 필드 목록에서 테이블의 컬렉션으로 시각화 되어 있으며, 대부분의 경우 해당 위치에도 알 수 없습니다.

데이터 모델 작업을 시작 하려면 먼저 몇 가지 데이터를 가져와야 합니다. 이를 위해 & 변환 가져오기 (파워 쿼리) 환경을 사용 하 여 한 단계 뒤로 진행 하 여 비디오를 시청 하거나, & 변환 및 Power Pivot의 학습 가이드를 참조 합니다.

파워 피벗은 어디에 있나요?

& 변환 가져오기 (파워 쿼리)는 어디에 있나요?

  • Excel 2016 & Office 365 for & 변환 (파워 쿼리)이 데이터 탭의 excel과 통합 되어 있습니다.

  • Excel 2013 -파워 쿼리는 Excel에 포함 되어 있지만 활성화 되어야 하는 추가 기능입니다. 파일 > 옵션 으로 이동 하 여 추가 기능을 > 한 다음 창 맨 아래에 있는 드롭다운에서 관리 드롭다운 메뉴에서 COM 추가 기능 > 이동을선택 합니다. Microsoft Excel 용 파워 쿼리를 확인 한 다음 확인 을 클릭 하 여 활성화 합니다. 파워 쿼리 탭이 리본 메뉴에 추가 됩니다.

  • Excel 2010 - 파워 쿼리 추가 기능을 다운로드 하 여 설치 합니다.. 활성화 되 면 파워 쿼리 탭이 리본 메뉴에 추가 됩니다.

시작하기

먼저 몇 가지 데이터를 가져와야 합니다.

  1. Excel 2016 및 Excel for Office 365의 경우 데이터를 가져와 데이터를 가져와 텍스트 파일, Excel 통합 문서, 웹 사이트, Microsoft Access, SQL Server 등의 여러 외부 데이터 원본에서 데이터를 가져올 수 있도록 데이터 > > & 변환 관련 된 여러 테이블을 포함 하는 관계형 데이터베이스입니다.

    Excel 2013 및 2010에서 파워 쿼리로 이동 하 > 외부 데이터를 가져오고데이터 원본을 선택 합니다.

  2. Excel에서 표를 선택 하 라는 메시지가 표시 됩니다. 동일한 데이터 원본에서 여러 테이블을 가져오려면 여러 테이블을 선택 하도록 설정 옵션을 선택 합니다. 여러 테이블을 선택 하면 Excel에서 자동으로 데이터 모델을 만듭니다.

    참고: 이 예제에서는 수업 및 성적에 대 한 가공의 학생 정보가 포함 된 Excel 통합 문서를 사용 하 고 있습니다. 학생 데이터 모델 예제 통합 문서를 다운로드 하 고 그에 따라 팔 로우 할 수 있습니다. 완료 된 데이터 모델을 사용 하 여 버전을 다운로드할 수도 있습니다..

    & 변환 (파워 쿼리) 탐색기 가져오기
  3. 테이블을 하나 이상 선택 하 고 로드를 클릭 합니다.

    원본 데이터를 편집 해야 하는 경우에는 편집 옵션을 선택할 수 있습니다. 자세한 정보는 쿼리 편집기 소개 (파워 쿼리)를 참고 하세요.

가져온 모든 테이블이 포함 된 데이터 모델을 사용할 수 있으며 피벗 테이블 필드 목록에 표시 됩니다.

참고 사항: 

  • Excel에서 두 개 이상의 테이블을 동시에 가져올 때 모델이 암시적으로 생성 됩니다.

  • 파워 피벗 추가 기능을 사용 하 여 데이터를 가져오는 경우 모델이 명시적으로 만들어집니다. 추가 기능에서 모델은 Excel과 비슷한 탭 레이아웃으로 표시 되며 각 탭에 표 형식 데이터가 포함 됩니다. SQL Server 데이터베이스를 사용 하 여 데이터 가져오기의 기본 사항에 대 한 자세한 내용은 Power Pivot 추가 기능을 사용 하 여 데이터가져오기를 참조 하세요.

  • 모델에는 단일 테이블이 포함 될 수 있습니다. 하나의 테이블을 기반으로 하는 모델을 만들려면 테이블을 선택 하 고 파워 피벗 에서 데이터 모델에 추가 를 클릭 합니다. 필터링 된 데이터 집합, 계산 된 열, 계산 필드, Kpi, 계층 구조 등의 파워 피벗 기능을 사용 하려는 경우이 작업을 수행할 수 있습니다.

  • 기본 및 외래 키 관계를 사용 하는 관련 테이블을 가져오는 경우 테이블 관계를 자동으로 만들 수 있습니다. 일반적으로 Excel에서는 가져온 관계 정보를 데이터 모델의 테이블 관계에 대 한 기준으로 사용할 수 있습니다.

  • 데이터 모델 크기를 줄이는 방법에 대 한 팁은 Excel 및 Power Pivot을 사용 하 여 메모리 효율적인 데이터 모델 만들기를 참조 하세요.

  • 추가 탐험에 대 한 자세한 내용은 자습서: Excel로 데이터 가져오기 및 데이터 모델 만들기를 참고 하세요.

팁: 통합 문서에 데이터 모델이 있는지 어떻게 알 수 있나요? 파워 피벗파워 피벗관리로 이동 합니다. 워크시트 같은 데이터가 표시 되는 경우 모델이 존재 합니다. 자세한 내용은 통합 문서 데이터 모델에서 사용 되는 데이터 원본 에 대해 자세히 알아보세요.

테이블 간 관계 만들기

다음 단계는 테이블 간의 관계를 만들어 데이터를 가져올 수 있도록 하는 것입니다. 각 테이블에는 기본 키 또는 학생 ID 또는 수업 번호와 같은 고유한 필드 식별자가 있어야 합니다. 가장 쉬운 방법은 해당 필드를 끌어서 놓아 Power Pivot의 다이어그램 보기에서 연결 하는 것입니다.

  1. Power Pivot > 관리로 이동 합니다.

  2. 탭에서 다이어그램 뷰를 선택 합니다.

  3. 가져온 테이블이 모두 표시 되며, 각 테이블에 있는 필드 수에 따라 크기를 조정 하는 데 약간의 시간이 필요할 수 있습니다.

  4. 다음으로 기본 키 필드를 한 테이블에서 다음 테이블로 끕니다. 다음 예는 학생 테이블의 다이어그램 보기입니다.

    파워 쿼리 데이터 모델 관계 다이어그램 보기

    다음 링크를 만들었습니다.

    • tbl_Students | 학생 일련번호 > tbl_Grades | 학생 일련번호

      즉, 학생 번호 필드를 Student 테이블의 학생 ID 필드로 끌어 점수를 입력 합니다.

    • tbl_Semesters | 반기 ID > tbl_Grades | 반기

    • tbl_Classes | 수업 번호 > tbl_Grades | 수업 번호

    참고 사항: 

    • 필드 이름은 관계를 만들기 위해 같을 필요는 없지만 데이터 형식이 동일할 필요는 없습니다.

    • 다이어그램 뷰의 연결선은 한쪽에 "1"이 있고 다른 쪽에는 "*"가 있습니다. 즉, 테이블 간에 일대다 관계가 있고 피벗 테이블에서 데이터를 사용 하는 방법을 결정할 수 있습니다. 자세한 내용은 데이터 모델의 테이블 간 관계 를 참조 하세요.

    • 연결선은 테이블 간에 관계가 있음을 나타냅니다. 서로 연결 된 필드를 실제로 표시 하지는 않습니다. 링크를 보려면 관계 관리> 고급 피벗 > > 디자인 > 관계관리 하세요. Excel에서는 데이터 > 관계로이동할 수 있습니다.

데이터 모델을 사용 하 여 피벗 테이블 또는 피벗 차트 만들기

Excel 통합 문서에는 하나의 데이터 모델만 포함할 수 있지만,이 모델은 통합 문서 전체에서 반복적으로 사용할 수 있는 여러 테이블을 포함 합니다. 언제 든 지 기존 데이터 모델에 테이블을 추가할 수 있습니다.

  1. 파워 피벗에서 관리로 이동 합니다.

  2. 탭에서 피벗 테이블을 선택 합니다.

  3. 피벗 테이블을 삽입할 위치 (새 워크시트 또는 현재 위치)를 선택 합니다.

  4. 확인을 클릭 하면 Excel에서 필드 목록 창이 오른쪽에 표시 된 빈 피벗 테이블을 추가 합니다.

    Power Pivot 피벗 테이블 필드 목록

그런 다음 피벗 테이블을 만들거나피벗 차트를 만듭니다. 테이블 간에 관계를 이미 만든 경우 피벗 테이블에서 해당 필드를 사용할 수 있습니다. 이미 학생 데이터 모델 예제 통합 문서에서 관계를 만들었습니다.

데이터 모델에 기존 관계 없는 데이터 추가

모델에서 사용 하려는 많은 양의 데이터를 가져오거나 복사 했다고 가정 했지만 데이터 모델에 추가 하지 않은 경우 새 데이터를 모델로 푸시하는 것이 생각 보다 쉽습니다.

  1. 먼저 모델에 추가 하려는 데이터 내에서 셀을 선택 합니다. 데이터 범위는 다를 수 있지만 Excel 테이블로 서식이 지정 된 데이터는 가장 적합 합니다.

  2. 다음 방법 중 하나를 사용 하 여 데이터를 추가 합니다.

  3. 파워 피벗파워 피벗데이터 모델에 추가를클릭 합니다.

  4. 피벗 테이블> 삽입 을 클릭 한 다음 피벗 테이블 만들기 대화 상자에서 데이터 모델에이 데이터 추가 를 선택 합니다.

이제 범위 또는 표가 연결 된 테이블로 모델에 추가 됩니다. 모델에서 연결 된 테이블을 사용 하 여 작업 하는 방법에 대 한 자세한 내용은 Power Pivot에서 Excel 연결 테이블을 사용 하 여 데이터 추가를 참조 하세요.

파워 피벗 테이블에 데이터 추가

파워 피벗 Excel 워크시트에서와 같이 새 행을 직접 입력 하 여 표에 행을 추가할 수 없습니다. 그러나 복사 하 여 붙여 넣거나원본 데이터를 업데이트 하 고 Power Pivot 모델을 새로 고치면행을 추가할 수 있습니다.

추가 도움이 필요하세요?

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

참고 항목

& 변형 및 파워 피벗 학습 가이드 가져오기

쿼리 편집기 소개(파워 쿼리)

Excel 및 Power Pivot을 사용 하 여 메모리 효율적인 데이터 모델 만들기

자습서: Excel로 데이터 가져오기 및 데이터 모델 만들기

통합 문서 데이터 모델에서 사용된 데이터 원본 확인

데이터 모델의 테이블 간 관계

참고:  이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 정보가 도움이 되는지 알려주세요. 참조할 수 있는 영문 문서가 여기 있습니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×