로그인

Access 2010의 기본 작업

중요:  본 문서는 기계 번역된 문서이므로 고지 사항을 확인하십시오. 이 문서의 영문 버전은 여기서 확인할 수 있습니다.

다음은 Microsoft Access 2010 를 사용 하는 방법을 배울 수 있도록 하기 위해 수행할 수 있는 몇 가지 기본적인 데이터베이스 작업입니다.

 

이 문서의 내용

Access란?

Access의 관계형 데이터베이스

Access 화면

서식 파일 찾기 및 적용

처음부터 데이터베이스 새로 만들기

기존 Access 데이터베이스 열기

새 데이터베이스를 사용하여 시작하기

표 추가

다른 원본에서 Access 테이블로 데이터 붙여넣기

다른 원본의 데이터 가져오기 또는 연결

다음 단계

스프레드시트나 다른 프로그램에서 데이터 가져오기

Access로 Excel 워크시트 가져오기

새 데이터베이스의 테이블로 Excel 워크시트 가져오기

테이블 분석 마법사를 사용하여 데이터 구성

다른 프로그램에 저장된 데이터 작업

여러 버전의 Access에서 이전 버전의 데이터베이스 사용

여러 버전의 Access에서 Access 데이터베이스 파일 사용

1단계: 기존 데이터베이스의 복사본을 만들어 새 형식으로 저장

2단계: 복사본 데이터베이스를 분할하고 원본 파일을 백 엔드 데이터베이스로 사용

3단계: 원본 데이터베이스에 새 프런트 엔드 연결

여러 버전의 Access에서 프런트 엔드/백 엔드 응용 프로그램 사용

Access란?

Access 2010 데이터베이스 응용 프로그램 디자인 및 배포 도구는 중요 한 정보를 추적 하는 데 사용할 수 있는입니다. 컴퓨터에서 데이터를 그대로 사용 하거나 웹에 게시할 수 등 다른 웹 브라우저와 데이터베이스를 사용할 수 있도록 합니다.

대부분의 사용자는 데이터를 추적하는 데 현재 사용 중인 프로그램이 점점 작업에 적합하지 않은 경우에 Access를 사용하기 시작합니다. 예를 들어 이벤트 계획가는 이벤트를 성공적으로 완료하기 위해 모든 세부 정보를 추적하고 관리해야 합니다. 이러한 작업에 워드 프로세서나 스프레드시트 프로그램을 사용할 수 있지만 데이터가 중복되고 일관성이 없는 문제가 쉽게 발생할 수 있습니다. 또한 일정 소프트웨어를 사용할 수 있지만 일정에서 재무 정보를 추적하는 것은 적절하지 않습니다.

Access의 관계형 데이터베이스

이러한 정보를 추적 하는 관계형 데이터베이스 고치-중복을 제거 하려면 작은 각종 데이터 (테이블)로 구분 되 고 서로 관련 된 데이터의 지식 저장소 정보 (필드 라고 함)의 일반적인 비트 기준입니다. 예를 들어 고객 정보가 들어 있는 표, 공급 업체 정보를 사용 하 여 테이블 및 이벤트 정보로 표는 이벤트 관계형 데이터베이스 계획 포함 될 수 있습니다. 고객 테이블을 관계 필드와 공급 업체 테이블을 관계 필드 이벤트 정보가 포함 된 테이블이 있을 수 있습니다. 이 방법은 예를 들어 공급 업체의 전화 번호 변경 된 경우 정보 수으로 변경할 수 한 번 공급 업체 테이블에서 대신 공급 업체와 관련 된 모든 이벤트입니다.

Access는 정보를 관리하는 데 유용한 관계형 데이터베이스 응용 프로그램을 쉽고 빠르게 개발하는 데 사용할 수 있는 도구입니다. 재고, 실무 담당자, 비즈니스 프로세스 등 거의 모든 종류의 정보를 추적할 수 있는 데이터베이스를 만들 수 있습니다. 실제로 Access에서는 다양한 정보를 추적하는 데 즉시 사용할 수 있는 서식 파일을 제공하며, 이러한 서식 파일은 초보자인 경우에도 쉽게 사용할 수 있습니다.

Access 화면

Access 2010 을 시작 하면 Microsoft Office Backstage 보기, 갖춘 Office.com 의 콘텐츠 보기는 현재 데이터베이스에 대 한 정보, 새 데이터베이스 만들기, 기존 데이터베이스를 열 수 및 위치 표시 합니다.

Access 2010의 Backstage 보기

Backstage 보기에는 데이터베이스를 조정하거나 유지 관리하거나 공유하는 데 사용할 수 있는 다른 많은 명령도 포함되어 있습니다. Backstage 보기의 명령은 일반적으로 데이터베이스에 포함된 개체가 아니라 전체 데이터베이스에 적용됩니다.

참고: 언제든지 파일 탭을 클릭하여 Backstage 보기를 표시할 수 있습니다.

맨 위로 이동

서식 파일 찾기 및 적용

Access에서는 데이터베이스 만들기 프로세스의 속도를 높이는 데 사용할 수 있는 다양한 서식 파일을 제공합니다. 서식 파일은 즉시 사용할 수 있는 데이터베이스로 특정 작업을 수행하는 데 필요한 테이블, 쿼리, 폼 및 보고서를 모두 포함합니다. 이러한 예로 문제를 추적하거나 연락처를 관리하거나 경비에 대한 레코드를 보관하는 데 사용할 수 있는 서식 파일이 있습니다. 일부 서식 파일에는 사용법을 설명하기 위한 몇 가지 예제 레코드가 들어 있습니다. 서식 파일 데이터베이스는 있는 그대로 사용할 수도 있고 필요에 맞게 사용자 지정할 수도 있습니다.

서식 파일을 찾아서 데이터베이스에 적용하려면 다음을 실행합니다.

  1. 파일 탭에서 새로 만들기를 클릭합니다.

  2. 사용 가능한 서식 파일에서 다음 중 하나를 실행합니다.

    • 최근에 사용한 서식 파일을 다시 사용하려면 최근 서식 파일을 클릭한 다음 원하는 서식 파일을 선택합니다.

    • 이미 설치한 서식 파일을 사용하려면 내 서식 파일을 클릭한 다음 원하는 서식 파일을 선택합니다.

    • Office.com, Office.com 서식 파일 에서 서식 파일을 찾으려면 서식 파일 범주를 클릭 하 고 원하는 서식 파일을 선택 컴퓨터에 Office.com에서 서식 파일을 다운로드 하려면 다운로드 를 클릭 합니다.

      참고:  Access 내에서 Office.com의 서식 파일을 검색할 수도 있습니다. Office.com 서식 파일 검색 상자에 검색 용어를 하나 이상 입력한 다음 화살표를 클릭하여 검색합니다.

  3. 또는 파일 이름 상자 옆의 폴더 아이콘을 클릭하여 데이터베이스를 만들려는 위치를 찾습니다. 특정 위치를 지정하지 않으면 파일 이름 상자 아래에 표시되는 기본 위치에 데이터베이스가 만들어집니다.

  4. 만들기를 클릭합니다.

데이터베이스가 만들어진 후 사용할 수 있는 상태로 열립니다.

맨 위로 이동

처음부터 데이터베이스 새로 만들기

참고: Access를 사용하여 데이터베이스를 만드는 작업의 개념에 대한 자세한 내용은 데이터베이스 디자인의 기초 문서를 참고하십시오.

원하는 서식 파일이 없거나 Access에서 사용할 데이터가 다른 프로그램에 있는 경우 처음부터 데이터베이스를 새로 만드는 편이 나을 수도 있습니다. Access 2010에서는 표준 데스크톱 데이터베이스 또는 웹 데이터베이스를 선택할 수 있습니다.

참고: 웹 데이터베이스에 대한 자세한 내용은 웹에서 공유할 데이터베이스 작성 문서를 참고하십시오.

새 데이터베이스를 만들려면 다음을 실행합니다.

  1. Access를 시작합니다.

  2. Backstage 보기의 새로 만들기 탭에서 새 데이터베이스 또는 새 웹 데이터베이스를 클릭합니다.

    중요: 여기에서 선택하는 항목에 따라 데이터베이스에서 사용할 수 있는 기능이 결정됩니다. 데스크톱 데이터베이스는 웹에 게시할 수 없으며, 웹 데이터베이스에서는 합계 쿼리와 같은 일부 데스크톱 기능이 지원되지 않습니다.

  3. 오른쪽의 파일 이름 상자에 데이터베이스 이름을 입력합니다.

    파일을 만들 수 있는 위치를 변경 하려면 파일 이름 상자 옆에 있는 찾아보기 단추 이미지 클릭 이동 하 고 새 위치를 선택한 다음 확인 을 클릭 합니다.

  4. 만들기를 클릭합니다.

    데이터베이스를 만들어져 데이터시트 보기 에서 빈 테이블 (표 1 이라는)를 엽니다.

  5. 새 테이블의 추가하려면 클릭 열의 첫 번째 빈 셀에 커서가 놓입니다.

    데이터를 추가 하려면 입력을 시작-하거나이 문서의 뒷부분에 나오는 Access 테이블에 다른 원본에서 데이터를 붙여 넣을섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수 있습니다.

    참고 사항: 

    • 데이터시트 보기에서의 데이터 입력은 Excel 워크시트에서의 데이터 입력과 매우 비슷합니다. 주요 제한 사항은 데이터시트의 왼쪽 위 모서리에서 시작하여 연속된 행과 열에 데이터를 입력해야 한다는 것입니다. Excel 워크시트에서처럼 빈 행이나 열을 포함하여 데이터의 서식을 지정하려고 하면 테이블 공간이 소모되므로 이렇게 해서는 안 됩니다. 테이블에는 데이터가 포함될 뿐입니다. 해당 데이터의 모든 시각적 표시는 나중에 디자인하는 폼과 보고서에서 수행됩니다.

    • 표 구조 데이터를 입력 하는 동안 만들어집니다. 데이터 시트에 새 열을 추가 하면 언제 든 지 새 필드를 테이블에 정의 되어 있습니다. 입력 하는 데이터 형식에 따라 필드의 데이터 형식 으로 설정 됩니다. 예를 들어 날짜 값만 입력 되어 있는 열이 있는 경우 Access가 해당 필드의 데이터 형식을 날짜/시간을 설정 합니다. 나중에 하려고 하면 해당 필드에 날짜가 아닌 값 (예: 이름 또는 전화 번호)를 입력 하는 경우 값 열의 데이터 형식과 일치 하지 않는 됨을 알리는 메시지가 표시 됩니다. 가능 하면 계획 해야 표의 각 열에 동일한 유형의 데이터를 포함 되도록 텍스트, 날짜, 숫자 또는 기타 형식 인지 합니다. 이렇게 하면 훨씬 더 쉽게 쿼리, 폼 및 원하는 데이터만 선택 하는 보고서를 작성할 수 있습니다.

아직 데이터를 입력 하려면 단추 이미지 닫기를 클릭 합니다.

참고: 저장하지 않고 닫으면 Table1이 삭제됩니다.

맨 위로 이동

기존 Access 데이터베이스 열기

팁: 마지막으로 열어 본 데이터베이스 중 하나를 신속하게 열려면 파일 탭에서 최근을 클릭한 다음 파일 이름을 클릭합니다.

  1. 파일 탭에서 열기를 클릭합니다.

  2. 열기 대화 상자에서 바로 가기를 클릭-하거나 찾는 위치 상자에서 원하는 데이터베이스가 있는 폴더나 드라이브를 클릭 합니다.

  3. 폴더 목록에서 데이터베이스가 포함된 폴더를 열 때까지 폴더를 두 번 클릭합니다.

  4. 데이터베이스를 찾으면 다음 중 하나를 실행합니다.

    • 기본 열기 모드로 데이터베이스를 열려면 데이터베이스를 두 번 클릭합니다.

    • 자신과 다른 사용자가 동시에 읽고 쓸 수 있도록 데이터베이스를 다중 사용자 환경에서 공유 액세스로 열려면 열기를 클릭합니다.

    • 현재 사용자가 볼 수만 있고 편집할 수는 없도록 읽기 전용 모드로 데이터베이스를 열려면 열기 단추 옆의 화살표를 클릭한 다음 읽기 전용으로 열기를 클릭합니다.

    • 현재 사용자가 데이터베이스를 연 동안 다른 사용자가 열 수 없도록 단독 사용 모드로 데이터베이스를 열려면 열기 단추 옆의 화살표를 클릭한 다음 단독으로 열기를 클릭합니다.

    • 데이터베이스를 읽기 전용으로 열려면 열기 단추 옆의 화살표를 클릭하고 단독 읽기 전용으로 열기를 클릭합니다. 그러면 다른 사용자는 해당 데이터베이스를 읽기 전용으로만 열 수 있습니다.

열려는 데이터베이스를 찾을 수 없는 경우   

  1. 열기 대화 상자에서 내 컴퓨터 바로 가기를 클릭-하거나 찾는 위치 상자에서 내 컴퓨터 를 클릭 합니다.

  2. 드라이브 목록에서 데이터베이스가 있을 것으로 예상되는 드라이브를 마우스 오른쪽 단추로 클릭하고 검색을 클릭합니다.

  3. 검색 조건을 입력한 다음 Enter 키를 눌러 데이터베이스를 검색합니다.

  4. 데이터베이스가 발견되면 검색 결과 대화 상자에서 이 데이터베이스를 두 번 클릭하여 엽니다.

    참고: 열기 대화 상자에서 검색이 시작되었으므로 데이터베이스가 열리기 전에 이 대화 상자에서 취소를 클릭해야 합니다.

외부 파일 형식 (예: dBASE, Paradox, Microsoft Exchange 또는 Excel)에서 데이터 파일을 직접 열 수 있습니다. 모든 ODBC 데이터 원본, Microsoft SQL Server 또는 Microsoft FoxPro 같은 직접 열 수 있습니다. 자동으로 새 Access 데이터베이스를 데이터 파일로 같은 폴더에 만들어져 외부 데이터베이스의 각 테이블에 대 한 링크를 추가 합니다.

맨 위로 이동

새 데이터베이스를 사용하여 시작하기

사용한 서식 파일에 따라 새 데이터베이스로 시작하려면 다음 중 하나 이상의 작업을 실행해야 합니다.

  • 사용자 목록이 비어 있는 로그인 대화 상자가 표시되면 다음 절차에 따라 시작합니다.

    1. 새 사용자를 클릭합니다.

    2. 사용자 정보 양식을 작성합니다.

    3. 저장 후 닫기를 클릭합니다.

    4. 방금 입력한 사용자 이름을 선택한 다음 로그인을 클릭합니다.

  • 빈 데이터시트가 표시되면 해당 시트에 직접 데이터를 입력하거나 다른 단추와 탭을 클릭하여 데이터베이스를 탐색할 수 있습니다.

  • 시작 페이지가 표시되면 해당 페이지의 링크를 클릭하여 데이터베이스에 대한 자세한 내용을 확인하거나 다른 단추와 탭을 클릭하여 데이터베이스를 탐색할 수 있습니다.

  • 메시지 표시줄에 보안 경고 메시지가 표시되고 서식 파일의 소스를 신뢰할 수 있는 경우 콘텐츠 사용을 클릭합니다. 데이터베이스에 로그인해야 하는 경우 다시 로그인해야 합니다.

데스크톱 및 웹 데이터베이스 모두 다음 단계 중 하나부터 시작할 수 있습니다.

맨 위로 이동

테이블 추가

만들기 탭의 테이블 그룹에 있는 도구를 사용하여 기존 데이터베이스에 새 테이블을 추가할 수 있습니다.

만들기 탭의 테이블 그룹

참고: 웹 데이터베이스의 테이블 그룹에서는 테이블 명령만 사용할 수 있습니다.

작업을 어떤 보기로 시작하든지 간에 항상 Access 창의 상태 표시줄에서 보기 단추를 사용하여 다른 보기로 전환할 수 있습니다.

데이터 시트 보기에서 빈 테이블 만들기    데이터 시트 보기에서 바로 데이터를 입력 한 액세스 하 여 문서의 표 구조를 만들 수 있습니다. (Field1, Field2, 및 등) 필드 이름은 숫자로 지정 되 고 입력 하는 데이터 형식에 따라 필드 데이터 형식으로 설정 됩니다.

  1. 만들기 탭의 그룹에서 단추 이미지 를 클릭 합니다.

  2. 테이블이 생성된 다음 추가하려면 클릭 열의 첫 번째 빈 셀에 커서가 놓입니다.

  3. 데이터를 추가 하려면 첫 번째 빈 셀에 입력을 시작-하거나이 문서의 뒷부분에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수 있습니다.

    • 열(필드) 이름을 바꾸려면 열 머리글을 두 번 클릭하고 새 이름을 입력합니다.

      팁: 데이터를 보지 않고도 필드의 내용을 알 수 있도록 각 필드에 의미 있는 이름을 지정합니다.

    • 열을 이동하려면 해당 열 머리글을 클릭하여 선택한 다음 원하는 위치에 끌어 놓습니다. 연속된 여러 열을 선택하여 한꺼번에 새 위치에 끌어 놓을 수도 있습니다.

      테이블에 필드를 추가하려면 데이터시트 보기의 추가하려면 클릭 열에서 입력을 시작하거나 필드 탭의 추가 및 삭제 그룹에 있는 명령을 사용하여 새 필드를 추가하면 됩니다.

디자인 보기에서 시작 하는 테이블 만들기    디자인 보기에서 먼저 새 테이블의 구조를 만듭니다. 다음 중 하나 보기로 전환 하면 데이터 시트, 데이터 입력 하거나 폼과 같은 몇 가지 다른 방법을 사용 하 여 데이터를 입력 합니다.

참고: 웹 데이터베이스의 테이블에는 디자인 보기를 사용할 수 없습니다.

  1. 만들기 탭의 그룹에서 표 디자인 을 클릭 합니다. 단추 이미지

  2. 테이블의 각 필드에 대해 필드 이름 열에 이름을 입력하고 데이터 형식 목록에서 데이터 형식을 선택합니다.

  3. 설명 열에 각 필드에 대한 추가 정보를 입력할 수 있습니다. 입력한 설명은 해당 필드에 입력 포인터를 놓을 때 상태 표시줄에 표시되며 필드 목록 창에서 폼이나 보고서로 필드를 끌어서 만든 컨트롤과 폼 마법사나 보고서 마법사로 해당 필드에 대해 만든 컨트롤의 상태 표시줄 텍스트로 사용됩니다.

  4. 모든 필드를 추가한 후 테이블을 저장합니다.

    • 파일 탭에서 저장을 클릭합니다.

  5. 데이터시트 보기로 전환한 다음 첫 번째 빈 셀을 클릭하고 데이터를 입력하여 언제든지 테이블에 데이터를 입력할 수 있습니다. 다음 섹션에서 설명한 대로 다른 원본의 데이터를 붙여 넣을 수도 있습니다.

SharePoint 목록에 따라 테이블 만들기    SharePoint 목록을 사용 하 여 데이터에 액세스 권한이 없는 사용자가 사용할 수 있습니다. 또한 목록 데이터는 일반적으로 데스크톱 컴퓨터에 저장 된 파일을 보다 데이터 손실에 대해 더 나은 보호 기능을 제공 하는 서버에 저장 됩니다. 새 목록 사용 하 여 시작 하거나 기존 목록에 연결할 수 있습니다. 목록, 만들려는 SharePoint 사이트에서 충분 한 권한이 있어야 합니다. 사이트 문의 옵션에 대 한 세부 정보 SharePoint 관리자에 게 문의 하 여 다를 수 있습니다.

참고: 이 기능은 웹 데이터베이스에서 사용할 수 없습니다.

  1. 만들기 탭의 테이블 그룹에서 SharePoint 목록을 클릭합니다.

  2. 목록 서식 파일 중 하나를 사용하여 연락처 또는 이벤트와 같은 표준 SharePoint 목록을 만들 수 있습니다.

    또한 사용자 지정 목록을 만들도록 선택할 수 있으며, 기존 목록에 연결하거나 기존 목록을 가져오도록 선택할 수도 있습니다. 원하는 옵션을 클릭합니다.

  3. 목록 서식 파일을 선택하거나 사용자 지정 목록을 만들도록 선택한 경우 프로세스를 안내하는 새 목록 만들기 대화 상자가 열리고, 기존 목록을 사용하도록 선택한 경우 작업을 도와주는 외부 데이터 가져오기 대화 상자가 열립니다.

테이블에 대한 자세한 내용은 테이블 소개 문서를 참고하십시오.

맨 위로 이동

다른 원본에서 Access 테이블로 데이터 붙여넣기

데이터가 Excel 등의 다른 프로그램에 저장되어 있는 경우 해당 데이터를 복사하여 Access 테이블에 붙여 넣을 수 있습니다. 일반적으로 Excel 워크시트와 같이 데이터가 이미 열로 구분되어 있는 경우 이 작업을 가장 효과적으로 실행할 수 있습니다. 데이터가 워드 프로세싱 프로그램에 있는 경우에는 먼저 워드 프로세싱 프로그램에서 탭 문자를 사용하여 데이터 열을 구분하거나 데이터를 테이블로 변환한 다음 데이터를 복사해야 합니다. 전체 이름을 이름과 성으로 구분하는 등 데이터를 편집 또는 조작해야 하는 경우에는 데이터를 복사하기 전에 해당 작업을 실행하는 것이 좋으며 특히 Access 사용이 익숙하지 않은 경우에는 데이터를 복사하기 전에 이러한 작업을 실행하는 것이 좋습니다.

데이터를 빈 테이블에 붙여 넣으면 필드에 있는 데이터의 종류에 따라 각 필드의 데이터 형식이 설정됩니다. 예를 들어 붙여 넣은 필드에 날짜 값만 들어 있으면 해당 필드에는 날짜/시간 데이터 형식이 적용됩니다. 붙여 넣은 필드에 "예"와 "아니요"라는 단어만 들어 있으면 해당 필드에는 예/아니요 데이터 형식이 적용됩니다.

붙여 넣은 데이터의 첫 번째 행 내용에 따라 필드 이름이 지정됩니다. 붙여 넣은 데이터의 첫 번째 행 형식이 다음 행과 비슷하면 해당 행은 데이터의 일부로 간주되고 Field1, Field2 등의 일반적인 이름이 필드에 지정됩니다. 붙여 넣은 데이터의 첫 번째 행이 다음 행과 비슷하지 않은 경우에는 첫 번째 행이 필드 이름으로 사용되고 실제 데이터에서 제외됩니다.

일반적인 필드 이름이 지정될 경우 혼동을 피하려면 다음 절차를 따라 가능한 한 빨리 필드 이름을 바꿔야 합니다.

  1. 파일 탭에서 저장을 클릭하여 테이블을 저장합니다.

  2. 데이터시트 보기에서 각 열 머리글을 두 번 클릭한 다음 열 이름을 입력합니다.

  3. 테이블을 다시 저장합니다.

맨 위로 이동

다른 원본의 데이터 가져오기 또는 연결

Access에서 사용하기 위해 다른 프로그램의 데이터를 수집해야 할 수 있습니다. 예를 들어 다른 프로그램에서 데이터를 저장한 사용자와 함께 작업하면서 해당 사용자의 데이터를 Access에서 사용하려는 경우 또는 여러 데이터 원본이 분산되어 있어 자세한 분석을 위해 이러한 데이터 원본을 함께 모아 둘 "공간"이 필요한 경우 등이 여기에 해당됩니다.

Access에서는 어떤 경우든 다른 프로그램의 데이터를 쉽게 가져오거나 연결할 수 있습니다. Excel 워크시트, 다른 Access 데이터베이스의 테이블, SharePoint 목록 및 기타 다양한 원본에서 데이터를 가져올 수 있습니다. 프로세스는 데이터 원본에 따라 약간씩 다르지만 다음 지침에 따라 시작할 수 있습니다.

  1. 외부 데이터 탭의 가져오기 및 연결 그룹에서 가져올 파일 형식에 해당하는 명령을 클릭합니다.

    예를 들어 Excel 워크시트에서 데이터를 가져오려면 Excel을 클릭합니다. 올바른 프로그램 종류가 표시되지 않으면 기타를 클릭합니다.

    참고: 가져오기 및 연결 그룹에서 올바른 형식을 찾을 수 없는 원래 데이터를 만든 프로그램을 시작 하 고 다음 해당 프로그램을 사용 하 여 데이터 (예: 한 분리된 텍스트 파일 ), Access에서 지 원하는 파일 형식으로 저장 한 다음 가져오거나 데이터에 연결 해야 합니다.

  2. 외부 데이터 가져오기 대화 상자에서 찾아보기를 클릭하여 원본 데이터 파일로 이동하거나 파일 이름 상자에 원본 데이터 파일의 전체 경로를 입력합니다.

  3. 현재 데이터베이스에서 데이터를 저장할 방법과 위치를 지정하십시오.에서 원하는 옵션을 클릭합니다. 가져온 데이터를 사용하여 새 테이블을 만들거나 데이터 원본에 대한 연결을 유지하는 연결된 테이블을 만들 수 있습니다.

  4. 확인을 클릭합니다.

    선택 항목에 따라 개체 연결 대화 상자 또는 개체 가져오기 대화 상자가 열립니다.

  5. 대화 상자를 사용하여 프로세스를 완료합니다. 따라야 할 정확한 절차는 선택한 가져오기 또는 연결 옵션에 따라 다릅니다.

  6. 마법사의 마지막 페이지에서 마침을 클릭합니다.

    가져오기를 선택한 경우 방금 마친 가져오기 작업의 세부 정보를 저장할 것인지 묻는 메시지가 표시됩니다.

  7. 이와 같은 가져오기 작업을 다시 수행할 것으로 판단되면 가져오기 단계 저장을 클릭하고 세부 정보를 입력합니다.

    그런 다음 외부 데이터 탭의 가져오기 그룹에 있는 저장된 데이터 가져오기를 클릭하고 가져오기 설정을 클릭한 다음 실행을 클릭하여 가져오기 작업을 손쉽게 다시 수행할 수 있습니다.

  8. 작업 정보를 저장하지 않으려면 닫기를 클릭합니다.

Access에서 데이터를 새 테이블로 가져온 다음 탐색 창의 테이블 아래에 해당 테이블을 표시합니다.

데이터를 Access로 가져오는 방법에 대한 자세한 내용을 보려면 이 문서의 관련 정보 섹션에 있는 링크를 참고하십시오.

맨 위로 이동

다음 단계

디자인 프로세스의 나머지 과정은 원하는 목표에 따라 다르지만 일반적으로 쿼리, 폼, 보고서 및 매크로를 만드는 방법을 알아두는 것이 좋습니다. 이 문서에서는 추가 데이터베이스 개체를 만드는 방법에 대한 정보는 제공하지 않습니다.

자세한 내용은 다음 문서를 참고하십시오.

맨 위로 이동

스프레드시트나 다른 프로그램에서 데이터 가져오기

다른 데이터베이스나 스프레드시트 프로그램에 익숙하면 아마도 해당 응용 프로그램의 작동 방식과 사용하는 데이터베이스에 대한 기본 사항을 알고 있을 것입니다. Access는 관계형 데이터베이스를 만들 수 있다는 점에서 다른 여러 데이터베이스 응용 프로그램과 다르며 정교한 쿼리, 폼 및 보고서를 개발할 수 있는 도구를 제공한다는 점에서 대부분의 스프레드시트 프로그램과 다릅니다. 또한 Access에서는 SQL Server와 같은 다른 데이터베이스 프로그램과 함께 작업하기 위한 많은 옵션도 제공합니다.

Access로 Excel 워크시트 가져오기

대부분의 사용자가 Excel에서 목록을 작성한 후 Access 탐색을 시작합니다. Excel은 목록을 시작하기에 좋은 프로그램이지만 목록이 커질수록 해당 목록을 구성하고 업데이트된 내용을 유지하기가 점점 더 어려워집니다. 일반적으로 목록을 Access로 이동하는 것이 다음 논리적 단계입니다.

데이터베이스 테이블은 행과 열에 데이터가 저장되는 워크시트와 구조가 비슷합니다. 따라서 일반적으로 워크시트를 데이터베이스 테이블로 쉽게 가져올 수 있습니다. 데이터를 워크시트에 저장하는 것과 데이터베이스에 저장하는 것의 주된 차이점은 데이터를 구성하는 방식에 있습니다. 전체 워크시트를 데이터베이스의 새 테이블로 가져오기만 해서는 데이터 구성 및 업데이트와 관련된 문제가 해결되지 않는데, 특히 워크시트에 중복 데이터가 포함된 경우에 그렇습니다. 이러한 문제를 해결하려면 테이블마다 관련 데이터가 포함되도록 스프레드시트 데이터를 별개의 테이블로 분할해야 합니다. 테이블의 데이터를 정렬하는 방법에 대한 자세한 내용은 데이터베이스 디자인의 기초 문서를 참고하십시오.

Access에는 이 작업을 완료하는 데 유용한 테이블 분석 마법사가 있습니다. 데이터를 테이블로 가져온 후 이 마법사를 통해 다른 테이블에 중복되지 않은 데이터가 포함된 별개의 테이블로 테이블을 분할할 수 있습니다. 이 마법사는 테이블 간에 필요한 관계도 만듭니다.

맨 위로 이동

새 데이터베이스의 테이블로 Excel 워크시트 가져오기

  1. 파일 탭에서 새로 만들기를 클릭한 다음 새 데이터베이스를 클릭합니다.

  2. 파일 이름 상자에 새 데이터베이스의 이름을 입력한 다음 만들기를 클릭합니다.

    새 데이터베이스가 열리고 Table1이라는 새 테이블이 만들어집니다.

  3. Table1을 닫습니다.

    Table1 디자인의 변경 내용을 저장할 것인지 묻는 메시지가 표시되면 아니요를 클릭합니다.

  4. 외부 데이터 탭의 가져오기 및 연결 그룹에서 Excel 을 클릭 합니다. 단추 이미지

  5. 외부 데이터 가져오기 대화 상자에서 찾아보기를 클릭합니다.

  6. 파일 열기 대화 상자를 사용하여 파일을 찾습니다.

  7. 파일을 선택한 다음 열기를 클릭합니다.

  8. 외부 데이터 가져오기 대화 상자에서 현재 데이터베이스의 새 테이블로 원본 데이터 가져오기 옵션이 선택되어 있는지 확인합니다.

  9. 확인을 클릭합니다.

    스프레드시트 가져오기 마법사가 시작되고 데이터에 대한 몇 가지 질문이 표시됩니다.

  10. 다음이나 뒤로를 클릭하여 페이지 사이를 이동하면서 지시를 따릅니다. 마법사의 마지막 페이지에서 마침을 클릭합니다.

    참고: 방금 마친 가져오기 작업의 세부 정보를 저장할 것인지 묻는 메시지가 표시됩니다. 이와 같은 가져오기 작업을 다시 수행할 것으로 판단되면 를 클릭한 다음 세부 정보를 입력합니다. 그런 다음 외부 데이터 탭의 가져오기 그룹에서 저장된 데이터 가져오기를 클릭하여 나중에 해당 작업을 손쉽게 다시 수행할 수 있습니다. 작업 정보를 저장하지 않으려면 닫기를 클릭합니다.

Access에서 데이터를 새 테이블로 가져온 다음 탐색 창의 모든 테이블 아래에 해당 테이블을 표시합니다.

맨 위로 이동

테이블 분석 마법사를 사용하여 데이터 구성

데이터를 Access 테이블로 가져온 후 테이블 분석 마법사를 사용하여 중복되는 데이터를 빠르게 식별할 수 있습니다. 그런 다음 이 마법사를 통해 데이터를 별개의 테이블로 간단하게 구성하여 가장 효율적인 방법으로 저장할 수 있습니다. 이 경우 원본 테이블이 백업으로 유지된 다음 데이터베이스 응용 프로그램의 기초로 사용할 수 있는 새 테이블이 생성됩니다.

  1. 분석할 테이블이 포함된 Access 데이터베이스를 엽니다.

  2. 분석 그룹에 있는 데이터베이스 도구 탭에서 테이블 분석을 클릭합니다.

    테이블 분석 마법사가 시작됩니다.

    마법사의 처음 두 페이지에 대 한 간단한 자습서 포함-완성 된 예제를 보려면 클릭할 수 있는 단추가 있습니다. 안내 페이지 표시 되지 않지만 대신 이라는 확인란을 참조 하는 경우 안내 페이지 표시? 확인란을 선택한 다음 다시 소개를 참조를 두 번 클릭 합니다. 페이지를 보려면 소개 소개 내용을 읽은 후에 다시 않으려면를 지울 수 있습니다를 안내 페이지 표시? 확인란 합니다.

  3. 여러 레코드에서 반복되는 값이 있는 필드가 어떤 테이블에 있습니까? 페이지에서 분석할 테이블을 선택하고 다음을 클릭합니다.

  4. 어떤 테이블에 어떤 필드를 넣을 것인지 마법사가 결정하도록 할 수도 있고 사용자가 직접 결정할 수도 있습니다. 마법사의 제안 내용을 따를 경우에도 마법사의 다음 페이지에서 테이블의 레이아웃을 변경할 수 있습니다.

    참고: 어떤 테이블에 어떤 필드를 넣을 것인지 마법사가 결정하도록 할 경우 해당 선택이 데이터에 적합하지 않을 수도 있는데, 특히 작업할 데이터가 많지 않은 경우에 이러한 문제가 발생합니다. 따라서 마법사의 결과를 신중하게 확인해야 합니다. 반면에 마법사가 제안한 구성이 사용자 결정보다 더 효율적일 수 있으므로 마법사의 결정 내용을 한 번 이상 시도해 보는 것이 좋습니다. 제안 내용이 마음에 들지 않으면 수동으로 필드를 다시 정렬할 수 있고 언제든지 뒤로를 클릭하여 직접 모든 필드를 정렬할 수 있습니다.

  5. 다음을 클릭합니다. 이 페이지에서 어떤 테이블에 어떤 필드를 포함할 것인지 지정합니다. 마법사가 결정하도록 선택한 경우 관계선으로 연결된 여러 테이블이 표시됩니다. 마법사가 결정하도록 선택하지 않은 경우 모든 필드가 포함된 테이블 하나만 생성됩니다. 어느 경우든지 이 페이지에서 변경할 수 있습니다.

    • 테이블에서 페이지의 빈 영역으로 필드를 끌어 해당 필드가 포함된 새 테이블을 만들 수 있습니다. 테이블 이름을 묻는 메시지가 표시됩니다.

    • 특정 테이블의 필드를 보다 효율적으로 저장하기 위해 적합한 다른 테이블로 끌어 놓을 수 있습니다.

    • 대부분의 테이블에는 ID 또는 고유 ID가 만들어졌습니다. 필드가 지정됩니다. ID 필드에 대한 자세한 내용을 보려면 마법사의 오른쪽 위 모서리에서 을 클릭합니다.

    • 변경을 취소하려면 실행 취소 단추를 클릭합니다.

    • 테이블의 이름을 바꾸려면 제목 표시줄을 두 번 클릭하고 새 이름을 입력한 다음 확인을 클릭합니다.

  6. 필드가 원하는 방식으로 정렬되면 다음을 클릭합니다.

  7. 값이 매우 비슷한 레코드가 있으면 해당 값이 가능한 인쇄상 오류로 식별되고 이 레코드에 대해 수행할 작업을 확인할 수 있는 화면이 표시됩니다. 목록에서 스크롤하여 수정 열에 이러한 값이 있는 항목을 찾은 다음 드롭다운 목록에서 해당 항목을 클릭합니다. 마법사가 값을 변경하지 못하도록 하려면 (그대로 유지)를 선택합니다. 작업을 마쳤으면 다음을 클릭합니다.

  8. 원본 테이블과 비슷한 쿼리를 만들 것인지 묻는 메시지가 표시됩니다. 이미 원본 테이블을 기초로 하는 폼과 보고서를 작성한 경우에는 쿼리를 만드는 것이 좋습니다. 예, 쿼리를 만듭니다.를 선택하면 테이블 이름에 "_OLD"가 추가되어 원본 테이블의 이름이 바뀐 다음 원본 테이블의 이름으로 새 쿼리의 이름이 지정됩니다. 테이블을 기초로 하는 폼과 보고서는 이제 해당 데이터에 대해 쿼리를 사용하고 계속해서 이전과 마찬가지로 작동합니다.

  9. 마침을 클릭합니다.

    지정한 대로 새 테이블이 생성된 다음 열립니다. 결과를 모두 확인한 후 테이블을 닫습니다.

맨 위로 이동

다른 프로그램에 저장된 데이터 작업

Access 2010에서는 다른 프로그램에 저장된 데이터로 작업하기 위한 기능을 제공합니다.

다른 파일 형식에서 데이터에 연결 하는 새 Access 데이터베이스 만들기    텍스트나 dBASE, 스프레드시트와 같은 다른 파일 형식으로 파일을 열에 대 한 액세스를 사용할 수 있습니다. 자동으로 Access 데이터베이스 만들어져 하면 파일에 연결 합니다.

  1. Access를 시작합니다.

  2. 파일 탭에서 열기를 클릭합니다.

  3. 열기 대화 상자의 목록에서 열려는 파일 형식을 클릭합니다. 파일 형식을 모르겠으면 모든 파일 (*.*)을 클릭합니다.

  4. 필요한 경우 열려는 파일이 포함된 폴더로 이동한 다음 파일을 찾으면 두 번 클릭하여 엽니다.

  5. 마법사의 지시를 따릅니다. 마법사의 마지막 페이지에서 마침을 클릭합니다.

기존 Access 데이터베이스로 데이터 가져오기 또는 연결    Access 파일 내 데이터에 포함 하거나 연결할 수 있습니다 데이터를 Access에서 Access 파일) (외부 원본 파일의 데이터가 하 게 유지 되도록 되도록 Access 테이블에 다른 원본 및 프로그램에서 데이터 가져오기 중 하나입니다.

  1. 외부 데이터 탭의 가져오기 및 연결 그룹에서 데이터가 저장된 형식을 클릭합니다.

    다음 원본에서 데이터를 가져오거나 연결할 수 있습니다.

    • Excel    워크시트 또는 Excel 통합 문서에서 명명된 된 범위에서 데이터를 가져올 수 있습니다. 각 워크시트 또는 명명 된 범위를 가져온 하거나 별도로 연결 해야 합니다.

    • 액세스    분할 데이터베이스를 만드는 데이터에서 프로세스를 구분 하는 경우 매우 유용 합니다. 즉, 모든 폼, 보고서 및 매크로 포함 하도록 하나의 데이터베이스를 사용할 수 있으며 다른 데이터베이스에 데이터를 유지. 그런 다음 누군가의 작업을 중단 없이 향상 된 기능을 개발할 수 있습니다. 하나를 손쉽게 데이터를 요약 하 부서 또는 비즈니스 파트너 사이 여러 다른 Access 데이터베이스에서 데이터를 결합할 수 있습니다.

    • ODBC 데이터베이스    많은 프로그램 많은 데이터베이스 서버 제품을 포함 하 여이 형식에서 지원 됩니다. 이렇게 하면 서로 다른 시스템에서 데이터를 결합 하면 "방문 패드" 데이터베이스를 만들 수 있습니다.

    • 텍스트 파일    간단한 텍스트 파일에 연결할 수 있으며 해당 파일의 내용을 변경 하려면 Access 사용할 수도 있습니다. 데이터에 액세스 하는 다양 한 프로그램에서 사용 하기 쉬운 확인 하는 데 도움이 됩니다.

    • XML 파일    또한이 형식 일부 웹 서버를 포함 하 여 다른 프로그램의 다양 한와의 호환성을 제공 합니다.

    • SharePoint 목록    이렇게 하면 데이터를 웹 브라우저에서 SharePoint 목록을 사용 하 여 표준 방식으로 사용할 수 없습니다.

    • 데이터 서비스    회사 내부 웹 데이터 서비스에 연결할 수 있습니다.

    • HTML 문서   

    • Outlook 폴더    데이터의 나머지 부분과 연락처 정보를 보다 쉽게 통합 되므로 Outlook 폴더에 연결할 수 있습니다.

    • dBase 파일    dBase은 Access에서 지원 되는 인기 대체 데이터베이스 시스템

      외부 데이터 가져오기 대화 상자가 나타납니다.

  2. 대화 상자의 지시를 따릅니다.

    데이터를 데이터베이스로 가져오거나 데이터가 데이터베이스에 연결됩니다. 대부분 형식의 경우 데이터 위치를 지정한 다음 데이터베이스에서 데이터를 저장할 방법을 선택해야 합니다.

맨 위로 이동

여러 버전의 Access에서 이전 버전의 데이터베이스 사용

Access 데이터베이스 또는 Access 프로젝트 Access 2000 이상에서 만든 데이터베이스 또는 프로젝트 버전의 Access에서 만들어진 또는 그 이상 버전에서 사용할 수 등의 파일 보안 기능을 사용할 경우에 있습니다. 예를 들어, Access 2000 파일 Access 2000, Access 2002, Access 2003, Access 2007과 Access 2010에서 사용할 수 있습니다.

이전 버전의 Access에서 데이터를 유지 하려고 하는데 해당 데이터에 연결 되지만 여전히 활용 이후 버전의 기능 중 일부를 최신 버전의 Access에서 사용자가 있는 상황을 할 수 있습니다. 솔루션 (폼, 보고서, 쿼리, 매크로, 하지만 테이블이 포함) 이상 버전에서 새 "프런트 엔드" 데이터베이스를 만들고 이전 버전 파일의 테이블에 연결 하는 것입니다. 데이터베이스 파일 하나에 포함 되어 있는지 아니면 프런트 엔드/백 엔드 응용 프로그램 으로 분할 이미 있는지 여부에 따라 다음 절차 중 하나를 사용 합니다.

여러 버전의 Access에서 Access 데이터베이스 파일 사용

Access 데이터베이스 이전 버전의 모든 테이블, 폼 및 기타 개체가 한 파일에 들어 있고 여러 버전의 Access에서 해당 데이터베이스를 사용하려면 이후 버전에서 프런트 엔드 데이터베이스를 새로 만들고 이를 원본 파일에 연결합니다. 이전 버전의 Access 사용자는 여전히 원본 데이터베이스를 사용할 수 있고, 이후 버전의 사용자는 새 프런트 엔드 데이터베이스를 사용하여 같은 데이터에 연결할 수 있습니다. 또한 여러 버전의 Access를 사용해야 하는 경우 여러 프런트 엔드 버전을 만들 수 있습니다.

맨 위로 이동

1단계: 기존 데이터베이스의 복사본을 만들어 새 형식으로 저장

다음 절차를 따라 데이터베이스를 최신 형식인 Access 2000, Access 2002-2003 또는 Access 2007 데이터베이스 중 하나로 변환합니다. 이렇게 하면 원래 형식으로 원본 데이터베이스가 유지되고 지정한 형식으로 복사본이 생성됩니다.

  1. Access 파일을 닫습니다. 파일이 서버나 공유 폴더에 있는 다중 사용자(공유) Access 데이터베이스인 경우 다른 사용자가 열지 않았는지 확인합니다.

  2. Access 2010을 시작합니다.

  3. 파일 탭에서 열기를 클릭합니다.

  4. 변환할 파일의 위치로 이동한 다음 해당 파일을 두 번 클릭하여 엽니다.

    참고: 데이터베이스의 기능을 업그레이드할지 묻는 데이터베이스 기능 향상 대화 상자가 나타나면 아니요를 클릭합니다.

  5. 데이터베이스를 시작할 때 폼이 열리면 해당 폼을 닫습니다.

  6. 파일 탭에서 다른 이름으로 데이터베이스 저장을 클릭합니다.

  7. 다른 이름으로 저장 대화 상자에서 새 데이터베이스의 이름을 입력합니다.

    참고: 새 데이터베이스를 다른 위치에 저장하려는 경우가 아니면 데이터베이스 이름은 원래 데이터베이스 이름과 달라야 합니다. 일반적으로 프런트 엔드 데이터베이스와 백 엔드 데이터베이스를 쉽게 구분할 수 있도록 다른 이름을 사용하는 것이 가장 좋습니다. 그러나 Access 2007 형식으로 변환하는 경우 파일 확장명이 .mdb에서 .accdb로 바뀌므로 같은 파일 이름을 사용할 수 있습니다.

  8. 저장을 클릭합니다.

맨 위로 이동

2단계: 복사본 데이터베이스를 분할하고 원본 파일을 백 엔드 데이터베이스로 사용

다음 절차를 따라 변환된 데이터베이스를 분할합니다.

  • 데이터베이스 도구 탭의 데이터 이동 그룹에서 Access 데이터베이스 를 클릭 합니다. 단추 이미지

  • 데이터베이스 분할 대화 상자에서 데이터베이스 분할을 클릭합니다.

    참고: 필요한 경우 백업을 만들 수 있지만 원본 데이터베이스를 사용하여 복사본을 다시 만들 수도 있습니다.

  • 백 엔드 데이터베이스의 이름을 입력하고 분할을 클릭합니다.

맨 위로 이동

3단계: 원본 데이터베이스에 새 프런트 엔드 연결

  1. 데이터베이스 분할 도구로 만든 백 엔드 데이터베이스를 삭제-하지 않도록 주의 해야 원래 데이터베이스를 삭제 합니다.

  2. 원래 데이터베이스의 테이블에 새 프런트 엔드 데이터베이스를 연결: 외부 데이터 탭의 가져오기 및 연결 그룹에서 연결 테이블 관리자 를 클릭 합니다. 단추 이미지

  3. 모두 선택을 클릭한 다음 새 위치 항상 확인 확인란을 선택합니다.

  4. 확인을 클릭하고 이전 버전의 데이터베이스로 이동한 다음 해당 데이터베이스를 두 번 클릭합니다.

    모든 작업이 성공적으로 실행되면 선택한 연결된 테이블을 모두 최신 정보로 고쳤다는 내용의 메시지가 표시됩니다.

이제 새 버전의 Access가 있는 사용자를 위해 새로운 기능을 지원하도록 새 프런트 엔드 데이터베이스를 개선할 수 있습니다. 이전 버전 사용자는 계속해서 이전 버전의 데이터베이스를 사용할 수 있습니다.

맨 위로 이동

여러 버전의 Access에서 프런트 엔드/백 엔드 응용 프로그램 사용

Access 데이터베이스 프런트 엔드/백 엔드 응용 프로그램 이미 있으면 프런트 엔드 새 파일 형식으로 변환할 수 있습니다. 변경이 백 엔드 데이터베이스에 대 한 필요 하지 않은 합니다.

다음 절차에서는 다른 이름으로 데이터베이스 저장 명령을 사용하여 프런트 엔드 데이터베이스를 최신 형식인 Access 2000, Access 2002-2003 또는 Access 2007 데이터베이스 중 하나로 변환하는 방법을 보여 줍니다. 이렇게 하면 원래 형식으로 원본 데이터베이스가 유지되고 지정한 형식으로 복사본이 생성됩니다.

  1. 프런트 엔드 데이터베이스를 닫습니다. 파일이 서버나 공유 폴더에 있는 다중 사용자(공유) Access 데이터베이스인 경우 다른 사용자가 열지 않았는지 확인합니다.

  2. Access 2010을 시작합니다.

  3. 파일 탭에서 열기를 클릭합니다.

  4. 프런트 엔드 데이터베이스의 위치로 이동한 다음 해당 데이터베이스를 두 번 클릭하여 엽니다.

    참고: 데이터베이스의 기능을 업그레이드할지 묻는 데이터베이스 기능 향상 대화 상자가 나타나면 아니요를 클릭합니다.

  5. 데이터베이스를 열 때 폼이 나타나면 해당 폼을 닫습니다.

  6. 파일 탭에서 다른 이름으로 데이터베이스 저장을 클릭합니다.

  7. 다른 이름으로 저장 대화 상자에서 새 데이터베이스의 이름을 입력합니다.

  8. 저장을 클릭합니다.

이제 새로운 기능을 지원하도록 새 프런트 엔드 데이터베이스를 개선할 수 있습니다.

맨 위로 이동

참고: 기계 번역 고지 사항: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft에서는 비영어권 국가에 거주하는 사용자가 Microsoft 제품, 서비스 및 기술을 손쉽게 접할 수 있도록 이러한 기계 번역 내용을 제공하고 있습니다. 본 문서는 기계 번역된 문서이므로 어휘, 구문 또는 문법에 오류가 있을 수 있습니다.



이 정보가 유용한가요?

개선 사항에 대해 말씀해 주세요.

개선 사항에 대해 말씀해 주세요.

개인 정보를 보호하기 위해 사용자 의견에 연락처 정보를 포함하지 마세요. 검토 요망: 개인정보취급방침.

의견 주셔서 감사합니다!