4단계 - 다른 사람과 매크로 공유

매크로 공유 시 반드시 알아야 할 점은 매크로는 Office 파일에 저장되므로 다른 사용자와 공유하기 위해서는 해당 파일을 공유해야 한다는 점입니다. Word에서 매크로를 만든 경우 파일을 Word 매크로 사용 서식 파일(.dotm) 또는 Word 매크로 사용 문서(.docm)로 공유해야 합니다. Excel에서 매크로를 만든 경우 파일을 Excel 매크로 사용 통합 문서(.xlsm) 또는 Excel 매크로 사용 서식 파일(.xltm)로 공유해야 합니다.

Word 매크로를 만든 경우, 매크로를 공유하기 위해서는 몇 가지 단계를 더 거쳐야 합니다.

비어 있는 Word 서식 파일 만들기

  1. 새 Word 문서를 엽니다.

  2. 파일 메뉴에서 다른 이름으로 저장을 클릭합니다.

  3. 파일의 이름을 global_macros.dotm으로 지정합니다.

  4. 형식 드롭다운 메뉴에서 Word 매크로 사용 서식 파일(*.dotm)을 형식으로 지정합니다.

  5. 네트워크에서 파일을 저장할 위치를 선택합니다.

  6. 저장을 클릭한 다음 서식 파일을 닫습니다.

문서에서 Word 매크로 내보내기

1단계에서 기록한 매크로에서 다음 단계를 수행하여 매크로를 내보냅니다.

  1. 내보내려는 매크로가 포함된 문서 또는 서식 파일을 엽니다.

  2. 도구 메뉴에서 매크로를 가리킨 다음 매크로를 클릭합니다.

  3. 내보내려는 매크로를 선택한 다음 편집을 클릭합니다. 내보낼 매크로 선택

  4. Visual Basic Editor에서 파일 > 파일 내보내기를 클릭합니다.

  5. 매크로 사용 서식 파일인 global_macros.dotm과 동일한 폴더에 매크로를 저장합니다.

비어 있는 새 서식 파일로 Word 매크로 가져오기

  1. global_macros.dotm을 연 다음 도구 > 매크로 > Visual Basic Editor를 클릭합니다.

  2. 매크로를 가져오려면 파일 > 파일 가져오기를 클릭하고 매크로를 내보낸 폴더로 이동하여 해당 파일을 선택한 다음 열기를 클릭합니다.

  3. 모듈을 저장하고 Visual Basic Editor를 종료한 다음 Word를 종료합니다.

이제 다른 사람과 매크로를 공유할 수 있으며 아래 단계를 따라 해당 컴퓨터에 매크로를 설치하도록 알려줄 수 있습니다.

서식 파일 설치: 매크로를 사용하도록 Word 설정

  1. global_macros.dotm 파일을 다음 위치에 놓습니다.

    • Word for Mac 2011: Macintosh HD: Users: Username: Library: Application Support: Microsoft: Office: User Templates: My Templates

    • Windows Word 2003 이상: C:\Documents and Settings\Username\Application Data\Microsoft\Word\STARTUP

      참고:  여기에서 Username은 사용자의 로그온 이름입니다.

  2. Word에서 Word > 기본 설정…을 클릭합니다.

Word 기본 설정

  1. 개인 설정 섹션에서 파일 위치를 클릭합니다. 

  2. 파일 위치 목록에서 시작을 선택하고 수정…을 클릭합니다.

파일 위치

  1. Word가 global_macro.dotm 파일이 있는 폴더를 시작 폴더로 사용하는지 확인합니다.

  2. 선택을 클릭하여 폴더 선택 대화 상자를 닫은 다음 확인을 클릭하여 파일 위치 대화 상자를 닫습니다.

마지막 단계는 Word를 시작할 때 global_macros.dotm 파일을 사용하도록 설정하는 것입니다.

  1. Word에서 도구 > 서식 파일 및 추가 기능…을 클릭합니다.

  2. 목록에서 global_macros.dotm 파일을 선택한 다음 확인을 클릭합니다.

    팁:  목록에 서식 파일이 없다면 global_macros.dotm 파일이 Word 시작 폴더에 없는 것입니다. 이 섹션의 1단계로 돌아가 Startup 폴더가 global_macros.dotm 파일을 복사한 폴더와 동일한지 확인합니다.

Word에서 전역 서식 파일 설정

 1단계 - 매크로 기록 시작

2단계 - 코드 읽기 및 이해

3단계 - 프로그래밍 기본 사항 배우기

4단계 - 다른 사람과 매크로 공유

5단계 - 예제

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×