여러 테이블을 사용하여 피벗 테이블 만들기

여러 테이블을 사용하여 피벗 테이블 만들기

피벗 테이블은 데이터에 대해 분석 및 보고를 수행하는 데 매우 유용합니다. 데이터가 서로 관련이 있는 경우, 즉 공통된 값으로 가져올 수 있는 개별 테이블에 저장된 경우 다음과 같은 피벗 테이블을 몇 분만에 만들 수 있습니다.

여러 개의 표가 포함된 피벗 테이블

이 피벗 테이블은 무엇이 다를까요? 오른쪽의 필드 목록은 한 개의 테이블만 표시하는 것이 아니라 테이블 모음을 표시합니다. 테이블마다 한 피벗 테이블에 결합 가능한 필드가 있어 데이터를 다양한 방법으로 나눌 수 있습니다. 직접 서식을 지정하거나 데이터를 준비할 필요가 없습니다. 데이터를 가져오는 즉시 관련 테이블을 기반으로 피벗 테이블을 작성할 수 있습니다.

피벗 테이블 필드 목록에 여러 테이블을 포함하려면 다음을 수행합니다.

  • Microsoft SQL Server, Oracle 또는 Microsoft Access와 같은 관계형 데이터베이스에서 테이블을 가져옵니다. 여러 테이블을 동시에 가져올 수 있습니다.

  • 텍스트 파일, 데이터 피드, Excel 워크시트 데이터를 비롯한 다른 데이터 원본에서 여러 테이블을 가져옵니다. 이러한 테이블을 Excel의 데이터 모델에 추가하고 서로 간의 관계를 만든 다음 데이터 모델을 사용하여 피벗 테이블을 만들 수 있습니다.

다음 방법으로 SQL Server 데이터베이스에서 여러 테이블을 가져올 수 있습니다.

  1. 서버 이름, 데이터베이스 이름, SQL Server에 연결할 때 사용할 자격 증명을 알고 있어야 합니다. 필요한 정보는 데이터베이스 관리자에게 문의하여 얻을 수 있습니다.

  2. 데이터 > 외부 데이터 가져오기 > 기타 원본에서 > SQL Server를 클릭합니다.

  3. 서버 이름 상자에 SQL Server를 실행하는 컴퓨터의 네트워크 컴퓨터 이름을 입력합니다.

  4. 로그온 자격 증명 상자에서 사용자 자신으로 연결하려면 Windows 인증 사용을 클릭합니다. 그 밖의 경우에는 데이터베이스 관리자가 제공한 사용자 이름 및 암호를 입력합니다.

  5. Enter 키를 누르고 데이터베이스 및 테이블 선택 상자에서 데이터베이스를 선택한 다음 여러 테이블 선택 사용을 클릭합니다.

    여러 테이블 선택 사용 확인란

  6. 작업에 사용할 테이블을 정확하게 알고 있다면 수동으로 선택합니다. 그렇지 않으면 테이블을 한두 개 고른 다음 관련 테이블 선택을 클릭합니다. 그러면 선택한 항목과 관련된 테이블이 자동으로 선택됩니다.

  7. 선택한 테이블 간 관계 가져오기 확인란이 선택되어 있다면 Excel에서 통합 문서에 해당하는 테이블 관계가 다시 만들어질 수 있도록 그대로 둡니다.

  8. 마침을 클릭합니다.

  9. 데이터 가져오기 대화 상자에서 피벗 테이블 보고서를 선택합니다.

    가져오기 옵션 대화 상자

  10. 확인을 클릭하여 필드 목록을 가져오고 채우기 시작합니다.

필드 목록에 여러 테이블이 포함되어 있는 것을 확인할 수 있습니다. 이러한 테이블은 모두 가져오기 중에 사용자가 선택한 것입니다. 각 테이블을 확장하고 축소하여 해당 필드를 확인할 수 있습니다. 테이블에 관련성이 있는 한 테이블에 있는 필드를 , 또는 영역으로 끌어와 피벗 테이블을 만들 수 있습니다.

피벗 테이블 필드 목록

  • 숫자 필드를 값 영역으로 끕니다. 예를 들어 극동 무역 (주) 예제 데이터베이스를 사용 중이라면 인터넷_판매 표에서 판매액을 끌어옵니다.

  • 매출을 날짜나 지역별로 분석하려면 날짜 또는 지역 필드를 또는 영역으로 끕니다.

  • 경우에 따라서는 두 표 사이에 관계를 만들어야 피벗 테이블에서 사용할 수 있습니다. 관계가 필요하다는 메시지가 나타나면 만들기를 클릭하여 시작합니다.

    관계가 필요하면 만들기 단추가 표시됩니다.

    다른 유형의 데이터베이스로 작업하는 경우

다른 원본에서 테이블 가져오기

SQL Server뿐 아니라 여러 다른 관계형 데이터베이스에서도 테이블을 가져올 수 있습니다.

관계형 데이터베이스 외에도 다른 데이터 원본을 사용해 피벗 테이블 필드 목록에서 여러 표를 작업할 수 있습니다. 통합 문서의 테이블을 사용하거나 데이터 피드를 가져와 통합 문서에 있는 다른 테이블의 데이터와 통합할 수도 있습니다. 관련이 없는 이 모든 데이터를 함께 사용하려면 각 테이블을 데이터 모델에 추가한 다음 일치하는 필드 값을 사용해 테이블 간에 관계를 만들어야 합니다.

데이터 모델을 사용하여 새 피벗 테이블 만들기

데이터 모델의 테이블 간 관계를 만들었으면 이 데이터를 분석에 사용할 준비가 된 것입니다. 다음 방법으로 통합 문서에서 데이터 모델을 사용하여 새 피벗 테이블 또는 피벗 차트를 만들 수 있습니다.

  1. 워크시트에서 아무 셀이나 클릭합니다.

  2. 삽입 > 피벗 테이블을 클릭합니다.

    삽입 탭의 피벗 테이블 단추

  3. 피벗 테이블 만들기 대화 상자의 분석할 데이터를 선택하십시오에서 외부 데이터 원본 사용을 클릭합니다.

    외부 데이터 원본 사용이 선택된 피벗 테이블 만들기 대화 상자

  4. 연결 선택을 클릭합니다.

  5. 테이블 탭의 이 통합 문서 데이터 모델에서 통합 문서 데이터 모델의 테이블을 선택합니다.
    데이터 모델의 테이블

  6. 열기를 클릭한 다음 확인을 클릭하여 데이터 모델의 모든 테이블이 포함된 필드 목록을 표시합니다.

피벗 테이블과 데이터 모델에 대한 추가 정보

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×