피벗 테이블 데이터 새로 고침

참고: 사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서가 여기 있습니다.

언제든지 새로 고침을 클릭하여 통합 문서에서 피벗 테이블의 데이터를 업데이트할 수 있습니다. 데이터베이스(SQL Server, Oracle, Access 등), Analysis Services 큐브, 데이터 피드, 기타 다양한 원본 등의 외부 데이터에 연결된 피벗 테이블의 데이터를 새로 고칠 수 있습니다. 같거나 다른 통합 문서에서 원본 테이블의 데이터를 새로 고칠 수도 있습니다. 또한 통합 문서를 열 때 자동으로 해당 피벗 테이블 데이터를 새로 고치도록 설정할 수 있습니다.

기본적으로 피벗 테이블 자동으로 고치지는 있지만 피벗 테이블 피벗 테이블이 포함 된 통합 문서를 열 때 새로 고침 자동으로 지정할 수 있습니다.

수동으로 새로 고침

  1. 피벗 테이블에서 아무 곳이나 클릭하여 리본 메뉴에 피벗 테이블 도구를 표시합니다.

    피벗 테이블 도구

  2. 분석 > 새로 고침을 클릭하거나 Alt+F5를 누릅니다.

    분석 탭의 새로 고침 단추

    팁: 통합 문서의 모든 피벗 테이블을 한 번에 업데이트 하려면 분석 을 클릭 > 모두 새로 고침 합니다.

새로 고치는 데 생각보다 시간이 많이 걸리면 분석 > 새로 고침 화살표 > 새로 고침 상태를 클릭하여 새로 고침 상태를 확인합니다.

새로 고침을 중지하려면 새로 고침 취소를 클릭합니다.

열 너비와 셀 서식이 조정되지 않도록 방지

피벗 테이블 데이터를 새로 고칠 때 데이터의 열 너비와 셀 서식이 조정되지 않도록 하려면 다음 옵션을 선택합니다.

  1. 분석 > 옵션을 클릭합니다.

    분석 탭의 옵션 단추

  2. 레이아웃 및 서식 탭에서 업데이트 시 열 자동 맞춤업데이트 시 셀 서식 유지 확인란을 선택합니다.

통합 문서를 열 때 자동으로 데이터 새로 고침

  1. 피벗 테이블에서 아무 곳이나 클릭하여 리본 메뉴에 피벗 테이블 도구를 표시합니다.

    피벗 테이블 도구

  2. 분석 > 옵션을 클릭합니다.

    분석 탭의 옵션 단추

  3. 데이터 탭에서 파일을 열 때 데이터 새로 고침 상자를 선택 합니다.

수동으로 새로 고침

  1. 피벗 테이블에서 아무 곳이나 클릭합니다.

    피벗 테이블 도구, 옵션디자인 탭 추가 표시 합니다.

  2. 옵션 탭의 데이터 그룹에서 다음 중 하나를 실행 합니다.

  3. 데이터 원본과 일치 하는 정보를 업데이트 하려면 새로 고침 단추를 클릭 하거나 ALT + f 5를 누릅니다.

    또한 피벗 테이블을 마우스 오른쪽 단추로 클릭 한 다음 새로 고침을 클릭 수 있습니다.

  4. 통합 문서의 모든 피벗 테이블을 새로 고치려면 새로 고침 단추 화살표를 클릭 하 고 모두 새로 고침 을 클릭 합니다.

    Excel 리본 메뉴 이미지

    예상 보다 긴 시간이 새로 고침을 클릭 옵션 > 새로 고침 > 새로 고침 상태를 확인 하려면 새로 고침 상태 입니다.

    새로 고침을 중지하려면 새로 고침 취소를 클릭합니다.

열 너비와 셀 서식이 조정되지 않도록 방지

피벗 테이블 데이터를 새로 고칠 때 데이터의 열 너비와 셀 서식이 조정되지 않도록 하려면 다음 옵션을 선택합니다.

  1. 옵션 > 옵션 입니다.

    피벗 테이블 도구의 옵션 탭에 있는 피벗 테이블 그룹
  2. 레이아웃 및 서식 탭에서 업데이트 시 열 자동 맞춤업데이트 시 셀 서식 유지 확인란을 선택합니다.

통합 문서를 열 때 자동으로 피벗 테이블 데이터 새로 고침

  1. 피벗 테이블에서 아무 곳이나 클릭합니다.

  2. 옵션 탭의 피벗 테이블 그룹에서 옵션을 클릭합니다.

    피벗 테이블 도구의 옵션 탭에 있는 피벗 테이블 그룹

  3. 피벗 테이블 옵션 대화 상자의 데이터 탭에서 파일을 열 때 데이터 새로 고침 확인란을 선택 합니다.

피벗 테이블 데이터 원본에 새 데이터를 추가 하는 경우 해당 데이터 원본에서 작성 된 모든 피벗 테이블 새로 고칠 수 있어야 합니다. 피벗 테이블을 새로 고치려면 피벗 테이블 범위에서 아무 곳 이나 마우스 오른쪽 단추로 클릭 다음 새로 고침 을 선택할 수 있습니다.

추가 지원

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×