프로젝트에서 작업 연결

참고: 사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서가 여기 있습니다.

프로젝트의 두 작업을 연결 하 여 관계 (작업 의존 관계 라고도 함)를 표시할 수 있습니다. 의존 관계 드라이브 작업을 연결한 후에는 선행 작업에 대 한 모든 변경 내용이 후속 작업에 영향을 주며, 그 다음에 영향을 주는 방식으로 작업을 수행 합니다.

실행할 작업

작업 연결

  1. > Gantt 차트보기 를 선택 합니다.

    보기 탭의 작업 보기 그룹

  2. Ctrl 키를 누른 채 (작업 이름 열에서) 연결할 두 작업을 선택합니다.

  3. 작업 > 연결 작업을 선택 합니다.

    작업 탭의 일정 그룹에 있는 링크 단추

연결을 제거 하려면 연결 된 두 작업을 선택한 다음 작업 > 작업 연결 끊기 리본 메뉴의 작업 탭에 있는 작업 연결 끊기 단추 을 선택 합니다.

Project에서는 기본적으로 두 번째 작업 ( _z0z_)을 시작할 수 있을 때까지 첫 번째 작업 ( 선행 작업)을 마쳐야 함을 의미 하는 간단한 완료 후 시작 작업 연결이 만들어집니다.

Project Online 구독자의 경우 선행 작업 또는 후속 작업 열의 드롭다운 상자를 사용 하 여 연결할 특정 작업을 선택할 수도 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 선행 작업 또는 후속 작업 열을 찾고 연결 하려는 작업의 셀을 선택 합니다.

    참고: 후속 작업 열은 기본적으로 표시 되지 않습니다. 이를 표시 하려면 행의 마지막 열로 이동 하 여 새 열 추가를 선택 합니다. 후속 작업을 선택 합니다.

  3. 모든 작업의 계층 구조 목록에서 위쪽 또는 아래쪽으로 스크롤하여 원하는 작업을 찾고 옆에 있는 확인란을 선택한 다음 드롭다운 상자 바깥쪽의 아무 곳 이나 클릭 합니다. 연결 하려는 작업의 작업 ID가 셀에 표시 됩니다.

드롭다운에서 링크를 선택 하면 연결 하려는 작업이 연결 하려는 작업에 가까이에 있지 않은 경우에 특히 유용 합니다.

연결된 작업 사이에 작업 삽입

연결된 작업 사이에 새 작업을 삽입하면 새 작업이 주위의 작업과 자동으로 연결되도록 Project를 설정할 수 있습니다.

  1. 파일 > 옵션을 선택합니다.

  2. 프로젝트 옵션 대화 상자에서 일정 을 선택 하 고 이 프로젝트의 일정 옵션 섹션으로 스크롤합니다.

  3. 삽입하거나 이동한 작업을 자동 연결 확인란을 선택합니다.

  4. 새 작업을 삽입합니다.

네트워크 다이어그램에서 작업 연결

  1. > 네트워크 다이어그램보기 를 선택 합니다.

    보기 탭의 네트워크 다이어그램 단추 이미지

  2. 선행 작업 상자의 가운데를 가리킵니다.

  3. 선을 후속 작업 상자로 끕니다.

    네트워크 다이어그램에 연결 된 두 작업의 이미지

달력에서 작업 연결

  1. 보기 > 일정을 선택합니다.

    보기 탭, 작업 보기 그룹, 일정 단추

  2. 선행 작업의 달력 막대를 가리킵니다.

  3. 선을 후속 작업의 달력 막대로 끕니다.

수동 일정 예약 작업 연결

수동 일정 예약 작업을 다른 작업에 연결할 경우 수동 일정 예약 작업이 다른 작업을 기준으로 이동합니다.

다음과 같이 수동 일정 예약 작업이 다른 작업에 연결될 때 이동하지 않도록 Project를 구성할 수 있습니다.

  1. 파일 > 옵션을 선택합니다.

  2. 프로젝트 옵션 대화 상자에서 일정 을 선택 하 고 이 프로젝트의 일정 옵션 섹션으로 스크롤합니다.

  3. 연결을 편집할 때 수동 일정 예약 작업 업데이트 확인란의 선택을 취소 합니다.

수동 및 자동 일정 예약 작업에 대해 자세히 알아보세요.

작업을 연결하는 다른 방법

  • 전체 프로젝트의 완료 여부에 따라 달라지는 작업이 있다면 마스터 프로젝트 설정을 고려하세요.

  • 단일 작업이 다른 작업과 연결된 방식을 확인하려면 작업 경로를 사용하세요.

맨 위로 이동

작업 의존 관계 변경 또는 제거

작업을 연결 하 여 작업 의존 관계 비교를 만들면 필요한 경우 다음 중 하나를 실행 하 여 종속성을 쉽게 변경 하거나 제거할 수 있습니다.

작업 의존 관계의 연결 형식 변경

기본적으로 Project에서는 작업을 완료 후 시작 의존 관계에 연결 합니다. 그러나 작업 정보 대화 상자의 고급 탭에서 작업 의존 관계 유형을 쉽게 변경할 수 있습니다. 작업 정보 대화 상자를 열려면 링크 형식을 변경할 작업의 이름을 두 번 클릭 합니다.

참고: 프로젝트를 사용할 수 있는 경우 외부 작업에 대 한 링크를 두 번 클릭 하 여 작업을 포함 하는 프로젝트를 엽니다. 외부 연결 작업은 작업 목록에서 흐리게 표시 됩니다. 외부 작업에 대 한 연결 형식을 수정 하려면 외부 연결 된 작업을 두 번 클릭 하 여 작업을 포함 하는 프로젝트를 연 후 다음을 실행 하 여 연결 된 작업을 수정 합니다. 예를 들어 project Z의 작업 A를 project 5의 작업 1에 연결한 경우 작업 1의 작업 정보에서 연결 종류를 수정할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 변경 하려는 연결선을 두 번 클릭 합니다.

    연결선을 두 번 클릭 합니다.

    단추 이미지

    링크 형식을 변경 하려면 여기를 두 번 클릭 합니다.

  3. 작업 의존 관계 유형을 변경 하려면 종류 목록에서 다른 종류를 선택 합니다.

다른 작업에 연결

현재 잘못 된 작업에 연결 된 작업이 있는 경우 올바른 의존 관계를 반영 하도록 쉽게 링크를 수정할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 작업 목록에서 링크를 변경할 작업을 선택 합니다.

  3. 작업 탭의 속성 그룹에서 정보를 선택 합니다.

  4. 선행 작업 탭의 작업 이름 열에서 연결 하지 않을 작업을 선택한 다음 목록에서 작업을 선택 하 여 올바른 종속성을 식별 합니다.

  5. typelag 열에서 연결 유형, 지연 기간 또는 겹치는 기간을 수정 합니다.

    팁: 겹치는 기간을 입력 하려면 지연 열에 음수 값을 입력 합니다 (예: 2 일 동안 -2 ).

작업에 대 한 모든 종속성 제거

작업이 더 이상 다른 작업에 종속 되지 않는 경우 작업의 모든 종속성을 한 번에 제거할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 작업 이름 필드에서 연결을 끊을 작업을 선택 합니다.

    연속적으로 나열 되지 않은 여러 작업을 선택 하려면 CTRL 키를 누른 채 각 작업을 선택 합니다. 연속적으로 나열 된 작업을 선택 하려면 첫 번째 작업을 선택 하 고 SHIFT 키를 누른 채 목록에서 선택 하려는 마지막 작업을 선택 합니다.

  3. 작업 탭의 일정 그룹에서 작업 연결 끊기를선택 합니다.

    다른 작업이 나 제약 조건에 대 한 연결을 기준으로 작업의 일정이 재조정 됩니다.

참고: 작업 연결을 제거 하면 작업 간 연결선으로 표시 되는 두 작업 간의 의존 관계가 제거 됩니다. 프로젝트에 대 한 개요 구조의 일부로 작업 또는 하위 작업의 계층 구조를 변경 하려는 경우 작업 연결을 제거 하는 대신 작업을 한 수준 올려야 합니다.

특정 작업 의존 관계 제거

작업이 여러 작업에 연결 되어 있고 특정 연결을 제거 해야 하는 경우 작업 정보 대화 상자에서 제거할 링크를 선택할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 작업 목록에서 종속성을 제거할 작업을 선택 합니다.

  3. 작업 탭의 속성 그룹에서 정보를 선택 합니다.

  4. 선행 작업 탭에서 제거할 의존 관계를 선택 하 고 delete 키를 누릅니다.

문제 해결

작업을 연결 했지만 후속 작업이 이동 하지 않는 경우 다음과 같은 여러 원인이 있을 수 있습니다.

  • 작업에 실제 시작 날짜 또는 작업 완료율 등의 실제 적용이 있으면 작업을 실제로 시작한 날짜 보다 일찍 일정을 재조정할 수 없습니다. 진행 상황을 입력 하지 않고 작업에 유연성이 제한가 있으면 제약 조건이 _z0z_보다 우선적으로 적용 될 수 있습니다.

    예를 들어 작업의 시작 날짜 이전 (SNET) 제한이 7 월 1 일로 설정 되어 있는 경우, 작업은 해당 날짜에 연결 되며, 이전 날짜로 전환 되 고,이는 선행 작업 가 6 월 28 일에 끝나고 후속 작업이 7 월 1 일 이전에 시작할 수 있는 경우에도 이전 날짜로 일정이 조정 되지 않습니다.

  • Project에서 Gantt 차트 보기의 차트 부분에 포인터를 끌어 작업을 만들면 시작 날짜를 기준으로 일정이 잡힌 프로젝트에 대 한 작업에 ' 이후에 시작 (SNET) ' 제한이 설정 됩니다. 완료 날짜에서 예약 된 프로젝트의 경우에는 작업에 ' 이후에 완료 (하면 fnlt) ' 제한이 설정 됩니다.

  • 후속 작업이 완료 되 면 링크를 반영 하기 위해 이동 되지 않습니다.

몇 가지 가능한 해결 방법은 다음과 같습니다.

  • 작업 제한을 더 유연 하 게 다시 설정 하려면 작업을 선택 하 고 정보를 선택한 다음 고급 탭을 선택 합니다. 제한 종류 목록에서 가능한 한 빨리를선택 합니다. 그런 다음 작업 의존 관계에 따라 작업의 시작 날짜를 예약 합니다.

  • 작업 의존 관계가 모든 작업에 대 한 고정적인 제한 사항을 무시 하도록 하려면 파일 > 옵션 > 일정을 선택 합니다. 일정 옵션 구역에서 작업의 제한 날짜가 항상 우선 확인란의 선택을 취소 합니다.

해당 지침은 Microsoft Project 2007에 적용됩니다.

실행할 작업

작업 연결

Project에서는 기본적으로 완료 후 시작 연결로 작업을 연결합니다. 그러나 모든 상황에서는 완료 후 시작 연결이 작동 하지 않습니다. project에서는 프로젝트를 현실적으로 모델링할 수 있도록 추가 작업 링크 유형을 제공 합니다.

연결 종류

예제

설명

완료 후 시작(FS)

완료 후 시작 연결 이미지

종속 작업 (B)은 종속 된 작업 (A)이 완료 되어야만 시작할 수 있습니다.

예를 들어 "심층적 토대" 및 "콘크리트 타설" 작업을 사용 하는 경우 "콘크리트 타설" 작업이 완료 될 때까지 "콘크리트 타설" 작업을 시작할 수 없습니다.

동시 시작(SS)

시작 연결 이미지

종속 작업 (B)은 시작 시에 의존 하는 작업 (a)이 시작 될 때까지 시작할 수 없습니다.

종속 작업은 작업이 시작 되는 작업 후에 언제 든 지 시작할 수 있습니다. SS 연결 형식에 두 작업이 동시에 시작 되지 않아도 됩니다.

예를 들어 "콘크리트 타설"과 "콘크리트 고르기"라는 두 가지 작업이 있을 경우 "콘크리트 고르기" 작업은 "콘크리트 타설" 작업이 시작되어야 시작할 수 있습니다.

동시 완료(FF)

완료 후 작업 연결 이미지

작업 B는 작업 A에 의존하고 있으며 작업 A가 완료되어야 완료할 수 있습니다.

의존 관계가 있는 작업이 완료 되 면 언제 든 지 종속 작업을 완료할 수 있습니다. FF 연결 형식에는 두 작업을 동시에 완료할 필요가 없습니다.

예를 들어 "배선 추가" 및 "전기 검사" 작업을 수행 하는 경우 "전선 추가" 작업이 완료 될 때까지 "전기 점검" 작업을 완료할 수 없습니다.

시작 후 완료(SF)

완료 후 시작 작업 연결 이미지

작업 B는 작업 A에 의존하고 있으며 작업 A가 시작되어야 완료할 수 있습니다.

의존 관계가 있는 작업이 시작 되 면 언제 든 지 작업을 완료할 수 있습니다. SF 연결 종류에서 한 작업의 시작 시점이 그 작업에 의존하는 작업의 완료 시점과 같아야 할 필요는 없습니다.

예를 들어 건설 프로젝트에 대 한 지붕 지붕 usses는 오프 사이트로 빌드됩니다. 프로젝트의 두 가지 작업은 "Truss 배송" 및 "지붕 조립"입니다. "Truss 배송" 작업이 시작 될 때까지 "지붕 조립" 작업을 완료할 수 없습니다.

연결 된 작업 사이에 작업을 삽입할 때 새 작업을 자동으로 연결 하거나 연결 하지 않을 수 있습니다.

  • 새 작업을 연결 하려면 새 작업을 추가할 작업을 선택한 다음 삽입 메뉴에서 새 작업 을 선택 합니다.

    참고: 이 문제가 해결 되지 않으면 도구 메뉴에서 옵션을 선택한 다음 일정 탭을 선택 합니다. 삽입 하거나 이동한 작업 을 자동 연결 확인란이 선택 되어 있는지 확인 합니다.

  • 새 작업을 연결 하지 않고 추가 하려면 새 작업을 동시에 수행할 작업을 선택한 다음 끌어서 네트워크 다이어그램의 빈 영역에서 새 작업을 만듭니다.

Gantt 차트 보기를 사용 하 여 작업 연결

  1. 보기 메뉴에서 Gantt 차트를 선택 합니다.

  2. 작업 이름 필드에서 연결 하려는 순서 대로 둘 이상의 작업을 선택 합니다.

    • 인접 하지 않은 작업을 선택 하려면 CTRL 키를 누른 채로 연결 하려는 작업을 선택 합니다.

    • 인접 한 작업을 선택 하려면 SHIFT 키를 누른 채로 연결 하려는 첫 번째 작업과 마지막 작업을 선택 합니다.

  3. 작업 연결 단추 이미지 을 선택 합니다.

    Project에서는 기본적으로 완료 후 시작 작업 연결이 만들어집니다. 이 작업 연결을 동시 시작, 동시 완료 또는 시작 후 완료로 변경할 수 있습니다.

네트워크 다이어그램 보기를 사용 하 여 작업 연결

  1. 보기 메뉴에서 네트워크 다이어그램을 선택 합니다.

  2. 선행 작업 상자 가운데에 포인터를 놓습니다.

  3. 후속 작업 상자로 끕니다.

일정 보기를 사용 하 여 작업 연결

  1. 보기 메뉴에서 일정을 선택 합니다.

  2. 선행 작업의 달력 표시줄에 포인터를 놓습니다.

  3. 후속 작업의 일정 표시줄로 끕니다.

autolinking 켜거나 끕니다.

기본적으로 연결 된 작업 사이에 작업을 삽입 하면 새 작업은 자동으로 주위의 작업과 연결 됩니다. 예를 들어 완료 후 시작 연결이 있는 세 개의 작업이 있고 그 사이에 새 작업을 추가 하는 경우 새 작업은 위/아래 작업과의 완료 후 시작 연결을 사용 합니다.

새 작업을 삽입 해도 자동으로 주위 작업과 자동으로 연결 되지 않도록이 옵션을 쉽게 해제할 수 있습니다. autolinking을 끄면 쉽게 다시 켤 수 있습니다.

  1. 도구 메뉴에서 옵션을 선택한 다음 일정 탭을 선택 합니다.

  2. autolinking 해제 하려면 삽입 하거나 이동한 작업 을 자동 연결 확인란의 선택을 취소 합니다.

    autolinking를 설정 하려면 삽입 하거나 이동한 작업 을 자동 연결 확인란을 선택 합니다.

맨 위로 이동

작업 의존 관계 변경 또는 제거

작업을 연결 하 여 작업 의존 관계 비교를 만들면 필요한 경우 다음 중 하나를 실행 하 여 종속성을 쉽게 변경 하거나 제거할 수 있습니다.

작업 의존 관계의 연결 형식 변경

기본적으로 Project에서는 작업을 완료 후 시작 의존 관계에 연결 합니다. 그러나 작업 정보 대화 상자의 고급 탭에서 작업 의존 관계 유형을 쉽게 변경할 수 있습니다. 작업 정보 대화 상자를 열려면 링크 형식을 변경할 작업의 이름을 두 번 클릭 합니다.

참고: 프로젝트를 사용할 수 있는 경우 외부 작업에 대 한 링크를 두 번 클릭 하 여 작업을 포함 하는 프로젝트를 엽니다. 외부 연결 작업은 작업 목록에서 흐리게 표시 됩니다. 외부 작업에 대 한 연결 형식을 수정 하려면 외부 연결 된 작업을 두 번 클릭 하 여 작업을 포함 하는 프로젝트를 연 후 다음을 실행 하 여 연결 된 작업을 수정 합니다. 예를 들어 project Z의 작업 A를 project 5의 작업 1에 연결한 경우 작업 1의 작업 정보에서 연결 종류를 수정할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 변경 하려는 연결선을 두 번 클릭 합니다.

    연결선을 두 번 클릭 합니다.

    단추 이미지

    링크 형식을 변경 하려면 여기를 두 번 클릭 합니다.

  3. 작업 의존 관계 유형을 변경 하려면 종류 목록에서 다른 종류를 선택 합니다.

다른 작업에 연결

현재 잘못 된 작업에 연결 된 작업이 있는 경우 올바른 의존 관계를 반영 하도록 쉽게 링크를 수정할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 작업 목록에서 링크를 변경할 작업을 선택 합니다.

  3. 작업 정보 단추 이미지 을 선택 합니다.

  4. 선행 작업 탭의 작업 이름 열에서 연결 하지 않을 작업을 선택한 다음 목록에서 작업을 선택 하 여 올바른 종속성을 식별 합니다.

  5. typelag 열에서 연결 유형, 지연 기간 또는 겹치는 기간을 수정 합니다.

    팁: 겹치는 기간을 입력 하려면 지연 열에 음수 값을 입력 합니다 (예: 2 일 동안 -2 ).

작업에 대 한 모든 종속성 제거

작업이 더 이상 다른 작업에 종속 되지 않는 경우 작업의 모든 종속성을 한 번에 제거할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 작업 이름 필드에서 연결을 끊을 작업을 선택 합니다.

    연속적으로 나열 되지 않은 여러 작업을 선택 하려면 CTRL 키를 누른 채 각 작업을 클릭 합니다. 연속적으로 나열 된 작업을 선택 하려면 첫 번째 작업을 클릭 하 고 SHIFT 키를 누른 채 목록에서 선택 하려는 마지막 작업을 클릭 합니다.

  3. 작업 연결 끊기 작업 연결 끊기 단추 이미지 을 선택 합니다.

    다른 작업이 나 제약 조건에 대 한 연결을 기준으로 작업의 일정이 재조정 됩니다.

참고: 작업 연결을 제거 하면 작업 간 연결선으로 표시 되는 두 작업 간의 의존 관계가 제거 됩니다. 프로젝트에 대 한 개요 구조의 일부로 작업 또는 하위 작업의 계층 구조를 변경 하려는 경우 작업 연결을 제거 하는 대신 작업을 한 수준 올려야 합니다.

특정 작업 의존 관계 제거

작업이 여러 작업에 연결 되어 있고 특정 연결을 제거 해야 하는 경우 작업 정보 대화 상자에서 제거할 링크를 선택할 수 있습니다.

  1. > Gantt 차트보기 를 선택 합니다.

  2. 작업 목록에서 종속성을 제거할 작업을 선택 합니다.

  3. 작업 정보 단추 이미지 을 선택 합니다.

  4. 선행 작업 탭에서 제거할 의존 관계를 선택 하 고 delete 키를 누릅니다.

문제 해결

작업을 연결 했지만 후속 작업이 이동 하지 않는 경우 다음과 같은 여러 원인이 있을 수 있습니다.

  • 작업에 실제 시작 날짜 또는 작업 완료율 등의 실제 적용이 있으면 작업을 실제로 시작한 날짜 보다 일찍 일정을 재조정할 수 없습니다. 진행 상황을 입력 하지 않고 작업에 유연성이 제한가 있으면 제약 조건이 _z0z_보다 우선적으로 적용 될 수 있습니다.

    예를 들어 작업의 시작 날짜 이전 (SNET) 제한이 7 월 1 일로 설정 되어 있는 경우, 작업은 해당 날짜에 연결 되며, 이전 날짜로 전환 되 고,이는 선행 작업 가 6 월 28 일에 끝나고 후속 작업이 7 월 1 일 이전에 시작할 수 있는 경우에도 이전 날짜로 일정이 조정 되지 않습니다.

  • Project에서 Gantt 차트 보기의 차트 부분에 포인터를 끌어 작업을 만들면 시작 날짜를 기준으로 일정이 잡힌 프로젝트에 대 한 작업에 ' 이후에 시작 (SNET) ' 제한이 설정 됩니다. 완료 날짜에서 예약 된 프로젝트의 경우에는 작업에 ' 이후에 완료 (하면 fnlt) ' 제한이 설정 됩니다.

  • 후속 작업이 완료 되 면 링크를 반영 하기 위해 이동 되지 않습니다.

  • 프로젝트에 대 한 계산 모드수동으로설정한 경우 후속 작업이 이동 되지 않습니다.

몇 가지 가능한 해결 방법은 다음과 같습니다.

  • 작업 제한을 더 유연 하 게 다시 설정 하려면 작업을 선택 하 고 작업 정보 단추 이미지 를 선택한 다음 고급 탭을 선택 합니다. 제한 종류 목록에서 가능한 한 빨리를선택 합니다. 그런 다음 작업 의존 관계에 따라 작업의 시작 날짜를 예약 합니다.

  • 작업 의존 관계에서 모든 작업에 대 한 고정적인 제한 사항을 무시 하려면 도구 메뉴에서 옵션을 선택한 다음 일정 탭을 선택 합니다. 일정 옵션 구역에서 작업의 제한 날짜가 항상 우선 확인란의 선택을 취소 합니다.

  • 계산을 자동으로 설정 하려면 도구 메뉴에서 옵션을 선택한 다음 계산 탭을 선택 합니다. Microsoft Office 프로젝트의 계산 옵션 구역에서 계산 모드옆에 있는 수동을 선택 합니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×