통합 문서에서 XML 맵 정보 삭제

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

보안 정보: XML 맵과 해당 데이터 원본 정보는 특정 워크시트가 아니라 통합 문서에 저장됩니다. 이 중요한 맵 정보는 VBA(Visual Basic for Applications) 매크로를 사용하는 악의적인 사용자에게 노출될 수 있습니다. 또한 사용자가 통합 문서를 매크로 사용 Excel Open XML 형식 파일로 저장하면 Microsoft 메모장이나 기타 텍스트 편집 프로그램을 통해서도 이 맵 정보를 볼 수 있습니다.

통합 문서에서 XML 맵의 데이터 원본 정의 삭제

맵 정보를 계속 사용할 수 있도록 하면서 중요한 데이터 원본 정보를 제거하려면 통합 문서에서 XML 스키마의 데이터 원본 정의를 삭제하면 됩니다. 이렇게 해도 XML 데이터를 내보낼 수는 있습니다.

이 절차를 수행하면 XML 맵에서 현재 데이터 원본 정의가 영구적으로 제거됩니다.

  1. 원하는 XML 맵을 선택하려면 매핑된 셀을 클릭합니다.

  2. 개발 도구 탭이 없는 경우 다음과 같이 이 탭을 표시할 수 있습니다.

    1. 파일 탭에서 옵션 을 클릭 > 리본 사용자 지정 합니다.

    2. 개발 도구 확인란을 선택 합니다.

  3. 개발 도구 탭의 지도 속성 을 클릭 합니다.

    개발 도구 탭

  4. XML 맵 속성 대화 상자에서 데이터 원본 아래에 있는 통합 문서에 데이터 원본 정의 저장 확인란을 선택 취소합니다.

    이 옵션은 기본적으로 선택되어 있습니다. 이 옵션을 선택 취소해도 워크시트의 데이터는 삭제되지 않습니다.

중요: 데이터 원본 정의에는 가져온 XML 데이터에 대한 연결 정보가 포함되어 있습니다. 이 정보를 제거하면 다른 사람이 해당 정보를 볼 수 없도록 하면서 매핑된 데이터를 XML 파일로 내보내는 기능은 계속 유지할 수 있습니다. 그러나 XML 데이터 파일을 다시 가져오면 데이터 원본 정의가 파일과 함께 다시 저장됩니다.

통합 문서에서 XML 맵 삭제

XML 맵을 삭제하기 전에 워크시트를 삭제하더라도 데이터 원본 및 기타 중요한 정보에 대한 맵 정보는 여전히 통합 문서에 저장되어 있습니다. 통합 문서를 업데이트하여 중요한 정보를 제거하려는 경우에는 워크시트를 삭제하기 전에 XML 맵을 삭제하여 통합 문서에서 맵 정보를 영구적으로 제거해야 합니다.

  1. 개발 도구 탭이 없는 경우 다음과 같이 이 탭을 표시할 수 있습니다.

    1. 파일 탭에서 옵션 을 클릭 > 리본 사용자 지정 합니다.

    2. 개발 도구 확인란을 선택 합니다.

  2. 개발 도구 탭의 XML 그룹에서 원본을 클릭합니다.

    개발 도구 탭

  3. XML 원본 작업창에서 XML 맵을 클릭합니다.

    XML 맵 대화 상자가 열립니다.

    맵 대화 상자

  4. 삭제하려는 XML 맵을 선택합니다.

  5. 삭제를 클릭하고 확인을 클릭합니다.

참고: XML 맵을 삭제하면 XML 맵만 제거되고 해당 XML 맵이 현재 매핑되어 있는 데이터는 제거되지 않습니다.

맨 위로 이동

통합 문서에서 XML 맵의 데이터 원본 정의 삭제

맵 정보를 계속 사용할 수 있도록 하면서 중요한 데이터 원본 정보를 제거하려면 통합 문서에서 XML 스키마의 데이터 원본 정의를 삭제하면 됩니다. 이렇게 해도 XML 데이터를 내보낼 수는 있습니다.

이 절차를 수행하면 XML 맵에서 현재 데이터 원본 정의가 영구적으로 제거됩니다.

  1. 원하는 XML 맵을 선택하려면 매핑된 셀을 클릭합니다.

  2. 개발 도구 탭을 사용할 수 없으면 다음을 수행하여 표시합니다.

    1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 Excel 옵션을 클릭합니다.

    2. 자주 사용하는 메뉴 범주의 Excel에서 가장 많이 사용하는 옵션에서 리본 메뉴에 개발 도구 탭 표시 확인란을 선택한 다음 확인을 클릭합니다.

  3. 개발 도구 탭의 XML 그룹에서 맵 속성을 클릭합니다.

    리본 메뉴의 XML 그룹

  4. XML 맵 속성 대화 상자에서 데이터 원본 아래에 있는 통합 문서에 데이터 원본 정의 저장 확인란을 선택 취소합니다.

    이 옵션은 기본적으로 선택되어 있습니다. 이 옵션을 선택 취소해도 워크시트의 데이터는 삭제되지 않습니다.

중요: 데이터 원본 정의에는 가져온 XML 데이터에 대한 연결 정보가 포함되어 있습니다. 이 정보를 제거하면 다른 사람이 해당 정보를 볼 수 없도록 하면서 매핑된 데이터를 XML 파일로 내보내는 기능은 계속 유지할 수 있습니다. 그러나 XML 데이터 파일을 다시 가져오면 데이터 원본 정의가 파일과 함께 다시 저장됩니다.

맨 위로 이동

통합 문서에서 XML 맵 삭제

XML 맵을 삭제하기 전에 워크시트를 삭제하더라도 데이터 원본 및 기타 중요한 정보에 대한 맵 정보는 여전히 통합 문서에 저장되어 있습니다. 통합 문서를 업데이트하여 중요한 정보를 제거하려는 경우에는 워크시트를 삭제하기 전에 XML 맵을 삭제하여 통합 문서에서 맵 정보를 영구적으로 제거해야 합니다.

  1. 개발 도구 탭을 사용할 수 없으면 다음을 수행하여 표시합니다.

    1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 Excel 옵션을 클릭합니다.

    2. 자주 사용하는 메뉴 범주의 Excel에서 가장 많이 사용하는 옵션에서 리본 메뉴에 개발 도구 탭 표시 확인란을 선택한 다음 확인을 클릭합니다.

  2. 개발 도구 탭의 XML 그룹에서 원본을 클릭합니다.

    리본 메뉴의 XML 그룹

  3. XML 원본 작업창에서 XML 맵을 클릭합니다.

    XML 맵 대화 상자가 열립니다.

  4. 삭제하려는 XML 맵을 선택합니다.

  5. 삭제를 클릭하고 확인을 클릭합니다.

참고: XML 맵을 삭제하면 XML 맵만 제거되고 해당 XML 맵이 현재 매핑되어 있는 데이터는 제거되지 않습니다.

맨 위로 이동

추가 지원

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×