통합 된 가져오기 및 변환 환경

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Excel 2016 강력한 가져오기 및 변환 이라고 하는 도구 집합을 도입 되었습니다. 파워 쿼리 기술 기반 이러한 도구 사용 손쉽게 연결을 결합 하 고 다양 한 원본에서에서 가져온 데이터 형성 수 있습니다. 다음 가져오기 및 변환 자습서 에서는 단계를 안내 기본 사항입니다.

우리는 다음 주요 업데이트 – Excel의 데이터 가져오기 및 셰이프를 알립니다 통합 된 가져오기 및 변환 발생 합니다. 3 월 2017 Office 365 업데이트는 Excel의 데이터 가져오기 기능 향상 한 데이터 탭에 있는 단추는 사무실 외부에 전체 가져오기 및 변환 기능 활용 보다 훨씬 더 쉽게 재정렬할 합니다.

가져오기 및 변환 하 고 데이터 탭의 옵션

통합 된 가져오기 및 변환 환경으로 데이터 가져오기 및 Excel의 기능 형성 잘 통합 되 고 최신 집합에서 이점이 있습니다. 쉽게 연결 하 고 다양 한 파일, 데이터베이스, Azure 및 온라인 서비스 등과 같은 일반적인 데이터 원본에서에서 데이터를 가져올 수 있습니다. 및 해당 데이터 형성 강력한 방식으로 정렬, 데이터 형식 변경, 열을 분할 하 여 데이터를 집계 하 고 등입니다. 어떤 Get & 변형 일상 작업에 시간을 절약 하며 매우 유용한 도구는는 계속 해 서 증가 하 고 새 연결선 및 변환이 수행 쉽게 제공 합니다.

노트의 새 환경을 이전, 기존 데이터를 대체 가져오기 마법사, 데이터 에서 사용할 수 있었던 하십시오 > 외부 데이터 가져오기. 그러나은 계속 액세스할 수 원하는 경우. 참고: 외부 데이터 가져오기 환경이 레거시를 복원 하려면 어떻게 하나요?

참고: 이 기능은 Office 365 구독이있는 경우에 Excel에서 사용할 수 있습니다. Office 365 등록자에 최신 버전의 Office 정하는경우.

CSV 파일 또는 웹 같은 인기 있는 원본에서 데이터 가져오기

알 수 있는 사용자가 쉽게 액세스할 수 있는 가장 많이 본 커넥터 하는 리본 메뉴의에 같은 데이터를 가져옵니다. 이 업데이트는 이러한 원리를 팔 로우 하려고 하 고 경험을 사용 하는 일관성 있게 유지 합니다. 데이터 탭의 가져오기 및 데이터 변환 섹션에서 사용할 수 있는 다음과 같은 세 커넥터를 찾을 수 있습니다: 에서 텍스트/c s V, 웹에서표/범위에서 합니다.

텍스트/c s V에서

이 커넥터 텍스트 (*.txt), 쉼표로 구분 된 값 (*.csv) 또는 서식된 있는 텍스트 (*.prn) 파일에서 데이터를 쉽게 가져올 수 있습니다. 이 최신 커넥터 파워 쿼리 기술에 기반 하 고 레거시 텍스트에서 마법사를 바꿉니다.

새 커넥터를 사용 하 여 데이터를 가져오는 시작 하려면 데이터 >에서 텍스트/c s V 원본 파일을 선택한 다음 확인 을 클릭 합니다. 새로운 기능과 향상 된 에서 텍스트/c s V 커넥터 다음 입력된 파일의 구조 분석 하 고 자동으로 관련 가져오기 설정이 적용 됩니다. 구분 기호를 기준으로 열 분할 첫 번째 행, 열 머리글 등으로 사용 되도록 승격 수 있는 것입니다.

가져오기 및 텍스트에서 변환 옵션

원하는 대로 하지 못하면 미리 보기를 원본 파일, 구분 기호 또는 데이터 형식을 검색 논리 바로 같은 기본 가져오기 설정을 구성할 수 있습니다. 선택 사항에 따라 데이터의 미리 보기가 자동으로 업데이트 됩니다.

다음 로드 직접 데이터를 워크시트로 로드를 클릭 하거나 데이터를 로드 하는 데이터 모델에 로드 옆에 있는 화살표를 클릭 합니다. 쿼리 편집기에서 추가 데이터 변환을 적용 하려면 편집 을 클릭 합니다.

이 커넥터와 "남은" HTML 페이지에서 데이터입니다. 파워 쿼리 기술 기반도 레거시 웹에서 마법사를 대체 하는 다른 현대적인 커넥터입니다.

사용을 시작 하려면 클릭 데이터 > 웹에서 대상 페이지 URL을 지정 하 고 확인 을 클릭 합니다. 탐색 창 대화 상자에서 페이지의 모든 테이블 목록이 표시 됩니다. 표 보기 또는 웹 보기 에서 웹 페이지와 상호 작용 하는 옵션이 있습니다. 표 보기와 먼저 왼쪽에 표 이름을 클릭 하 고 해당 테이블의 데이터를 오른쪽에 표시 됩니다. 웹 보기와 탐색 창 목록에서 나 웹 보기 미리 보기 창에서 표를 클릭 하거나 있습니다. 어느 보기에서 여러 테이블을 선택할 수 있습니다.

가져오기 및 웹에서 변환 옵션

표/범위에서

이 커넥터와 명명 된 Excel 워크시트에서 범위 또는 테이블에 연결 되는 새 쿼리를 만들 수 있습니다. 다음 데이터를 구체화 하 쿼리 편집기 창에서에 추가 변환을 적용할 수 있습니다.

가져오기 및 테이블에서 변환 옵션

XML 파일이 나 Microsoft SQL Server와 같은 다른 원본에서 데이터 가져오기

Microsoft Access 데이터베이스 또는 OData 피드 또는 폴더의 여러 텍스트 파일에서 한 번에 데이터를 가져올 수와 같이 하나의 데이터 원본에서 데이터 가져오기에 새 쿼리를 만들 수 있습니다.

데이터 를 클릭할 때 > 데이터 가져오기, 사용 가능한 데이터 원본을 표현에 드롭다운 메뉴에서 합니다. SQL Server 또는 Oracle을 HDInsight 등의 서비스 Azure Blob 저장소, SharePoint Online 목록 또는 Salesforce와 같은 온라인 서비스와 같은 옵션은 Excel 통합 문서, XML 파일 또는 전체 폴더와 같은 파일을 비롯 한 범주로 구성 되어 원본 데이터베이스 OData 또는 ODBC와 같은 다른 원본 다양 합니다.

사용 가능한 커넥터 목록 지속적으로 증가 하 고 있습니다.

가져오기 및 데이터베이스의 변환 옵션

이 업데이트는 또한 제거한 데이터 탭의 외부 데이터 가져오기 섹션에서 이전에 사용할 수 있는 다음 레거시 마법사: Access, 웹에서 텍스트에서 SQL Server, OData 데이터 피드에서, XML 데이터 가져오기 및 데이터 연결에서 마법사입니다. 어떤 이유로 든 제거 된 레거시 마법사 중 하나를 사용 하 여 필요 하면, 참고: 외부 데이터 가져오기 환경이 레거시를 복원 하려면 어떻게 하나요?

그러나는 두 개의 인기, 오래 된 외부 데이터 가져오기 기능에 포함 된 매우 고유 마법사가 설정 하 고 새 환경에 남아 있습니다: Analysis ServicesMicrosoft Query 합니다. 데이터 에서 찾을 수 있습니다 > 데이터베이스에서데이터 > 새에서 기타 원본에서 범주 각각 발생 합니다.

활용 하려면 어떻게 가져오기 및 변환 기능을 정리 하 고 내 데이터 형성 하 시겠습니까?

가져오기 및 변환 정리 하 고 강력한 데이터 분석을 위한 필수 단계로 데이터 형성 수 있습니다. 열 제거 하 여 행을 필터링, 열 데이터 형식을 변경 값 바꿀 수 있습니다. 이 촉진 하 고 모든 데이터 변환 표시 하는 전용된 쿼리 편집기 창을 통해 수행 됩니다.

리본 메뉴의 데이터 탭으로 전환 데이터 가져오기를 클릭 합니다 (예: 파일 또는 데이터베이스) 원하는 데이터 원본에 연결 사용 가능한 커넥터 중 하나를 사용 하 여 및 탐색 창에서 데이터를 미리 봅니다.

에이전트 및 변환 탐색

그런 다음, 쿼리 편집기 창을 시작 하려면 편집 을 클릭 하 고 가져올 하려는 테이블을 선택 합니다.

가져오기 및 쿼리 편집기 변환

쿼리 편집기 창 리본 메뉴에서 사용할 수 있는 명령의 넓은 모음을 사용 합니다. 정렬 및 필터링 데이터, 데이터 형식으로 변환, 분할 또는 열을 병합 하 여 데이터 및 기타 집계 강력한 변환을 적용할 수 있습니다.

데이터에 적용 되는 모든 변환 단계 기록 되 고 쿼리의 일부로 저장 됩니다. 기록 된 변환의 관찰 적용 된 단계 를 통해 관리 하 고 쿼리 편집기 창이 안에 섹션을 쿼리를 새로 고칠 때마다 데이터를 다시 적용 됩니다.

최근에 사용한 원본, 데이터베이스 연결 ODC (Office) 파일, 다른 통합 문서 연결 또는 테이블에서 데이터 가져오기

연결 및 최근에 사용한 원본에서 데이터를 가져오는 데이터 가져오기 영역에서 가장 널리 사용 시나리오 중 하나입니다. 사용자가 자주 사용 하는 원본 데이터를 가져오는 데 연결할의 집합을 자주 설정 합니다.

데이터 연결 하 고 최근에 사용한 데이터 원본 중 하나에서 쿼리 만들기를 클릭 하 > 최근에 사용한 원본 입니다. 다음 최근에 연결 된 원본 찾아봅니다 한 하나를 선택한 다음 가져오기 흐름을 계속 하려면 연결 클릭 수 있습니다.

가져오기 및 최근에 사용한 원본 변형 창

또 다른 일반적인 시나리오 기존 연결 또는 통합 문서에 있는 테이블에서 데이터 가져오기 됩니다. 예를 들어 이전에 만든된 통합 문서 연결에 따라 새 피벗 테이블을 만들 경우가 있습니다. 또는 조직 내 다른 사용자가 정의한 데이터베이스 ODC (Office 연결) 파일을 사용 하 여 데이터 원본에서 가져오기 및 연결을 설정할 수도 있습니다.

이 업데이트를 설치한 ODC 파일로 여 쿼리 정의 중 하나를 내보내려면 다음 통합 문서 전체 또는 동료와 공유 수 있습니다. ODC 파일에 쿼리 정의 내보내려면 쿼리 및 연결 왼쪽 창에서 쿼리를 마우스 오른쪽 단추로 클릭 하 고 연결 파일 내보내기를 선택 합니다. 만든된 ODC 파일의 데이터 원본 및 데이터에 적용 되 고 변형 단계 연결 지침을 비롯 한 모든 종속성이 있는 쿼리 정의 포함 됩니다. 쿼리 정의 내보내려면 또 다른 방법은 쿼리의 상황에 맞는 메뉴에서 속성 을 선택 하 여 열 수 있는 쿼리 속성 대화 상자를 통해입니다.

ODC 파일을 받게 되 면을 사용 하 고 쿼리 정의 통합 문서로 가져옵니다를 수 있습니다. ODC 메커니즘을 통해 데이터를 가져오려면 데이터 를 클릭 >기존 연결 합니다. 기존 연결 대화 상자가 나타납니다 하 고 사용 가능한 ODC 파일, 기존 통합 문서 연결 또는 테이블에서 가져올 수 있습니다.

기존 연결 또는 쿼리의 선택

Visio 또는 Excel 2013 및 이전 버전에서 같은 다른 응용 프로그램에서 사용할 수 있는 ODC 파일을 만드는 데 필요한 경우 할 수 있는 다음과 같은 연결선을 사용 하는: SQL Server 데이터베이스, Microsoft Access 데이터베이스에서 OData 피드에서 , Analysis Services, Microsoft Query 또는 기존 데이터 연결 마법사에서 합니다. 것이 알아야 하는 다른 응용 프로그램에서 ODC 파일을 사용 하는 경우 응용 프로그램이 연결 명령, ODC에서 다시 사용 하 고 원래 쿼리 포함 되어 있을 수 있는 모든 변환 단계 포함 되지 것입니다. 레거시에서 Access 복원 해야 할 경우 SQL Server, OData 데이터 피드에서 커넥터 참고: 외부 데이터 가져오기 환경이 레거시를 복원 하려면 어떻게 하나요?

기존 통합 문서 쿼리 및 연결 관리 하려면 어떻게 해야 하나요?

가져오기 및 변환 도입 되었습니다 때 Excel 2016에, 두 개의 데이터 가져오기 방법론 도입 되었습니다: 첫 번째 된 새 가져오기 및 변환 환경 하는 쿼리 를 사용 (및도 의존 하 여 문서의 서식에 대 한 통합 문서 연결 새로 고침 및 통합 문서 요소를 로드). 두 번째 통합 문서 연결을 사용 하는 이전, 레거시 환경을 했습니다. 통합 문서 쿼리 및 연결 관리 별도로 수행도 되었습니다. 연결 된 통합 문서 연결 대화 상자를 관리 하는 동안 전용된 쿼리 창을 통해 통합 문서 쿼리 관리 되었습니다. 사용자 들 간에 혼동을 발생합니다.

이 업데이트를 통해이 문제를 해결 했습니다. 이제 액세스 및 전용에서 통합 문서 쿼리 및 연결을 관리할 수 쿼리 및 연결 왼쪽 창입니다. 작업창을 열려면 클릭 해 데이터 > 쿼리 및 연결 단추입니다.

쿼리 및 연결 창 가져오기 및 변환

창 맨 위에 있는 쿼리 탭을 클릭 하면 찾아 통합 문서에서 사용할 수 있는 쿼리를 관리할 수 있습니다. 추가 작업을 수행할 수 있는 쿼리의 상황에 맞는 메뉴에 액세스 하는 쿼리를 마우스 오른쪽 단추로 클릭 합니다. 쿼리 데이터를 새로 고칠 수 예를 들어 기본 원본에서 쿼리 복사/붙여넣기, 편집을 사용 하 여 쿼리 편집기 쿼리 변환 합니다.

쿼리 및 쿼리 속성 대화 상자에 새 기본 해당 연결의 관리를 간소화 되어 했습니다. 오늘, 통합 문서에서 새 쿼리를 만들 때마다 새 기본 연결 엔터티 배경에서 자동으로 만들어 집니다 있으며이 쿼리를 연결 됩니다. 기본 연결 된 데이터는 어디 제어를 데이터 원본에 연결 하 고이 필요한 데이터 변환을 적용 하려면 쿼리의 역할은 쿼리 데이터 새로 고침 설정 뿐만 아니라 되 로드 (예: 워크시트 또는 데이터 모델) 등의 빈도를 새로 고칩니다. 새 쿼리 속성 대화 상자와 중앙 집중식으로 해당 이름 또는 변환 명령 및 새로 고침 설정 등 기본 연결 속성 같은 모든 쿼리 속성을 쉽게 제어할 수 있습니다. 새 쿼리 속성 대화 상자를 열려면 쿼리 및 연결 왼쪽 창에서 쿼리 상황에 맞는 메뉴에서 속성 명령 클릭 합니다.

왼쪽 창의 위쪽에서 연결 탭 클릭 하면 찾아 하나 텍스트Analysis Services 와 같은 레거시 마법사와 관련 된 통합 문서에서 사용할 수 있는 기존 연결을 관리 하거나 Microsoft query에서 합니다. 상황에 맞는 메뉴에 액세스에 대 한 연결을 마우스 오른쪽 단추로 클릭 합니다. 있는 연결 데이터 원본의 데이터 새로 고침 등의 추가 작업을 수행 하거나, 연결을 삭제 하거나 잘 알고 연결 속성 대화 상자를 통해 연결 속성 관리 수 있습니다.

외부 데이터 가져오기 환경이 레거시 복원 하려면 어떻게 해야 하나요?

새 가져오기 및 변환 환경을 제공 연결선 및 변환 기능 레거시 마법사에 비해 상사입니다. 그러나 여전히는 이전 마법사 중 하나를 사용 하 여 데이터를 가져오는 하려는 경우가 합니다. 예를 들어 하려는 경우 통합 문서의 일부로 데이터 원본을 로그인 자격 증명을 저장 합니다. (하십시오이 방법은 및 이와 같이 최신 보안 표준을 충족 하지 않는 노트 지원 되지 않습니다 새 가져오기 및 변환 환경에서).

리본 메뉴 사용자 지정 하 여 이전 커넥터 액세스할 수 있고 수도 있습니다 다시 가져올 레거시 데이터 가져오기 마법사 바로 아래에서 표시는 데이터 > 데이터 가져오기 Excel 옵션 대화 상자에서 새 쉽고 구성 설정을 통해 드롭다운 메뉴입니다.

파일 을 이동 > 옵션 > 데이터 > 쇼 레거시 데이터 가져오기 마법사, 레거시 마법사를 사용 하 여 선택 합니다.

파일에서 가져오기 및 변환 레거시 마법사 옵션 이미지 > 옵션 > 데이터입니다.

열려 있는 데이터 > 데이터 가져오기 전용된 레거시 마법사 범주에서 드롭다운 메뉴와 이전에 선택한 레거시 데이터의 출시 하나 가져오기 마법사:

가져오기 및 변환 레거시 메뉴 옵션

가져오기 및 변환 하는 방법에 대 한 추가 정보

가져오기 및 변환 기능에 대 한 자세한 정보를 원하는 경우 시작 하는 데 Excel 도움말에 대 한 Microsoft 파워 쿼리입니다.

추가 지원

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×