최신 버전으로 Access 2.0 및 Access 95 데이터베이스 가져오기

최신 버전으로 Access 2.0 및 Access 95 데이터베이스 가져오기

Access 2.0 형식(.mdb) 또는 Access 95 형식(.mdb)의 데이터베이스를 사용 중이라면 경우에 따라 이 데이터베이스의 테이블, 쿼리 및 매크로를 .accdb 파일 형식을 사용하는 보다 최신 버전의 Access 버전으로 가져올 수 있습니다.

VBA 코드(및 모듈)가 포함된 폼과 보고서를 가져오려면 먼저 Microsoft Office Access 2003, Access 2002 또는 Access 2000을 이용하여 Access 2.0 또는 Access 95 데이터베이스를 Access 2002 - 2003 또는 Access 2000 파일 형식으로 변환합니다. 변환한 뒤에는 Access 2007과 같은 보다 최신 버전을 이용하여 이 파일을 .accdb 파일 형식으로 변환하여 Access 2010, Access 2013 또는 Access 2016에서 열 수 있습니다.

이 문서의 이어지는 섹션에서는 이러한 작업을 수행하는 방법을 설명합니다.

Access 2010, Access 2013 또는 Access 2016을 사용 중인 경우

Access 2007은 Access 2.0 및 Access 95의 열기, 가져오기, 연결 또는 내보내기를 지원하는 마지막 버전입니다. Access 1.0 및 2.0 (Red 2 또는 Jet 2) 파일과 Access 95 데이터베이스의 내보내기, 가져오기 또는 데이터 링크를 수생하려면 Access 2007이 필요합니다. 이때 Access 2007은 Access 2.0 데이터베이스를 이러한 버전으로 변환하기 위한 중간 단계에서 이용됩니다.

실행할 작업

Access 2007에서 Access 2.0 데이터베이스 열기

Access 2.0 데이터베이스의 데이터를 Access 2007로 가져오기

Access 95 데이터베이스의 데이터를 Access 2007로 가져오기

Access 2003, Access 2002 또는 Access 2000을 이용하여 Access 2.0 또는 Access 95 데이터베이스 변환

Access 2007에서 Access 2.0 데이터베이스 열기

Access 2007에서 Access 2.0 데이터베이스를 열면 Access에 일련의 안내 메시지가 표시됩니다. 메시지를 따라가다 보면 마지막으로 이 데이터베이스는 Microsoft Access 2.0 파일 형식으로 저장되었습니다라는 메시지가 표시됩니다.

이 데이터베이스는 Microsoft Access 2.0 파일 형식으로 저장되었습니다.

Access 2.0 데이터베이스의 테이블, 쿼리 및 매크로를 Access 2007 데이터베이스(.accdb)로 가져올 수 있습니다. 폼, 보고서 또는 모듈을 2007 데이터베이스로 가져오려면 먼저 이전 버전의 Access를 이용하여 데이터베이스를 변환하고, 변환된 데이터베이스를 Access 2007에서 연 다음 이 데이터베이스를 Access 2007 .accdb 파일 형식의 데이터베이스로 변환해야 합니다. 자세한 내용은 Access 2003, Access 2002 또는 Access 2000을 이용하여 Access 2.0 또는 Access 95 데이터베이스 변환 섹션을 참조하세요.

Access 2.0 데이터베이스의 데이터를 Access 2007로 가져오기

다른 데이터베이스에서 개체를 가져오면 대상 데이터베이스에 가져온 개체의 복사본이 생성됩니다. 원본은 변경되지 않습니다. Access 2.0 데이터베이스의 데이터를 Access 2007로 가져오려면 먼저 데이터를 가져올 대상 데이터베이스를 엽니다. 그런 다음 외부 데이터 탭에 있는 명령을 사용하여 가져오기 과정을 진행합니다. 이때 가져오기 마법사도 호출됩니다.

  1. Access 2007을 열고 Microsoft Office 단추를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 표, 쿼리 또는 매크로를 가져올 대상 데이터베이스를 선택하여 엽니다.

  3. 외부 데이터 탭에 있는 가져오기 그룹에서 Access를 클릭합니다.

  4. 외부 데이터 가져오기 마법사의 파일 이름 텍스트 상자에 원본 데이터베이스의 이름을 입력하거나 찾아보기를 클릭하여 파일 열기 대화 상자를 표시하고 원본 데이터베이스의 유형 또는 이름을 선택합니다.

  5. 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스로 가져오기를 클릭하고 확인을 클릭합니다.

  6. 개체 가져오기 대화 상자에서 각 탭을 클릭하여 원하는 개체를 선택합니다. Access 2.0 데이터베이스의 테이블, 쿼리 및 매크로는 Access 2007로만 가져올 수 있다는 사실을 기억하세요.

    개체 가져오기 대화 상자

    선택한 개체를 취소하려면 개체를 다시 클릭합니다.

  7. 옵션을 클릭하여 추가 설정을 지정합니다.

    다음 표에서는 각 옵션이 작업 결과에 미치는 영향을 설명합니다.

    요소

    설명

    관계 확인란

    선택한 테이블 사이의 관계를 가져옵니다.

    메뉴 및 도구 모음 확인란

    원본 데이터베이스에 있는 사용자 지정 메뉴 및 도구 모음을 가져옵니다. 메뉴 및 도구 모음은 추가 기능 탭에 표시됩니다.

    가져오기/내보내기 설정 확인란

    원본 데이터베이스에 있는 저장된 가져오기 또는 내보내기 설정을 가져옵니다.

    탐색 창 그룹 확인란

    원본 데이터베이스에 있는 사용자 지정 탐색 창 그룹을 가져옵니다.

    정의 및 데이터 단추

    선택한 테이블의 구조와 데이터를 가져옵니다.

    정의만 단추

    선택한 테이블의 필드만 가져옵니다. 원본 레코드는 가져오지 않습니다.

    쿼리로 단추

    선택한 쿼리를 쿼리로 가져옵니다. 이 경우 쿼리와 함께 기본 테이블을 모두 가져와야 합니다.

    테이블로 단추

    쿼리를 테이블로 가져옵니다. 이 경우 기본 테이블을 가져오지 않아도 됩니다.

  8. 확인을 클릭하여 작업을 완료합니다.

    데이터가 복사되고, 문제가 발생할 경우 오류 메시지가 표시됩니다. 데이터 가져오기 작업이 성공하면 마법사의 최종 페이지에서 나중에 사용하기 위해 작업의 세부 정보를 가져오기 설정으로 저장할 수 있습니다.

Access 95 데이터베이스의 데이터를 Access 2007로 가져오기

Access 95 데이터베이스의 데이터를 Access 2007로 가져오려면 먼저 데이터를 가져올 대상 Access 2007 데이터베이스를 엽니다. 그런 다음 외부 데이터 탭에 있는 명령을 사용합니다. 이때 가져오기 마법사도 호출됩니다.

Access 95 형식(.mdb) 데이터베이스의 테이블, 쿼리 및 매크로는 Access 2007 데이터베이스(.accdb)로 가져올 수 있습니다. VBA 코드를 사용하지 않는 폼과 보고서도 가져올 수 있습니다. VBA 코드(및 모듈)가 포함된 폼과 보고서를 가져오려면 먼저 Microsoft Office Access 2003, Access 2002 또는 Access 2000을 이용하여 Access 95 데이터베이스를 Access 2002 - 2003 또는 Access 2000 파일 형식으로 변환한 다음 변환한 파일을 Access 2007을 이용하여 Access 2007 .accdb 파일 형식으로 변환합니다.

  1. Access 2007을 열고 Microsoft Office 단추를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 표, 쿼리 또는 매크로를 가져올 대상 데이터베이스를 선택하여 엽니다.

  3. 외부 데이터 탭에 있는 가져오기 그룹에서 Access를 클릭합니다.

  4. 외부 데이터 가져오기 마법사의 파일 이름 상자에 원본 데이터베이스의 이름을 입력하거나 찾아보기를 클릭하여 파일 열기 대화 상자를 표시하고 원본 데이터베이스의 유형 또는 이름을 선택합니다.

  5. 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스로 가져오기를 클릭하고 확인을 클릭합니다.

  6. 개체 가져오기 대화 상자에서 각 탭을 클릭하여 가져오려는 개체를 선택합니다.

    개체의 선택을 취소하려면 해당 개체를 다시 클릭합니다.

  7. 옵션을 클릭하여 추가 설정을 지정합니다. 추가 설정은 개체 목록 아래에 그룹으로 표시됩니다.

  8. 확인을 클릭하여 작업을 완료합니다.

    데이터가 복사되고, 문제가 발생할 경우 오류 메시지가 표시됩니다. 데이터 가져오기 작업이 성공하면 마법사의 최종 페이지에서 나중에 사용하기 위해 작업의 세부 정보를 가져오기 설정으로 저장할 수 있습니다.

Access 2003, Access 2002 또는 Access 2000을 이용하여 Access 2.0 또는 Access 95 데이터베이스 변환

아래 표에 있는 Access 버전 중 하나를 이용하여 Access 2.0 데이터베이스를 Access 2000 또는 Access 2002 - 2003 파일 형식으로 변환할 수 있습니다. 이때 이용하려는 버전의 Access를 구입하여 컴퓨터에 설치한 상태여야 합니다. Access 버전에 따라 Access 2.0 변환기가 이미 설치되어 있을 수 있습니다.

버전

Access 2.0 변환기

Microsoft Office Access 2003

이 버전을 이용하려면 Access 2003용 Access 2.0 변환기를 다운로드하여 설치해야 합니다. 단, Access 2003은 추가 지원이 중단된 상태이기 때문에 이 도구는 Microsoft 다운로드 센터에서 더 이상 찾을 수 없습니다.

Microsoft Access 2002

제품에 포함되어 있습니다.

Microsoft Access 2000

제품에 포함되어 있습니다.

Access 2.0 또는 Access 95 파일을 Access 2000 또는 Access 2002 - 2003 .mdb 파일로 변환해야 합니다. 그런 다음 변환한 파일을 Access 2007을 이용하여 Access 2007 .accdb 파일 형식으로 변환합니다. 이 작업을 완료하면 데이터베이스를 Access 2007에서 사용하거나 Access 2010, Access 2013 또는 Access 2016에서 열 수 있습니다. 이전 버전의 Access 중 어느 버전을 사용하고 있는지에 따라 다음 단계를 수행합니다.

  1. Access 2003, Access 2002 또는 Access 2000을 시작합니다.

  2. 파일 메뉴에서 열기를 클릭한 다음 변환하려는 Access 95 데이터베이스의 파일 이름을 클릭합니다.

  3. 도구 메뉴에서 데이터베이스 유틸리티를 클릭하고 데이터베이스 변환을 클릭한 다음 Access 2000 파일 형식으로를 클릭합니다.

  4. 데이터베이스 변환 대화 상자에서 새 파일의 이름을 입력하고 저장을 클릭합니다.

    변환된 데이터베이스를 이전 버전의 Access에서 사용할 수 없다는 경고 메시지가 나타날 수 있습니다. 메시지가 나타나면 확인을 클릭합니다.

    파일이 Access 2000 파일 형식으로 저장됩니다.

  5. Access 2007을 시작합니다.

  6. Microsoft Office 단추를 클릭하고 열기를 클릭합니다.

  7. 열기 대화 상자에서 변환된 데이터베이스를 선택하여 엽니다.

  8. Microsoft Office 단추를 클릭하고 변환을 클릭합니다.

  9. 다른 이름으로 저장 대화 상자에서 Access 2007 파일의 이름을 입력하거나 표시된 파일 이름 그대로 저장을 클릭합니다.

    파일이 Access 2007 .accdb 파일 형식으로 저장됩니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×