워크시트 데이터로 XML 데이터 파일 및 XML 스키마 파일 만들기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

워크시트의 셀 범위로 XML 데이터 파일 및 XML 스키마 파일을 만들려는 경우 Microsoft Excel 2007 이상에서 Excel 2003 XML 도구 추가 기능 버전 1.1을 사용하여 기존 XML 기능을 향상시킬 수 있습니다.

  1. 추가 기능을 다운로드하려면 Excel 2003 XML 도구 추가 기능(영어) 링크를 클릭한 다음 다운로드 페이지에 설명된 지침을 따릅니다.

  2. Excel을 시작합니다.

  3. 클릭 하 고 파일 > 옵션 > 추가 기능 입니다.

    Excel 2007 클릭 Office 단추 이미지 Microsoft Office 단추> Excel 옵션 > 추가 기능 입니다.

  4. 관리 상자에서 Excel 추가 기능을 클릭한 다음 이동을 클릭합니다.

  5. 추가 기능 대화 상자에서 찾아보기를 클릭하고 XmlTools.xla 파일을 찾아 선택한 다음 확인을 클릭합니다.

    기본적으로이 파일은 하드 드라이브의 다음 폴더에 저장:
    \Office Samples\OfficeExcel2003XMLToolsAddin 합니다.

  6. 사용 가능한 추가 기능 목록에서 XmlTools 확인란을 선택한 다음 확인을 클릭하여 해당 추가 기능을 로드합니다.

  7. 추가 기능이 활성화되어 있는지 확인하려면 추가 기능 탭의 메뉴 명령 범주에 XML 도구 명령 메뉴가 나타나는지 확인합니다.

참고: 이 추가 기능은 Excel 2003용으로 개발되었습니다. 관련 설명서 및 사용자 인터페이스에서 쓰이는 목록이라는 용어는 Excel 2003 이후 버전의 Excel 표를 의미합니다.

이 추가 기능을 사용하는 방법에 대한 자세한 내용은 Excel 2003 XML 도구 추가 기능 버전 1.1 사용(영어)을 참조하세요.

  1. XML 데이터 파일 및 XML 스키마 파일로 만들 데이터를 입력합니다. 이 데이터는 열과 행으로 이루어진 표 형식의 데이터 또는 단층적 데이터여야 합니다.

  2. 추가 기능 탭의 메뉴 명령 그룹에서 XML 도구 옆의 화살표를 클릭한 다음 범위를 XML 목록으로 변환을 클릭합니다.

  3. 변환할 데이터의 셀 범위를 절대 참조로 텍스트 상자에 입력합니다.

    팁: 올바른 셀 참조를 보다 쉽게 입력하려면 대화 상자에서 텍스트 상자 오른쪽의 단추를 클릭한 다음 해당 범위의 왼쪽 맨 위 셀을 클릭한 채 오른쪽 맨 아래 셀로 마우스를 끕니다.

  4. 첫 행을 열 이름으로 사용 아래에서 첫 행에 데이터가 포함된 경우 아니요를 선택하고 첫 행에 열 머리글이 포함된 경우에는 를 선택한 다음 확인을 클릭합니다.

    Excel에서는 자동으로 XML 스키마를 만들고 셀을 스키마에 매핑하여 XML 표를 만듭니다.

    중요:  Visual Basic Editor가 나타나고 VBA(Visual Basic for Applications) 오류 메시지가 표시되는 경우 다음을 수행합니다.

    1. 확인을 클릭합니다.

    2. VBA 코드 모듈에서 강조 표시 된 줄에서 "50" 줄에서 제거 합니다. 즉, 변경:
      XMLDoc로 msxml2합니다. DOMDocument50
      To:
      msxml2XMLDoc 합니다. DOMDocument

    3. F5 키를 눌러 "XMLDoc As msxml2.DOMDocument50"이 포함된 다음 줄을 찾고 확인을 클릭한 다음 2단계에서와 같이 변경합니다.

    4. F5 키를 다시 눌러 해당 문자열을 모두 찾아 변경합니다.

    5. F5 키를 눌러도 더 이상 VBA 오류 메시지가 나타나지 않으면 Visual Basic Editor를 닫고 통합 문서로 돌아갑니다. 그러면 셀 범위가 XML 표로 변환됩니다.

      참고: 통합 문서의 모든 XML 맵을 확인하려면 개발 도구 탭의 XML 그룹에서 원본을 클릭하여 XML 원본 작업창을 표시한 다음 이 작업창의 아래쪽에서 XML 맵을 클릭합니다.

      개발 도구 탭이 없는 경우 다음 섹션의 3단계 아래에 있는 세 단계를 수행하여 Excel 리본 메뉴에 이 탭을 추가합니다.

  1. 개발 도구 탭을 사용할 수 없는 경우이 사용 하도록 설정 합니다. 자세한 내용은 개발 도구 탭 표시를 참조 하십시오.

  2. 개발 도구 탭의 XML 그룹에서 내보내기를 클릭합니다.

    개발자 탭에서 내보내기

    참고: 확인취소 단추만 있는 작은 XML 내보내기 대화 상자가 나타나면 사용할 XML 맵을 클릭한 다음 확인을 클릭합니다. 작은 XML 내보내기 대화 상자는 XML 표가 선택되어 있지 않고 통합 문서에 둘 이상의 XML 맵이 포함된 경우에만 표시됩니다.

  3. XML 내보내기 대화 상자의 파일 이름 상자에 XML 데이터 파일의 이름을 입력합니다.

  4. 내보내기를 클릭합니다.

참고:  Excel에서 XML 맵을 만들어 데이터를 XML 파일로 내보려는 경우 내보낼 수 있는 행에는 개수 제한이 있습니다. Excel에서 XML로 내보내면 최대 65536개의 행이 저장됩니다. 파일에 65536개를 초과하는 행이 있는 경우 Excel에서는 첫(#ROWS mod 65537) 행을 내보냅니다. 예를 들어 워크시트에 행이 70000개 있으면 Excel은 70000 mod 65537 = 4464개 행을 내보냅니다. 따라서 1) 대신 xlsx를 사용하거나 2) 파일을 XML 스프레드시트 2003(.xml) 형식으로 저장하거나(매핑이 손실됨) 3) 65536행 다음의 행을 모두 삭제한 다음 다시 내보내는 것(매핑은 유지되나 파일 끝에 있는 데이터가 손실됨)을 권장합니다.

  1. 매핑된 Excel 표에서 아무 셀이나 선택합니다.

  2. 추가 기능 탭의 메뉴 명령 그룹에서 XML 도구 옆의 화살표를 클릭한 다음 현재 셀에서 XML 스키마에 대한 XSD 파일 만들기를 클릭합니다.

    Excel에서는 XML 스키마를 복사하여 메모장에 붙여 넣습니다.

  3. 메모장에서 파일, 다른 이름으로 저장을 차례로 클릭합니다.

  4. 파일 이름 및 파일 형식을 ProdOrders.xsd와 같이 입력한 다음 저장을 클릭합니다.

추가 지원

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×