외부 데이터 원본으로 피벗 테이블 만들기

모든 데이터를 분석할 수 있다면 효과적인 비즈니스 의사 결정을 내리는 데 큰 도움이 됩니다. 하지만 특히 Microsoft Access 또는 Microsoft SQL Server 데이터베이스나 OLAP(온라인 분석 처리) 큐브 파일과 같이 Excel 외부에 데이터가 대량 저장되어 있는 경우에는 어디서부터 시작해야 할지 모르겠다는 사용자가 많습니다. 이 경우 외부 데이터 원본에 연결한 다음 피벗 테이블을 만들어 해당 데이터를 요약, 분석, 탐색, 표시하면 됩니다.

기존 외부 데이터 연결을 사용하여 피벗 테이블을 만드는 방법은 다음과 같습니다.

  1. 워크시트에서 아무 셀이나 클릭합니다.

  2. 삽입 > 피벗 테이블을 클릭합니다.

    삽입 탭의 피벗 테이블 단추

  3. 피벗 테이블 만들기 대화 상자의 분석할 데이터를 선택하십시오에서 외부 데이터 원본 사용을 클릭합니다.

    외부 데이터 원본 사용이 선택된 피벗 테이블 만들기 대화 상자

  4. 연결 선택을 클릭합니다.

  5. 연결 탭의 표시 상자에서 모든 연결이 선택된 상태로 두거나, 연결할 데이터 원본이 있는 연결 범주를 선택합니다.

기존 연결을 다시 사용하거나 공유하려면 이 통합 문서의 연결에서 연결을 사용합니다.

  1. 연결 목록에서 원하는 연결을 선택하고 열기를 클릭합니다.

  2. 피벗 테이블 보고서를 넣을 위치를 선택하십시오.에서 위치를 선택합니다.

    • 새 워크시트의 A1 셀에서부터 피벗 테이블이 시작되도록 하려면 새 워크시트를 클릭합니다.

    • 현재 워크시트에 피벗 테이블을 놓으려면 기존 워크시트를 선택한 다음 위치 상자에 피벗 테이블이 시작될 셀을 입력합니다.

  3. 확인을 클릭합니다.

    그러면 빈 피벗 테이블이 추가되고 필드 목록이 표시되어 사용자가 원하는 필드를 표시하고 다시 정렬하여 자신만의 레이아웃을 만들 수 있습니다.

    외부 데이터 필드를 보여 주는 필드 목록

  4. 필드 목록 구역에서 필드 이름 옆의 확인란을 선택하여 필드 목록의 영역 구역에 있는 기본 영역에 필드를 놓습니다.

    일반적으로 숫자가 아닌 필드는 영역에, 숫자 필드는 영역에, 날짜 및 시간 필드는 영역에 추가됩니다. 필요에 따라 필드를 다른 영역으로 이동할 수 있습니다.

    팁: 필드 이름을 마우스 오른쪽 단추로 클릭한 다음 보고서 필터에 추가, 열 레이블에 추가, 행 레이블에 추가 또는 값에 추가를 선택하여 필드를 영역 구역의 해당 영역에 놓거나, 필드 구역에서 영역 구역의 한 영역으로 필드를 끌어올 수도 있습니다 .

    필드 목록에서 영역 구역의 필드를 마우스 오른쪽 단추로 클릭한 다음 원하는 영역을 선택하거나, 영역 구역의 영역 간에 필드를 끌어와 피벗 테이블 데이터를 다시 정렬할 수 있습니다.

새 외부 데이터 원본에 연결

SQL Server에 대한 새 외부 데이터 연결을 만들고 Excel에 표 또는 피벗 테이블 형태로 데이터를 가져오려면 다음을 수행합니다.

  1. 데이터 > 기타 원본을 클릭합니다.

데이터 탭의 기타 원본에서 단추

  1. 원하는 연결을 클릭합니다.

    • SQL Server 테이블에 연결하려면 SQL Server를 클릭합니다.

    • SQL Server Analysis 큐브에 연결하려면 Analysis Services를 클릭합니다.

  2. 데이터 연결 마법사의 단계에 따라 연결을 설정합니다.

    • 1페이지에서는 데이터베이스 서버를 입력하고 서버 로그온 방법을 지정합니다.

    • 2페이지에서는 원하는 데이터를 포함하는 데이터베이스, 테이블 또는 쿼리를 입력합니다.

    • 3페이지에서는 만들려는 연결 파일을 입력합니다.

Access 데이터베이스에 대한 새 연결을 만들고 Excel에 표 또는 피벗 테이블 형태로 데이터를 가져오려면 다음을 수행합니다.

  1. 데이터 > Access를 클릭합니다.

데이터 탭의 Access 단추

  1. 데이터 원본 선택 대화 상자에서 연결할 데이터베이스를 찾고 열기를 클릭합니다.

  2. 테이블 선택 대화 상자에서 원하는 테이블을 선택하고 확인을 클릭합니다.

테이블이 여러 개인 경우 원하는 테이블의 확인란을 선택할 수 있도록 여러 테이블 선택 사용 확인란을 선택하고 확인을 클릭합니다.

  1. 데이터 가져오기 대화 상자에서 통합 문서의 데이터 보기 방식과 데이터를 놓을 위치를 선택하고 확인을 클릭합니다.

테이블이 자동으로 데이터 모델에 추가되고 Access 데이터베이스가 통합 문서 연결에 추가됩니다.

피벗 테이블에 대한 추가 정보

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×