외부 데이터 범위 및 속성 관리

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

데이터베이스, 웹 쿼리 또는 텍스트 파일 등의 외부 데이터 원본에 대 한 연결을 통해 워크시트로 가져온 컨트롤 데이터를 외부 데이터 범위 속성을 변경할 수 있습니다.

외부 데이터 범위 (쿼리 테이블이 라고도 함)에 정의 된 이름이 나 워크시트에 표시 되는 데이터의 위치를 정의 하는 테이블 이름입니다. 외부 데이터에 연결 하는 경우 Excel 외부 데이터 범위를 자동으로 만들어집니다. 이 규칙의 유일한 예외는 데이터 원본에 연결 되어 있는 피벗 테이블 보고서-피벗 테이블 보고서를 외부 데이터 범위를 사용 하지 않습니다. Excel에서 있습니다 하거나 서식을 지정할 수 및 외부 데이터 범위 배치 다른 데이터와 마찬가지로 계산에 사용 합니다.

외부 데이터 범위 속성

외부 데이터 범위에 대 한 추가 속성 (사용 하지 않는 연결 속성와 다름) 사용 셀 서식 및 열 너비 보존 등 데이터를 제어할 수 있습니다. 데이터 탭의 연결 그룹에서 속성 을 클릭 하 여 이러한 외부 데이터 범위 속성을 변경할 수 있습니다. 다음을 실행 하 여 변경 내용을 확인 합니다.

  • Microsoft Query 및 데이터 연결 마법사에서 만들어진 외부 데이터 범위에 대 한 외부 데이터 속성 대화 상자를 사용 합니다.

  • 가져온된 텍스트 파일 또는 웹 쿼리 HTML 데이터를 검색 하 여 만든 외부 데이터 범위에 대 한 외부 데이터 범위 속성 대화 상자를 사용 합니다.

  • XML 데이터를 검색 하는 웹 쿼리에서 만든 외부 데이터 범위에 대 한 XML 맵 속성 대화 상자를 사용 합니다.

외부 데이터 범위가 지정 된 서식 파일 사용

요약 또는 외부 데이터에 기반 하는 보고서를 공유 하려는 경우 외부 데이터 범위에 포함 된 통합 문서를 다른 사용자에 게 제공 하거나 보고서 서식 파일을 만들 수 있습니다. 보고서 서식 파일 파일 크기가 되도록 외부 데이터를 저장 하지 않고 요약 이나 보고서를 저장할 수 있습니다. 사용자가 보고서 서식 파일을 열 때 외부 데이터를 검색 합니다.

  1. 외부 데이터 범위 검색 워크시트를 선택 합니다.

  2. 수식 입력줄이름 상자 옆의 화살표를 클릭 한 다음 원하는 외부 데이터 범위 이름을 클릭 합니다.

  1. 수식 탭의 정의된 이름 그룹에서 이름 관리자를 클릭합니다.

    Excel 리본 메뉴 모양

  2. 이름 관리자 대화 상자에서 외부 데이터 범위의 이름을 클릭 한 다음 편집 을 클릭 합니다. 이름을 두 번 클릭 합니다.

  3. 이름 편집 대화 상자의 이름 상자에 대 한 참조에 대 한 새 이름을 입력 합니다.

참고: 닫기 단추 이름 관리자 대화 상자를 닫습니다. 이미 변경한 내용을 적용 하려면 닫기를 클릭 하지 않아도 됩니다.

Microsoft Query, 가져온된 텍스트 파일, 웹 쿼리 또는 데이터 연결 마법사에서 생성 된 외부 데이터 범위에 대 한 기본 쿼리를 변경할 수 있습니다.

  1. 기본 쿼리를 변경 하려면 외부 데이터 범위에서 셀을 클릭 합니다.

  2. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  3. 외부 데이터 속성 대화 상자에서 속성 연결 속성 클릭 합니다.

  4. 연결 속성 대화 상자에서 정의 탭을 클릭 한 다음 쿼리 편집 을 클릭 합니다.

구성 하 고 Microsoft Query에서 쿼리를 편집 하는 방법에 대 한 자세한 내용은 Microsoft Query 도움말을 참조 합니다.

  1. 기본 쿼리를 변경 하려면 외부 데이터 범위에서 셀을 클릭 합니다.

  2. 데이터 탭의 연결 그룹에서 연결을 클릭합니다.

    Excel 리본 메뉴 이미지

  3. 통합 문서 연결 대화 상자에서 속성 을 클릭 합니다.

  4. 연결 속성 대화 상자에서 정의 탭을 클릭 한 다음 쿼리 편집 을 클릭 합니다.

  5. 텍스트 파일 가져오기 대화 상자에서 가져오기 를 클릭 합니다.

  6. 텍스트 가져오기 마법사에서 가져온된 텍스트 파일을 변경 하 고 완료 를 클릭 합니다.

    텍스트 파일 가져오기에 대 한 자세한 내용은 가져오기 또는 내보내기 텍스트 파일을 참조 하십시오.

  1. 기본 쿼리를 변경 하려면 외부 데이터 범위에서 셀을 클릭 합니다.

  2. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  3. 통합 문서 연결 대화 상자에서 속성 을 클릭 합니다.

  4. 연결 속성 대화 상자에서 정의 탭을 클릭 한 다음 쿼리 편집 을 클릭 합니다.

  5. 웹 쿼리 편집 대화 상자에서 웹 쿼리를 변경 하 고 완료 를 클릭 합니다.

만들기 및 웹 쿼리를 편집 하는 방법에 대 한 자세한 내용은 웹 페이지 (파워 쿼리)에 연결을 참조 합니다.

  1. 기본 쿼리를 변경 하려면 외부 데이터 범위에서 셀을 클릭 합니다.

  2. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  3. 외부 데이터 속성 대화 상자에서 속성 연결 속성 클릭 합니다.

  4. 연결 속성 대화 상자에서 정의 탭을 클릭 합니다.

  5. 다음 중 하나를 수행합니다.

    • 명령 유형 상자에서 테이블 을 클릭 한 다음 명령 텍스트 상자에 적절 한 테이블, 뷰 또는 쿼리 이름을 값 변경 합니다.

    • 명령 유형 상자에서 SQL기본 또는 클릭 한 다음, 명령 텍스트 상자에 SQL 문을 편집 합니다.

      참고: 연결 정의 방법에 따라 명령 유형 상자 하지 못할 (흐리게 표시).

  1. 수식 입력줄의 이름 상자 옆의 화살표를 클릭 하 고 복사할 외부 데이터 범위 이름을 선택 합니다.

    Excel 테이블에 대 한 범위에서 이름을 선택 하 고 표 머리글을 선택 하려면 CTRL + A를 누릅니다.

    열 레이블 또는 외부 데이터 범위에 포함 되지 않은 수식을 포함 하려는 경우 열 레이블 또는 복사 하려는 수식이 들어 있는 셀을 선택 합니다. 수식 입력줄의 이름 상자 옆의 화살표를 클릭 하 고 복사할 외부 데이터 범위의 이름을 클릭 합니다.

  2. 탭의 클립보드 그룹에서 복사를 클릭합니다.

    Excel 리본 메뉴 모양

  3. 외부 데이터 범위를 붙여 넣을 통합 문서로 전환 합니다.

  4. 붙여 넣을 영역 의 왼쪽 위 셀을 클릭 합니다.

    외부 데이터 기존 데이터를 대체 하지 않습니다 되도록 워크시트에서 또는 클릭 하 여 셀의 오른쪽에 데이터가 없는 있는지 확인 합니다.

  5. 탭의 클립보드 그룹에서 붙여넣기를 클릭합니다.

참고: 외부 데이터 범위 중 일부를 복사 하는 경우 내부 쿼리 복사 하지 않고 하 고 복사한 데이터를 새로 고칠 수 없습니다.

데이터를 새로 고칠 때 Excel에 반환 되는 작거나 큰 데이터 집합을 처리 하는 방법을 제어할 수 있습니다.

  1. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  2. 외부 데이터 범위 속성 대화 상자에서 새로 고칠 때의 데이터 범위에 있는 행의 수를 변경 하는 경우 에서 다음 중 하나를 클릭 합니다.

    • 새 데이터에 대 한 셀 삽입, 사용 하지 않는 셀 삭제

      참고 사항: 

      • 데이터 원본에서 하나 이상의 행을 추가할 때 직접 외부 데이터 범위에서 셀을 아래로 이동 하지만 외부 데이터 범위 오른쪽에 있는 셀을 이동 하지 않습니다.

      • 데이터 원본에서 하나 이상의 행이 삭제 직접 외부 데이터 범위에서 셀을 위로 이동 하지만 외부 데이터 범위 오른쪽에 있는 셀을 이동 하지 않습니다.

    • 새 데이터에 대 한 전체 행 삽입을 사용 하지 않는 셀 지우기

      참고 사항: 

      • 데이터 원본에서 하나 이상의 행을 추가할 때 바로 아래 및 외부 데이터 범위를 오른쪽으로 셀 아래로 이동 합니다.

      • 데이터 원본에서 하나 이상의 행이 삭제 셀 바로 아래에서 외부 데이터 범위를 오른쪽으로 이동 하지 않습니다.

    • 기존 셀을 새 데이터로 덮어쓰기, 사용 하지 않는 셀 지우기

      참고 사항: 

      • 데이터 원본에서 하나 이상의 행을 추가할 때 직접 외부 데이터 범위에서 셀을 덮어씁니다 되지만 외부 데이터 범위 오른쪽에 있는 셀을 이동 하지 않습니다.

      • 데이터 원본에서 하나 이상의 행이 삭제 셀 바로 아래에서 외부 데이터 범위를 오른쪽으로 이동 하지 않습니다.

  1. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  2. 데이터 서식 및 레이아웃에서 다음 중 하나 이상을 실행 합니다.

    • 필드 이름을 첫 번째 행을 포함 하려면 필드 이름 포함 확인란을 선택 합니다.

      참고: 이 확인란은 프로그래밍 방식으로 만들어지는 외부 데이터 범위 또는 Microsoft Office 2003 프로그램에서 변환 되는 외부 데이터 범위에 사용할 수만 있습니다.

    • 행 숫자 열을 추가 하려면 행 번호 포함 확인란을 선택 합니다.

      참고: 이 확인란은 가져온된 텍스트 파일, XML 파일 또는 웹 쿼리를 사용할 수 있습니다.

    • 서식을 적용 하는 셀을 유지 하려면 셀 서식 유지 확인란을 선택 합니다.

      참고: 이 옵션이 웹 쿼리에 대 한 완전 한 HTML 서식옵션 대화 상자에서를 선택할 때 자동으로 지워집니다. 쿼리 편집 대화 상자에서 옵션 대화 상자에 액세스 합니다.

    • 설정 하는 열 너비를 유지 하려면 열 너비 조정 확인란을 선택 합니다.

    • 정렬, 필터링 및 레이아웃을 적용 하는 열을 유지 하려면 열 정렬/필터/레이아웃 유지 확인란을 선택 합니다.

      참고: 이 확인란은 웹 쿼리를 사용할 수 있습니다.

    • 적용 하는 열 필터링을 유지 하려면 열 필터 유지 확인란을 선택 합니다.

      참고: 이 확인란은 XML 데이터에 기반 하는 웹 쿼리에 대해서만 사용할 수 있습니다.

참고: 다음 절차에 따라 Microsoft Office 2003 프로그램에서 변환 되는 외부 데이터 범위 또는 프로그래밍 방식으로 만들어지는 외부 데이터 범위에만 적용 됩니다. 사용자 인터페이스를 사용 하 여 만든 모든 외부 데이터 범위는 Excel 표로 만들어집니다. 다음이 표에 새 행 추가 되 고 채우기 때 자동으로 확장 아래쪽 계산 된 열입니다.

  1. 외부 데이터 범위에서 데이터의 첫 번째 행에 인접 한 셀에 수식을 입력 합니다.

    참고: 첫 번째 데이터 행에 첫 번째 행에 머리글 포함 되는지 여부에 따라 외부 데이터 범위에 있는 첫 번째 또는 두 번째 행 수 있습니다.

  2. 셀을 선택 하 고 외부 데이터 범위에 있는 모든 행에 수식을 복사 하려면 채우기 핸들 를 두 번 클릭 합니다.

  3. 외부 데이터 범위에서 셀을 클릭합니다.

  4. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  5. 외부 데이터 범위 속성 대화 상자에서 데이터에 인접 한 열에 수식을 아래로 채우기 확인란을 선택 합니다.

    참고: 외부 데이터 범위를 새로 고침, Excel 또는 외부 데이터 범위 내에 즉시 인접 한 수식만 복사 하는 경우 확장 합니다.

고정 된 외부 데이터 범위를 새로 고칠 수 없음 되므로 데이터 하지만 기본 쿼리 하지를 유지 외부 데이터 범위를 중지 합니다.

  1. 데이터 연결을 제거 하려는 Excel 표가 포함 된 워크시트를 클릭 합니다.

  2. 수식 입력줄의 이름 상자 옆의 화살표를 클릭 한 다음 데이터 연결을 제거 하려는 외부 데이터 범위 이름을 클릭 합니다. 데이터 범위를 선택 합니다.

  3. 도구 탭의 외부 테이블 데이터 그룹에서 연결 끊기 를 클릭 합니다. 데이터 범위를 유지 되 고 이름이 같은 여전히 되지만 연결이 삭제 됩니다.

참고: 다음 절차에 따라 Microsoft Office 2003 프로그램에서 변환 되는 외부 데이터 범위 또는 프로그래밍 방식으로 만들어지는 외부 데이터 범위에만 적용 됩니다. 사용자 인터페이스를 사용 하 여 만든 모든 외부 데이터 범위는 Excel 표로 만들어집니다. 다음이 표에 새 행 추가 되 고 채우기 때 자동으로 확장 아래쪽 계산 된 열입니다.

  1. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  2. 쿼리 정의 에서 쿼리 정의 저장 확인란의 선택을 취소 합니다.

참고: 통합 문서를 저장 하면 통합 문서에서 기본 쿼리 삭제 됩니다. 그러나 저장 된 데이터베이스 쿼리 파일 (.dqy 또는.odc 파일)는 삭제 되지 않습니다. Microsoft Query 또는 쿼리 마법사에서 만든을 쿼리를 저장 하는 경우 쿼리의 파일이 컴퓨터에 저장 된 및 외부 데이터를 검색 하는 쿼리를 다시 사용할 수 있습니다. 자세한 내용은 Microsoft 쿼리 도움말을 참조 합니다.

참고: 다음 절차에만 적용 데이터 연결 마법사 또는 Microsoft Query를 사용 하 여 만든 외부 데이터 범위 (되며 가져온된 텍스트 파일 또는 웹 쿼리를 하지), Microsoft Office 2003 프로그램 또는 외부에서 변환 된 외부 데이터 범위 데이터 범위 프로그래밍 방식으로 만들어집니다. 사용자 인터페이스를 사용 하 여 만든 모든 외부 데이터 범위는 Excel 표로 만들어집니다.

  1. 다음 중 하나를 실행 하 여 외부 데이터 범위 위에 빈 행을 삽입 합니다.

    • 새 행을 삽입 하려는 위의 셀을 선택 합니다. 그런 다음 탭의 그룹에서 삽입 옆의 화살표를 클릭 하 고 시트 행 삽입 을 클릭 합니다. 한 셀을 선택 하면 때문에 새 행이 하나 현재 행 위에 삽입 됩니다.

    • 새 행을 삽입할 위치 위에서 행의 행 선택기를 클릭 합니다. 그런 다음 탭의 그룹에서 삽입 을 클릭 합니다. 전체 행이 하나를 선택 하면 때문에 새 행이 하나 선택한 행 위에 삽입 됩니다.

  2. 빈 행에 있는 셀에 원하는 레이블을 입력 합니다.

  3. 외부 데이터 범위에서 셀을 클릭합니다.

  4. 데이터 탭의 연결 그룹에서 속성 을 클릭 합니다.

    Excel 리본 메뉴 이미지

  5. 데이터 서식 및 레이아웃에서 외부 데이터 범위 속성 대화 상자의 필드 이름 포함 확인란의 선택을 취소 한 다음 확인 을 클릭 합니다.

  6. 기존 필드 이름 제거 하 고 외부 데이터 범위를 새로 고치려면, 외부 데이터 범위에서 셀을 클릭 하 고 단추 모양 데이터 새로 고침 클릭 합니다.

참고: 데이터베이스에서 데이터를 검색할 때는 Microsoft Query에서 열 이름에 변경 내용은 외부 데이터 범위에 유지 됩니다. 쿼리에서 열 이름을 변경 하는 방법에 대 한 정보를 Microsoft 쿼리 도움말을 참조 합니다.

  1. 삭제 하려는 외부 데이터 범위에 포함 된 워크시트를 클릭 합니다.

  2. 수식 입력줄의 이름 상자 옆의 화살표를 클릭 한 다음 삭제할 외부 데이터 범위 이름을 클릭 합니다.

    외부 데이터 범위는 Excel 표를 전체 표를 선택 하려면 CTRL + A를 누릅니다.

  3. 외부 데이터 범위를 삭제 하려면 DELETE 키를 누릅니다.

  4. Excel 묻는 메시지가 나타나면 기본 쿼리를 삭제 하려면 를 클릭 합니다.

추가 지원

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×