시작: InfoPath 및 SharePoint를 사용하여 회의 메모 시스템 만들기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

예제 양식 서식 파일에서 Microsoft Office InfoPath 2007 부 수정 하 고 Windows SharePoint Services 3.0 사이트에서 문서 라이브러리를 만들어를 일관 된 방식에 대 한 회의 노트, 모든 모임 참석자에 게는 노트 보내기 하는 데 사용할 수 있는 시스템을 구현할 수 및 SharePoint Services 문서 라이브러리에서 해당 노트를 저장 합니다. 이 문서는이 시스템을 만드는 방법을 보여 줍니다.

이 문서의 내용

개요

시작 하기 전에

새 만들기 회의 메모 시스템

양식 서식 파일 업데이트

개요

InfoPath에 포함 된 회의록, 참석자, 토론 항목 및 작업 항목 등의 일반적인 모임 데이터를 수집 하기 위해 특별히 디자인 된 예제 양식 서식 파일이입니다. 예제 양식 서식 파일의 모든 모임 참석자에 게 전자 메일을 통해 서식 파일에 기반 하는 양식 복사본을 보낼 수 있도록 구성 됩니다.

예제 양식 서식 파일은 일반적으로 모임에 기록 된 데이터 수집 노트 필기 하는 데 도움이 되도록 구성 됩니다. 컨트롤에 올바른 데이터를 수집 하 고도 자동으로 생성 될 수 있는 데이터를 수집 하기 줄이고 노트 필기 하는 데 도움이 논리적 섹션에서 정렬 됩니다. 또한 컨트롤의 레이아웃 채워지도록 수집할 데이터 종류를 기억 하지 노트 필기 하는 대신 그만 모임 진행에 따른 비어 있는 일관 된 프레임 워크를 제공 합니다.

추가 데이터를 수집 하기 위해 양식 서식 파일을 수정할 수는 있지만 완성 된 양식을 SharePoint 문서 라이브러리에 저장할 수 있는 하나의 수정 그대로 기존 양식 서식 파일을 사용 하는 것이 좋습니다. 다음 시스템의 효율성을 테스트 하 고 그룹의 요구에 맞게 양식 서식 파일을 수정 하는 테스트 하는 동안 배운 사용 하 여 수 있습니다.

SharePoint 사이트에서 새 문서 라이브러리에 예제 양식 서식 파일을 게시 하 여이 예제 양식 서식 파일 시스템에서 사용할 수 있습니다. 게시 프로세스의 일환으로 새 문서 라이브러리를 만들게 됩니다. 양식 서식 파일을 게시 하 고 새 문서 라이브러리를 만들어 후 완성된 된 양식을 새 문서 라이브러리에 저장 하 고 모임 참석자에 게 폼의 복사본을 보냅니다 되도록 양식 서식 파일을 수정 다음 합니다.

이 시스템을 사용 하려면 노트 필기 문서 라이브러리로 이동 하 고이 양식 서식 파일에 기반 하는 새 양식을 만듭니다. 모임 중 노트 필기 양식에서 적절 한 컨트롤의 데이터를 채웁니다. 모임 끝 노트 필기 제출 문서 라이브러리에 양식 및 양식 사본을 각 모임 참석자에 게 전송 됩니다. 모임 참석 하지 않은 사람 InfoPath에서 양식을 열고 문서 라이브러리로 이동 하 여 노트를 읽을 수 있습니다.

예제 양식 서식 파일에는 다음 섹션에서는 포함 됩니다.

4개 구역이 있는 회의 일정 및 의사록 양식 서식 파일

1. 제목 섹션 이름, 목적, 위치 및 모임 날짜 및 시간에 대 한 컨트롤을 포함합니다. 날짜 컨트롤 양식을 만든 날짜를 자동으로 표시 합니다. 종료 시간 텍스트 상자 컨트롤에는 기본적으로 시간 즉 1 시간까지 시작 시간 텍스트 상자 컨트롤에 입력 된 시간 보다 나중에 자동으로 표시 됩니다.

2. 참석자 구역에 포함 된 이름 및 각 모임 참석자의 전자 메일 주소에 대 한 반복 합니다. 노트 필기가 완료 된 양식을 전송 하는 경우이 섹션에 나열 된 각 attendee 완료 된 폼의 복사본을 받습니다.

3. 토론 항목 반복 구역 컨트롤에 각 발표자 도구 (토론 잠재 고객을 누가 참석자) 및 각 토론 항목에 대 한 메모 포함 되어 있습니다. 발표자 드롭다운 목록 상자 컨트롤의 참석자 섹션에서 이름을 표시 합니다.

4. 반복 구역 작업 항목 이름, 배정 및 기한에 대 한 컨트롤이 포함 된 각 작업 항목에 대 한 날짜입니다. 배정 드롭다운 목록 상자 컨트롤의 참석자 섹션의 이름이 표시 됩니다.

InfoPath을 처음 접하는 경우 다음 문서는 중요 한 개념을 이해 하 고 효율적이 문서의 각 작업을 완료 하면 발생할 수 있는 조건으로 정의 데 도움이 됩니다. 또한 작업을 완료 하면 더 많은 정보가 필요한 경우에이 문서의 적절 한 섹션에서이 링크를 찾을 수 있습니다.

  • 양식 서식 파일 및 양식 소개 양식 서식 파일 및 양식에 차이점에 설명 합니다. 양식 서식 파일을 만들어집니다. 시스템에서이 양식 서식 파일에 기초한 양식을 만드는 모임 메모를 사용 하는 모든 사람

  • 데이터 원본 소개 양식 서식 파일에 기반 하는 양식을 작성 하는 경우 데이터 저장에 대해 설명 합니다.

  • 양식 서식 파일에 기반 하는 양식 가져오고 데이터를 보냅니다 소개 데이터 연결에 설명 합니다.

  • 양식 데이터 전송 소개 SharePoint 문서 라이브러리의 저장소 위치를 폼에 데이터를 제출 하는 방법에 설명 합니다.

  • 컨트롤에 수식을 추가 양식 서식 파일에 기초한 양식 컨트롤에 새 데이터 수 있는 자동으로 계산 하는 방법을 설명 합니다.

  • 양식 서식 파일 게시 소개 사용자 전에 수행 해야 하는 최종 작업은 양식 서식 파일에 기반 하는 양식을 채울 수에 대해 설명 합니다.

맨 위로 이동

시작하기 전에

되는 URL Uniform Resource Locator ()을, 여기에 최소한 디자인 권한이이 시스템에 대해 사용 하려는 SharePoint 사이트의 사이트 모음에 있습니다. 사이트 모음에서 문서 라이브러리를 만들면 적절 한 사용 권한이 있는입니다. 모임 메모를 보려면 필요한 사용자가 읽기 사이트 모음을 권한이 필요 합니다. 문서 라이브러리를 만들거나 양식 사용자에 대 한 사이트 모음에 대 한 읽기 권한을 설정 하려면 사용 권한이 필요한 경우 사이트 모음 관리자에 게 문의 합니다.

도 완성 된 양식 및 전자 메일 클라이언트 Microsoft Office Outlook 2007, 양식 서식 파일을 테스트할 수 있도록 메시지를 수신 하도록 구성 하는 등의 복사본을 보낼 수 있는 하나 이상의 전자 메일 주소를 걸어야 합니다.

이 문서에서는 SharePoint Services의 기본 구성을 사용 하는 것으로 가정 합니다.

맨 위로 이동

새 만들기 회의 메모 시스템

이 시스템을 만들려면 다음을 수행 합니다.

  1. 열기 및 예제 양식 서식 파일을 저장 합니다.

  2. 모임 메모에 대 한 새 문서 라이브러리를 만들려면 예제 양식 서식 파일을 게시 합니다.

  3. 완성 된 양식을 새 문서 라이브러리에 저장 한 다음 각 참석자 복사본을 보낼 예제 양식 서식 파일을 수정 합니다.

  4. 수정 된 양식 서식 파일을 게시 합니다.

  5. 수정 된 양식 서식 파일 및 새 문서 라이브러리를 만들고이 양식 서식 파일을 기반으로 하는 테스트 양식을 전송 하 여 테스트 합니다.

열기 및 양식 서식 파일 저장

  1. 파일 메뉴에서 양식 서식 파일 디자인 을 클릭 합니다.

  2. 양식 서식 파일을 열고 사용자 지정 예제를 클릭 합니다.

  3. 샘플 사용자 지정 샘플 의사록 을 두 번 클릭 합니다.

  4. 파일 메뉴에서 저장을 클릭합니다.

  5. InfoPath 양식 서식 파일 게시에 대 한 메시지가 나타나면 확인 을 클릭 합니다.

  6. 다른 이름으로 저장 대화 상자에서 양식 서식 파일을 저장할 위치를 지정 합니다.

  7. 파일 이름 상자에 양식 서식 파일의 이름을 입력 합니다.

  8. 파일 형식 목록에서 InfoPath 양식 서식 파일 을 클릭 한 다음 저장 을 클릭 합니다.

양식 서식 파일 게시

게시 프로세스의 일환으로, 새 문서 라이브러리를 만들게 됩니다.

양식 서식 파일 게시 하는 방법에 대 한 자세한 내용은 양식 서식 파일 게시 소개문서를 참조 합니다.

  1. 파일 메뉴에서 게시 를 클릭 합니다.

  2. 게시 마법사의 첫 번째 페이지에서 SharePoint 서버와 관계 없이 InfoPath Forms Services를 클릭 한 후 다음 을 클릭 합니다.

  3. InfoPath Forms Services 또는 SharePoint 사이트의 위치를 입력 하십시오 상자에서 마법사의 다음 페이지에서 SharePoint 사이트에서 사이트 모음의 URL을 입력 한 후 다음 을 클릭 합니다. 예를 들어 URL http://www.adventureworks.com/EmployeesOnly으로 사이트 모음을 사용 하려면 입력할 http://www.adventureworks.com/EmployeesOnly 상자에 있습니다.

  4. 다음 페이지에서 문서 라이브러리 를 클릭 하 고 을 클릭 합니다.

  5. 다음 페이지에서 새 문서 라이브러리 만들기 를 클릭 한 후 다음 을 클릭 합니다.

  6. 다음 페이지에서 이름 및 새 문서 라이브러리에 대 한 설명을 입력 한 후 다음 을 클릭 합니다.

  7. 제안 된 열에 동의 하 고 을 클릭 합니다.

  8. 마법사의 마지막 페이지에 표시 된 정보가 올바른지 확인 하 고 게시 를 클릭 합니다.

  9. 닫기를 클릭합니다.

    양식 서식 파일을 성공적으로 게시 하는 경우 마법사의 마지막 페이지에서 확인을 받았으면 됩니다.

새 문서 라이브러리; URL 기록 이 문서 뒷부분에이 정보가 필요 합니다. 새 문서 라이브러리의 URL 뒤에 슬래시 (/) 문서 라이브러리의 이름을 차례로 사이트 모음의 URL 됩니다. 예를 들어 http://www.adventureworks.com/EmployeeOnlyURL 포함 된 사이트 모음에서 회의 노트 이라는 새 문서 라이브러리를 만든 경우 새 문서 라이브러리의 URL http://www.adventureworks.com/EmployeeOnly/MeetingNotes수 있습니다.

양식 서식 파일 수정

이 섹션에서는 다음을 수행 하는 방법에 설명:

  • 데이터 연결을 제출 완료 된 양식을 새 문서 라이브러리에 저장 하는 추가 합니다.

    전송 데이터 연결에 대 한 자세한 내용을 보려면, 데이터 연결 소개를 참고 합니다.

  • 완성 된 양식을 문서 라이브러리에 저장 하 고 각 모임 참석자에 완료 된 폼의 복사본을 보냅니다 있도록 데이터 연결에 대 한 옵션을 변경 합니다.

  • 양식을 전송한 후 닫기 양식 서식 파일을 구성 합니다.

양식 서식 파일에 기반 하는 양식을 전송 하는 방법에 대 한 자세한 내용은 양식 데이터 전송 소개문서를 참고 하세요.

새 추가 전송 데이터 연결

이 섹션에 새 만들어집니다 새 문서 라이브러리에 데이터 연결을 제출 하 고 양식을 고유한 이름으로 저장 하는 데이터 연결을 구성 합니다. 양식 이름을 모임 제목 및 양식을 만든 날짜의 조합 됩니다.

데이터 연결 만들기 시작
  1. 도구 메뉴에서 데이터 연결 을 클릭 합니다.

  2. 데이터 연결 대화 상자에서 추가 클릭 합니다.

  3. 데이터 연결 마법사에서 새 연결을 만들려면 을 클릭 데이터 전송 클릭 한 후 다음 을 클릭 합니다.

  4. 마법사의 다음 페이지에서 SharePoint 사이트의 문서 라이브러리를 클릭 한 후 다음 을 클릭 합니다. 데이터 연결 마법사에서 데이터를 전송할 대상 선택

  5. 문서 라이브러리 상자에서 마법사의 다음 페이지에서 이전 섹션에서 만든 문서 라이브러리의 URL을 입력 합니다. 예를 들어 문서 라이브러리에서 http://www.adventureworks.com/EmployeesOnly/MeetingNotesURL 사용 하려면 입력할 http://www.adventureworks.com/EmployeesOnly/MeetingNotes문서 라이브러리 상자에 있습니다.

    다음 섹션에서는 마법사의이 페이지에 유지 해야 하는 고유한 양식 이름을 정의 하는 과정을 안내 합니다. 클릭 하지 다음 아직 합니다.

고유한 양식 이름 정의

양식 서식 파일을 기본 이름으로 문서 라이브러리에 양식 저장 됩니다. 기본 이름을 사용 하는 경우 새 문서 라이브러리를 하나만 완성 된 양식을 저장 합니다. 이 섹션에서 모임 제목, 모임 날짜도 구성 된 이름 가진이 양식 서식 파일을 기반으로 하는 폼을 저장 하려면 데이터 연결을 구성 합니다. XPath 함수를 사용 하는 수식을 작성 하 여이 수행 합니다.

수식 및 함수 사용에 대 한 자세한 내용은 컨트롤에 수식을 추가참조 합니다.

  1. 수식 삽입 수식 단추 를 클릭 합니다.

  2. 수식 삽입 대화 상자에서 함수 삽입 을 클릭 합니다.

  3. 함수 삽입 대화 상자의 범주 목록에서 텍스트 를 클릭 합니다.

  4. 함수 목록에서 concat 클릭 한 다음 확인 을 클릭 합니다.

  5. 수식 상자에서 필드를 삽입 하려면 두 번 클릭 의 첫 번째 인스턴스를 두 번 클릭 합니다.

    두 번 클릭하여 양식 이름의 일부로 사용할 첫 번째 필드 삽입

  6. 필드 또는 그룹 선택 대화 상자에서 모임 열기 meetingTitle 를 클릭 한 다음 확인 을 클릭 합니다.

    필드 또는 그룹 선택 대화 상자에서 meetingTitle 필드 선택

  7. 수식 상자에서 필드를 삽입 하려면 두 번 클릭 하 여 선택의 두 번째 인스턴스를 클릭 (없는 두 번 클릭).

    두 번 클릭하여 대시 문자를 양식 이름의 일부로 삽입

  8. 큰따옴표를 입력 ("), 대시 (-), 다른 큰따옴표 옵니다.

    대시 문자를 양식 이름의 일부로 삽입

  9. 필드를 삽입 하려면 두 번 클릭 의 세 번째 인스턴스를 두 번 클릭 합니다.

    두 번 클릭하여 양식 이름의 일부로 사용할 다른 필드 삽입

  10. 필드 또는 그룹 선택 대화 상자에서 모임 열기 meetingDate 를 클릭 한 다음 확인 을 클릭 합니다.

    필드 또는 그룹 선택 대화 상자에서 meetingDate 필드 선택

    수식 삽입 대화 상자는 다음과 같이 표시 됩니다.

    양식 이름을 작성하는 수식 삽입 대화 상자의 완성된 수식

  11. 수식 삽입 대화 상자에서 올바른 구문을 수식 확인 하려면 수식 확인 을 클릭 합니다.

  12. 수식 오류가 포함 되어 있지 않으면, 대화 상자를 닫으려면 확인 클릭 합니다.

데이터 연결 설정 완료
  1. 마법사에서 다음 을 클릭 합니다.

  2. 이 데이터 연결에 대 한 이름 입력 상자에 마법사의 다음 페이지에서이 대 한 설명이 포함 된 이름을 입력 하는 데이터 연결을 제출 합니다.

  3. 요약 구역에 있는 정보가 정확한 지 확인 한 후 완료 를 클릭 합니다.

  4. 닫기를 클릭합니다.

  5. 파일 메뉴에서 저장을 클릭합니다.

두 전송 데이터 연결을 사용 하 여 전송 옵션 변경

  1. 도구 메뉴에서 전송 옵션 을 클릭 합니다.

  2. 전송 옵션 대화 상자에서 사용자가이 양식을 제출할 수 있음 확인란을 선택 합니다.

  3. 규칙을 사용 하 여 사용자 지정 작업 수행 을 클릭 한 다음 규칙 을 클릭 합니다.

  4. 양식 전송에 대 한 규칙 대화 상자에서 추가 클릭 합니다.

  5. 작업 추가 클릭 합니다.

  6. 작업 상자에서 데이터 연결을 사용 하 여 전송을 클릭 합니다.

  7. 데이터 연결 목록에서 이전 섹션에서 만든 문서 라이브러리에 대 한 데이터 연결을 클릭 한 다음 확인 을 클릭 합니다.

  8. 작업 추가 클릭 합니다.

  9. 작업 상자에서 데이터 연결을 사용 하 여 전송을 클릭 합니다.

  10. 데이터 연결 목록에서 기본 전송 을 클릭 한 다음 확인 을 클릭 합니다.

    기본 전송 데이터 연결을 사용 하면 각 참석자 폼의 복사본을 보냅니다.

  11. 규칙 대화 상자의 이름 상자에 방금 만든 규칙을 식별 하는 전송 규칙 을 입력 합니다.

  12. 확인을 두 번 클릭합니다.

양식을 전송한 후 닫으려면 양식 서식 파일을 구성 합니다.

  1. 전송 옵션 대화 상자에서 고급 을 클릭 합니다.

  2. 제출 후 목록에서 양식 닫기 를 클릭 합니다.

  3. 확인을 클릭합니다.

  4. 파일 메뉴에서 저장을 클릭합니다.

양식 서식 파일 게시

양식 서식 파일을 수정한 후 수정 배포 하는 데 문서 라이브러리에 게시 해야 합니다.

  1. 파일 메뉴에서 게시 를 클릭 합니다.

  2. 게시 마법사의 첫 번째 페이지에서 SharePoint 서버와 관계 없이 InfoPath Forms Services를 클릭 한 후 다음 을 클릭 합니다.

  3. InfoPath Forms Services 또는 SharePoint 사이트의 위치를 입력 하십시오 상자에서 마법사의 다음 페이지에서 SharePoint 사이트의 사이트 모음에서 문서 라이브러리의 위치를 입력 한 후 다음 을 클릭 합니다.

  4. 다음 페이지에서 문서 라이브러리 를 클릭 하 고 을 클릭 합니다.

  5. 다음 페이지에서 기존 문서 라이브러리의 양식 서식 파일 업데이트 를 클릭 합니다.

  6. 문서 라이브러리를 업데이트 목록에서 문서 라이브러리를 클릭 한 후 다음 을 클릭 합니다.

  7. 다음을 클릭합니다.

  8. 다음 페이지에서 표시 된 정보가 올바른지 확인 하 고 게시 를 클릭 합니다.

    양식 서식 파일을 성공적으로 게시 하는 경우 마법사의 마지막 페이지에서 확인을 받았으면 됩니다.

양식 서식 파일 및 사이트 테스트

  1. 게시 마법사의 마지막 페이지에서 이 문서 라이브러리 열기 를 클릭 한 다음 닫기 를 클릭 합니다.

  2. 문서 라이브러리에서 새로 만들기 를 클릭 합니다.

  3. 모임에서 노트를 작성 된 경우에 따라 양식을 작성 합니다. 시작 시간 텍스트 상자 컨트롤에 시간을 입력 한 후 다음 컨트롤을 이동 하려면 TAB 키를 누릅니다. InfoPath 종료 시간 텍스트 상자 컨트롤에 자동으로 채웁니다.

  4. 참석자 섹션의 전자 메일 상자에 모임 참석자의 전자 메일 주소를 입력 합니다. 다른 참석자와의 전자 메일 주소를 추가 하려면 추가 참석자 를 클릭 합니다.

  5. InfoPath 도구 모음에서 전송 을 클릭 합니다.

  6. 대화 상자에서 올바른 전자 메일 주소가 표시 되는지 확인 합니다.

  7. 보내기를 클릭 한 다음 대화 상자를 닫으려면 확인 클릭 합니다.

모임 메모 문서 라이브러리에서 나타나고 새 전자 메일 메시지를 다른 이름으로 전자 메일 받은 편지함에 도달도 해야 합니다.

시스템을 만들고이 양식 서식 파일에 따라 몇 가지 양식을 전송 하 여 테스트 한 후 저장 하 고 모임 메모를 배포 시스템을 사용 하 여 시작할 수 있습니다.

맨 위로 이동

양식 서식 파일 업데이트

다른 사람이 모임 노트 만들기 및 저장 하 여 새 시스템 아웃 려 했을 후 자신의 의견에 대 한 응답에서 양식 서식 파일의 디자인을 변경 해야 할 수 있습니다. 양식 서식 파일을 변경 하려면 다음을 수행 해야 합니다.

  1. 문서 라이브러리에서 양식 서식 파일을 열고, 필요에 따라 양식 서식 파일 수정 및 다음 변경 내용을 저장 합니다.

  2. 양식 서식 파일을 게시 하 여 문서 라이브러리에 변경 내용을 적용 합니다.

문서 라이브러리에서 양식 서식 파일 열기

  1. 문서 라이브러리를 엽니다.

  2. 설정 을 클릭 한 다음 양식 라이브러리 설정을 클릭 합니다.

  3. 일반 설정 고급 설정을 클릭 합니다.

  4. 문서 서식 파일 섹션에 있는 서식 파일 URL 상자에서 서식 파일 편집 을 클릭 합니다.

  5. InfoPath 양식 서식 파일 게시에 대 한 메시지가 나타나면 를 클릭 합니다.

양식 서식 파일을 수정한 후 게시 하기 전에 양식 서식 파일을 저장 합니다.

양식 서식 파일 게시

모든 수정 후 수정 된 양식 서식 파일 문서 라이브러리에 게시 해야 합니다.

  1. 파일 메뉴에서 게시 를 클릭 합니다.

  2. 게시 마법사의 첫 번째 페이지에서 SharePoint 서버와 관계 없이 InfoPath Forms Services를 클릭 한 후 다음 을 클릭 합니다.

  3. InfoPath Forms Services 또는 SharePoint 사이트의 위치를 입력 하십시오 상자에서 마법사의 다음 페이지에서 SharePoint 사이트의 사이트 모음에서 문서 라이브러리의 위치를 입력 한 후 다음 을 클릭 합니다.

  4. 다음 페이지에서 문서 라이브러리 를 클릭 하 고 을 클릭 합니다.

  5. 다음 페이지에서 기존 문서 라이브러리의 양식 서식 파일 업데이트 를 클릭 합니다.

  6. 문서 라이브러리를 업데이트 목록에서 문서 라이브러리를 클릭 한 후 다음 을 클릭 합니다.

  7. 다음을 클릭합니다.

  8. 다음 페이지에서 표시 된 정보가 올바른지 확인 하 고 게시 를 클릭 합니다.

  9. 닫기를 클릭합니다.

    양식 서식 파일을 성공적으로 게시 한 경우 마법사의 마지막 페이지에서 확인을 받았으면 됩니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×