셰이프 사이 연결선 추가

Visio를 사용하면 드로잉에서 셰이프를 쉽게 연결할 수 있습니다. 자동 연결을 사용하여 셰이프를 추가할 때 연결할 수 있으며, 연결선 도구를 사용하여 기존 셰이프를 연결할 수 있습니다. 또한 미니 도구 모음에 표시되는 셰이프를 변경하고 자동 연결을 설정하거나 해제할 수 있습니다.

자동으로 셰이프 연결

페이지에 이미 있는 셰이프 연결

다른 페이지의 셰이프에 연결

테마를 사용하여 연결선 모양 변경

대체 연결선 셰이프 사용

자동 연결 미니 도구 모음의 셰이프 변경

자동 연결 설정/해제

자동으로 셰이프 연결

셰이프를 연결하는 한 가지 방법은 페이지에 셰이프를 추가할 때 자동으로 연결되도록 하는 것입니다. 이 방법은 순서도를 만들 때 특히 편리합니다.

  1. 자동 연결이 활성화되어 있는지 확인합니다. 보기 탭의 시각 보조 기능 그룹에서 자동 연결이 선택되어 있는지 확인합니다.

  2. 셰이프 창에서 페이지로 셰이프를 끕니다.

  3. 셰이프 주변에 자동 연결 화살표가 나타날 때까지 셰이프 위에 포인터를 둡니다.

    자동 연결이 활성화되면 셰이프를 마우스로 가리켜 연결 화살표를 표시합니다.
  4. 셰이프를 추가할 방향의 화살표 위에 포인터를 둡니다.

    자동 연결 화살표를 마우스로 가리키면 추가할 셰이프의 도구 모음이 표시됩니다.

    현재 빠른 셰이프 스텐실에 있는 처음 4개의 빠른 셰이프가 포함된 미니 도구 모음이 나타납니다. 도구 모음에서 셰이프를 가리키면 페이지에 해당 셰이프의 미리 보기가 표시됩니다.

  5. 추가하려는 셰이프를 클릭합니다.

  6. 계속하려면 새로 추가한 셰이프에 있는 자동 연결 화살표를 가리키고 다른 셰이프를 추가합니다. 추가된 셰이프도 자동으로 연결됩니다.

    새로 추가된 셰이프를 마우스로 가리키면 다른 셰이프를 추가할 수 있는 자동 연결 화살표가 표시됩니다.

맨 위로 이동

페이지에 이미 있는 셰이프 연결

팁:  탭의 도구 그룹에 있는 명령은 Visio를 다른 상태 또는 모드로 전환하여 때로 혼란스러울 수 있습니다. 키보드를 사용하여 포인터 도구 개체 선택 (Ctrl+1 누르기)와 연결선 단추 이미지 (Ctrl+3 누르기) 도구 간에 편리하게 전환하세요. 텍스트 블록 또는 연결점 등 사용 중인 도구가 무엇이든지 Esc 키를 몇 번 눌러 포인터 도구로 돌아가세요.

  1. 탭의 도구 그룹에서 연결선 단추 이미지 을 클릭하거나 Ctrl+3을 누릅니다.

  2. 셰이프를 클릭하고 연결선을 다른 셰이프로 끌어옵니다.

  3. 작업을 마치면 도구 그룹의 탭에서 포인터 도구 개체 선택 를 클릭하거나 Ctrl+1을 누릅니다.

연결선 도구가 각 끝에 지점 연결이 있는 셰이프로 연결합니다.

또는 셰이프 연결 명령을 리본에 추가하고 선택한 순서대로 여러 개의 셰이프를 연결하는 데 사용할 수 있습니다.

팁: 리본에 표시되지 않은 유용한 명령은 파일 > 옵션 > 리본 메뉴 사용자 지정을 클릭하여 추가할 수 있습니다.

맨 위로 이동

다른 페이지의 셰이프에 연결

같은 페이지에 있는 셰이프 간에만 연결선을 사용할 수 있습니다. 다른 페이지의 셰이프에 연결하려면 다른 페이지 참조 셰이프를 사용하여 한 페이지에서 다음 페이지로의 하이퍼링크를 만들거나, 셰이프에 하이퍼링크두 번 클릭 동작을 추가하여 같은 문서의 다른 페이지로 이동할 수 있습니다.

다른 페이지 참조 사용

  1. 기본 순서도 셰이프 스텐실을 연 다음 현재 페이지에서 다른 페이지 참조 셰이프를 끕니다.

    다른 페이지 참조 셰이프
  2. 다른 페이지 참조 대화 상자에서 확인을 선택하여 현재 페이지 및 새로 만든 페이지에 셰이프를 추가합니다.

  3. 새 페이지에서 다이어그램 만들기를 계속합니다.

  4. 다른 페이지 참조 셰이프의 모양을 변경하려면 셰이프를 마우스 오른쪽 단추로 클릭한 다음 송신, 수신, 또는 화살표를 선택합니다.

페이지 간에 이동하려면 양쪽 페이지에서 다른 페이지 참조 셰이프를 두 번 클릭합니다. 자세한 내용은 다른 페이지 참조 대화 상자를 참조하세요.

하이퍼링크 및 두 번 클릭 사용

  1. 마우스 오른쪽 단추로 셰이프를 클릭하거나 CTRL+K를 누른 후 하이퍼링크를 선택합니다.

  2. 하위 주소 필드 옆의 찾아보기를 클릭한 다음 페이지 옆의 드롭다운 목록을 클릭하여 원하는 페이지를 선택합니다.

    하이퍼링크 대화 상자

    참고: 대상 페이지의 셰이프 이름을 하이퍼링크에 지정할 수도 있습니다. 개발자 탭을 클릭한 다음 셰이프 이름을 선택합니다. 이름 필드에 기본 이름을 사용하거나 편집한 다음 확인을 클릭합니다.

  3. 셰이프에 대해 두 번 클릭 작업을 설정하려면 개발자 탭을 클릭한 다음 동작을 선택합니다.

  4. 두 번 클릭 탭을 클릭하고 페이지로 이동 옵션을 선택한 다음 드롭다운 목록을 클릭하여 원하는 페이지를 선택합니다.

    Visio 두 번 클릭 동작

    참고: 페이지 이름은 여기에서 자동으로 업데이트되지 않으므로 편집한 후에만 이 작업을 수행하세요.

맨 위로 이동

테마를 사용하여 연결선 모양 변경

연결선의 기본 모양은 단순한 선일 수 있으나 화살촉 같은 장식을 추가하는 테마를 사용하도록 디자인할 수 있습니다. 기본 제공 테마는 디자인 탭의 테마 갤러리에서 적용할 수 있습니다.

참고 사항: 

  • 더 많은 장식을 보려면 디자인 탭을 클릭합니다. 적용 그룹에서 드롭다운 화살표를 클릭한 다음 연결선을 선택합니다.

대체 연결선 셰이프 사용

기본 동적 연결선 셰이프를 사용하지 않고 다른 셰이프 > 기타 > 연결선 스텐실에서 제공되는 셰이프와 같은 모든 연결선 셰이프를 사용하여 셰이프를 함께 연결할 수 있습니다. 이러한 연결선 셰이프를 페이지로 끌어서 놓거나 연결선셰이프 연결 도구에서 사용하도록 선택하거나 이러한 셰이프를 사용하여 기존 연결선을 대체할 수 있습니다.

  1. 대체 연결선 셰이프가 포함된 스텐실을 엽니다.

  2. 페이지에서 대체할 기존 연결선을 선택합니다.

  3. 편집 그룹의 탭에서 셰이프 변경을 클릭한 다음 원하는 연결선 모양을 선택합니다.

참고: 셰이프 변경 기능은 Visio 2013에서 도입되었지만 연결선셰이프 연결 도구는 Visio 2007 이전에 도입되었습니다.

맨 위로 이동

자동 연결 미니 도구 모음의 셰이프 변경

미니 도구 모음에 있는 셰이프는 다이어그램의 빠른 셰이프 스텐실에서 가져옵니다. 미니 도구 모음에는 최대 4개의 셰이프가 표시됩니다. 미니 도구 모음에 표시되는 셰이프를 사용자 지정할 수 있습니다. 다음 절차에서는 기본 다이어그램을 예로 사용합니다.

  1. 기본적으로 미니 도구 모음의 셰이프는 빠른 셰이프 스텐실 바로 뒤에 있는 스텐실의 처음 4개 셰이프입니다. 예를 들어 다음은 기본 스텐실의 처음 4개 셰이프입니다.

    기본 셰이프를 사용하는 미니 도구 모음
  2. 특정 스텐실에 대해 미니 도구 모음에 다른 셰이프를 표시하려면 셰이프를 스텐실 맨 위로 끌어 셰이프 순서를 재정렬할 수 있습니다. 예를 들어 포인트가 4개인 별, 포인트가 5개인 별, 포인트가 6개인 별포인트가 7개인 별 셰이프를 기본 스텐실 맨 위로 끌 수 있습니다.

    새로운 기본 셰이프가 있는 미니 도구 모음
  3. 또한 셰이프 창에서 스텐실을 위 또는 아래로 끌어 스텐실의 순서를 변경할 수 있습니다. 이러한 셰이프의 하위 집합은 빠른 셰이프 스텐실에서 셰이프 창에서의 순서와 같게 표시됩니다. 예를 들어 셰이프 창에서 빠른 셰이프 스텐실 바로 뒤의 장식 셰이프 스텐실을 끌면 빠른 셰이프 스텐에서 시퀀스가 변경됩니다.

    순서를 재정렬하여 다른 스텐실을 사용하는 미니 도구 모음

    참고: 다이어그램을 닫았다가 다시 열면 셰이프 창에 있는 스텐실의 기본 순서가 자동으로 복원되어 빠른 셰이프에 반영됩니다.

  4. 미니 도구 모음의 기본으로 다른 스텐실을 사용하려면 빠른 셰이프 스텐실에서 스텐실에 대한 이러한 셰이프의 하위 집합에서 셰이프를 선택합니다. 예를 들어 그래픽 및 수학 셰이프 스텐실에서 벤 다이어그램을 선택합니다.

    선택하여 새 스텐실을 사용하는 미니 도구 모음

팁: 스텐실의 기본 셰이프 시퀀스로 돌아가려면 셰이프 창에서 스텐실 이름을 마우스 오른쪽 단추로 클릭한 다음 스텐실 다시 설정을 선택합니다.

참고: 일부 스텐실에는 미니 도구 모음에서 사용할 수 있는 셰이프가 없습니다. 예를 들어 화살표 셰이프 스텐실의 셰이프는 미니 도구 모음에 표시되지 않습니다.

맨 위로 이동

자동 연결 설정/해제

현재 드로잉에 대해 또는 모든 Visio 드로잉에 대한 기본값으로 자동 연결을 활성화 및 비활성화할 수 있습니다.

활성 다이어그램에서 자동 연결 설정/해제

  • 보기 탭의 시각 보조 기능 그룹에서 자동 연결을 선택하거나 선택 취소합니다.

    보기 탭에서 자동 연결을 선택 또는 취소하여 자동 연결을 활성화하거나 비활성화합니다.

자동 연결 확인란을 사용할 수 없는 경우 다음 절차를 실행하여 모든 다이어그램에 대해 자동 연결이 해제되었는지 확인합니다.

모든 다이어그램에서 자동 연결 설정/해제

  1. 파일 탭을 클릭한 다음 옵션을 클릭합니다.

  2. Visio 옵션에서 고급을 클릭합니다.

  3. 편집 옵션에서 자동 연결 사용을 선택하여 자동 연결을 활성화합니다. 자동 연결을 해제하려면 자동 연결 확인란의 선택을 취소합니다.

    자동 연결 사용을 선택하거나 취소하여 모든 다이어그램 및 드로잉에 대한 자동 연결을 활성화 또는 비활성화합니다.
  4. 확인을 클릭합니다.

맨 위로 이동

자동 연결을 사용하여 셰이프 연결

셰이프를 연결하는 한 가지 방법은 사용자가 드로잉에 셰이프를 추가할 때 자동으로 연결되도록 하는 것입니다. 이 방법은 순서도를 만들 때 특히 편리합니다.

드로잉에 셰이프를 추가할 때 기존 셰이프에 자동으로 연결되도록 하려면 다음 절차를 사용합니다.

셰이프를 페이지로 끄는 동안 자동 연결 사용

  1. 스텐실의 셰이프를 드로잉 페이지로 끌어 다른 셰이프 근처에 놓습니다.

    다른 셰이프 가까이에 배치한 셰이프

  2. 마우스 단추를 계속 누른 상태에서 포인터를 파란색 삼각형 중 하나 위로 이동합니다. 삼각형이 진한 파랑으로 바뀝니다.

    파란색 삼각형 위에 포인터를 놓은 모습

  3. 마우스 단추를 놓습니다. 셰이프가 드로잉 페이지에 배치되고, 연결선이 추가되고 양쪽 셰이프에 붙습니다.

    파란색 삼각형을 클릭하면 연결선이 추가되고 양쪽 셰이프에 붙음

팁: 셰이프를 끌지 않지 않으려면, 먼저 스텐실에서 셰이프를 선택하고 드로잉에서 셰이프 위에 포인터를 놓은 다음 해당 셰이프 근처에 나타나는 파란색 삼각형 중 하나를 클릭하여 같은 결과를 얻을 수 있습니다.

페이지에 이미 있는 셰이프에 자동 연결 사용

  1. 연결을 시작할 셰이프 위에 포인터를 놓습니다.

    연결할 첫 번째 셰이프 위에 포인터를 놓은 모습

  2. 연결 대상 셰이프에 가장 가까운 파란색 삼각형 위에 포인터를 놓습니다.

    연결할 셰이프에 가장 가까운 파란색 삼각형 위에 위치한 포인터

    삼각형이 진한 파랑으로 바뀌고, 연결할 셰이프 주변에 빨간색 상자가 나타납니다.

    참고: 연결하려는 셰이프 주변에 빨간색 상자가 나타나지 않으면 셰이프가 너무 멀리 있는 것일 수 있습니다. 셰이프를 더 가까이 이동하고 다시 시도하거나, 연결선 도구를 사용하세요.

  3. 파란색 삼각형을 클릭합니다. 연결선이 추가되고 양쪽 셰이프에 붙습니다.

    파란색 삼각형을 클릭하면 연결선이 추가되고 양쪽 셰이프에 붙음

자동 연결 설정/해제

모든 Visio 드로잉에서 또는 현재 드로잉에서만 자동 연결 기능을 사용하거나 사용하지 않도록 설정할 수 있습니다. 모든 드로잉에 대해 설정하는 경우:

  1. 도구 메뉴에서 옵션을 클릭합니다.

  2. 일반 탭을 클릭합니다.

  3. 드로잉 창 옵션에서 자동 연결 사용 확인란을 선택합니다.

현재 드로잉에 대해서만 설정하는 경우:

  • 표준 도구 모음에서 자동 연결 도구를 클릭합니다.

    참고: 자동 연결 도구를 클릭해도 자동 연결이 사용하도록 설정되지 않으면 옵션 대화 상자에서 자동 연결 사용 확인란이 선택되어 있는지 확인합니다.

연결선 도구를 사용하여 셰이프 연결

연결선을 추가하고 붙이는 가장 유연한 방법 중 하나는 표준 도구 모음에 있는 연결선 도구 단추 이미지 를 사용하여 연결선을 그리는 것입니다.

  1. 표준 도구 모음에서 연결선 도구 단추 이미지 를 클릭합니다.

  2. 다음 중 하나를 수행합니다.

    • 연결선을 셰이프의 특정 지점에 붙은 상태로 유지하려면 첫 번째 셰이프의 연결점 연결점 이미지 - 파란색 X 에서 두 번째 셰이프의 연결점으로 끕니다. 셰이프가 연결되면 연결선 끝점이 빨간색으로 바뀝니다. 이를 점 대 점 연결이라고 합니다. 점 대 점 연결을 사용하면, 셰이프 중 하나를 이동할 때 연결선이 같은 연결점에 붙은 상태로 유지됩니다.

    • 연결선이 사용 가능한 가장 가까운 연결점으로 이동할 수 있게 하려면, 셰이프 주변에 빨간색 상자가 나타날 때까지 연결선 도구를 첫 번째 셰이프의 가운데에 놓습니다. 마우스 단추를 누른 상태에서 두 번째 셰이프의 가운데로 끕니다. 두 번째 셰이프 주변에 빨간색 상자가 나타나면 마우스 단추를 놓습니다. 이를 셰이프 대 셰이프 연결이라고 합니다. 셰이프 대 셰이프 연결을 사용하면, 셰이프 중 하나를 이동할 때 사용 가능한 가장 가까운 연결점으로 이동하여 연결선이 각 셰이프에 붙은 상태로 유지됩니다. 연결점이 없는 경우 연결선은 가장 가까운 쪽으로 이동합니다.

      참고: 연결선의 한쪽 끝이 연결점에 연결되고 연결선의 다른 쪽 끝이 셰이프에 연결되는 셰이프 간에도 연결을 만들 수 있습니다(그 반대의 경우도 마찬가지).

  3. 표준 도구 모음에서 포인터 도구 포인터 단추 를 클릭하여 일반 편집 모드로 돌아갑니다.

    참고 사항: 

    • 한 셰이프에서 여러 셰이프로 연결선을 추가하려면 여러 연결선을 추가해야 합니다. “분기” 연결선 셰이프는 없습니다.

    • 점 대 점 연결을 만들려고 하는데 정확히 원하는 위치에 연결선을 붙이기가 어려우면 다른 맞추기 및 붙이기 설정을 사용해 보세요.

    • 도구 메뉴에서 맞추기 및 붙이기를 클릭한 다음 일반 탭에서 원하는 옵션을 선택합니다.

      셰이프 기하 도형, 셰이프 핸들 또는 셰이프 정점에 붙이는 경우 연결점이 아직 없으면 자동으로 추가됩니다.

셰이프 연결과 점 연결 간 전환

셰이프의 한 지점에서 다른 셰이프의 다른 지점으로 연결선을 붙이거나, 전체 셰이프에서 다른 전체 셰이프로 연결선을 붙일 수 있습니다. 또한 연결선의 한쪽 끝이 셰이프의 한 지점에 붙어 있고 연결선의 다른 쪽 끝이 전체 셰이프에 붙어 있는 연결을 만들 수 있습니다.

  1. 연결선 끝점을 셰이프에서 멀리 끕니다.

  2. 다음 중 하나를 수행합니다.

    • 연결선의 한 끝점을 셰이프의 연결점에 붙이려면 연결점 주변에 빨간색 상자가 나타날 때까지 셰이프의 연결점 중 하나로 끝점을 끕니다.

    • 연결선의 한 끝점을 전체 셰이프에 붙이려면 전체 셰이프 주변에 빨간색 상자가 나타날 때까지 셰이프의 가운데로 끝점을 끕니다.

참고 항목

연결선 텍스트 추가 및 편집

사용자 지정 연결선 만들기

연결선 붙이기 또는 붙이기 해제

Visio 교육

All you need to know about Visio desktop connectors (Visio team blog)

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×