셰이프에 데이터 추가

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Microsoft Office Visio 드로잉은 단순한 그림 이상이며 데이터를 구성하고 보고서의 데이터를 검색하는 중요한 방법입니다.

이 문서에서는 선택한 셰이프에 수동으로 데이터를 추가하는 가장 좋은 방법, 드로잉의 여러 셰이프에 적용할 수 있는 재사용 가능한 데이터 집합을 만드는 방법 및 마스터 셰이프에 데이터를 추가하는 방법에 대해 설명합니다.

참고: 다음 절차는 Microsoft Office Visio Professional 2007 및 Microsoft Office Visio Standard 2007에 모두 적용됩니다. Visio Professional이 있는 경우 자동으로 데이터를 가져와서 셰이프에 추가하고 셰이프의 데이터를 데이터 그래픽을 사용하여 보여 줄 수 있습니다. 사용하고 있는 Visio 버전을 확인하려면 도움말 메뉴에서 Microsoft Office Visio 정보를 클릭합니다.

실행할 작업

선택한 셰이프에 데이터 추가

재사용 가능한 데이터 필드 집합 만들기

마스터 셰이프에 데이터 필드 추가

선택한 셰이프에 데이터 추가

이미 드로잉에 있는 셰이프에 데이터를 추가하려면 우선 데이터 필드를 셰이프에 추가한 다음 값을 추가합니다.

팁: 다음 절차는 셰이프에 데이터를 추가하는 가장 간단한 방법입니다. 하지만 같은 데이터를 여러 셰이프에 추가하려는 경우 이 항목의 다른 섹션에서 설명하는 방법 중 하나를 사용하는 것이 좋습니다.

데이터 필드와 값의 차이점

  • 데이터 필드는 값을 보유할 수 있는 레이블이 지정된 셀입니다.

  • 값은 데이터베이스 테이블의 셀, 워크시트의 셀 또는 이 경우 셰이프의 셀에 있는 텍스트 또는 숫자입니다.

다음은 기본 순서도 스텐실의 판단 셰이프에 대한 필드와 값이 있는 셰이프 데이터 창을 보여 주는 예제입니다. 이 경우 필드는 시간당 급여, 네트워크 액세스 필요 여부, 계약 기간이며 값은 49,000원, 예, 3주입니다.

필드와 값을 보여 주는 셰이프 데이터 창

선택한 셰이프에 데이터 필드 추가

  1. 데이터를 추가할 셰이프를 선택합니다.

  2. 선택 영역을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 데이터를 가리킨 다음 셰이프 데이터를 클릭합니다.

  3. 지금 데이터를 정의할 것인지 묻는 메시지가 나타나면 를 클릭합니다.

    참고: 셰이프에 이미 데이터 필드가 포함되어 있는 경우 이 메시지가 표시되지 않습니다.

  4. 셰이프 데이터 정의 대화 상자에서 필드의 레이블을 입력합니다.

  5. 다른 필드를 만들려면 새로 만들기를 클릭하고 4단계를 반복합니다.

  6. 데이터 필드를 모두 정의했으면 확인을 클릭합니다.

    필드를 보여 주는 셰이프 데이터 대화 상자가 나타납니다.

데이터 필드에 값 추가

  1. 보기 메뉴에서 셰이프 데이터 창을 클릭합니다.

  2. 셰이프 데이터 창에서 각 셰이프를 한 번에 하나씩 선택하고 데이터 필드에 값을 입력합니다.

    참고: 셰이프 데이터 창의 내용에는 선택한 셰이프에 대한 데이터만 표시됩니다.

맨 위로 이동

재사용 가능한 데이터 필드 집합 만들기

드로잉에 이미 있는 셰이프뿐 아니라 나중에 드로잉에 배치할 셰이프에 적용할 수 있는 데이터 필드 집합을 만들 수 있습니다.

  1. 보기 메뉴에서 셰이프 데이터 창을 클릭합니다.

  2. 셰이프 데이터 창의 아무 곳이나 마우스 오른쪽 단추로 클릭한 다음 셰이프 데이터 집합을 클릭합니다.

  3. 셰이프 데이터 집합 창에서 추가를 클릭합니다.

  4. D셰이프 데이터 집합 추가 대화 상자에서 데이터 집합의 이름을 입력합니다.

  5. 새 집합 만들기를 선택한 다음 확인을 클릭합니다.

    데이터 집합은 셰이프 데이터 집합 창의 이름 열에 나타납니다.

    참고: 기존의 데이터 집합을 변경하려는 경우 다른 옵션 중 하나를 클릭할 수도 있습니다.

  6. 이름에서 새 데이터 집합을 클릭한 다음 정의를 클릭합니다.

  7. 셰이프 데이터 정의 대화 상자에서 필드의 레이블을 입력합니다.

  8. 다른 필드를 만들려면 새로 만들기를 클릭한 다음 7단계를 반복합니다.

  9. 데이터 필드를 모두 정의했으면 확인을 클릭합니다.

  10. 드로잉에서 선택한 셰이프에 데이터 집합을 적용하려면 셰이프 데이터 집합 창에서 집합을 선택한 다음 적용을 클릭합니다.

    팁: 데이터 집합을 적용한 셰이프 중 하나의 새 필드를 보려면 해당 셰이프를 선택한 다음 셰이프 데이터 창을 살펴봅니다.

맨 위로 이동

마스터 셰이프에 데이터 필드 추가

특정 셰이프를 사용할 때마다 같은 셰이프 데이터 집합을 추가하려는 경우 해당 셰이프의 마스터 복사본에 데이터 필드를 추가하면 시간을 절약할 수 있습니다. 예를 들어 이름과 직원 번호 같은 데이터 필드를 직원 셰이프의 마스터에 추가할 수 있습니다.

  1. 셰이프 데이터를 추가할 마스터를 마우스 오른쪽 단추로 클릭하고 내 셰이프에 추가를 가리킨 다음 새 스텐실에 추가를 클릭합니다.

    참고: 사용자 지정 스텐실이 이미 있으면 새 스텐실을 만드는 대신 사용자 지정 스텐실에 마스터를 추가할 수 있습니다.

  2. 다른 이름으로 저장 대화 상자에서 새 스텐실의 이름을 입력한 다음 저장을 클릭합니다.

  3. 파일 메뉴에서 셰이프, 내 셰이프를 차례로 가리킨 다음 복사된 마스터가 들어 있는 스텐실을 클릭합니다.

  4. 새 스텐실의 제목 표시줄을 마우스 오른쪽 단추로 클릭한 다음 바로 가기 메뉴에서 스텐실 편집을 클릭합니다.

  5. 방금 스텐실에 추가한 셰이프를 마우스 오른쪽 단추로 클릭하고 마스터 편집을 가리킨 다음 마스터 셰이프 편집을 클릭합니다.

  6. 셰이프의 편집 창에서 해당 셰이프를 마우스 오른쪽 단추로 클릭하고 데이터를 가리킨 다음 셰이프 데이터를 클릭합니다.

  7. 지금 데이터를 정의할 것인지 묻는 메시지가 표시되면 를 클릭합니다.

    참고: 셰이프에 이미 데이터 필드가 포함되어 있는 경우 이 메시지가 표시되지 않지만 나머지 단계는 계속 진행됩니다.

  8. 셰이프 데이터 정의 대화 상자에서 필드의 이름을 입력하고 원하는 다른 모든 정보를 채웁니다. 예를 들어 데이터 형식을 변경하거나 셰이프 프롬프트를 추가하려고 할 수 있습니다.

  9. 다른 필드를 만들려면 새로 만들기를 클릭하고 8단계를 반복합니다.

  10. 데이터 필드 정의를 마쳤으면 확인을 클릭합니다.

    필드를 보여 주는 셰이프 데이터 대화 상자가 나타납니다.

    참고: 필드를 변경하려면 정의를 클릭하고 8단계를 반복합니다.

  11. 셰이프의 편집 창을 닫으려면 파일 메뉴에서 닫기를 클릭합니다.

  12. 셰이프를 업데이트할 것인지 묻는 메시지가 표시되면 를 클릭합니다.

  13. 변경 내용을 스텐실에 저장할 것인지 묻는 다른 메시지가 표시되면 를 클릭합니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×